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PREFACE 
This manual provides information you need to understand and use the IHS Clinical 
Scheduling for Windows (BSDX) package. The IHS Clinical Scheduling for 
Windows package is based on an easy-to-use graphical user interface (GUI) for 
scheduling appointments. 

This manual contains reference information about the IHS Clinical Scheduling for 
Windows package, examples of its processes, and procedures by which you can 
perform the activities supported by the package. Step-by-step procedures are 
provided to aid in your use of the IHS Clinical Scheduling for Windows package. 

SECURITY 
The IHS Clinical Scheduling for Windows (BSDX) uses security keys to limit user’s 
ability to change system set-up parameters and patient information. In other words, 
not all features are available to all users. Contact your site administrator to determine 
or change your security keys. 

RULES OF BEHAVIOR 
All RPMS users are required to observe HHS and IHS Rules of Behavior regarding 
patient privacy and the security of both patient information and IHS computers and 
networks. This document provides both RPMS and BSDX Rules of Behavior. 
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1.0 Introduction 
IHS Clinical Scheduling for Windows (BSDX) package is the Windows Extension of 
the PIMS Scheduling program. It gives you many appointment management functions 
included in PIMS Scheduling, but with the added convenience and usability of a 
Graphic User Interface (GUI). The IHS Clinical Scheduling for Windows (BSDX) 
package should be used with PIMS Scheduling. 

1.1 Using This Manual 
If this package was just installed at your site, it must first be setup before you can 
begin scheduling patients. See Section 6, Setting Up and Administering BSDX, for 
instructions. 

If you need help understanding the screen layout or how to log in or out, see Section 
2, Orientation, or Section 3, Getting Started, for more specific instructions. 

If the IHS Clinical Scheduling for Windows (BSDX) package was previously 
installed at your site and it has be upgraded for this version, you can schedule patients 
as described in Section 4, Managing Patient Appointments, or view and print 
schedules as described in Section 5, Viewing and Printing. 
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2.0 Orientation 
Note: The screenshots in this manual are from a Windows 2000 
environment and may differ from those on your screen 

2.1 Definitions 
Table 2.1 defines terms used in this document for various areas of the user interface.  

Table 2.1: Screen Area Descriptions 

Term Description 

Access Block Access Blocks are color-coded representations of the amount of 
time allotted for a specific Access Type (or appointment). 

Access Types Access Types refer to the variety of different appointment types 
available in the RPMS system. Each type of appointment, such as 
routine physical, dental, walk-in, or other specific appointment 
type is an Access Type. 

Access 
Groups 

Access Groups are categories of Access Types. Assigning Access 
Types to Access Groups makes it easier to schedule and search for 
certain types of appointments. 

Resources The term Resources refers to any person or service for which a 
patient can be scheduled. Resources can be physicians, diagnostic 
equipment (such as MRI, CT scan, ultrasound, and so on.), or 
specialty appointment slots, such as physical therapy. 

Resource 
Groups 

Resource Groups are categories of Resources that help to organize 
the variety of Resources available at each location. 

Slot Number of appointments per defined appointment length. For 
example: If SLOTS = 4 and your clinic (resource) appointment 
length is 30 minutes, then there are four (4) available appointments 
for every 30 minutes. 

See Setting Up and Administering BSDX on page 43 for information regarding 
Resource and Access variables. 
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2.2 Clinic Display Area 
The clinic schedule area is composed of date columns and time rowsEach column 
represents a day and each row represents a time interval. The time intervals can be 
10, 15, 20, or 30 minutes. You can change the time interval using the View menu. For 
more information about Time Scale, see the View Menu. 

Access Blocks (areas of the schedule which are available for patient appointments) 
are indicated by the adjacent appointment times and dates. They may be color-coded 
to user preference. Different colors represent different Access Types. Position the 
cursor in such an area and click on the schedule display. The type of clinic access and 
the number of appointment slots available are visible in a message in the status bar at 
the bottom of the scheduling window. Clinic Access Types and colors can be defined 
and changed by the administrator of the scheduling package. (See Setting Up and 
Administering BSDX on page 43 for more information.) 

Patient appointments are displayed on the schedule as white boxes containing a 
patient name and a note (if applicable), as shown in Figure 2-1. 

 
Figure 2-1: Desktop showing patient appointments and multiple clinic schedules 

2.3 Basic Screen Layout 
The basic 5-day appointment screen is displayed in Figure 2-2. At the far left is a 
menu tree view showing the Resources organized by Resource Group. In this case, 
the expanded view of Cardiology group shows three Resources. A Resource can be 
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linked to an RPMS scheduling clinic so that when a patient has an appointment at that 
clinic and checks in, a PCC visit is initialized for that clinic.  

Note: Equipment Resources such as treadmills or ultrasound 
cannot be linked to a schedule in RPMS. 

The colors on the schedule display correspond to various Access Types, set up for 
this Resource. The Resources, Resource Groups, Access Types, and colors can be 
customized to your individual clinic. You can create your own Access Types, 
Resource Groups using the Scheduling Management window. (See Using the 
Scheduling Management Window on page 54 for detailed instructions.)  

 
Figure 2-2: Basic Screen Layout 

Table 2.2 describes the various items displayed on the basic screen layout. 

Table 2.2: Descriptions of screen items 

Screen Item Description 

Title Bar Shows user ID and facility location in the upper left corner of 
the screen 

Menu Bar Appears below the “Name and location of current user. The 
available text menus are: File, Appointment, View, and Help. 
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Screen Item Description 

Resource Group Appears at the far left of the screen, below the menu bar. 
Pane Displays the available Resources. 

Times Appears at the left side of the screen. Times are shown by 
hour and then by segment. They are listed in military time 
(for example 13:00 equals 1:00PM). 

Resource Name  Appears in the upper left side of the screen, immediately 
above the “Times” column. Displays the name of the 
Resource currently active in the client window. 

Client Window Area on your screen that shows the work space for an 
application. 

Appointment Date Appears in the upper right corner of the screen, below the 
Selector Minimize, Maximize, and Exit buttons. The date selected is 

the starting date of the appointments currently displayed in 
the client window. The range of appointments displayed can 
be 1-day, 5-day, or 7-day. 

Minimize, Appears in the uppermost right corner of the screen. These 
Maximize, and Exit  buttons function just as they do in MS Windows applications.

Scroll Bars, Box, Appears at the far right side and at the bottom of the screen. 
and Arrows These buttons function just as they do in MS Windows 

applications.. 

Colors Displays Appointments using colors found in the Client 
Window area on the Schedule correspond to the various 
Access Types that can be set up for a particular provider. 

2.4 Using the Resource Group Pane 
The Resource Group Pane at the left-hand side of the screen lists both Resources and 
Resource Groups. If there is a plus sign (+), click it to expand the resource group to 
see all available resources. Click the minus sign (-) to collapse the group. 

2.5 Dialog Boxes 
Dialog boxes appear when the computer requires input from you or when an error 
occurs. In this manual, a dialog box is defined as any small box or screen that appears 
in front of the Scheduling interface and requests your attention or specific 



Clinical Scheduling for Windows (BSDX)  v2.0 

information. Most error dialog boxes ask you to click either OK or Cancel to 
acknowledge the error.  

2.6 Viewing Long/Wide Reports 
When information extends beyond the bottom of the screen, a vertical scroll bar on 
the right side of the screen becomes active. Click the up and down arrows on the 
scroll bar to view the previously hidden portions of the report or screen. Likewise, if 
the screen information extends beyond the right side of the screen, the horizontal 
scroll bar on the bottom of the screen becomes active. Click the left and right arrows 
on the scroll bar to view the previously hidden portions of the report or screen. 

2.7 Changing the View 
You can view the schedule in four modes: patients without appointments (walk-ins), 
1-day, 5-day, or 7-day. The 1-day mode gives you maximum detail for a single day 
schedule. The 5-day and 7-day modes give you a view of five or seven days of the 
schedule from the selected date. Use the View menu shown in Figure 2-3 to change 
viewing modes. 

 
Figure 2-3: View menu 
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2.7.1 1-Day View 

 
Figure 2-4: Screen showing 1-Day view of schedule 

2.7.2 5-Day View 

 
Figure 2-5: Screen showing 5-Day view of schedule  
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2.7.3 7-Day View 

 
Figure 2-6: Screen showing 7-Day view of schedule  

2.8 Appointment Window 
The appointment window shows the patient name, time of appointment, and notes. 
Figure 2-7 shows an appointment made for the 11:00-11:40 time slots for POCO 
REMUS. The patient selection is directly connected to RPMS. When an appointment 
is made, the appointment information is also stored in the RPMS scheduling package. 
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Figure 2-7: Appointment window 

2.9 Resource Group View 
You can view an entire Resource Group’s schedule for one day. Figure 2-8 shows 
that you can look at an entire group of Resources. In this case, the appointment 
window for the cardiology group is shown and all three Resource schedules for June 
25th are displayed. You can also drag an appointment from one Resource to another 
or from one time slot to another. 

To view a Resource Group’s schedule: 

1. Right Click a Resource Group. 

2. Click Open Schedule. The Resource Group schedule shown in Figure 2-8 is 
displayed. 
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Figure 2-8: Viewing a Resource Group
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3.0 Getting Started 
This section provides instructions for accessing and exiting the Clinical Scheduling 
application, as well as an overview of the menus and commands available from the 
application menu bar. 

3.1 Login  
This section provides instructions for accessing the Clinical Scheduling application. 
Make sure you have an IHS user ID and password before you attempt to login. 

To start the Scheduling application: 

1. Select IHS Clinical Scheduling from IHS Clinical Scheduling WX using the 
Start menu or double-click the IHS Clinical Scheduling desktop icon shown 
Figure 3-1. 

 
Figure 3-1: Shortcut icon for Scheduling 

The splash screen and RPMS login dialog box are displayed as shown in Figure 
3-2 

 
Figure 3-2: RPMS Login dialog box 

Note: This application requires a user ID and password. If you do 
not have them, please contact your supervisor or site administrator. 

2. Enter your user ID in the RPMS Access Code text box. 

3. Enter your password in the RPMS Verify Code text box. 

A window similar to Figure 3-3 opens. 
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Figure 3-3: Initial view of the Clinical Scheduling application after logging in 

You can now add, change, or cancel patient appointments, as necessary. Refer to the 
specific section of this manual for additional instructions. 

3.2 Logout 
In addition to logging out of the IHS Clinical Scheduling application during 
normal daily activity, you may also be instructed to log out by your site 
administrator when maintenance is required. This section provides instructions for 
logging out. 

To log out of the IHS Clinical Scheduling application: 

1. Do one of the following: 

• If you are done scheduling appointments, choose Close Schedule from 
File menu. 

• If you receive a message similar to the one shown in Figure 3-4, click OK 
and quickly complete any tasks on which you are working. 

 
Figure 3-4: Shutdown warning  message 
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• If you receive a message similar to the one shown in Figure 3-5, click OK. 
All users must click OK before the system can shutdown. All information 
entered into the system prior to the shutdown is saved. 

 
Figure 3-5: System Shutdown notification message 

This completes the instructions for logging out of the IHS Clinical Scheduling 
application. 

3.3 Menus and Commands 
As with most MS Windows-compatible software, many menu commands duplicate 
the commands associated with the right-click menu. Either approach, whether 
through the right-click menu or the menu items, is acceptable. If a menu item is 
unavailable (or dimmed), it means that it cannot be used for the function you are 
currently performing. When performing specific operations, you must select the 
Resource, Appointment, or Patient you want before selecting a command. 

3.3.1 File Menu and Commands 
Figure 3-6 shows the commands on the File menu and the paragraphs that follow 
describe each command’s function. 

Figure 3-6: File menu 

Open Multiple Schedules—

 

Use this command to open schedules for several or all 
Resources.  
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To open multiple schedules: 

1. Click Open Multiple Schedules on the File menu. The dialog box shown in 
Figure 3-7 opens. 

  
Figure 3-7: Open Multiple Schedules dialog box 

2. Select the Resource Group and Resources as necessary and click OK. Figure 3-8 
provides an example of multiple schedules open on a desktop. 

 
Figure 3-8: Desktop with multiple schedules open 

User Manual 14 Getting Started 
   May 2008 



Clinical Scheduling for Windows (BSDX)  v2.0 

Change RPMS Server—Use this command to change the RPMS server you are 
using. If schedules are open when you select this command, the system prompts you 
to confirm that you want to continue. (See Changing the RPMS Server on page 18 for 
more information.) 

Change RPMS Login—Use this command to change the login you use to access the 
Scheduling program. (See This completes the instructions for logging into the RPMS 
server.. 

Changing Your Login on page 18 for more information.) 

Change RPMS Division—Use this command to access another division from the 
Clinical Scheduling program. Click this command to open the dialog box shown in 
Figure 3-9; select another division; and click OK to access another division. 

  
Figure 3-9: Select Division dialog box 

Scheduling Management—Use this command to open the Scheduling Management 
window. (See Error! Reference source not found. on page Error! Bookmark not 
defined. for more information.) 

Print Clinic Schedules—Use this command to access the Print Clinic Schedules 
window. (See Clinic Schedules on page 35 for more information.) 

Print Reminder Letters—Use this command to access the Print Clinic letters 
window. (See Reminder, Rebook, and Cancellation Letters on page 37 for more 
information.) 

Print Rebook Letters—Use this command to access the Print Clinic letters window. 
(See Reminder, Rebook, and Cancellation Letters on page 37 for more information.) 

Print Cancellation Letters—Use this command to open the a cancellation letter for 
a selected patient in the preview window. (See Reminder, Rebook, and Cancellation 
Letters on page 37 for more information.) 
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Print Patient Letters—Use this command to view all appointments for a selected 
patient in the print preview window. (See Patient Appointments on page 41 for more 
information.) 

Close Schedule—Use this command to exit the Clinical Scheduling for Windows 
package. 

3.3.2 Appointment Menu and Commands 
Figure 3-10 shows the commands on the Appointment menu and the paragraphs that 
follow describe each command’s function. 

 
Figure 3-10: Appointment menu 

New Appointment—Use this command to create a new appointment. (See Making 
an Appointment on page 25 for more information.)  

Edit Appointment—Use this command to edit an existing appointment. (See Editing 
Appointment Information on page 26 for more information.) 

Cancel Appointment—Use this command to cancel an appointment. (See Deleting 
Appointments on page 27 for more information) 

Mark as No Show—Use this command to indicate that a patient did not show up for 
an appointment and did not cancel it. (See Marking a No-Show Appointment on page 
28) 

Undo No Show—Use this command to unmark an appointment as a no show. (See 
Undoing a No-Show Appointment  on page 29) 

Copy Appointment to Clipboard—Use this command to copy an appointment to 
the Appointment Clipboard which makes scheduling duplicate appointments faster. 
(See Using the Appointment Clipboard on page 30 for more information.) 

Create Walk-In Appointment—Use this command to add a same-day appointment 
for a patient without a scheduled appointment. 
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Find Available Appointment—Use this command to search the Scheduling system 
for an appointment that matches your criteria. (See Finding an Available 
Appointment on page 20 for more information.) 

Check In Patient—Use this command to check a patient in when they arrive for an 
appointment. (See Checking a Patient In on page 31 for more information.) 

View Patient Appointments—Use this command to view the appointments for a 
specific patient. (See Patient Appointments on page 41 for more information.) 

3.3.3 View Menu and Commands 
Figure 3-11 shows the commands on the View menu and the paragraphs that follow 
describe each command’s function. 

 
Figure 3-11: View menu 

1-Day View—Use this command to view the schedule for a single day. This provides 
the most detail available. (See Figure 2-4) 

5-Day View—Use this command to view the schedule for Monday through Friday. 
(See Figure 2-5) 

7-Day View—Use this command to view the schedule for the entire week. (See 
Figure 2-6) 

Time Scale—This command sets to the amount of time allotted for each 
appointment. You can customize the appointment interval to fit your clinic’s needs as 
follows: 

• 10 minute 

• 15 minute 

• 20 minute 

• 30 minute 

Schedule Tree—This command shows or hides the Resource Group pane at the left 
side of the Scheduling window. 
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Appointment Clipboard—This command opens the appointment clipboard. (See 
Using the Appointment Clipboard on page 28 for more information.) 

3.4 Changing the RPMS Server  
To change the RPMS Server:  

1. Select the Change RPMS Server command from the File menu shown on Figure 
3-6. 

2. Click OK in response to the prompt shown in Figure 3-12. 

 
Figure 3-12: Changing the RPMS server confirmation message 

3. Type the appropriate RPMS Server Address and Port in the text boxes and click 
OK in the dialog box shown in Figure 3-13. 

 
Figure 3-13: Changing the RPMS server 

This completes the instructions for logging into the RPMS server.. 

3.5 Changing Your Login 
This section provides instructions for changing a user login. 
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To change the RPMS Login: 

1. Select the Change RPMS Login command from the File menu shown on Figure 
3-6. 

2. Click OK in response to the prompt shown in Figure 3-14. 

 
Figure 3-14: Changing the Login 

3. Type the appropriate RPMS Access and Verify Codes in the text boxes and click 
OK in the dialog box shown in Figure 3-15. 

 
Figure 3-15: Changing the Login 

This completes the instructions for changing a user login. The next section provides 
instructions for scheduling a patient appointment.
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4.0 Managing Patient Appointments 
This section provides instructions for scheduling, viewing, editing, canceling an 
appointment for a patient, as well as checking a patient in. It also provides 
instructions for using the Appointment Clipboard which is useful when scheduling 
multiple appointments for the same patient. 

4.1 Opening or Viewing a Schedule for a Selected Resource 
This section provides instructions for opening or viewing an appointment for a 
patient. 

To view the schedule for a selected Resource: 

1. Select a Resource Group or individual Resource from the Resource Group pane. 
Expand and collapse the groups by clicking the plus sign (+) or minus sign (-) 
next to a group. 

2. Do one of the following:  

• Double-click the Resource name and select Open Schedule from the File 
menu. 

• Right-click the Resource name and select Open Schedule from the Resource 
Group pane. 

You can also view the schedule of all Resources in a group by selecting the group and 
then double-clicking the group name. 

4.2 Finding an Available Appointment 
You can search an entire Resource Group or specific Resource within a group for an 
available appointment using Find Available Appointment. 

To find an available appointment for a Resource Group or individual Resource: 

1. Click the Resource Group or individual Resource within a group on the Resource 
Group pane for which you want to find the available appointment. 

2. Do one of the following:  

• On the Appointment Menu, click Find Available Appointment. (See Figure 
4-1) 

• Right-click on the Resource in the Resource Group pane, then click Find 
Available Appointment. (See Figure 4-2) 
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Figure 4-1: Finding an available appointment using Find Available Appointment from the File menu 

 
Figure 4-2: Finding an available appointment using right-click 

The Appointment Search window is displayed. Figure 4-3 is provided as an 
example. 
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Figure 4-3: Search parameters 

3. Select the search parameter using the options in the Search Parameters box shown 
in Figure 4-4 as follows: 

 
Figure 4-4: Available search options 

• In the Date Range box shown in Figure 4-5, select the range of dates in which 
you want to find an appointment. Click and drag the cursor from the 
beginning date to the ending date of the range. The date range must be 14 
consecutive days, or less. 
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Figure 4-5: Date range box 

• In the Time of Day box shown in Figure 4-6, click AM Only, PM Only, or 
Both. 

 
Figure 4-6: Time of day box 

• In the Day of the Week box shown in Figure 4-7, check the days of the week 
for which you want to find an appointment time. 

 
Figure 4-7: Day of the week box 

• In the Access Group box shown in Figure 4-8, select the appropriate Access 
Group from the drop-down list. 

Figure 4-8: Access group box 

• In the Access Type box shown in Figure 4-9, check all applicable Access 
Types for the appointment time you want to find. 

 
Figure 4-9: Access type box 
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4. Click Search when you have finished selecting your search parameters. 

A list of available appointments is displayed in the Search Result box. Figure 
4-10 is provided as an example. 

 
Figure 4-10: Searching for an available appointment (results) 

If there are not any appointments available for the parameters you selected, the 
message shown in Figure 4-11 is displayed. 

 
Figure 4-11: No availability dialog box 

You can change the order of the list by clicking any column heading in the search 
results. 

If there are multiple appointments available, scroll through the results list to find the 
appointment you want. To select an appointment, double-click any where on the row 
for that appointment. When you select an appointment from the list, the Scheduling 
window opens to that date. You can now make the appointment. See Making an 
Appointment on page 25 for instructions. 
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4.3 Making an Appointment 
This section provides instructions for making appointments for patients. 

To create a new patient appointment: 

1. Click-and-hold the cursor over an area of the schedule that is available for 
appointments (as indicated by the Access Type color), and then drag the cursor to 
cover the entire time range needed for the appointment.  

2. Do one of the following: 

• Click New Appointment from the Appointment menu. 

• Right-click on the selected area, then click the Add Appointment option. 

The Select Patient window shown in Figure 4-12 is displayed. 

3. Select a patient by typing lookup information (name, SSN, DOB, or HRN) in the 
Select Patient Search box. You may enter the first part of the patient's last name, 
the last 4 digits of the SSN, the entire SSN, HRN, or the DOB in the M-D-YYYY 
format. 

4. Press Return or click Search. If the system finds only one match, the fields are 
automatically populated in the Select Patient field. If there is more than one 
match, a list of available patients is displayed. To select from this list, 
double-click the patient and then click OK to confirm your selection. 

Note: You can also recall the last patient you typed in this field by 
pressing the Spacebar and then Return. 

 

 
Figure 4-12: Making an appointment (steps 1-4) 

The Patient Appointment dialog box shown in Figure 4-13 is displayed. 
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Figure 4-13: Patient Appointment dialog box 

5. Use the Patient Appointment dialog box to confirm the patient's contact 
information and to enter any relevant notes. The patient’s identification 
information shows in the Patient ID box, and the appointment information 
appears in the Appointment box. You can also click the Contact Information tab 
to view the patient’s contact information. The Contact Information tab is 
read-only; any changes made are not saved. 

6. Click OK to enter this appointment in the schedule. 

This completes the instructions for making appointments for patients. 

4.4 Editing Appointment Information 
This section provides instructions for editing appointments information. 

Note: To change a patient’s appointment time, see Changing 
Appointment Times on page 27. 

To edit appointment information: 

1. Select the appointment that you want to edit. 

2. Do one of the following:  

• Right-click the appointment and then click Edit Appointment. 

• Choose Edit Appointment from the Appointment menu.  

The Patient Appointment dialog box shown in Figure 4-13 is displayed. 

3. Edit the appointment information as appropriate. 

This completes the instructions for editing patient appointments. 
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4.5 Changing Appointment Times 
This section provides instructions for changing the time of a  patient appointment. 

To change an appointment time: 

1. Click-and hold the appointment box. 

2. Drag the appointment to a new time slot. You can move appointments from one 
clinic to another by opening both clinic schedules, then clicking and dragging the 
appointment to the new time or Resource. (Figure 4-14). 

 
Figure 4-14: Changing an appointment time between two Resources 

The dialog box shown in Figure 4-15 is displayed. 

 
Figure 4-15: IHS Clinical Scheduling dialog box 

3. Click Yes to confirm or No to cancel the move. 

This completes the instructions for changing the time of a patient appointment. 
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4.6 Deleting Appointments 
This section provides instructions for canceling patient appointments. 

To cancel an existing appointment: 

1. Click the appointment that you want to cancel. 

2. Click Cancel Appointment in the Appointment menu. The Cancel Appointment 
dialog box shown in Figure 4-16 is displayed.  

 
Figure 4-16: Cancel Appointment dialog box 

3. Click the appropriate button to select whether the appointment was cancelled by 
the clinic or by the patient in the Appointment Cancelled By group box. 

4. Click the appropriate reason for the cancellation in the Reason for Cancellation 
(Select one) list. 

5. Type any comments or remarks as needed in the Remarks (Optional) text box. 

6. Click OK to cancel the appointment or click Cancel to keep the appointment and 
return to the schedule. 

This completes the instructions for canceling patient appointments. 

4.7 Marking a No-Show Appointment 
This section provides instructions for marking a patient as a No Show when there was 
no cancellation. 
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To mark a patient appointment as a no show: 

1. Click the appointment for the patient that you want to mark as a no show. Make 
certain that there is a thick box around the patient name. 

2. Choose Mark as No Show from the Appointment menu. The dialog box shown in 
Figure 4-17 is displayed  

 
Figure 4-17: No Show Appointment dialog box 

3. Do one of the following: 

• To schedule another appointment for this patient, check Auto Rebook and 
change the Start time in Days and the Maximum Days as necessary using 
the arrows; choose an Access Type for the Rebooked Appointment as 
necessary; then click OK. The text and background colors change to show 
this patient as a no show. 

• To dismiss this dialog box without scheduling another appointment, click 
Cancel. 

This completes the procedure for marking a no-show appointment. 

4.8 Undoing a No-Show Appointment 
This section provides instructions for changing a patient appointment from a No Show 
to booked. 

To unmark a patient appointment as a no show: 

1. Click the appointment for the patient that you want to mark as a no show. Make 
certain that there is a thick box around the patient name. 
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2. Choose Undo as No Show from the Appointment menu. The dialog box shown in 
Figure 4-17 is displayed. The text and background colors change to show this 
patient as booked. 

This completes the procedure for undoing a no-show appointment. 

4.9 Using the Appointment Clipboard 
This section provides instructions for using the Appointment Clipboard to set 
multiple appointments for a patient. This is an excellent tool when you are making 
several follow-up appointments at one time. 

To use the Appointment Clipboard: 

1. Click Appointment Clipboard on the View menu after making an appointment. 
(See Making an Appointment on page 25 for more information.) 

The Appointment Clipboard pane is displayed on the right side of the screen as 
shown in Figure 4-18. 

 
Figure 4-18: Using the appointment clipboard 

2. Click-and-drag the patient name you want to the Appointment Clipboard pane. 

3. Release the patient name inside the Appointment Clipboard pane. 

4. Click the patient name in the Appointment Clipboard pane. 

5. Drag it to a new appointment. You can create as many appointments (in as many 
clinics) for this patient as necessary using this method. 

This completes the procedure for marking an appointment using the Appointment 
Clipboard. 

User Manual 30 Managing Patient Appointments 
   May 2008 



Clinical Scheduling for Windows (BSDX)  v2.0 

4.9.1 Removing a Patient Name from the Appointment Clipboard 
The section provides instructions for removing a patient name from the Appointment 
Clipboard. 

To remove al patient displayed in the Appointment Clipboard: 

1. Select patient name you want to remove from the Appointment Clipboard. 

2. Right-click and select Remove Item. The selected name is removed from the 
Appointment Clipboard. 

This completes the instructions for removing a patient name the Appointment 
Clipboard. 

4.9.2 Clearing the Appointment Clipboard 
The section provides instructions for removing all patient names from the 
Appointment Clipboard. 

To remove all patients displayed on the Appointment Clipboard: 

1. Move your cursor to the Appointment Clipboard pane. 

2. Right-click and select Clear All. 

This completes the instructions for removing all patient names from the Appointment 
Clipboard. 

4.10 Checking a Patient In 
A PCC Visit is created in RPMS for the patient if this option is selected through 
PIMS. The text in the patient appointment box on the schedule appears green in color 
after you check in the patient. 

To check in a patient when they arrive at the clinic for treatment: 

1. Click the patient appointment you want to check in. 

2. Do one of the following:  

• Click Check In Patient on the Appointment menu. The Appointment Check 
In dialog box shown in Figure 4-19 is displayed.  
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Figure 4-19: Appointment Check In dialog box  

• Right-click on the patient appointment, then click Check In Patient. The 
Appointment Check In dialog box shown in Figure 4-19 is displayed 

The current time and date are displayed in the Check In Time box. To adjust the 
check-in information, select the component of the time field that you want to 
change (month, day, year, hour, or minute) and then click the up or down arrows 
to adjust the value one increment up or down, or manually type a new value. 

3. Click OK to check the patient in, or click Cancel to cancel the check-in process 

This completes the instructions for checking a patient in.
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5.0 Viewing and Printing 
This section provides instructions for viewing and printing clinic schedules, patient 
letters, and patient appointments, as well as describing portions of the window and 
toolbar buttons related to the window.  

5.1 Print Preview 
When you select a print command, the Print Preview window opens after making 
your command selections. This section describes the different buttons in this window. 
Any button that is not available for selection is dimmed. 

 
Figure 5-1: Previewing a report 

Table 5.1 describes various items and portions of the print preview window shown in 
Figure 5-1. 

Table 5.1: Screen Item Descriptions 

Screen Item Description 

Title bar Shows the name of the current window. Appears in the 
upper left corner of the screen. In Figure 5-1, Clinic 
Schedules is the current view. 
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Screen Item Description 

Toolbar Appears across the top of the screen, below the Title bar. 
Shows buttons that perform various tasks available from 
the Print Preview window. 

Resource Group 
Pane 

Appears in the left pane of the screen below the tool bar, 
Allows you to view Resource Groups. Use the plus and 
minus signs to expand or collapse lists of Resources. 

Main Report tab Appears at the top of  the right pane just below the print 
icon.. Shows a printable view of a schedule or letter   

Current Page No. Appears at the bottom-left of the screen. Shows the page 
number that is currently displayed. In Figure 5-11, it is 
page. 6. 

Total Page No. Appears at the bottom of the screen. Displays the total 
pages for the particular report. In Figure 5-11, it is 7. 

Zoom Factor Found at the bottom-right of the screen. Displays the 
current zoom factor of the current display. In Figure 5-11, 
it is 100%. 

5.2 Toolbar buttons 

 Go to First Page: This button takes you to go the first page of a multi-page 
report. 

 Go to Previous Page: This button takes you to the previous page of a 
multi-page report. 

 Go to next page: This button takes you to the next page of a multi-page report. 

 Go to last page: This button takes you to the last page of a multi-page report. 

 Go to Page: This button takes you to a specific page. When you click this 
button, the Go to Page dialog box opens. To go to the page you want, enter that 
page number. 

 Close Current View: This button closes the current view if you have selected a 
particular view. 

 Print: This button prints the report. Use the Print dialog box to select the printer 
you want to use to print the report. 
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 Refresh: This button allows you to update the selected report with the latest 
information. 

 Export Report: This button allows you to send the current report to another 
application or use another format such as Word (.doc), Excel (.xls), Adobe 
Acrobat (.pdf), or Rich Text (.rtf) formats. 

 Toggle Tree View: This button allows you to show or conceal the Resource 
Groups pane. 

 Zoom: This is the Zoom button. Use it to zoom in (enlarge) or out (shrink) the 
view of your report by clicking the arrow and selecting from the menu. 

  Search Text: Use this button to find a word or phrase in the text displayed. 
When you click the Search Text button, the Search Text dialog box is displayed. 
Enter the word or phrase in the Find What text box, and click Find Next. 

5.3 Printing  
This section provides instructions for printing clinic schedules, patient letters, and 
patient appointments, as well as describing portions of the window and toolbar 
buttons related to the window.  

5.3.1 Clinic Schedules 
The Print Clinic Schedules command allows you to print a clinic schedule, an entire 
Resource group, or individual Resources within a given Resource Group.  

To print a clinic schedule: 

1. Click Print Clinic Schedules from the File menu. The Print Clinic Schedules 
dialog box shown in Figure 5-2 is displayed. 
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Figure 5-2: Print Clinic Schedules dialog box 

2. Select a Resource Group from the Resource Group drop-down list. 

3. Double click to select each individual resource or check the Select All Resources 
box to print resource schedules.  

4. Choose the Beginning Date and the Ending Date dates using the drop-down list. 

5. Click OK and the Print Preview window opens showing the clinic schedule. 
Figure 5-3 is provided as an example. 
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Figure 5-3: Clinic Schedule example 

Use the. Toolbar buttons to export, print, and view pages of your schedule as 
necessary. See Toolbar buttons on page 34 for more information. 

This completes the instructions for printing clinic schedules. 

5.3.2 Reminder, Rebook, and Cancellation Letters 
The Print Clinic Letters command allows you to print various patient letters. The text 
of the letter can be added or edited as necessary using the dialog boxes shown in the 
examples in Figure 6-14 and Figure 6-17. 

To print reminder, rebook, and cancellation letters: 

1. Select Print Reminder Letters, Print Rebook Letters, or Print Cancellation 
Letters from the File menu. A dialog box similar to the one shown in Figure 5-4 
is displayed. 
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Figure 5-4: Print Reminder Letter dialog box 

Note: The Print Rebook Letters and Print Cancellation

 

 Letters 
dialog boxes contain the same choices; only the dialog box names 
are different. 

2. Choose a Resource Group from the list under Resource Group. 

3. Double click to select each individual resource or check the Select All Resources 
box to print the selected letter.  

4. Choose the Beginning Date and the Ending Date dates using the drop-down list. 

5. Click OK and the Print Preview window opens showing the selected letter. Figure 
5-5 is provided as an example. 
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Figure 5-5: Reminder Letter example 

Use the Toolbar buttons to export, print, and view pages of your reminder rebook, 
and cancellation letters as necessary. See Toolbar buttons on page 34 for more 
information. 

This completes the instructions for printing reminder, rebook, and cancellation letters. 

5.3.3 Patient Letters 
The Print Patient Letters command allows you to view or print all appointments in all 
clinics for the selected patient. 
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To print patient  letters: 

1. Click Print Patient Letters on the File menu. The Select Patient dialog box 
shown in Figure 5-6 opens. 

 
Figure 5-6: Select Patient dialog box 

2. Enter the name of the patient in the Select Patient text box and click Search. 

3. Select the patient and click OK. The Print Preview window opens. 

4. Use the Resource Group Pane to view the list of the clinics in which the patient 
has appointments. Figure 5-7 is provided as an example. 
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Figure 5-7: Patient Letter window showing all appointments in all clinics for the selected patient 

This completes the instructions for printing reminder, rebook, and cancellation letters. 

 

5.3.4 Patient Appointments 
The View Patient Appointments command allows you view or print, or view and 
print all appointments (future or past) for a single patient.  
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To view a patient’s appointments: 

1. Click View Patient Appointment from the Appointment menu The Select 
Patient dialog box shown in Figure 5-6 is displayed. 

2. Select a patient by typing lookup information (name, SSN, DOB, or HRN) in the 
Select Patient Search box. You may enter the first part of the patient's last name, 
the last 4 digits of the patient SSN, the entire SSN, or the patient's DOB in the 
form MM/DD/YYYY. 

3. Click Search. If the system finds one or more matches, the fields in the Select 
Patient dialog box are automatically populated with the appropriate data for each 
patient found. To select a patient from this list, double-click the patient name, 
then click OK to confirm your choice. 

Figure 5-8 is provided as an example of the Patient Appointments print preview 
window. 

Note: You can also recall the last patient you typed in this field by 
pressing the Spacebar and then the Return key.  

 
Figure 5-8: Patient Appointments window 

This completes the instructions for viewing or printing patient appointments. 
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6.0 Setting Up and Administering BSDX 
This section includes instructions for the following tasks: 

• Using the Edit Availability window to set up schedules using Access Blocks, 
Access Types, and templates. See Using the Edit Availability Window on page 
43. 

• Using the Scheduling Management window to set up Users and User Roles, 
Resources, Resource Groups, Access Types, and Access Groups, as well as 
importing schedules from other RPMS applications and performing 
administrative tasks such as viewing, communicating, and shutting down 
workstations. See Using the Scheduling Management Window on page 54. 

6.1 Using the Edit Availability Window 
This section includes setting up new schedules for Resources. To create a new 
schedule you must first define Access Blocks using the Edit Availability window as 
described in the following section. 

6.1.1 Accessing the Edit Availability Window 
Before you can schedule appointments, you must first design the layout for a 
schedule. This section provides instructions for creating schedules for a Resource 
using the Edit Availability window.  

Note: To use the Edit Availability window, your (IHS Clinical 
Scheduling) Resource user profile must include the Modify Clinic 
Availability setting. See your supervisor or IHS Clinical 
Scheduling administrator to change your profile. 

To access the Edit Availability window: 

1. Select a Resource from the Resource Group pane that contains the Resource 
whose availability you want to change. 

2. Right-click the Resource you want as shown in Figure 6-1. 
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Figure 6-1: Setting up Resource availability 

3. Click Edit Resource Availability as shown in Figure 6-1. 

The Edit Resource Availability window opens. This window is similar to the 
regular scheduling window, except it has a blue background. Figure 6-2 is 
provided as an example. 

 
Figure 6-2: Setting up Resource availability 

This completes the procedure for accessing the Edit Availability window. The next 
section provides instructions for using this window. 
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6.1.2 Menus and Commands 
As with most MS Windows applications, many commands can be performed by 
clicking the command either on the menu bar or by right-clicking. Either method is 
acceptable. If a command is unavailable (or dimmed), it means that it cannot be used 
for the function you are currently performing. When performing specific operations, 
you must select an Access Block before selecting a command. 

6.1.2.1 File Menu and Commands 
Figure 6-3 shows the commands on the File menu and the paragraphs that follow 
describe each command’s function. 

 
Figure 6-3: File menu 

Apply Template—Use this command to apply a saved template to create a schedule 
for a new Resource. See Applying a Scheduling Template check on page 52 for more 
information. 

Save Template —Use this command to save your template so that you can use it to 
create a new schedule with the same layout. See Creating a Scheduling Template on 
page 51 for more information. 

Scheduling Management—Use this command to open the Scheduling Management 
window. (See Using the Scheduling Management Window on page 54 for more 
information.) 

Close—Use this command to exit the Edit Availability window. 

This completes the descriptions of the commands on the File menu. 

6.1.2.2 Access Blocks Menu and Commands 
Figure 6-4 shows the commands on the Access Blocks menu and the paragraphs that 
follow describe each command’s function. 
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Figure 6-4: Appointment menu 

Add New Block—Use this command to add a new Access Block that can be used to 
schedule appointments 

Remove Block —Use this command to remove an Access Block. 

Edit Block —Use this command to change the appearance of an Access Block. 

This completes the descriptions of the commands on the Access Blocks menu. 

6.1.2.3 View Menu and Commands 
Figure 6-5 shows the commands on the View menu and the paragraphs that follow 
describe each command’s function. 

Figure 6-5: View menu 

1-Day View—Use this comm

 

and to create Access Blocks and a schedule for a single 
day. This provides the most detail available. (See Figure 2-4) 

5-Day View—Use this command to create Access Blocks and a schedule for Monday 
through Friday. (See Figure 2-5) 

7-Day View—Use this command to create Access Blocks and a schedule for the 
entire week. (See Figure 2-6) 

Time Scale—This command sets to the amount of time allotted for each appointment 
time slot You can customize the appointment time slot to fit your clinic’s needs as 
follows: 

• 10 minute 

• 15 minute 

• 20 minute 
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• 30 minute 

Access Block Clipboard—This command opens the Access Block Clipboard. (See 
Using the Access Block Clipboard on page 50 or more information.) Use the Access 
Block Clipboard to create multiple copies of Access Blocks with the same hours and 
appointment time slots. 

This completes the descriptions of the commands on the View menu. 

6.1.3 Setting up Clinic Availability 
Resource availability is set up using Access Blocks. Each Access Block covers a 
given time range, and contains a defined number of time lots. Each block is reserved 
for a particular type of Access Group and Access Type. The sections that follow 
explain how to set up Access Blocks. These options are only available using the Edit 
Availability window. 

6.1.3.1 Adding an Access Block 
The following procedure provides instructions for adding an Access Block. 

To add an Access Block: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in Figure 6-1. 

2. Select the date of the schedule using the drop-down calendar at the top right-hand 
corner of the window. 

3. Click your preferred view (1-day, 5-day, or 7-day) from the View menu. 

4. Click Time Scale, and select a 10, 15, 20, or 30 minute interval. 

5. Click-and-drag the pointer to outline the time range of the Access Block. The 
time range is displayed in the status bar at the bottom of the schedule.  

6. Do one of the following: 

• Click Add New Block on the Access Blocks menu  

• Right-click on the selected block, then click Add New Access Block. 

The Access Block dialog box shown in Figure 6-6 is displayed. 
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Time range of selected area 

Figure 6-6: Adding an Access Block 

7. Select the number of appointments that can be made per defined appointment 
length in the Access Block from the Slot list, the Access Group from the Access 
Group list, and the Access Type from the Access Type list. For example, if 
SLOTS = 4 and your resource has a defined appointment length of 15 minutes, 
then there are four (4) available appointments for each 15 minute appointment 
time. Type any notes pertaining to this particular Access Block in the Note text 
box. 

8. Click OK to save the new Access Block, or click Cancel to discard your 
selections and return to the Edit Availability window. 

This completes the procedure for adding an Access Block. You can continue adding 
Access Blocks or you can exit and close this window. The next section provides 
instructions for editing Access Blocks. 

6.1.3.2 Editing an Access Block 
The following procedure provides instructions for editing an Access Block. 

To edit an Access Block: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in Figure 6-1. 

2. Click an Access Block 

3. Do one of the following:  

• Click Edit Block on the Access Blocks menu. 
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• Right-click on an Access Block, and then click Edit Access Block. 

The Access Block dialog box shown in Figure 6-6 is displayed. 

4. Edit the following items as necessary: 

• Change the number of appointments per hour in the Access Block using the 
Slot list 

• Change the Access Group using the Access Group list 

• Change the Access Type using the Access Type list 

5. Edit the notes pertaining to this particular Access Block in the Note text box, as 
necessary. 

6. Click OK to save you changes to the Access Block, or click Cancel to discard 
your changes and return to the Edit Availability window. 

This completes the procedure for editing an Access Block. You can continue editing 
or adding Access Blocks or you can exit and close this window. The next section 
provides instructions for deleting Access Blocks. 

6.1.3.3 Deleting an Access Block 
The following procedure provides instructions for removing an Access Block. 

To delete an Access Block: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in Figure 6-1. 

2. Click an Access Block 

3. Do one of the following: 

• Click Remove Block on the Access Blocks menu. 

• Right-click on an Access Block and then click Delete Access Block. 

The IHS Clinical Scheduling dialog box shown in Figure 6-7 appears. 

 
Figure 6-7: IHS Clinical Scheduling confirmation dialog box 

4. Click Yes to confirm deletion of the Access Block, or click No to cancel the 
deletion. 
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The Edit Availability window is redisplayed and the selected Access Block is 
removed. 

This completes the procedure for deleting an Access Block. You can continue adding, 
editing, and deleting Access Blocks or you can exit and close this window. The next 
section provides instructions for using the Access Block Clipboard. 

6.1.4 Using the Access Block Clipboard 
The Access Block Clipboard allows you to duplicate Access Block by copying and 
pasting Access Blocks temporarily stored on the Access Block Clipboard. This 
feature is useful if you are adding several identical Access Blocks. You can store an 
unlimited number of Access Blocks in the clipboard. However, the Access Block 
Clipboard is cleared when you exit the Edit Availability window. 

To use the Access Block Clipboard: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in Figure 6-1. 

2. Click Access Block Clipboard on the View menu. Figure 6-8 shows the Access 
Block Clipboard. 

3. Add a new Access Block as described in Adding an Access Block on page 47 or 
click an existing Access Block. 

4. Drag the Access Block to the Access Block Clipboard. This does not move the 
Access Block; instead it copies the Access Block information to the clipboard. 

You can now create a new  Access Block on any area on the schedule by clicking 
and dragging the information to the new day and time. There is no limit to how 
many times you can copy the Access Block to the schedule. 
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Figure 6-8: Using the Access Block clipboard 

This completes the procedure for using the Access Block Clipboard. The next section 
provides instructions for creating and using Access Block Templates for quickly 
creating a schedule for a Resource. 

6.1.5 Using Templates to Set Up Resources 
Access Block templates are an excellent way to help set up a Resource appointment 
schedule. Templates can be for one, five, or seven days. Once created, you can apply 
them to the schedule repeatedly. Schedule Template files have a .bsdxa file extension 
(for example: pedstemplate.bsdxa for a pediatric clinic schedule or 
15mintemplate.bsdxa for Resources that use a 15-minute appointment slot). 

6.1.5.1 Creating a Scheduling Template 
This section provides instructions for creating a Scheduling Template. 

Note: The template you create whether it be 1, 5, or 7 days can 
only be applied for the same time interval (that is you can only 
apply a 1 day template to a 1 day schedule). 

To create a template: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in Figure 6-1. 
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2. Create a full 1, 5, or 7 day schedule for a particular Resource using Access Blocks 
as described in Setting up Clinic Availability on page 47. 

3. Click Save Template on the File menu. The Save As dialog box shown in Figure 
6-9 opens. 

 
Figure 6-9: Save As dialog box 

4. Type file name of the template in the File Name field. Use a descriptive name for 
the template so that you can have multiple templates that are easy to identify by 
name (such as pedtemplate.bsdxa or 15mintemplate.bsdxa). 

5. Select a location for your templates using the Save In drop-down list. You may 
want to create a separate folder to store your templates, such as BSDX Templates. 

6. Click Save to save your template or Cancel to exit without saving the template. 

This completes the instructions for creating a Scheduling Template. The next section 
provides instructions for setting up a schedule for a Resource using a Scheduling 
Template. 

6.1.5.2 Applying a Scheduling Template check 
This section provides instructions for setting up a schedule for a Resource using a 
Scheduling Template. 

To apply a scheduling template: 

1. Open the Edit Availability window by right-clicking a Resource and choosing 
Edit Resource Availability, as shown in Figure 6-1. 

2. Select a 1- Day View, 5- Day View, or 7-Day View from the View menu. 

3. Click Apply Template on the File menu. 

The Apply Access Template dialog box shown in Figure 6-10 opens. 
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Figure 6-10: Apply Access Template dialog box 

4. Click Select Access Template. The Open dialog box is displayed 

5. Locate folder that contains the template and choose the template you want. 

Note: A template has a .bsdxa file extension. 

6. Click Open to apply the template or Cancel to cancel your action. 

7. Choose the week for which you want to create a schedule by selecting a week 
from the Starting Week (Monday) list. 

8. Choose the number of weeks for which you want to create schedules from the 
Number of Weeks to Apply list. 

9. Click OK to apply this template to your schedule or Cancel to return to the Edit 
Availability window without creating a new schedule. 

Note: You cannot load a template if there are already Access 
Blocks defined for the particular week you are applying the 
template.  

You can edit individual Access Blocks using the Edit Access Block feature (see 
Editing an Access Block on page 48 for more information). 
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6.2 Using the Scheduling Management Window 
This section provides instructions for setup and administration tasks using the 
Scheduling Management window. Using this window, the Clinical Scheduling 
administrator can set up users and their privileges as well as schedules for the 
availability of doctors, procedures, clinics and the layout and appearance of the 
overall schedule. 

The procedures described in this section require the manager key. See your site 
administrator to determine or change your security keys. The Scheduling 
Management window shown in Figure 6-11 includes these tabs: 
• Resources and Users 
• Resource Groups 
• Access Types 

• Access Groups 
• Copy Appointments. 
• Workstations 

With the exception of the Copy Appointments tab, each tab contains a table. You can 
expand the first column of the table by clicking the plus sign (+). These rows are 
called group list rows. 

Figure 6-11: Scheduling management window 

When you click the (+) sign, the sub list is displayed in blue. Click the sub list to 

 

view the options for that list. When you select a sub list, you can return to the group 
list by clicking the left-arrow button located in the top right hand side of the table 
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view. You can also click Show/Hide (shown in Figure 6-12) for the current set of sub 
lists.  

 
Figure 6-12: Show/Hide button 

6.2.1 Defining Resources and Users 
The Resources and Users tab allows you to define the set of Resources available for 
scheduling at your facility. Resources can include providers (such as Dentists and 
Physicians) or other kinds of scheduled services, facilities, or equipment. The 
ResourceUser list, shown in Figure 6-13, allows you to manage the users who can 
schedule the Resource. To define the parameters of an RPMS Resource, you must log 
into RPMS and use the PIMS Scheduling Supervisor’s menus. 

 
Figure 6-13: Resources and users tab in scheduling management window 

6.2.1.1 Adding a Resource 
The following procedure provides instructions for adding a new resource. 

To add a new Resource: 

1. Select Scheduling Management from the File menu. 

2. Click the Resources and Users tab in the Scheduling Management window. 
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3. Click Add. The Add New Scheduling Resource dialog box shown in Figure 6-14 
opens. 

 
Figure 6-14: Add New Scheduling Resource dialog box 

4. Type the name of the Resource in the Resource Name text box.  

5. Select the default time scale for appointments from the Time Scale drop-down 
list. This time interval controls the time interval between appointments. 

6. Select the clinic, as needed, that you want this Resource linked to from the RPMS 
Clinic drop-down list in the RPMS Clinic field. 

7. Select Reminder Letter, Rebook Letter, or Cancellation Letter; and add the 
text as necessary. Figure 6-15 provided an example of letter text. 
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Figure 6-15: Reminder Letter tab on the Add New Scheduling Resource dialog box 

Note: Do not press return at the end of a line. Doing so closes this 
dialog box, sends you an error message, and takes you to the 
previous window. 

8. Click OK to save your letter or Cancel to dismiss the dialog box without saving 
your entries. 

This completes the procedure for adding a new resource. 

6.2.1.2 Editing a Resource 
This section provides instructions for editing a resource. Using the instructions in this 
section, you can: 

• Edit a resource name 

• Inactivate or reactivate a resource 

• Change the time scale of a resource 

• Revise RPMS clinic link information 

• Edit patient letters using the Reminder, Reboot, and Cancellation Letter tabs 
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To edit a Resource: 

1. Select Scheduling Management from the File menu. 

2. Click the Resources and Users tab in the Scheduling Management window 
shown in Figure 6-13. 

3. Select the Resource you want to edit. 

4. Click Change. The Edit Scheduling Resource window shown in Figure 6-16 
opens. 

 
Figure 6-16: Edit Scheduling Resource dialog box 

5. Make the following changes as necessary:  

• Change the name of the resource in the Resource Name text box. 

• Check or uncheck the Inactive box to inactive or reactive this resource. 

• Reset the minutes by selecting another number from the Time Scale list. 

• Edit the fields in the RPMS Clinic Link tab. To define the parameters for an 
RPMS clinic, you must log into RPMS and use the RPMS Scheduling 
Supervisor’s menu. 

• Select Reminder Letter, Rebook Letter, or Cancellation Letter; and edit 
the text as necessary. Figure 6-17 provided an example of letter text. 
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Figure 6-17: Reminder Letter tab on the Edit Scheduling Resource dialog box 

Note: Do not press return at the end of a line. Doing so closes this 
dialog box, sends you an error message, and take you to the 
previous window. 

6. Click OK to save your changes or Cancel to dismiss the dialog box without 
saving your entries. 

This completes the procedure for editing a resource. 

6.2.1.3 Maintaining Resource Users 
Use these steps to add, change, or remove users who can create appointments and 
establish availability for this Resource. Users must first be given basic access to the 
RPMS Scheduling package, using standard RPMS menu and key management before 
they can be selected and assigned as a resource user. 

To add, change, or remove Resource users: 

1. Select Scheduling Management from the File menu. 

2. Click the Resources and Users tab in the Scheduling Management window.  

3. Expand the Resource you want by clicking the plus sign (+) next to it as shown in 
Figure 6-18. 
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Figure 6-18: Defining Resource users 

4. Click ResourceUser.  

The current list of Resource Users is displayed. Figure 6-19 is provided as an 
example. 

 
Figure 6-19: New Resource User added 
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5. Do one of the following:  

• Click Add User to add a new user. The Add New Resource User dialog box 
shown in Figure 6-20 is displayed. Type the name of the new user and check 
the boxes as necessary. If you want this user to be able to overbook 
appointments, click the Overbook check box. If you want this user to be able 
to modify the schedule, click the Modify Clinic Availability check box. 
Click OK to add this user or Cancel to dismiss the dialog box without saving 
your entries.  

Note: At least one user at your site must be able to perform each of 
the tasks listed. It is also recommended that a limited number of 
users at each site have Modify Clinic Availability privileges. 

Figure 6-20: Add New Resource User dialog box 

• Select a user and click Change User to edit an existing 

 

user. The Edit 
Scheduling Resource dialog box shown in Figure 6-21 is displayed. Check or 
uncheck the attributes for the selected user as necessary. If you want this user 
to be able to overbook appointments, click the Overbook check box. If you 
want this user to be able to modify the schedule, click the Modify Clinic 
Availability check box. Click OK when you finish to save your changes or 
Cancel to dismiss the dialog box and discard your changes.  

Note: Only users who have the BSDXZMENU key in RPMS 
appear in the selection list. When you are editing an existing user, 
you cannot alter their name. 

User Manual 61 Setting Up and Administering BSDX 
   May 2008 



Clinical Scheduling for Windows (BSDX)  v2.0 

 
Figure 6-21: Edit Scheduling Resource dialog box 

• Select a user and click Remove User. Figure 6-22 shows the updated window 
after a user was deleted from this Resource. There is no confirmation message 
before the user is deleted so be careful to select the correct user. Click OK 
when you finish to save your changes or Cancel to dismiss the dialog box and 
keep this user. 
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Figure 6-22: Scheduling Management window with Resources and Users tab selected 

6.2.2 Resource Groups 
Use this window to organize Resources into useful groups. Resource Groups may 
include departments, clinics, or any other collection of Resources. Resource Groups 
are visible to all scheduling users.  

To display the Scheduling Management window shown in Figure 6-23 select 
Scheduling Management from the File menu. 
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Figure 6-23: Scheduling Management window with Resource Groups tab selected 

6.2.2.1 Adding a Resource Group 
This section provides instructions for adding a resource group. In the example shown 
in Figure 6-23  there are two resource groups displayed. After you add a resource 
group, you can add resources to the resource groups, you create. See Adding 
Resources to Resource Groups on page 66 for instructions. 

To add a Resource Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

3. Click Add Group to add a new Resource Group. The Add New Resource Group 
window is displayed. 

4. Type the name of the new Resource Group in the Resource Group Name text 
box as shown in Figure 6-24. 
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Figure 6-24: Adding a Resource Group 

5. Click OK to add the new Resource Group to the list of Resource Groups as 
shown in Figure 6-25 or Cancel to dismiss the dialog box without adding your 
entry. 

Figure 6-25: Adding a Resource Group  

This completes the s instructions for adding a resource group. You can add reso

 

urces 
to the resource groups you created. See Adding Resources to Resource Groups on 
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page 66 for instructions. Otherwise, select another tab or click Close to exit the 
Scheduling Management window. 

6.2.2.2 Adding Resources to Resource Groups 
This section provides instructions for adding resources such as diagnostics, clinics, 
procedures, and so forth to a resource. 

To add a resource to a resource group: 

1. Select Scheduling Management from the File menu. 

2. Click Resource Groups tab in the Scheduling Management window. 

3. Click the plus sign (+) next to the Resource Group to which you want to add a 
resource as shown in Figure 6-26. 

 
Figure 6-26: Adding Resources to groups (steps 1 and 3) 

4. Click GroupResource. A list of available Resources is displayed as shown in 
Figure 6-27. 
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Figure 6-27: Adding Resources to groups  

5. Select the Resource you want to add from the Select Resource drop-down list in 
the Add New Resource to Group dialog box and click OK. 

The Resource is now listed in the Resource Group as shown in Figure 6-28. 

Figure 6-28: Scheduling Management window showing new resource group 

This completes the procedure for adding a new resource to the Resources Groups tab. 
To remove a resource, see Removing a Resource from Resource Groups on page 71. 
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Otherwise, select another tab or click Close to exit the Scheduling Management 
window. 

6.2.2.3 Removing a Resource from Resource Groups 
This section provides instructions for removing a resource from a Resource Group. 

To remove a Resource from a group: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

Figure 6-29 is provided as an example 

 
Figure 6-29: Adding a Resource Group  

3. Click the plus sign (+) next to the Resource Group from which you want to 
remove a resource as shown in Figure 6-30. 
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Figure 6-30: Opening a list of Resources  

4. Click GroupResource to display a list of resources similar to the one shown in 
Figure 6-31. 

 
Figure 6-31: Removing a Resource  
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5. Select the resource you want to remove from the list. 

6. Click Remove Resource to delete this resource from the list. There is no 
confirmation message before the resource is deleted so be careful to select the 
correct resource. This does not delete the resource completely; it only removes 
the resource from the Resource Group. 

This completes the procedure for removing a resource from a Resource Group. To 
remove more resources, repeat this procedure. Otherwise, select another tab or click 
Close to exit the Scheduling Management window. 

6.2.2.4 Editing a Resource Group 
This section provides instructions for editing a Resource group. 

To edit a Resource Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

3. Select the Resource Group you want to change. 

4. Click Change Group to edit this Resource Group. The Edit Resource Group 
dialog box shown in Figure 6-32 is displayed. 

  
Figure 6-32: Edit Resource Group dialog box 

5. Change the name of the Resource Group in the Resource Group Name text box. 
No changes are made to the actual resources within the Resource Groups. 
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6. Click OK to save your changes or Cancel to dismiss the Edit Resource Group 
and return to the Resource Groups tab without changing the name. 

This completes the procedure for editing a Resource Group. Repeat this procedure to 
edit more Resource Groups, select another tab, or click Close to exit the Scheduling 
Management window. 

6.2.2.5 Removing a Resource Group 
Use this option to remove Resource Groups that are no longer needed. This does not 
delete the Resources within the group; only the group is deleted. 

To remove a Resource Group, follow: 

1. Select Scheduling Management from the File menu. 

2. Click the Resource Groups tab in the Scheduling Management window. 

3. Select the Resource Group you want to remove as shown in Figure 6-33. 

 
Figure 6-33: Removing a Resource Group 

4. Click Remove Group to remove a Resource Group. 

Note: There is no prompt asking you to confirm your choice, so be 
careful when removing Resource Groups. 

This completes the procedure for removing a Resource Group. Repeat this procedure 
to remove more Resource Groups; select another tab, or click Close to exit the 
Scheduling Management window. 
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6.2.3 Access Types 
Access types refer to the type of appointment being scheduled (such as routine 
physical, injection, and so on.). The following procedures provide instructions for 
adding and editing Access Types that can are used when scheduling an appointment. 

6.2.3.1 Add an Access Type 
The following procedure provides instructions for adding an access type. An access 
type describes an appointment category (for example: walk-in, first visit, routine 
exam, consultation, and so on. 

To add an Access Type: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Types tab in the Scheduling Management window. 

3. Click Add Access Type to add a new Access Type. The Manage Access Types 
dialog box is displayed. 

4. Type the name of the new Access Type in the Access Type Name text box of the 
Manage Access Types dialog box.. 

5. Click Select Display Color. The Color dialog box shown in Figure 6-34 is 
displayed. 

 
Figure 6-34: Manage Access Types  

6. Click a color swatch for the Basic color you want to assign to the new access type 
or click Define Custom Colors to create a new color. 
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If you define a custom color, click Add Custom Colors to save it on Custom 
colors palette on  the Color dialog box. 

7. Click OK on the Colors dialog box. 

8. Click OK on the Manage Access Types dialog box. 

9. Click OK in the Manage Access Types window. The new Access Type is now 
listed on the Access Types list. 

This completes the procedure for adding an Access Type. The following section 
provides instructions for editing an Access Type. Repeat this procedure to add more 
Access Types, select another tab, or click Close to exit the Scheduling Management 
window. 

6.2.3.2 Edit an Access Type 
This section provides instructions for editing an access type. Using the instructions in 
this section, you can: 

• Edit an access type name 

• Change the color used to display an access type 

• Change the status of an access type (by checking or unchecking Inactive) 

To edit an Access Type: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Types tab in the Scheduling Management window. 

3. Select the row for the Access Type you want to edit (in Figure 6-35 Inpatient is 
selected on the Access Types tab). 
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Figure 6-35: Screen examples for Editing an Access Type 

4. Click Change Access Type to edit the Access Type. The Manage Access Types 
dialog box shown in Figure 6-35 is displayed. 

5. Do any of the following as necessary:  

• Change the Access Type name, as necessary. 

• Click another color swatch for the Basic color you want to assign to the access 
type or click Define Custom Colors to create a new color. 

If you define a custom color , click Add Custom Colors to save it on Custom 
colors palette on  the Color dialog box. 

• Check or uncheck the Inactive box to change the status of the Access Type. 

6. Click OK to save your changes or Cancel to dismiss the Manage Access Types 
and return to the Access Types tab without saving your changes. 

This completes the procedure for editing an Access Type. Repeat this procedure to 
edit more Access Types, select another tab, or click Close to exit the Scheduling 
Management window. 

The following section provides instructions for adding, editing, and removing Access 
Groups, as well as adding Access Types to Access Groups. 

6.2.4 Access Groups 
Access Groups are categories of different Access Types. You can organize Access 
Types for faster searching and scheduling.  
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6.2.4.1 Add an Access Group 
The following procedure provides instructions for adding an Access Group. 

To add an Access Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window to display 
the Add New Access Group dialog box shown in Figure 6-36. 

 
Figure 6-36: Add New Access Group dialog box 

3. Click Add Group to add a new Access Group. The Add New Access Group 
dialog box shown in Figure 6-36 is displayed  

4. Type the name of the new Access Group in the Access Group Name text box. 

5. Click OK to add the new Access Group or Cancel to close the Add New Access 
Group dialog box without adding a new Access Group. 

If you clicked OK, the new Access Group is listed in the window as shown in the 
Figure 6-37. 
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Figure 6-37: Access Group dialog list with a new Access Group added 

This completes the procedure for adding a new Access Group. To add Access T

 

ypes 
to Access Groups, see Adding Access Types to Access Groups in the section that 
follows. Repeat this procedure to add more Access Groups, select another tab, or 
click Close to exit the Scheduling Management window. 

6.2.4.2 Adding Access Types to Access Groups 
This section provides instructions for adding Access Types to Access Groups. 

To add an Access Type to Access Groups 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window. 

3. Click the plus sign (+) next to the appropriate Access Group as shown in the 
example in Figure 6-38. 

User Manual 76 Setting Up and Administering BSDX 
   May 2008 



Clinical Scheduling for Windows (BSDX)  v2.0 

 
Figure 6-38: Adding an AccessGroup Type  

4. Click AccessGroupType. The list shown in Figure 6-39 is displayed. 

 
Figure 6-39: Adding an Access Type 

5. Click Add Type. The Add New Access Type to Group dialog box shown in 
Figure 6-40 is displayed. 
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Figure 6-40: Adding a New Access Type 

6. Select an Access Type from the Select Access Type drop-down list and click OK 
to add this Access Type or Cancel to return to the Scheduling Management 
Window without adding this Access Type. 

If you clicked OK, the new Access Type is now listed. Figure 6-41 is provided as 
an example. 

 
Figure 6-41: New Access Type Added to Access Group 
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This completes the procedure for adding new Access Types to Access Groups. You 
can continue adding more Access Types by using this procedure; or you can select 
another tab, or click Close to exit the Scheduling Management window.  

The procedure the follows provides instructions for editing an Access Group. 

6.2.4.3 Edit an Access Group 
Use this option to edit the name of an Access Group. 

To edit an Access Group 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window. 

3. Select the appropriate Access Group. 

4. Click Change. The Edit Access Group dialog box shown in Figure 6-42 is 
displayed. 

 
Figure 6-42: Editing an Access Group 

5. Edit the name of the Access Group in the Access Group Name text box shown in 
Figure 6-42. No changes are made to the actual Access Types within the Access 
Groups. 

6. Click OK to save the edited Access Group name or Cancel to return to the 
Scheduling Management window without changing the name. 

This completes the procedure for editing an Access Groups name. You can continue 
editing Access Group names as necessary by repeating this procedure, or you can 
select another tab, or click Close to exit the Scheduling Management window.  

s the procedure for editing an Access Groups name. You can continue 
editing Access Group names as necessary by repeating this procedure, or you can 
select another tab, or click Close to exit the Scheduling Management window.  
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The procedure the follows provides instructions for deleting an Access Group. 

6.2.4.4 Remove an Access Group 
The procedure that follows provides instructions for removing an Access Group that 
is no longer needed. This does not delete the Access Types within the group; only the 
Access Group is deleted. 

To remove an Access Group: 

1. Select Scheduling Management from the File menu. 

2. Click the Access Groups tab in the Scheduling Management window. 

3. Select the Access Group you want to remove. 

4. Click Remove Group to remove an Access Group as shown in Figure 6-43 

 
Figure 6-43: Removing an Access Group 

The Access Group is removed from the Access Groups window. 

Note: There is no prompt asking you to confirm your choice, so be 
careful when removing Access Groups. 

This completes the procedure for removing an Access Group. You can continue 
updating Access Groups, or you can select another tab, or click Close to exit the 
Scheduling Management window. 

The procedure the follows provides instructions for copying an RPMS appointments 
to this application. 
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6.2.5 Copy Appointments 
The following procedure provides instructions for copying appointments from an 
RPMS clinic in to this application. All appointments, except cancelled appointments, 
are copied from the RPMS clinic to the selected Resource. This is useful if you want 
to move all scheduling tasks from RPMS roll and scroll to this application with its 
graphical user interface instead of reentering them manually. 

To copy appointments from RPMS to an MS Windows Scheduling Resource, 

1. Select Scheduling Management from the File menu. 

2. Click the Copy Appointments tab in the Scheduling Management window to 
open the Copy Appointments tab shown in Figure 6-44. 

 
Figure 6-44: Copying appointments from RPMS into Windows Scheduling Resource 

3. Select the RPMS clinic from which you want to copy appointments using the 
Copy From RPMS Clinic drop-down menu. 

4. Select the Scheduling Resource to which you want to copy the appointments 
using the Copy To Windows Scheduling Resource drop-down menu. 

5. Select the beginning date for the appointment transfer from the Start with 
appointments on drop-down menu. 

6. Select the ending date for the appointment transfer from the End with 
appointments on drop-down menu. 

7. Click Copy Appointments. 

The Copy Appointments window shown in Figure 6-45 opens displaying Job 
Summary and Status boxes. 
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Figure 6-45: Copying appointments from RPMS into Windows Scheduling Resource 

8. Click Cancel to stop the transfer before it finishes or click OK when the transfer 
is done. 

This completes the procedure for copying RPMS appointments. You can continue 
moving more RPMS clinic schedules to this application, or you can select another 
tab, or click Close to exit the Scheduling Management window.  

The procedure that follows provides instructions for changing colors used to color 
code you schedule to identify various types of appointments (open, closed, booked, 
and so on). 

6.2.6 WorkStations 
The WorkStations tab in Schedule Management allows a system administrator to 
view, communicate with, and shut down workstations running the clinical scheduling 
application. 

6.2.6.1 Refresh Workstations List 
The section provides instructions for finding out which workstations on your network 
are currently running this application. 

To view the current list of workstations at your site running clinical scheduling 
software: 

1. Select Scheduling Management from the File menu. 
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2. Click the WorkStations tab in the Scheduling Management window to display 
the window shown in Figure 6-46. 

 
Figure 6-46: WorkStations tab 

3. Click Refresh to display a list of the workstations at your site running the clinical 
scheduling application. Figure 6-47 is provided as an example. 

 
Figure 6-47: Refresh list of active workstations 
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This completes the procedure for determining which workstations are currently 
running this application. You may now select another task under this tab, choose 
another tab, or click Close to exit the Scheduling Management window. The section 
that follows provides instructions for sending a message to workstations currently 
running this application. 

6.2.6.2 Send Message to Workstations 
This section provides instructions for sending messages to other workstations on your 
network currently running this application. This is useful when you need to shutdown 
the network or anytime you need to communication with all user logged on to the 
application quickly and efficiently. 

To send a message to workstations currently logged on to this application: 

1. Select Scheduling Management from the File menu. 

2. Click the WorkStations tab in the Scheduling Management window. 

3. Click Refresh. A list showing the workstations at your site currently running 
clinical scheduling application is updated. Figure 6-48 is provided as an example. 

 
Figure 6-48: Send a message to scheduling workstations. 

4. Click Send Message. The Send Message to Scheduling Client dialog box shown 
in Figure 6-49 opens.  
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Figure 6-49: Send message to scheduling clients dialog box 

5. Type the message you want to send in the text field and click OK. Figure 6-49 
provides an example of a message. 

Your message is sent to all clients currently logged into this application. Figure 
6-50 is provided as an example of a message other workstations receive. As the 
sender of the message, you do not receive the message on your system, nor do 
you receive any confirmation that the message was sent. 

 
Figure 6-50: Sent message 

This completes the instructions for sending a message to other workstations. You can 
now select another workstation task or Scheduling Management tab, or click Close to 
exit Scheduling Management. The section that follows provides instructions for 
stopping all workstations currently running this application. 

6.2.6.3 Stop Workstations 
This section provides instructions for stopping all workstations on your network 
currently running this application. 

To stop all workstations currently running this application: 

1. Select Scheduling Management from the File menu. 

2. Click the WorkStations tab in the Scheduling Management window. 

3. Click Refresh. A list of the workstations at your site running clinical scheduling 
software is displayed. Figure 6-51 is provided as an example. 
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Figure 6-51: Stop workstations 

4. Type a brief notification message in the text box next shown in Figure 6-51 and 
click Stop Workstations. 

The IHS Clinical Scheduling Client Shutdown confirmation dialog box shown in 
Figure 6-52 is displayed. 

 
Figure 6-52: Shutdown confirmation dialog box 

5. Click Yes to confirm shutdown or No to return to the Workstation tab without 
shutting down all clients currently running this application. 

Your message is sent to all clients currently logged into this application. Figure 
6-50 is provided as an example of a message other workstations receive. As the 
sender of the message, you do not receive the message on your system, nor do 
you receive any confirmation that the message was sent. 
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Figure 6-53: Shutdown notification message 

Users must click OK before the system can shutdown. All informa

 

tion entered 
into the system prior to the shutdown is saved. 

To verify that all systems have been shutdown, perform a Refresh (Section 
6.2.6.1) to locate all systems still running the clinical scheduling software. As the 
System Administrator, your system should be the only one on the list. 

Figure 6-54: Verify system shutdown and close scheduling management 

6. Click Close to exit Scheduling Management and the shutdown comme

 

nces. 
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7.0 Rules of Behavior Overview 

7.1 Background 
The Indian Health Service (IHS) Information Technology (IT) Rules of Behavior 
(RoB) summarize the laws and guidance from various IHS, Department of Health and 
Human Services (HHS), and other Federal requirements. All users of IHS IT 
resources should be fully aware of, and abide by, IHS security policies as well as 
related federal policy contained in the Office of Management and Budget (OMB) 
Circular A-130, the Health Insurance Portability and Accountability Act (HIPAA), 
the Privacy Act, the Freedom of Information Act (FOIA), and IHS Records 
Management Policy and procedures. These guidelines should be used by all IHS 
organizational components as a basis for their own security plans and procedures. 

These RoBs are founded on the principles described in the IHS published security 
policies and other regulatory documents such as the Code of Ethics for Government 
Employees, Office of Personnel Management regulations, OMB regulations and 
Standard of Conduct for Federal Employees, HHS policy and procedure and NIST 
Special Publications. Therefore, these RoBs carry the same responsibility for 
compliance as the official documents. 

7.2 Purpose 
The purpose of this SOP is to establish the RPMS RoBs. The RPMS RoBs are part of 
a comprehensive program to provide complete information security. These guidelines 
were established to hold users accountable for their actions and responsible for 
information security. The RPMS RoBs establish standards of behavior in recognition 
of the fact that knowledgeable users are the foundation of a successful security 
program. Users need to understand that taking personal responsibility for the security 
of their computer and the data it contains is an essential part of their job. 

IHS has many computer systems to which IHS, Tribal, or Urban (I/T/U) employees 
must be given access in order to accomplish their jobs. As each user processes into an 
organization upon initial employment, changes jobs within the organization, or leaves 
the organization, there is an opportunity and responsibility for the organization to 
give or take away access to IT systems. It is at these junctions in the employment 
process that the rules pertaining to this access should be explained to and agreed upon 
by the employer and the employee. It is the responsibility of the users, supervisors, 
and computer systems administrators to follow the policies, regulations, and 
procedures to protect and assure that IT resources are appropriately protected when 
authorizing access of IHS automated information and systems. 
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7.3 Scope 
This SOP applies to all IHS organizational components including, but not limited to, 
IHS headquarters offices and functions; all IHS area office locations and functional 
areas; all IHS service units and functions; all IHS funded or direct supported health 
facilities or locations; also to be included are all IHS partners’ facilities as described 
below. The term facilities includes all Indian Health Urban locations where health 
care is provided or managed; and all IHS or Tribally owned or operated hospitals, 
clinics or all other locations where the health care services are provided, managed or 
otherwise supported. 

• Facilities managed by Tribes or Tribal organizations that have retained IT shares 
with the IHS shall follow this SOP in accordance with their contracts or 
compacts. 

• It is recommended that facilities managed by Tribes or Tribal organizations that 
have taken their Information Technology shares follow this SOP. 

• Contractors’ facilities shall follow this SOP in accordance with their 
interconnection agreements with IHS. 

• For the purposes of this document, the use of the term IHS is intended to include 
any of the above facilities and employees of same. 

• These RoB procedures apply to all IHS facilities and are in accordance with HHS 
reporting requirements and directives. 

• This also includes individuals conducting business on behalf of the IHS through 
contractual relationships, unless they are specifically excluded under the terms of 
their contract. 

The policies contained in this SOP apply to all RPMS IT activities including the 
equipment, procedures, and technologies that are employed in managing these 
activities. The policy includes work performed while tele-working, on travel, at other 
off-site locations, and at all IHS office locations. 
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8.0 Specific RPMS Rules of Behavior 
All users (Contractors and IHS Employees) of RPMS will be provided a copy of the 
rules of behavior (RoB) and will have to acknowledge them in accordance IHS policy 
prior to being granted access to a RPMS system. The RPMS system is a United States 
Department of Health and Human Services, Indian Health Service information system 
that is FOR OFFICIAL USE ONLY. The system is subject to monitoring; therefore, 
no expectation of privacy shall be assumed. Individuals found performing 
unauthorized activities are subject to disciplinary action including criminal 
prosecution. 

RPMS users must follow these RoB in addition to the RoB listed in the IHS General 
User Security Handbook and, if a privileged user, the RoB listed in the IHS Technical 
and Managerial Handbook.  

IMPORTANT: The RoBs listed in this document are specific to 
RPMS. For a listing of general RoB for all users, please see the 
IHS General User Security Handbook and for a listing of system 
administrators/managers rules, the IHS Technical and Managerial 
Handbook located at http://home.ihs.gov/ITSC-
CIO/security/secpgm/ITproced.cfm.  

8.1 All RPMS Users 
In addition to these rules, each application may include additional RoBs, which may 
be defined within the individual application’s documentation (for example: PCC, 
Dental, or Pharmacy). 

8.1.1 Access 

RPMS Users Shall: 
• Only use data for which you have been granted authorization. 

• Only give information to personnel who have access authority and have a need to 
know.  

• Always verify a caller’s identification and job purpose with your supervisor or the 
entity provided as employer before providing any type of information system 
access, sensitive information, or non-public agency information. 

• Be aware that personal use of information resources is authorized on a limited 
basis within the provisions Indian Health Manual Chapter 6 OMS Limited 
Personal Use of Information Technology Resources TN 03-05," August 6, 2003. 
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Users Shall Not: 
• Retrieve information for someone who does not have authority to access the 

information. 

• Access, research, or change any user account, file, directory, table, or record not 
required to perform your OFFICIAL duties. 

• Store sensitive files on a PC hard drive, or portable devices or media, if access to 
the PC or files cannot be physically or technically limited. 

• Exceed their authorized access limits in RPMS by changing information or 
searching databases beyond the responsibilities of their job or by divulging 
information to anyone not authorized to know that information. 

8.1.2 Logging On To The System 

RPMS Users Shall: 
• Have a unique User Identification/Account name and password. 

• Be granted access based on authenticating the account name and password 
entered. 

• Be locked out of an account after 5 successive failed login attempts within a 
specified time period (e.g., one hour). 

8.1.3 Information Accessibility 
RPMS shall restrict access to information based on the type and identity of the user. 
However, regardless of the type of user, access shall be restricted to the minimum 
level necessary to perform the job. 

Users Shall: 
• Access only those documents they created and those other documents to which 

they have a valid need-to-know and to which they have specifically granted 
access through an RPMS application based on their menus (job roles), keys, and 
FileMan access codes. Some users may be afforded additional privileges based on 
the function they perform such as system administrator or application 
administrator. 

• Acquire a written preauthorization in accordance with IHS polices and procedures 
prior to interconnection to or transferring data from RPMS.  
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8.1.4 Accountability 

Users Shall: 
• Behave in an ethical, technically proficient, informed, and trustworthy manner. 

• Logout of the system whenever they leave the vicinity of their PC. 

• Be alert to threats and vulnerabilities in the security of the system. 

• Report all security incidents to their local Information System Security Officer 
(ISSO)  

• Differentiate tasks and functions to ensure that no one person has sole access to or 
control over important resources. 

• Protect all sensitive data entrusted to them as part of their government 
employment. 

• Shall abide by all Department and Agency policies and procedures and guidelines 
related to ethics, conduct, behavior and IT information processes. 

8.1.5 Confidentiality 

Users Shall: 
• Be aware of the sensitivity of electronic and hardcopy information, and protect it 

accordingly. 

• Store hardcopy reports/storage media containing confidential information in a 
locked room or cabinet. 

• Erase sensitive data on storage media, prior to reusing or disposing of the media. 

• Protect all RPMS terminals from public viewing at all times. 

• Abide by all HIPAA regulations to ensure patient confidentiality. 

Users Shall Not: 
• Allow confidential information to remain on the PC screen when someone who is 

not authorized to that data is in the vicinity. 

• Store sensitive files on a portable device or media without encrypting. 
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8.1.6 Integrity 

Users Shall: 
• Protect your system against viruses and similar malicious programs. 

• Observe all software license agreements.  

• Follow industry standard procedures for maintaining and managing RPMS 
hardware, operating system software, application software, or database software, 
or both, and database tables. 

• Comply with all copyright regulations and license agreements associated with 
RPMS software. 

Users Shall Not: 
• Violate Federal copyright laws. 

• Install or use unauthorized software within the system libraries or folders. 

• Use freeware, shareware, nor public domain software on (or with) your system 
without your manager’s written permission and without scanning it for viruses 
first. 

8.1.7 Passwords 

Users Shall: 
• Change passwords a minimum of every 90 days. 

• Create passwords with a minimum of eight characters. 

• If the system allows, use a combination of alpha and numeric characters for 
passwords, with at least one uppercase letter, one lower case letter, and one 
number and, if possible, a special character. 

• Change vendor-supplied passwords immediately. 

• Protect passwords by committing them to memory or store them in a safe place 
(do not store passwords in login scripts, or batch files).  

• Change password immediately if password is seen, guessed, or otherwise 
compromised. Report compromised or suspected compromise to your ISSO. 

• Keep user identifications (ID) and passwords confidential. 
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Users Shall Not: 
• Use common words found in any dictionary as a password. 

• Use obvious readable passwords or passwords that incorporate personal data 
elements (e.g., user’s name, date of birth, address, telephone number, or social 
security number; names of children or spouses; favorite band, sports team, or 
automobile; or other personal attributes). 

• Share passwords/IDs with anyone or accept the use of another’s password/ID, 
even if offered. 

• Reuse passwords. A new password must contain no more than five characters per 
8 characters from the previous password. 

• Post passwords. 

• Keep a password list in an obvious place, such as under keyboards, in desk 
drawers, or in any other location where it might be disclosed. 

• Give a password out over the phone. 

8.1.8 Backups 

Users Shall: 
• Plan for contingencies such as physical disasters, loss of processing, and 

disclosure of information by preparing alternate work strategies and system 
recovery mechanisms. 

• Make backups of systems and files on a regular, defined basis.  

• If possible, store backups away from the system in a secure environment. 

8.1.9 Reporting 

Users Shall: 
• Contact and inform your ISSO that you have identified an IT security incident and 

you will begin the reporting process by providing an IT Incident Reporting Form 
regarding this incident. 

• Report security incidents as detailed in IHS SOP 05-03, Incident Handling Guide. 
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Users Shall Not: 
• Assume that someone else has already reported an incident. The risk of an 

incident going unreported far outweighs the possibility that an incident gets 
reported more than once. 

8.1.10 Session Time Outs 
RPMS system implements system-based timeouts that back users out of a prompt 
after no more than 5 minutes of inactivity. 

Users Shall: 
• Utilize a screen saver with password protection set to suspend operations at no 

greater than 10-minutes of inactivity. This will prevent inappropriate access and 
viewing of any material displayed on your screen after some period of inactivity. 

8.1.11 Hardware 

Users Shall: 
• Avoid placing system equipment near obvious environmental hazards (e.g., water 

pipes).  

• Keep an inventory of all system equipment.  

• Keep records of maintenance/repairs performed on system equipment. 

Users Shall Not: 
• Do not eat or drink near system equipment. 

8.1.12 Awareness 

Users Shall: 
• Participate in organization-wide security training as required.  

• Read and adhere to security information pertaining to system hardware and 
software. 

• Take the annual information security awareness. 

• Read all applicable RPMS Manuals for the applications used in their jobs. 
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8.1.13 Remote Access 
Each subscriber organization establishes its own policies for determining which 
employees may work at home or in other remote workplace locations. Any remote 
work arrangement should include policies that: 

a) Are in writing; 

b) Provide authentication of the remote user through the use of ID and password or 
other acceptable technical means; 

c) Outline the work requirements and the security safeguards and procedures the 
employee is expected to follow; 

d) Ensure adequate storage of files, removal and non-recovery of temporary files 
created in processing sensitive data, virus protection, intrusion detection, and 
provides physical security for government equipment and sensitive data; and  

e) Establish mechanisms to back up data created and/or stored at alternate work 
locations. 

Remote Users Shall: 
• Remotely access RPMS through a virtual private network (VPN) when ever 

possible. Use of direct dial in access must be justified and approved in writing 
and its use secured in accordance with industry best practices or government 
procedures. 

Remote Users Shall Not: 
• Disable any encryption established for network, internet and web browser 

communications. 

8.2 RPMS Developers 

Developers Shall: 
• Always be mindful of protecting the confidentiality, availability, and integrity of 

RPMS when writing or revising code. 

• Always follow the IHS RPMS Programming Standards and Conventions (SAC) 
when developing for RPMS. 

• Only access information or code within the namespaces for which they have been 
assigned as part of their duties. 

User Manual 96 Specific RPMS RoBs 
  May 2008 



Clinical Scheduling for Windows (BSDX)  v2.0 

• Remember that all RPMS code is the property of the U.S. Government, not the 
developer. 

• Shall not access live production systems without obtaining appropriate written 
access, shall only retain that access for the shortest period possible to accomplish 
the task that requires the access. 

• Shall observe separation of duties policies and procedures to the fullest extent 
possible.  

• Shall document or comment all changes to any RPMS software at the time the 
change or update is made. Documentation shall include the programmer’s initials, 
date of change and reason for the change. 

• Shall use checksums or other integrity mechanism when releasing their certified 
applications to assure the integrity of the routines within their RPMS applications. 

• Shall follow industry best standards for systems they are assigned to develop or 
maintain; abide by all Department and Agency policies and procedures. 

• Shall document and implement security processes whenever available. 

Developers Shall Not: 
• Write any code that adversely impacts RPMS, such as backdoor access, “Easter 

eggs,” time bombs, or any other malicious code or make inappropriate comments 
within the code, manuals, or help frames. 

• Grant any user or system administrator access to RPMS unless proper 
documentation is provided.  

• Not release any sensitive agency or patient information. 

8.3 Privileged Users 
Personnel who have significant access to processes and data in RPMS, such as, 
system security administrators, systems administrators, and database administrators 
have added responsibilities to ensure the secure operation of RPMS. 

Privileged Users Shall: 
• Verify that any user requesting access to any RPMS system has completed the 

appropriate access request forms. 
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• Ensure that government personnel and contractor personnel understand and 
comply with license requirements. End users, supervisors, and functional 
managers are ultimately responsible for this compliance. 

• Advise the system owner on matters concerning information technology security. 

• Assist the system owner in developing security plans, risk assessments, and 
supporting documentation for the certification and accreditation process. 

• Ensure that any changes to RPMS that affect contingency and disaster recovery 
plans are conveyed to the person responsible for maintaining continuity of 
operations plans.  

• Ensure that adequate physical and administrative safeguards are operational 
within their areas of responsibility and that access to information and data is 
restricted to authorized personnel on a need to know basis.  

• Verify that users have received appropriate security training before allowing 
access to RPMS. 

• Implement applicable security access procedures and mechanisms, incorporate 
appropriate levels of system auditing, and review audit logs.  

• Document and investigate known or suspected security incidents or violations and 
report them to the ISSO, CISO, and systems owner. 

• Protect the supervisor, superuser or system administrator passwords. 

• Avoid instances where the same individual has responsibility for several functions 
(i.e., transaction entry and transaction approval). 

• Watch for unscheduled, unusual, and unauthorized programs. 

• Help train system users on the appropriate use and security of the system. 

• Establish protective controls to ensure the accountability, integrity, 
confidentiality, and availability of the system. 

• Replace passwords when a compromise is suspected. Delete user accounts as 
quickly as possible from the time that the user is no longer authorized system. 
Passwords forgotten by their owner should be replaced, not reissued. 

• Terminate user accounts when a user transfers or has been terminated. If the user 
has authority to grant authorizations to others, review these other authorizations. 
Retrieve any devices used to gain access to the system or equipment. Cancel 
logon IDs and passwords, and delete or reassign related active and back up files. 
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• Use a suspend program to prevent an unauthorized user from logging on with the 
current user's ID if the system is left on and unattended. 

• Verify the identity of the user when resetting passwords. This can be done either 
in person or having the user answer a question that can be compared to one in the 
administrator’s database. 

• Shall follow industry best standards for systems they are assigned to; abide by all 
Department and Agency policies and procedures. 

Privileged Shall Not: 
• Access any files, records, systems, etc., that are not explicitly needed to perform 

their duties 

• Grant any user or system administrator access to RPMS unless proper 
documentation is provided.  

• Not release any sensitive agency or patient information. 
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9.0 Specific BSDX RoBs 
There are no specific RoBs that are applicable to BSDX. 
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10.0 Glossary 
Term Definition 
Access Block Access Blocks are color-coded representations of the 

amount of time allotted for a specific Access Type (or 
appointment). 

Access Type Access Types refer to the variety of different appointment 
types available in the RPMS system. Each type of 
appointment, such as routine physical, dental, walk-in, or 
other specific appointment type is an Access Type. 

Access Group Access Groups are categories of Access Types. Assigning 
Access Types to Access Groups makes it easier to 
schedule and search for certain types of appointments. 

Appointment Date 
Selector 

Appears in the upper right corner of the screen, below the 
Minimize, Maximize, and Exit buttons. The date selected 
is the starting date of the appointments currently displayed 
in the scheduling pane The range of appointments 
displayed can be 1-day, 5-day, or 7-day. 

Archiving The storing of historical or little-used data off-line (often 
on tape). 

ASUFAC Number Area Service Unit Facility; A unique identifier for each 
facility within IHS. A six-digit number comprised of 2 
digits for Area, 2 digits for Service Unit, and 2 digits for 
Facility.  

Client Window Area on your screen that shows the work space for an 
application. 

Default Facility A user selects a facility identification to work with 
patients registered to that facility. 

Health Record 
Number (HRN) 

Each facility assigns a unique number within that facility 
to each patient. Each HRN with its facility identification 
“ASUFAC” make a unique identifier within all of IHS. 

Internal Entry 
Number (IEN) 

The number used to identify an entry within a file. Every 
record has a unique internal entry number. 
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Term Definition 

IRM Information Resource Management. The IHS personnel 
responsible for information systems management and 
security. 

Menu An item on the menu bar of an MS Windows application 
that includes a list of commands for performing specific 
actions. For example, the File menu includes commands 
for opening, saving, and printing files. 

Menu Bar Appears below the “Name and location of current user. 
The available text menus are: File, Appointment, View, 
and Help. 

Namespace A unique set of 2 to 4 alpha characters that are assigned by 
the database administrator to a software application. 

Official Registering A facility so designated that when HRNs are 
Facility added/modified, those changes are sent to the central 

database. A Service Unit may have several satellites for 
which it is registering patients. 

Pane A rectangular division of a-screen window that contains 
information for the user. A window may have many panes. 

Patient Care The central repository for data in the Resource and Patient 
Component (PCC) Management System (RPMS). 

Resource The term Resources refers to any person, service, or clinic 
for which a patient can be scheduled. Resources can be 
physicians, diagnostic equipment (such as MRI, CT scan, 
ultrasound, and so on.), or specialty appointment slots, 
such as physical therapy. However, only Resources that 
are clinics can be linked to an RPMS PIMS schedule. 

Resource Group Resource Groups are categories of Resources that help to 
organize the variety of Resources available at each 
location. 

Resource Group Pane Appears at the far left of the screen, below the menu bar. 
Displays the available Resources. 

Resource Name Appears in the upper left side of the screen, immediately 
above the Time column. Displays the name of the 
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Term Definition 
Resource currently active in the client window. 

Time Appears at the left side of the screen. Times are shown by 
hour and then by segment. They are listed in military time 
(for example 13:00 equals 1:00PM). 

Title Bar Shows user ID and facility location in the upper left corner 
of the screen 
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11.0 Contact Information 
If you have any questions or comments regarding this distribution, please contact the 
OIT User Support (IHS) by: 

Phone:  (505) 248-4371 or 

   (888) 830-7280 

Fax:   (505) 248-4297 

Web:   http://www.ihs.gov/GeneralWeb/HelpCenter/Helpdesk/index.cfm 

Email:  mailto:support@ihs.gov 
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