Namespaces

BMXNET 4.0 Developer API

Namespaces

Namespace | Description
IndianHealthService.BMXNet |
IndianHealthService.BMXNet.Ado |
IndianHealthService.BMXNet.EHR |
IndianHealthService.BMXNet.Model |
IndianHealthService.BMXNet.Net |
IndianHealthService.BMXNet.Util |
IndianHealthService.BMXNet.WinForm |
IndianHealthService.BMXNet.WinForm.Configuration |

Send comments about this topic to Microsoft.


IndianHealthService.BMXNet Namespace

| [image]
Visual Basic

C#

Visual C++

JavaScript

.NET Framework Class Library
IndianHealthService.BMXNet Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes | Interfaces
Name Description
BMXNetException
This simple exception wrapper is used for Exceptions thrown by umknown sources and by the BMX library. Check the InnerException for details.
LocalConsumer
This interface is used on UserControl-based components which are designed to work both inside the EHR and inside a WinForm application. "Consumer" interfaces basically tell Frameworks that a "Consumer"-implementating object need a specific service, versus the service being queried.
LocalEventArgs
The event args used by the LocalEventService.
LocalEventService
Access to local services are access through this interface.
LocalSession
The LocalSession is scoped to the client, whether EHR/VueCentric or a WinForm application. User management, patient/visit context, and local events are the key services. Components/controls that are programmed against this API will work within both the EhrFramework and WinFramework environments.
Log
Current Logging facility for BMXNet. This facility conforms to the EHR/VueCentric method of logging. Logging is either on or off, there is no scale from Info to Fatal to turn off and on.
M
Common M[umps] related function libraries implemented with static members.
RemoteEventArgs
The event args used by the RemoteEventService
RemoteEventService
All async communications with RPMS is performed through the RemoteEventService which is found by calling aRemoteSession.EventServices.
RemoteSession
All server-side RPMS RPC calls are performed through this interface. Each instance of RemoteSession corresponds to a single job (e.g. Cache process) on RPMS. There is always one primary RemoteSession and potentially more when using RemoteSessionPool. When the primary RemoteSession is closed all secondary pooled sessions are also closed and the server broker connection is terminated.
RemoteSessionConsumer
This interface is used on an UserControl-based components that are designed to work both inside the EHR and inside a WinForm application. The "Consumer" interfaces basically tell Frameworks that "Consumer" implementating objects need an specific service.
RemoteSessionPool

Each BMX connection to RPMS contains a single RemoteSessionPool with at least one Session, the primary session. Applications that need additional server processes beyond what can be done with async commands can used the RemoteSessionPool.

Access to the RemoteSessionPool is accomplished by implementing the RemoteSessionPoolConsumer interface on your component/control. Secondary sessions can be opened and closed as they are needed. If the AvailableSessionCount is zero then a null RemoteSession is returned so it is recommend to first check the if a pool HasAvailableSessions before an OpenSession() request.

RemoteSessionPool high-performance can be achieved by keeping RPMS server jobs alive even after secondary sessions are closed. The pool will maintain MaxSessions - 1 number of jobs alive on the server. If the application is finished for awhile needing IdleSessionCount idle jobs, then TerminateIdleSessions() will release those resources on the server. New jobs will then be created on demand.

RemoteSessionPoolConsumer
This interface is used on an UserControl-based components that are designed to work both inside the EHR and inside a WinForm application. The "Consumer" interfaces basically tell Frameworks that "Consumer" implementating objects need an specific service.


BMXNetException Class

Visual Basic

C#

Visual C++

JavaScript

| Members | See Also
.NET Framework Class Library
BMXNetException Class

BMXNET 4.0 Developer API

This simple exception wrapper is used for Exceptions thrown by umknown sources and by the BMX library. Check the InnerException for details.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
[SerializableAttribute]
public class BMXNetException : ApplicationException
<SerializableAttribute> _
Public Class BMXNetException _
    Inherits ApplicationException
[SerializableAttribute]
public ref class BMXNetException : public ApplicationException

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BMXNetException()()() |
BMXNetException(String) |
BMXNetException(SerializationInfo, StreamingContext) |
BMXNetException(String, Exception) |
Data | (Inherited from Exception.)
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetBaseException()()() | (Inherited from Exception.)
GetHashCode()()() | (Inherited from Object.)
GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
GetType()()() | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
MemberwiseClone()()() | (Inherited from Object.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)
ToString()()() | (Inherited from Exception.)

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
IndianHealthService.BMXNet..::.BMXNetException

See Also

IndianHealthService.BMXNet Namespace


BMXNetException Constructor

JavaScript

| See Also
.NET Framework Class Library
BMXNetException Constructor

BMXNET 4.0 Developer API

Overload List

Name | Description
BMXNetException()()() |
BMXNetException(String) |
BMXNetException(SerializationInfo, StreamingContext) |
BMXNetException(String, Exception) |

See Also

BMXNetException Class
IndianHealthService.BMXNet Namespace


BMXNetException Constructor

JavaScript

BMXNetException Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetException()
Public Sub New
public:
BMXNetException()

See Also

BMXNetException Class
BMXNetException Overload
IndianHealthService.BMXNet Namespace


BMXNetException Constructor (String)

JavaScript

BMXNetException Constructor (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
BMXNetException(
    String^ message
)

Parameters

message
String

See Also

BMXNetException Class
BMXNetException Overload
IndianHealthService.BMXNet Namespace


BMXNetException Constructor (SerializationInfo, StreamingContext)

JavaScript

BMXNetException Constructor (SerializationInfo, StreamingContext)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetException(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
BMXNetException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
SerializationInfo
context
StreamingContext

See Also

BMXNetException Class
BMXNetException Overload
IndianHealthService.BMXNet Namespace


BMXNetException Constructor (String, Exception)

JavaScript

BMXNetException Constructor (String, Exception)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetException(
    string message,
    Exception inner
)
Public Sub New ( _
    message As String, _
    inner As Exception _
)
public:
BMXNetException(
    String^ message,
    Exception^ inner
)

Parameters

message
String
inner
Exception

See Also

BMXNetException Class
BMXNetException Overload
IndianHealthService.BMXNet Namespace


BMXNetException Methods

JavaScript

BMXNetException Methods

BMXNET 4.0 Developer API

The BMXNetException type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetBaseException()()() | (Inherited from Exception.)
GetHashCode()()() | (Inherited from Object.)
GetObjectData(SerializationInfo, StreamingContext) | (Inherited from Exception.)
GetType()()() | (Inherited from Exception.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Exception.)

See Also

BMXNetException Class
IndianHealthService.BMXNet Namespace


BMXNetException Properties

JavaScript

BMXNetException Properties

BMXNET 4.0 Developer API

The BMXNetException type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Data | (Inherited from Exception.)
HelpLink | (Inherited from Exception.)
HResult | (Inherited from Exception.)
InnerException | (Inherited from Exception.)
Message | (Inherited from Exception.)
Source | (Inherited from Exception.)
StackTrace | (Inherited from Exception.)
TargetSite | (Inherited from Exception.)

See Also

BMXNetException Class
IndianHealthService.BMXNet Namespace


LocalConsumer Interface

JavaScript

| Members | See Also
.NET Framework Class Library
LocalConsumer Interface

BMXNET 4.0 Developer API

This interface is used on UserControl-based components which are designed to work both inside the EHR and inside a WinForm application. "Consumer" interfaces basically tell Frameworks that a "Consumer"-implementating object need a specific service, versus the service being queried.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface LocalConsumer
Public Interface LocalConsumer
public interface class LocalConsumer

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LocalSession | This property is set with a LocalSession by the framework. The receiver uses it for Context, local Events, and other services.

Remarks

If your component doesn't implement LocalConsumer you can still have a user-control. However, implementing LocalConsumer is very common because of exclusive access to the patient/visit Context.

See Also

IndianHealthService.BMXNet Namespace


LocalConsumer Properties

JavaScript

LocalConsumer Properties

BMXNET 4.0 Developer API

The LocalConsumer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LocalSession | This property is set with a LocalSession by the framework. The receiver uses it for Context, local Events, and other services.

See Also

LocalConsumer Interface
IndianHealthService.BMXNet Namespace


LocalSession Property

JavaScript

LocalConsumer..::LocalSession Property

BMXNET 4.0 Developer API

This property is set with a LocalSession by the framework. The receiver uses it for Context, local Events, and other services.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
LocalSession LocalSession { set; }
WriteOnly Property LocalSession As LocalSession
property LocalSession^ LocalSession {
    void set (LocalSession^ value);
}

See Also

LocalConsumer Interface
IndianHealthService.BMXNet Namespace


LocalEventArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
LocalEventArgs Class

BMXNET 4.0 Developer API

The event args used by the LocalEventService.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class LocalEventArgs : EventArgs
Public Class LocalEventArgs _
    Inherits EventArgs
public ref class LocalEventArgs : public EventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LocalEventArgs()()() |
Details | This is an optional peice of data with some event-specific details.
Equals(Object) | (Inherited from Object.)
EventType | This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed within a local desktop application (WinFramework) or in the EHR.
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
IndianHealthService.BMXNet..::.LocalEventArgs

See Also

IndianHealthService.BMXNet Namespace


LocalEventArgs Constructor

JavaScript

LocalEventArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public LocalEventArgs()
Public Sub New
public:
LocalEventArgs()

See Also

LocalEventArgs Class
IndianHealthService.BMXNet Namespace


LocalEventArgs Methods

JavaScript

LocalEventArgs Methods

BMXNET 4.0 Developer API

The LocalEventArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

LocalEventArgs Class
IndianHealthService.BMXNet Namespace


LocalEventArgs Properties

JavaScript

LocalEventArgs Properties

BMXNET 4.0 Developer API

The LocalEventArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Details | This is an optional peice of data with some event-specific details.
EventType | This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed within a local desktop application (WinFramework) or in the EHR.

See Also

LocalEventArgs Class
IndianHealthService.BMXNet Namespace


Details Property

JavaScript

LocalEventArgs..::Details Property

BMXNET 4.0 Developer API

This is an optional peice of data with some event-specific details.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Details { get; set; }
Public Property Details As String
public:
property String^ Details {
    String^ get ();
    void set (String^ value);
}

See Also

LocalEventArgs Class
IndianHealthService.BMXNet Namespace


EventType Property

JavaScript

| Example | See Also
.NET Framework Class Library
LocalEventArgs..::EventType Property

BMXNET 4.0 Developer API

This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed within a local desktop application (WinFramework) or in the EHR.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string EventType { get; set; }
Public Property EventType As String
public:
property String^ EventType {
    String^ get ();
    void set (String^ value);
}

Examples

The framewrk implements LocalSession.EventServices.RefreshRequested by sending or receiving the LocalEvent with the EventType=="REFRESH".

Examples

The Well Child Module growth chart displays Height and Weight. When the EHR vitals component adds new Heights and Weights it publishes a LocalEvent with an EventType PCC*MSR. If the growth chart detects the Vitals update event it then refreshes the growth chart:
Copy Code
             void Session_ApplicationEvent(object sender, LocalEventArgs e)
             {
                if (this.IsVitalsUpdatedEvent(e))
                {
                    this.RefreshAll();
                }
             }

             protected bool IsVitalsUpdatedEvent(LocalEventArgs anEvent)
             {
                return anEvent.EventType.StartsWith("PCC") && anEvent.EventType.EndsWith("MSR");
             }

See Also

LocalEventArgs Class
IndianHealthService.BMXNet Namespace


LocalEventService Interface

JavaScript

| Members | See Also
.NET Framework Class Library
LocalEventService Interface

BMXNET 4.0 Developer API

Access to local services are access through this interface.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface LocalEventService
Public Interface LocalEventService
public interface class LocalEventService

Members

All Members | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ApplicationEvent | Local event subscribers will have this event triggered.
HasSubscribers(String) | Checks to see there are any subscriptions for this event.
RefreshRequested | This commonly broadcasted event is request to refresh content.
Subscribe(String) | Subscribe to the local event named anEventName.
TriggerEvent(String, String) | To publish an event call TriggerEvent with the event name and optional details. There is no restriction on what local events that can be triggered. A "REFRESH" event can be broadcast as well as any other application specific or well-known loal event.
Unsubscribe(String) | Unscribe scribes from the event. It is not mandatory to unsubscribe from this event at the end of your object's lifecycle but you should either subsubscribe or remote the event handler.

See Also

IndianHealthService.BMXNet Namespace


LocalEventService Methods

JavaScript

LocalEventService Methods

BMXNET 4.0 Developer API

The LocalEventService type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
HasSubscribers(String) | Checks to see there are any subscriptions for this event.
Subscribe(String) | Subscribe to the local event named anEventName.
TriggerEvent(String, String) | To publish an event call TriggerEvent with the event name and optional details. There is no restriction on what local events that can be triggered. A "REFRESH" event can be broadcast as well as any other application specific or well-known loal event.
Unsubscribe(String) | Unscribe scribes from the event. It is not mandatory to unsubscribe from this event at the end of your object's lifecycle but you should either subsubscribe or remote the event handler.

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


HasSubscribers Method

JavaScript

LocalEventService..::HasSubscribers Method

BMXNET 4.0 Developer API

Checks to see there are any subscriptions for this event.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool HasSubscribers(
    string anEventName
)
Function HasSubscribers ( _
    anEventName As String _
) As Boolean
bool HasSubscribers(
    String^ anEventName
)

Parameters

anEventName
String
The name of the event checking to see if it's been subscribed already.

Return Value

Remarks

If publishing an event, there is no need to first check if there are subscribers unless there is a performance hit for the application to Trigger the event.

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


Subscribe Method

JavaScript

LocalEventService..::Subscribe Method

BMXNET 4.0 Developer API

Subscribe to the local event named anEventName.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Subscribe(
    string anEventName
)
Sub Subscribe ( _
    anEventName As String _
)
void Subscribe(
    String^ anEventName
)

Parameters

anEventName
String
The name of the event. This name should be shared and wellknown between many components.

Remarks

To receive published events, handle the ApplicationEvent. If you explicity subscript to the "REFRESH" event then both RefreshRequested and ApplicationEvent will be triggers.

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


TriggerEvent Method

JavaScript

LocalEventService..::TriggerEvent Method

BMXNET 4.0 Developer API

To publish an event call TriggerEvent with the event name and optional details. There is no restriction on what local events that can be triggered. A "REFRESH" event can be broadcast as well as any other application specific or well-known loal event.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void TriggerEvent(
    string anEventName,
    string someDetails
)
Sub TriggerEvent ( _
    anEventName As String, _
    someDetails As String _
)
void TriggerEvent(
    String^ anEventName,
    String^ someDetails
)

Parameters

anEventName
String
The event name. This is normally a well-known event that multiple components used for event-driven communications.
someDetails
String
An arbitrary string containing event specific data

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


Unsubscribe Method

JavaScript

LocalEventService..::Unsubscribe Method

BMXNET 4.0 Developer API

Unscribe scribes from the event. It is not mandatory to unsubscribe from this event at the end of your object's lifecycle but you should either subsubscribe or remote the event handler.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Unsubscribe(
    string anEventName
)
Sub Unsubscribe ( _
    anEventName As String _
)
void Unsubscribe(
    String^ anEventName
)

Parameters

anEventName
String
The name of the event unsubscribing from.

Return Value

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


LocalEventService Events

JavaScript

LocalEventService Events

BMXNET 4.0 Developer API

The LocalEventService type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ApplicationEvent | Local event subscribers will have this event triggered.
RefreshRequested | This commonly broadcasted event is request to refresh content.

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


ApplicationEvent Event

JavaScript

| Example | See Also
.NET Framework Class Library
LocalEventService..::ApplicationEvent Event

BMXNET 4.0 Developer API

Local event subscribers will have this event triggered.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler<LocalEventArgs> ApplicationEvent
Event ApplicationEvent As EventHandler(Of LocalEventArgs)
 event EventHandler<LocalEventArgs^>^ ApplicationEvent {
    void add (EventHandler<LocalEventArgs^>^ value);
    void remove (EventHandler<LocalEventArgs^>^ value);
}

Remarks

The "REFRESH" event is filtered out and is triggered using the RefreshRequested event

Examples

The Well Child Module growth chart displays Height and Weight. When the EHR vitals component adds new Heights and Weights it publishes a LocalEvent with an EventType PCC*MSR. If the growth chart detects the Vitals update event it then refreshes the growth chart:
Copy Code
                public void Startup()
                {
                    this.LocalSession.EventServices.ApplicationEvent+= new EventHandler<LocalEventArgs>(Session_ApplicationEvent);
                }

             void Session_ApplicationEvent(object sender, LocalEventArgs e)
             {
                if (this.IsVitalsUpdatedEvent(e))
                {
                    this.RefreshAll();
                }
             }

             protected bool IsVitalsUpdatedEvent(LocalEventArgs anEvent)
             {
                return anEvent.EventType.StartsWith("PCC") && anEvent.EventType.EndsWith("MSR");
             }

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


RefreshRequested Event

JavaScript

| Example | See Also
.NET Framework Class Library
LocalEventService..::RefreshRequested Event

BMXNET 4.0 Developer API

This commonly broadcasted event is request to refresh content.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler RefreshRequested
Event RefreshRequested As EventHandler
 event EventHandler^ RefreshRequested {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

In the EHR, this is equivalent to the "REFRESH" event. The WinFramework also uses "REFRESH" as the event name for triggering a refresh request.

Examples

The following code from Well Child Module's Growth Chart shows registering for the Refresh event at startup:
Copy Code
                 public void Startup()
                 {
                     this.LocalSession.EventServices.RefreshRequested += new EventHandler(Session_RefreshRequested);
                 }

                 void Session_RefreshRequested(object sender, EventArgs e)
                 {
                     this.RefreshAll();
                 }

See Also

LocalEventService Interface
IndianHealthService.BMXNet Namespace


LocalSession Interface

JavaScript

| Members | See Also
.NET Framework Class Library
LocalSession Interface

BMXNET 4.0 Developer API

The LocalSession is scoped to the client, whether EHR/VueCentric or a WinForm application. User management, patient/visit context, and local events are the key services. Components/controls that are programmed against this API will work within both the EhrFramework and WinFramework environments.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface LocalSession : Log
Public Interface LocalSession _
    Implements Log
public interface class LocalSession : Log

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()() | Call to close the LocalSession which is the last action to take when shutdown down your application.
Context | The current patient and visit context.
EventServices | Access to the LocalSessions EventServices
IsLogging | True if logging is currently enabled. It's recommend to turn logging off except for diagnositics. (Inherited from Log.)
Log(String, String, array<String>[]()[]) | Call to send information to the log. (Inherited from Log.)
Log(String, String, Exception, array<String>[]()[]) | Call to send information to the log where an exception occured. (Inherited from Log.)
NewUser(String, String, Division) | Create a new user object.
Notify(String, Exception) | Simple uniform call for local notifications to the user when an exception occurs.
Notify(String, String) | Simple uniform call for local notifications to the user.
User | Authenticated user associated with LocalSession

See Also

IndianHealthService.BMXNet Namespace


LocalSession Methods

JavaScript

LocalSession Methods

BMXNET 4.0 Developer API

The LocalSession type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()() | Call to close the LocalSession which is the last action to take when shutdown down your application.
Log(String, String, array<String>[]()[]) | Call to send information to the log. (Inherited from Log.)
Log(String, String, Exception, array<String>[]()[]) | Call to send information to the log where an exception occured. (Inherited from Log.)
NewUser(String, String, Division) | Create a new user object.
Notify(String, Exception) | Simple uniform call for local notifications to the user when an exception occurs.
Notify(String, String) | Simple uniform call for local notifications to the user.

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


Close Method

JavaScript

LocalSession..::Close Method

BMXNET 4.0 Developer API

Call to close the LocalSession which is the last action to take when shutdown down your application.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Close()
Sub Close
void Close()

Remarks

In the EHR this call does nothing because each instance of BMX EhrFramework manages a single component within the greater EHR/VueCentric framework. In a WinForm application this call shuts down the WinFramework, closes all RemoteSessions, and closes the LocalSession and disconnects from RPMS.

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


Log Method

JavaScript

LocalSession..::Log Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Log(String, String, array<String>[]()[]) | Call to send information to the log.
Log(String, String, Exception, array<String>[]()[]) | Call to send information to the log where an exception occured.

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


NewUser Method

JavaScript

LocalSession..::NewUser Method

BMXNET 4.0 Developer API

Create a new user object.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
User NewUser(
    string aName,
    string anIen,
    Division aDivision
)
Function NewUser ( _
    aName As String, _
    anIen As String, _
    aDivision As Division _
) As User
User^ NewUser(
    String^ aName,
    String^ anIen,
    Division^ aDivision
)

Parameters

aName
String
Display name of the user
anIen
String
IEN or DUZ of the User
aDivision
Division
Currently set division of the user

Return Value

Remarks

Instances of user are used by Frameworks or for configuration/comparisons.

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


Notify Method

JavaScript

LocalSession..::Notify Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Notify(String, Exception) | Simple uniform call for local notifications to the user when an exception occurs.
Notify(String, String) | Simple uniform call for local notifications to the user.

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


Notify Method (String, Exception)

JavaScript

LocalSession..::Notify Method (String, Exception)

BMXNET 4.0 Developer API

Simple uniform call for local notifications to the user when an exception occurs.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Notify(
    string aTitle,
    Exception anException
)
Sub Notify ( _
    aTitle As String, _
    anException As Exception _
)
void Notify(
    String^ aTitle,
    Exception^ anException
)

Parameters

aTitle
String
Title of the dialog
anException
Exception
Exception to be displayed

Remarks

API is not commonly used

See Also

LocalSession Interface
Notify Overload
IndianHealthService.BMXNet Namespace


Notify Method (String, String)

JavaScript

LocalSession..::Notify Method (String, String)

BMXNET 4.0 Developer API

Simple uniform call for local notifications to the user.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Notify(
    string aTitle,
    string aMessage
)
Sub Notify ( _
    aTitle As String, _
    aMessage As String _
)
void Notify(
    String^ aTitle,
    String^ aMessage
)

Parameters

aTitle
String
Title of the dialog
aMessage
String
Message to be displayed

Remarks

API is not commonly used.

See Also

LocalSession Interface
Notify Overload
IndianHealthService.BMXNet Namespace


LocalSession Properties

JavaScript

LocalSession Properties

BMXNET 4.0 Developer API

The LocalSession type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Context | The current patient and visit context.
EventServices | Access to the LocalSessions EventServices
IsLogging | True if logging is currently enabled. It's recommend to turn logging off except for diagnositics. (Inherited from Log.)
User | Authenticated user associated with LocalSession

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


Context Property

JavaScript

| Example | See Also
.NET Framework Class Library
LocalSession..::Context Property

BMXNET 4.0 Developer API

The current patient and visit context.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Context Context { get; }
ReadOnly Property Context As Context
property Context^ Context {
    Context^ get ();
}

Examples

The context object is access exclusively through the LocalSession and LocalSession events. The context can be obtained if your control or component is a LocalSessionConsumer and if so then define the Context property as follows:
Copy Code
            public Context Context
            {
                get { return this.LocalSession == null ? null : this.LocalSession.Context; }
            }

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


EventServices Property

JavaScript

LocalSession..::EventServices Property

BMXNET 4.0 Developer API

Access to the LocalSessions EventServices

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
LocalEventService EventServices { get; }
ReadOnly Property EventServices As LocalEventService
property LocalEventService^ EventServices {
    LocalEventService^ get ();
}

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


User Property

JavaScript

| Example | See Also
.NET Framework Class Library
LocalSession..::User Property

BMXNET 4.0 Developer API

Authenticated user associated with LocalSession

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
User User { get; }
ReadOnly Property User As User
property User^ User {
    User^ get ();
}

Remarks

If there are also RemoteSessions, the RemoteSessions will have the same User object

Examples

Copy Code
            this.StatusLabel.Text= aLocalSession.User == null ? "No user" : aLocalSession.User.Name;

See Also

LocalSession Interface
IndianHealthService.BMXNet Namespace


Log Interface

JavaScript

| Members | See Also
.NET Framework Class Library
Log Interface

BMXNET 4.0 Developer API

Current Logging facility for BMXNet. This facility conforms to the EHR/VueCentric method of logging. Logging is either on or off, there is no scale from Info to Fatal to turn off and on.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface Log
Public Interface Log
public interface class Log

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
IsLogging | True if logging is currently enabled. It's recommend to turn logging off except for diagnositics.
Log(String, String, array<String>[]()[]) | Call to send information to the log.
Log(String, String, Exception, array<String>[]()[]) | Call to send information to the log where an exception occured.

Remarks

Logging is not heavily used in BMXNET40. In the EHR/VueCentric, the VIM.exe can be started on the command-line with the /trace option to see RPC calls.

See Also

IndianHealthService.BMXNet Namespace


Log Methods

JavaScript

Log Methods

BMXNET 4.0 Developer API

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Log(String, String, array<String>[]()[]) | Call to send information to the log.
Log(String, String, Exception, array<String>[]()[]) | Call to send information to the log where an exception occured.

See Also

Log Interface
IndianHealthService.BMXNet Namespace


Log Method

JavaScript

Log..::Log Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Log(String, String, array<String>[]()[]) | Call to send information to the log.
Log(String, String, Exception, array<String>[]()[]) | Call to send information to the log where an exception occured.

See Also

Log Interface
IndianHealthService.BMXNet Namespace


Log Method (String, String, String[])

JavaScript

Log..::Log Method (String, String, array<String>[]()[])

BMXNET 4.0 Developer API

Call to send information to the log.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Log(
    string aClass,
    string aCategory,
    params string[] lines
)
Sub Log ( _
    aClass As String, _
    aCategory As String, _
    ParamArray lines As String() _
)
void Log(
    String^ aClass,
    String^ aCategory,
    ... array<String^>^ lines
)

Parameters

aClass
String
A grouping of log entries
aCategory
String
A sub-grouping of log entries
lines
array< String >[]()[]
Lines of text to write to the log

See Also

Log Interface
Log Overload
IndianHealthService.BMXNet Namespace


Log Method (String, String, Exception, String[])

JavaScript

Log..::Log Method (String, String, Exception, array<String>[]()[])

BMXNET 4.0 Developer API

Call to send information to the log where an exception occured.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Log(
    string aClass,
    string aCategory,
    Exception anException,
    params string[] lines
)
Sub Log ( _
    aClass As String, _
    aCategory As String, _
    anException As Exception, _
    ParamArray lines As String() _
)
void Log(
    String^ aClass,
    String^ aCategory,
    Exception^ anException,
    ... array<String^>^ lines
)

Parameters

aClass
String
A grouping of log entries
aCategory
String
A sub-grouping of log entries
anException
Exception
An exception to write to the log
lines
array< String >[]()[]
Lines of text to write to the log

See Also

Log Interface
Log Overload
IndianHealthService.BMXNet Namespace


Log Properties

JavaScript

Log Properties

BMXNET 4.0 Developer API

The Log type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
IsLogging | True if logging is currently enabled. It's recommend to turn logging off except for diagnositics.

See Also

Log Interface
IndianHealthService.BMXNet Namespace


IsLogging Property

JavaScript

Log..::IsLogging Property

BMXNET 4.0 Developer API

True if logging is currently enabled. It's recommend to turn logging off except for diagnositics.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsLogging { get; set; }
Property IsLogging As Boolean
property bool IsLogging {
    bool get ();
    void set (bool value);
}

See Also

Log Interface
IndianHealthService.BMXNet Namespace


M Class

JavaScript

| Members | See Also
.NET Framework Class Library
M Class

BMXNET 4.0 Developer API

Common M[umps] related function libraries implemented with static members.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static class M
Public NotInheritable Class M
public ref class M abstract sealed

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateFromFileMan(String) | M-like utility method to convert from a FileMan date/time formatted String to a .NET DateTime
DateToFileMan(DateTime) | M-like utility method to convert from a DateTime to the FileMan data/time format
Piece(String, String, Int32) | M-like utility method to answer the piece at a 1-based offset. Corresponds to M's $$Piece function
Piece(String, String, Int32, Int32) | M-like utility method to answer a delimited string of pieces between two 1-based offsets
PieceLength(String, String) | M-like utility method to answer the number of pieces limited by aDelimiter. Corresponds to M's $L(STRING,DELIMITER)

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet..::.M

See Also

IndianHealthService.BMXNet Namespace


M Methods

JavaScript

M Methods

BMXNET 4.0 Developer API

The M type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateFromFileMan(String) | M-like utility method to convert from a FileMan date/time formatted String to a .NET DateTime
DateToFileMan(DateTime) | M-like utility method to convert from a DateTime to the FileMan data/time format
Piece(String, String, Int32) | M-like utility method to answer the piece at a 1-based offset. Corresponds to M's $$Piece function
Piece(String, String, Int32, Int32) | M-like utility method to answer a delimited string of pieces between two 1-based offsets
PieceLength(String, String) | M-like utility method to answer the number of pieces limited by aDelimiter. Corresponds to M's $L(STRING,DELIMITER)

See Also

M Class
IndianHealthService.BMXNet Namespace


DateFromFileMan Method

JavaScript

M..::DateFromFileMan Method

BMXNET 4.0 Developer API

M-like utility method to convert from a FileMan date/time formatted String to a .NET DateTime

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static DateTime DateFromFileMan(
    string aString
)
Public Shared Function DateFromFileMan ( _
    aString As String _
) As DateTime
public:
static DateTime DateFromFileMan(
    String^ aString
)

Parameters

aString
String
date/time formated FileMan string

Return Value

.NET DateTime object from parsing input FileMan string

Exceptions

Exception | Condition
System..::.Exception | Exception thrown in conversion fails

See Also

M Class
IndianHealthService.BMXNet Namespace


DateToFileMan Method

JavaScript

M..::DateToFileMan Method

BMXNET 4.0 Developer API

M-like utility method to convert from a DateTime to the FileMan data/time format

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string DateToFileMan(
    DateTime aDateTime
)
Public Shared Function DateToFileMan ( _
    aDateTime As DateTime _
) As String
public:
static String^ DateToFileMan(
    DateTime aDateTime
)

Parameters

aDateTime
DateTime
DateTime to convert

Return Value

String representing aDateTime in FileMan format

Exceptions

Exception | Condition
System..::.Exception | Exception thrown in conversion fails

See Also

M Class
IndianHealthService.BMXNet Namespace


Piece Method

JavaScript

M..::Piece Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Piece(String, String, Int32) | M-like utility method to answer the piece at a 1-based offset. Corresponds to M's $$Piece function
Piece(String, String, Int32, Int32) | M-like utility method to answer a delimited string of pieces between two 1-based offsets

See Also

M Class
IndianHealthService.BMXNet Namespace


Piece Method (String, String, Int32)

JavaScript

| Example | See Also
.NET Framework Class Library
M..::Piece Method (String, String, Int32)

BMXNET 4.0 Developer API

M-like utility method to answer the piece at a 1-based offset. Corresponds to M's $$Piece function

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string Piece(
    string thePieces,
    string aDelimiter,
    int nthPiece
)
Public Shared Function Piece ( _
    thePieces As String, _
    aDelimiter As String, _
    nthPiece As Integer _
) As String
public:
static String^ Piece(
    String^ thePieces,
    String^ aDelimiter,
    int nthPiece
)

Parameters

thePieces
String
Delimited input string e.g. one^two^three
aDelimiter
String
Delimiter character or string, commonly ~ ^ or |
nthPiece
Int32
The 1-based index of the piece

Return Value

The piece at the index, or an empty string if the index is higher than the explicit number of pieces

Examples

Copy Code
                String demographics="DOE,JOHN~555-55-5555~34~M";
                int age=0;
                if (int.TryParse(M.Piece(demographics,"~",3), out age)) {
                    System.Console.Writeln(M.Piece(demographics,"~",1)+" is "+ (age >= 18 ) ? "an adult" : "a child");
                }

See Also

M Class
Piece Overload
IndianHealthService.BMXNet Namespace


Piece Method (String, String, Int32, Int32)

JavaScript

M..::Piece Method (String, String, Int32, Int32)

BMXNET 4.0 Developer API

M-like utility method to answer a delimited string of pieces between two 1-based offsets

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string Piece(
    string thePieces,
    string aDelimiter,
    int nthStart,
    int mthEnd
)
Public Shared Function Piece ( _
    thePieces As String, _
    aDelimiter As String, _
    nthStart As Integer, _
    mthEnd As Integer _
) As String
public:
static String^ Piece(
    String^ thePieces,
    String^ aDelimiter,
    int nthStart,
    int mthEnd
)

Parameters

thePieces
String
Delimited input string e.g. one^two^three
aDelimiter
String
Delimiter character or string, commonly ~ ^ or |
nthStart
Int32
Starting 1-based index of the pieces to copy from
mthEnd
Int32
Ending 1-based index of the pieces to copy to

Return Value

The delimited string from start to end, including delimitered blanks for indexes higher than the explicit number of pieces

See Also

M Class
Piece Overload
IndianHealthService.BMXNet Namespace


PieceLength Method

JavaScript

| Example | See Also
.NET Framework Class Library
M..::PieceLength Method

BMXNET 4.0 Developer API

M-like utility method to answer the number of pieces limited by aDelimiter. Corresponds to M's $L(STRING,DELIMITER)

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static int PieceLength(
    string thePieces,
    string aDelimiter
)
Public Shared Function PieceLength ( _
    thePieces As String, _
    aDelimiter As String _
) As Integer
public:
static int PieceLength(
    String^ thePieces,
    String^ aDelimiter
)

Parameters

thePieces
String
Delimited input string e.g. one^two^three
aDelimiter
String
Delimiter character or string, commonly ~ ^ or |

Return Value

Count of pieces in thePieces delimited by aDelimiter

Examples

Copy Code
                String team="DOE,JOHN^SMITH, PETER^JONES, SALLY";
                if (M.PieceLength(team,"~") >=5 ) {
                    this.PlayBasketBall();
                }
                else
                {
                    this.PlayTrackAndField();
                }

See Also

M Class
IndianHealthService.BMXNet Namespace


RemoteEventArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
RemoteEventArgs Class

BMXNET 4.0 Developer API

The event args used by the RemoteEventService

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class RemoteEventArgs : EventArgs
Public Class RemoteEventArgs _
    Inherits EventArgs
public ref class RemoteEventArgs : public EventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RemoteEventArgs()()() |
Details | This is an optional peice of data with some event-specific details.
Equals(Object) | (Inherited from Object.)
EventType | This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed between BMX implementations using RemoteSessions.
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
IndianHealthService.BMXNet..::.RemoteEventArgs

See Also

IndianHealthService.BMXNet Namespace


RemoteEventArgs Constructor

JavaScript

RemoteEventArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public RemoteEventArgs()
Public Sub New
public:
RemoteEventArgs()

See Also

RemoteEventArgs Class
IndianHealthService.BMXNet Namespace


RemoteEventArgs Methods

JavaScript

RemoteEventArgs Methods

BMXNET 4.0 Developer API

The RemoteEventArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

RemoteEventArgs Class
IndianHealthService.BMXNet Namespace


RemoteEventArgs Properties

JavaScript

RemoteEventArgs Properties

BMXNET 4.0 Developer API

The RemoteEventArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Details | This is an optional peice of data with some event-specific details.
EventType | This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed between BMX implementations using RemoteSessions.

See Also

RemoteEventArgs Class
IndianHealthService.BMXNet Namespace


Details Property

JavaScript

RemoteEventArgs..::Details Property

BMXNET 4.0 Developer API

This is an optional peice of data with some event-specific details.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Details { get; set; }
Public Property Details As String
public:
property String^ Details {
    String^ get ();
    void set (String^ value);
}

See Also

RemoteEventArgs Class
IndianHealthService.BMXNet Namespace


EventType Property

JavaScript

RemoteEventArgs..::EventType Property

BMXNET 4.0 Developer API

This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed between BMX implementations using RemoteSessions.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string EventType { get; set; }
Public Property EventType As String
public:
property String^ EventType {
    String^ get ();
    void set (String^ value);
}

See Also

RemoteEventArgs Class
IndianHealthService.BMXNet Namespace


RemoteEventService Interface

JavaScript

| Members | See Also
.NET Framework Class Library
RemoteEventService Interface

BMXNET 4.0 Developer API

All async communications with RPMS is performed through the RemoteEventService which is found by calling aRemoteSession.EventServices.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface RemoteEventService
Public Interface RemoteEventService
public interface class RemoteEventService

Members

All Members | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EventPollingInterval | The number of milliseconds (ms) to wait before polling. If a polling event is currently being processed when a second event is trigger, the second event is skipped. It's recommended to keep this interval at 5000 (5 seconds) or higher.
InvokedControl | Set InvokedControl to a form or control of your WinForm application or EHR/VueCentric component that will live the lifetime of your RemoteSession. The RemoteEventServices will Invoke() on the InvokedControl to ensure all events are triggered on the UI thread.
IsEventPollingEnabled | EventPolling is used for RemoteService events and Async RPC calls. IsEventPollingEnabled is used to turn polling on and off: True for on and False for off. The Async RPC framework and remote event service needs polling to be turned on.
RpmsEvent | This event is triggered when an event named anEventType is published and the receiver has a subscription. Remember that this event is not on the UI-thread unless InvokedControl is properly set.
Subscribe(String) | Subscribe to an event named anEventType. These events are trigger exclusivley by other BMXNet remote services and travel from client-to-server-to-client. Once subscribed, the RemoteSession will poll based on the EventPollingInterval to see if a server-side event is waiting to be triggered on the client.
TimerEvent | This event is triggered every time the event timer is triggered, based on the EventPollingInterval. Remember that this event is not on the UI-thread unless InvokedControl is properly set.
TriggerEvent(String, String, Boolean) | Access to a RemoteEventService also allows you to publish your own events. Publishing is done through design and documentation to notify other developers what events you will trigger. An event is published, or triggered, by using TriggerEvent with the name of the event, an optional event specific string with data, and whether or not the publisher, if subsubscribed, wants the event published to them.
Unsubscribe(String) | Unsubscribe from an event named anEventType. Once unsubscribed, published events named anEventType will no longer trigger an event for this RemoteSession.

Remarks

By default remote events are asynchronous and are not on the UI thread. The development must handed the events propertly and if interacting with a user interface control must use Invoke(). As a convinenence, InvokedControl can be set to any non-disposed Control and the event service is use Invoke() so that the event is triggered on the UI thread

The Event timer, IsEventPollingEnabled and EventPollingInterval, is used by the Async RPC calls and is automattically turned on with IsEventPollingEnabled. If the developer turns on polling or changes the EventPollingInterval to be a long period, then the Async RPC calls will not respond in a timely manner if at all.

See Also

IndianHealthService.BMXNet Namespace


RemoteEventService Methods

JavaScript

RemoteEventService Methods

BMXNET 4.0 Developer API

The RemoteEventService type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Subscribe(String) | Subscribe to an event named anEventType. These events are trigger exclusivley by other BMXNet remote services and travel from client-to-server-to-client. Once subscribed, the RemoteSession will poll based on the EventPollingInterval to see if a server-side event is waiting to be triggered on the client.
TriggerEvent(String, String, Boolean) | Access to a RemoteEventService also allows you to publish your own events. Publishing is done through design and documentation to notify other developers what events you will trigger. An event is published, or triggered, by using TriggerEvent with the name of the event, an optional event specific string with data, and whether or not the publisher, if subsubscribed, wants the event published to them.
Unsubscribe(String) | Unsubscribe from an event named anEventType. Once unsubscribed, published events named anEventType will no longer trigger an event for this RemoteSession.

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


Subscribe Method

JavaScript

RemoteEventService..::Subscribe Method

BMXNET 4.0 Developer API

Subscribe to an event named anEventType. These events are trigger exclusivley by other BMXNet remote services and travel from client-to-server-to-client. Once subscribed, the RemoteSession will poll based on the EventPollingInterval to see if a server-side event is waiting to be triggered on the client.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int Subscribe(
    string anEventType
)
Function Subscribe ( _
    anEventType As String _
) As Integer
int Subscribe(
    String^ anEventType
)

Parameters

anEventType
String
The name of the event to subscribe to

Return Value

1 if successful, otherwise it's an error. Refer to KIDS source for error codes.

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


TriggerEvent Method

JavaScript

RemoteEventService..::TriggerEvent Method

BMXNET 4.0 Developer API

Access to a RemoteEventService also allows you to publish your own events. Publishing is done through design and documentation to notify other developers what events you will trigger. An event is published, or triggered, by using TriggerEvent with the name of the event, an optional event specific string with data, and whether or not the publisher, if subsubscribed, wants the event published to them.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int TriggerEvent(
    string anEventType,
    string aParameter,
    bool raiseBack
)
Function TriggerEvent ( _
    anEventType As String, _
    aParameter As String, _
    raiseBack As Boolean _
) As Integer
int TriggerEvent(
    String^ anEventType,
    String^ aParameter,
    bool raiseBack
)

Parameters

anEventType
String
Name of the event to publish
aParameter
String
An optional string with event specific data
raiseBack
Boolean
Set to True if the publisher of anEventType, that is also a subscriber to anEventType, also wants the event to be triggered back to them

Return Value

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


Unsubscribe Method

JavaScript

RemoteEventService..::Unsubscribe Method

BMXNET 4.0 Developer API

Unsubscribe from an event named anEventType. Once unsubscribed, published events named anEventType will no longer trigger an event for this RemoteSession.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int Unsubscribe(
    string anEventType
)
Function Unsubscribe ( _
    anEventType As String _
) As Integer
int Unsubscribe(
    String^ anEventType
)

Parameters

anEventType
String
The name of the event to unsubscribe from

Return Value

1 if successful, otherwise it's an error. Refer to KIDS source for error codes.

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


RemoteEventService Properties

JavaScript

RemoteEventService Properties

BMXNET 4.0 Developer API

The RemoteEventService type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EventPollingInterval | The number of milliseconds (ms) to wait before polling. If a polling event is currently being processed when a second event is trigger, the second event is skipped. It's recommended to keep this interval at 5000 (5 seconds) or higher.
InvokedControl | Set InvokedControl to a form or control of your WinForm application or EHR/VueCentric component that will live the lifetime of your RemoteSession. The RemoteEventServices will Invoke() on the InvokedControl to ensure all events are triggered on the UI thread.
IsEventPollingEnabled | EventPolling is used for RemoteService events and Async RPC calls. IsEventPollingEnabled is used to turn polling on and off: True for on and False for off. The Async RPC framework and remote event service needs polling to be turned on.

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


EventPollingInterval Property

JavaScript

RemoteEventService..::EventPollingInterval Property

BMXNET 4.0 Developer API

The number of milliseconds (ms) to wait before polling. If a polling event is currently being processed when a second event is trigger, the second event is skipped. It's recommended to keep this interval at 5000 (5 seconds) or higher.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int EventPollingInterval { get; set; }
Property EventPollingInterval As Integer
property int EventPollingInterval {
    int get ();
    void set (int value);
}

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


InvokedControl Property

JavaScript

RemoteEventService..::InvokedControl Property

BMXNET 4.0 Developer API

Set InvokedControl to a form or control of your WinForm application or EHR/VueCentric component that will live the lifetime of your RemoteSession. The RemoteEventServices will Invoke() on the InvokedControl to ensure all events are triggered on the UI thread.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Control InvokedControl { get; set; }
Property InvokedControl As Control
property Control^ InvokedControl {
    Control^ get ();
    void set (Control^ value);
}

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


IsEventPollingEnabled Property

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteEventService..::IsEventPollingEnabled Property

BMXNET 4.0 Developer API

EventPolling is used for RemoteService events and Async RPC calls. IsEventPollingEnabled is used to turn polling on and off: True for on and False for off. The Async RPC framework and remote event service needs polling to be turned on.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsEventPollingEnabled { get; set; }
Property IsEventPollingEnabled As Boolean
property bool IsEventPollingEnabled {
    bool get ();
    void set (bool value);
}

Remarks

If Async RPC's or remote events are not working debug the RemoteEventService to verify polling is enabled and configured.

Examples

If using Async RPC or remote service events activate and configure the timer when your applications starts
Copy Code
            ... //Poll every 10000 ms, or 10 seconds
                this.RemoteSession.EventServices.EventPollingInterval=10000;
                this.RemoteSession.EventServices.IsEventPollingEnabled=True;
            ...
            ... //Perhaps in another part of your application you have a small active Chat Window
            ... //Increase the frequency of polling by decreasing the EventPollingInterval to every 2 seconds
                this.RemoteSession.EventServices.EventPollingInterval=2000;

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


RemoteEventService Events

JavaScript

RemoteEventService Events

BMXNET 4.0 Developer API

The RemoteEventService type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RpmsEvent | This event is triggered when an event named anEventType is published and the receiver has a subscription. Remember that this event is not on the UI-thread unless InvokedControl is properly set.
TimerEvent | This event is triggered every time the event timer is triggered, based on the EventPollingInterval. Remember that this event is not on the UI-thread unless InvokedControl is properly set.

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


RpmsEvent Event

JavaScript

RemoteEventService..::RpmsEvent Event

BMXNET 4.0 Developer API

This event is triggered when an event named anEventType is published and the receiver has a subscription. Remember that this event is not on the UI-thread unless InvokedControl is properly set.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler<RemoteEventArgs> RpmsEvent
Event RpmsEvent As EventHandler(Of RemoteEventArgs)
 event EventHandler<RemoteEventArgs^>^ RpmsEvent {
    void add (EventHandler<RemoteEventArgs^>^ value);
    void remove (EventHandler<RemoteEventArgs^>^ value);
}

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


TimerEvent Event

JavaScript

RemoteEventService..::TimerEvent Event

BMXNET 4.0 Developer API

This event is triggered every time the event timer is triggered, based on the EventPollingInterval. Remember that this event is not on the UI-thread unless InvokedControl is properly set.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler TimerEvent
Event TimerEvent As EventHandler
 event EventHandler^ TimerEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Remarks

Respond quickly to this event.

See Also

RemoteEventService Interface
IndianHealthService.BMXNet Namespace


RemoteSession Interface

JavaScript

| Members | See Also
.NET Framework Class Library
RemoteSession Interface

BMXNET 4.0 Developer API

All server-side RPMS RPC calls are performed through this interface. Each instance of RemoteSession corresponds to a single job (e.g. Cache process) on RPMS. There is always one primary RemoteSession and potentially more when using RemoteSessionPool. When the primary RemoteSession is closed all secondary pooled sessions are also closed and the server broker connection is terminated.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface RemoteSession
Public Interface RemoteSession
public interface class RemoteSession

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AppContext
The active AppContext (OPTION) of this remote session.
AsyncTableFromCommand(String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, DataSet, String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, DataSet, String, String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, DataSet, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, DataSet, String, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromSQL(String)
AsyncTableFromSQL(String, String)
AsyncTableFromSQL(String, DataSet, String)
AsyncTableFromSQL(String, DataSet, String, String)
Close()()()
When done with session it should be closed. Once closed it is unusable.
DebugLastRpcResult
String value of last successful non-DataTable RPC call
DebugLastRpcSignature
String describing RPC call and input parameters of last non-DataTable RPC call
DebugLastTableResult
Last DataTable retrieved by non-async calls
EventServices
Access the session's RemoteEventServices service provider to configure receiving remote events and to source new events.
HostAddress
BMX Broker's host address name or IP Address
IsBmxAdoCommand(String)
Answer True if aString is a standard BMX ADO SS command that uses the BMX ADO SCHEMA files
IsPrimary
The primary session has the unique in that it holds the authenication privileges for all sessions. If you close the primary session, then all will close.
Job
Job number of server-side Cache/MDB process. Very useful for debugging.
Log
ReceiveTimeout
The networking data receive timeout (in milliseconds). This value can be changed if the developer finds it neccessary to extend the time after login.
RpcResult
String value of last successful non-DataTable RPC call
SafelyTransmitRPC(String, String)
Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.
SafelyTransmitRPC(String, String, String)
Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.
SaveChanges(DataTable)

Examples

Copy Code

            this.Context.Visit.Create();
            if (this.Context.Visit.IsStub)
            {
                if (!this.Context.Visit.Create())
                {
                    return false;
                }
            }
            this.RemoteSession.SaveChanges(this.ScoreTable);
SendTimeout
The networking data send timeout (in milliseconds). This value can be changed if the developer finds it neccessary to extend the time after login but normally the send timeout should be kept short unless network conditions are poor.
TableFromCommand(String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, DataSet, String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, DataSet, String, String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromRPC(String, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, DataSet, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, DataSet, String, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromSQL(String)
TableFromSQL(String, String)
TableFromSQL(String, DataSet, String)
TableFromSQL(String, DataSet, String, String)
SELECT VA_PATIENT.NAME, VA_PATIENT.SSN, PATIENT.CURRENT_COMMUNITY FROM VA_PATIENT, PATIENT WHERE VA_PATIENT.BMXIEN =* INTERNAL[PATIENT.NAME] AND VA_PATIENT.NAME LIKE 'DEMO%' AND VA_PATIENT.AGE BETWEEN 15 AND 24 SHOWPLAN
TransmitRPC(String, String)
Calls a remote procedure on the RPMS server and returns the result as a String.
TransmitRPC(String, String, String)
User
Authenticated user associated with this remote session

See Also

IndianHealthService.BMXNet Namespace


RemoteSession Methods

JavaScript

RemoteSession Methods

BMXNET 4.0 Developer API

The RemoteSession type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AsyncTableFromCommand(String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, DataSet, String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, DataSet, String, String)
Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, DataSet, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, DataSet, String, String)
Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromSQL(String)
AsyncTableFromSQL(String, String)
AsyncTableFromSQL(String, DataSet, String)
AsyncTableFromSQL(String, DataSet, String, String)
Close()()()
When done with session it should be closed. Once closed it is unusable.
IsBmxAdoCommand(String)
Answer True if aString is a standard BMX ADO SS command that uses the BMX ADO SCHEMA files
SafelyTransmitRPC(String, String)
Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.
SafelyTransmitRPC(String, String, String)
Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.
SaveChanges(DataTable)

Examples

Copy Code

            this.Context.Visit.Create();
            if (this.Context.Visit.IsStub)
            {
                if (!this.Context.Visit.Create())
                {
                    return false;
                }
            }
            this.RemoteSession.SaveChanges(this.ScoreTable);
TableFromCommand(String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, DataSet, String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, DataSet, String, String)
Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromRPC(String, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, DataSet, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, DataSet, String, String)
TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromSQL(String)
TableFromSQL(String, String)
TableFromSQL(String, DataSet, String)
TableFromSQL(String, DataSet, String, String)
SELECT VA_PATIENT.NAME, VA_PATIENT.SSN, PATIENT.CURRENT_COMMUNITY FROM VA_PATIENT, PATIENT WHERE VA_PATIENT.BMXIEN =* INTERNAL[PATIENT.NAME] AND VA_PATIENT.NAME LIKE 'DEMO%' AND VA_PATIENT.AGE BETWEEN 15 AND 24 SHOWPLAN
TransmitRPC(String, String)
Calls a remote procedure on the RPMS server and returns the result as a String.
TransmitRPC(String, String, String)

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


AsyncTableFromCommand Method

JavaScript

RemoteSession..::AsyncTableFromCommand Method

BMXNET 4.0 Developer API

Overload List

Name | Description
AsyncTableFromCommand(String) | Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, String) | Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, DataSet, String) | Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromCommand(String, DataSet, String, String) | Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


AsyncTableFromCommand Method (String)

JavaScript

RemoteSession..::AsyncTableFromCommand Method (String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromCommand(
    string aCommand
)
Function AsyncTableFromCommand ( _
    aCommand As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromCommand(
    String^ aCommand
)

Parameters

aCommand
String
The name of the RPC

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromCommand Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromCommand Method (String, String)

JavaScript

RemoteSession..::AsyncTableFromCommand Method (String, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromCommand(
    string aCommand,
    string aContext
)
Function AsyncTableFromCommand ( _
    aCommand As String, _
    aContext As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromCommand(
    String^ aCommand,
    String^ aContext
)

Parameters

aCommand
String
The name of the RPC
aContext
String
The AppContext to set prior to the call

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromCommand Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromCommand Method (String, DataSet, String)

JavaScript

RemoteSession..::AsyncTableFromCommand Method (String, DataSet, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromCommand(
    string aCommand,
    DataSet aDataSet,
    string aTableName
)
Function AsyncTableFromCommand ( _
    aCommand As String, _
    aDataSet As DataSet, _
    aTableName As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromCommand(
    String^ aCommand,
    DataSet^ aDataSet,
    String^ aTableName
)

Parameters

aCommand
String
The name of the RPC
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromCommand Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromCommand Method (String, DataSet, String, String)

JavaScript

RemoteSession..::AsyncTableFromCommand Method (String, DataSet, String, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromCommand call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromCommand(
    string aCommand,
    DataSet aDataSet,
    string aTableName,
    string aContext
)
Function AsyncTableFromCommand ( _
    aCommand As String, _
    aDataSet As DataSet, _
    aTableName As String, _
    aContext As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromCommand(
    String^ aCommand,
    DataSet^ aDataSet,
    String^ aTableName,
    String^ aContext
)

Parameters

aCommand
String
The name of the RPC
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create
aContext
String
The AppContext to set prior to the call

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromCommand Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromRPC Method

JavaScript

RemoteSession..::AsyncTableFromRPC Method

BMXNET 4.0 Developer API

Overload List

Name | Description
AsyncTableFromRPC(String, String) | Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, String) | Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, DataSet, String) | Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future
AsyncTableFromRPC(String, String, DataSet, String, String) | Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


AsyncTableFromRPC Method (String, String)

JavaScript

RemoteSession..::AsyncTableFromRPC Method (String, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromRPC(
    string rpcCommand,
    string rpcParameter
)
Function AsyncTableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromRPC Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromRPC Method (String, String, String)

JavaScript

RemoteSession..::AsyncTableFromRPC Method (String, String, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromRPC(
    string rpcCommand,
    string rpcParameter,
    string context
)
Function AsyncTableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    context As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    String^ context
)

Parameters

rpcCommand
String
rpcParameter
String
context
String

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromRPC Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromRPC Method (String, String, DataSet, String)

JavaScript

RemoteSession..::AsyncTableFromRPC Method (String, String, DataSet, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromRPC(
    string rpcCommand,
    string rpcParameter,
    DataSet aDataSet,
    string aTableName
)
Function AsyncTableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    aDataSet As DataSet, _
    aTableName As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    DataSet^ aDataSet,
    String^ aTableName
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromRPC Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromRPC Method (String, String, DataSet, String, String)

JavaScript

RemoteSession..::AsyncTableFromRPC Method (String, String, DataSet, String, String)

BMXNET 4.0 Developer API

Same as the corresponding TableFromRPC call except a DataTableFuture is returned. See DataTableFuture on how to use a 'Future

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromRPC(
    string rpcCommand,
    string rpcParameter,
    DataSet aDataSet,
    string aTableName,
    string aContext
)
Function AsyncTableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    aDataSet As DataSet, _
    aTableName As String, _
    aContext As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    DataSet^ aDataSet,
    String^ aTableName,
    String^ aContext
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create
aContext
String
The AppContext to set prior to the call

Return Value

A DataTableFuture

See Also

RemoteSession Interface
AsyncTableFromRPC Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromSQL Method

JavaScript

RemoteSession..::AsyncTableFromSQL Method

BMXNET 4.0 Developer API

Overload List

Name | Description
AsyncTableFromSQL(String) |
AsyncTableFromSQL(String, String) |
AsyncTableFromSQL(String, DataSet, String) |
AsyncTableFromSQL(String, DataSet, String, String) |

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


AsyncTableFromSQL Method (String)

JavaScript

RemoteSession..::AsyncTableFromSQL Method (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromSQL(
    string sql
)
Function AsyncTableFromSQL ( _
    sql As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromSQL(
    String^ sql
)

Parameters

sql
String

See Also

RemoteSession Interface
AsyncTableFromSQL Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromSQL Method (String, String)

JavaScript

RemoteSession..::AsyncTableFromSQL Method (String, String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromSQL(
    string sql,
    string aContext
)
Function AsyncTableFromSQL ( _
    sql As String, _
    aContext As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromSQL(
    String^ sql,
    String^ aContext
)

Parameters

sql
String
aContext
String

See Also

RemoteSession Interface
AsyncTableFromSQL Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromSQL Method (String, DataSet, String)

JavaScript

RemoteSession..::AsyncTableFromSQL Method (String, DataSet, String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromSQL(
    string sql,
    DataSet aDataSet,
    string aTableName
)
Function AsyncTableFromSQL ( _
    sql As String, _
    aDataSet As DataSet, _
    aTableName As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromSQL(
    String^ sql,
    DataSet^ aDataSet,
    String^ aTableName
)

Parameters

sql
String
aDataSet
DataSet
aTableName
String

See Also

RemoteSession Interface
AsyncTableFromSQL Overload
IndianHealthService.BMXNet Namespace


AsyncTableFromSQL Method (String, DataSet, String, String)

JavaScript

RemoteSession..::AsyncTableFromSQL Method (String, DataSet, String, String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTableFuture AsyncTableFromSQL(
    string sql,
    DataSet aDataSet,
    string aTableName,
    string aContext
)
Function AsyncTableFromSQL ( _
    sql As String, _
    aDataSet As DataSet, _
    aTableName As String, _
    aContext As String _
) As DataTableFuture
DataTableFuture^ AsyncTableFromSQL(
    String^ sql,
    DataSet^ aDataSet,
    String^ aTableName,
    String^ aContext
)

Parameters

sql
String
aDataSet
DataSet
aTableName
String
aContext
String

See Also

RemoteSession Interface
AsyncTableFromSQL Overload
IndianHealthService.BMXNet Namespace


Close Method

JavaScript

RemoteSession..::Close Method

BMXNET 4.0 Developer API

When done with session it should be closed. Once closed it is unusable.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Close()
Sub Close
void Close()

Remarks

Internally the session is a lightweight object and when using multiple sessions internal RPMS connections are pooled . Close sessions when finished

Remarks

Closing the primary session closes all sessions and shuts down the RPMS connection

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


IsBmxAdoCommand Method

JavaScript

RemoteSession..::IsBmxAdoCommand Method

BMXNET 4.0 Developer API

Answer True if aString is a standard BMX ADO SS command that uses the BMX ADO SCHEMA files

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsBmxAdoCommand(
    string aString
)
Function IsBmxAdoCommand ( _
    aString As String _
) As Boolean
bool IsBmxAdoCommand(
    String^ aString
)

Parameters

aString
String
The command to be examined

Return Value

True if it complied, otherwise false

Remarks

This is mostly used by the framework but exposed for potential use.

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


SafelyTransmitRPC Method

JavaScript

RemoteSession..::SafelyTransmitRPC Method

BMXNET 4.0 Developer API

Overload List

Name | Description
SafelyTransmitRPC(String, String) | Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.
SafelyTransmitRPC(String, String, String) | Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


SafelyTransmitRPC Method (String, String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::SafelyTransmitRPC Method (String, String)

BMXNET 4.0 Developer API

Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string SafelyTransmitRPC(
    string rpcCommand,
    string rpcParameter
)
Function SafelyTransmitRPC ( _
    rpcCommand As String, _
    rpcParameter As String _
) As String
String^ SafelyTransmitRPC(
    String^ rpcCommand,
    String^ rpcParameter
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters

Return Value

The result of the RPC call. If there are any exceptions a colon delimited string in the format Exception:Message is returned.

Remarks

Presumes that the AppContext was set prior to the call.

Examples

Copy Code
            ...
            this.RemoteSession.AppContext="VEN RPC";
            ...
            String asqThreadholds= this.RemoteSession.SafelyTransmitRPC("VEN ASQ GET DATA", this.Context.Patient.Ien);

See Also

RemoteSession Interface
SafelyTransmitRPC Overload
IndianHealthService.BMXNet Namespace


SafelyTransmitRPC Method (String, String, String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::SafelyTransmitRPC Method (String, String, String)

BMXNET 4.0 Developer API

Calls a remote procedure on the RPMS server and returns the result as a String. If there are any exceptions a colon delimited string in the format Exception:Message is returned.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string SafelyTransmitRPC(
    string rpcCommand,
    string rpcParameter,
    string context
)
Function SafelyTransmitRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    context As String _
) As String
String^ SafelyTransmitRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    String^ context
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters
context
String

Return Value

The result of the RPC call. If there are any exceptions a colon delimited string in the format Exception:Message is returned.

Remarks

Presumes that the AppContext was set prior to the call.

Examples

Copy Code
            ...
            this.RemoteSession.AppContext="VEN RPC";
            ...
            String asqThreadholds= this.RemoteSession.SafelyTransmitRPC("VEN ASQ GET DATA", this.Context.Patient.Ien);

See Also

RemoteSession Interface
SafelyTransmitRPC Overload
IndianHealthService.BMXNet Namespace


SaveChanges Method

JavaScript

RemoteSession..::SaveChanges Method

BMXNET 4.0 Developer API

Examples

Copy Code

            this.Context.Visit.Create();
            if (this.Context.Visit.IsStub)
            {
                if (!this.Context.Visit.Create())
                {
                    return false;
                }
            }
            this.RemoteSession.SaveChanges(this.ScoreTable);

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool SaveChanges(
    DataTable aDataTable
)
Function SaveChanges ( _
    aDataTable As DataTable _
) As Boolean
bool SaveChanges(
    DataTable^ aDataTable
)

Parameters

aDataTable
DataTable

Return Value

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


TableFromCommand Method

JavaScript

RemoteSession..::TableFromCommand Method

BMXNET 4.0 Developer API

Overload List

Name | Description
TableFromCommand(String) | Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, String) | Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, DataSet, String) | Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.
TableFromCommand(String, DataSet, String, String) | Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


TableFromCommand Method (String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::TableFromCommand Method (String)

BMXNET 4.0 Developer API

Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromCommand(
    string aCommand
)
Function TableFromCommand ( _
    aCommand As String _
) As DataTable
DataTable^ TableFromCommand(
    String^ aCommand
)

Parameters

aCommand
String
The co /// The name of the RPC

Return Value

The resulting DataTable

Remarks

Normally the AppContext is set once, after logging into the BMX, with a single AppContext for the current applications or specified in every RPC call.

Examples

The VEN namespace is for PCC+ and the example below would be used at the beginning of a PCC+ application.
Copy Code
            aRemoteSession.AppContext = "VEN RPC";
The M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients. See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
Copy Code
            Figure 5 2 shows the M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients.  See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
            PDEMO(BMXY,BMXPAT,BMXCOUNT)	;EP
                ;This simple RPC demonstrates how to format data
            ;for the BMXNet ADO.NET data provider
            ;
            ;Returns a maximum of BMXCOUNT records from the
            ;VA PATIENT file whose names begin with BMXPAT
            ;
            N BMXI,BMXD,BMXC,BMXNODE,BMXDOB
            ;
            ; BMXY is passed in by reference.  Set it to
            ;the value of the variable in which we will return our data:
            S BMXY="^TMP(BMX,"_$J_")"
            ;
            ;The first subnode of the data global contains the column header information
            ;in the form "txxxxxCOLUMN1NAME^txxxxxCOLUMN2NAME"_$C(30)
            ;where t is the column data type:
            ;	T for text
            ;	I for integer
            ;	N for floating point number
            ;	D for date/time.
            ;xxxxx is the length of the column in characters.
            ;
            S BMXI=0,BMXC=0
            S ^ TMP(BMX,$J,BMXI)="T00030NAME^T00010SEX^D00020DOB"_$C(30)
            ;
            ;You MUST set an error trap:
            S X="PDERR^BMXRPC6",@^%ZOSF("TRAP")
            ;
            ;Strip CR, LF, TAB from BMXCOUNT parameter
            S BMXCOUNT=$TR(BMXCOUNT,$C(13),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(10),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(9),"")
            ;
            ;Iterate through the global and set the data nodes:
            S:BMXPAT="" BMXPAT="A"
            S BMXPAT=$O(^DPT("B",BMXPAT),-1)
            S BMXD=0
            F  S BMXPAT=$O(^DPT("B",BMXPAT)) Q:BMXPAT=""  S BMXD=$O(^DPT("B",BMXPAT,0)) I +BMXD  S BMXC=BMXC+1 Q:(BMXCOUNT)BMXC BMXCOUNT)  D
            . Q:'$D(^DPT(BMXD,0))
            . S BMXI=BMXI+1
            . S BMXNODE=^DPT(BMXD,0)
            . ;Convert the DOB from FM date to external form
            . S Y=$P(BMXNODE,U,3)
            . I +Y X ^DD("DD")
            . S BMXDOB=Y
            . ;The data node fields are in the same order as the column header, i.e. NAME^SEX^DOB
            . ;and terminated with a $C(30)
            . S ^ TMP(BMX,$J,BMXI)=$P(BMXNODE,U)_U_$P(BMXNODE,U,2)_U_BMXDOB_$C(30)
            ;
            ;After all the data nodes have been set, set the final node to $C(31) to indicate
            ;the end of the recordset
            S BMXI=BMXI+1
            S ^ TMP(BMX,$J,BMXI)=$C(31)
            Q
            ;
            PDERR	;Error trap for PDEMO
            ;
            S ^ TMP(BMX,$J,BMXI+1)=$C(31)
            Q
Register as an RPC

NAME: BMX DEMO TAG: PDEMO ROUTINE: BMXRPC6 RETURN VALUE TYPE: GLOBAL ARRAY

Call using a RemoteSession
Copy Code
            DataTable demoTable=aRemoteSession.TableFromCommand("BMX DEMO^S^10");

See Also

RemoteSession Interface
TableFromCommand Overload
IndianHealthService.BMXNet Namespace


TableFromCommand Method (String, String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::TableFromCommand Method (String, String)

BMXNET 4.0 Developer API

Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromCommand(
    string aCommand,
    string aContext
)
Function TableFromCommand ( _
    aCommand As String, _
    aContext As String _
) As DataTable
DataTable^ TableFromCommand(
    String^ aCommand,
    String^ aContext
)

Parameters

aCommand
String
The co /// The name of the RPC
aContext
String
The AppContext to set prior to the call

Return Value

The resulting DataTable

Remarks

Normally the AppContext is set once, after logging into the BMX, with a single AppContext for the current applications or specified in every RPC call.

Examples

The VEN namespace is for PCC+ and the example below would be used at the beginning of a PCC+ application.
Copy Code
            aRemoteSession.AppContext = "VEN RPC";
The M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients. See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
Copy Code
            Figure 5 2 shows the M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients.  See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
            PDEMO(BMXY,BMXPAT,BMXCOUNT)	;EP
                ;This simple RPC demonstrates how to format data
            ;for the BMXNet ADO.NET data provider
            ;
            ;Returns a maximum of BMXCOUNT records from the
            ;VA PATIENT file whose names begin with BMXPAT
            ;
            N BMXI,BMXD,BMXC,BMXNODE,BMXDOB
            ;
            ; BMXY is passed in by reference.  Set it to
            ;the value of the variable in which we will return our data:
            S BMXY="^TMP(BMX,"_$J_")"
            ;
            ;The first subnode of the data global contains the column header information
            ;in the form "txxxxxCOLUMN1NAME^txxxxxCOLUMN2NAME"_$C(30)
            ;where t is the column data type:
            ;	T for text
            ;	I for integer
            ;	N for floating point number
            ;	D for date/time.
            ;xxxxx is the length of the column in characters.
            ;
            S BMXI=0,BMXC=0
            S ^ TMP(BMX,$J,BMXI)="T00030NAME^T00010SEX^D00020DOB"_$C(30)
            ;
            ;You MUST set an error trap:
            S X="PDERR^BMXRPC6",@^%ZOSF("TRAP")
            ;
            ;Strip CR, LF, TAB from BMXCOUNT parameter
            S BMXCOUNT=$TR(BMXCOUNT,$C(13),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(10),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(9),"")
            ;
            ;Iterate through the global and set the data nodes:
            S:BMXPAT="" BMXPAT="A"
            S BMXPAT=$O(^DPT("B",BMXPAT),-1)
            S BMXD=0
            F  S BMXPAT=$O(^DPT("B",BMXPAT)) Q:BMXPAT=""  S BMXD=$O(^DPT("B",BMXPAT,0)) I +BMXD  S BMXC=BMXC+1 Q:(BMXCOUNT)BMXC BMXCOUNT)  D
            . Q:'$D(^DPT(BMXD,0))
            . S BMXI=BMXI+1
            . S BMXNODE=^DPT(BMXD,0)
            . ;Convert the DOB from FM date to external form
            . S Y=$P(BMXNODE,U,3)
            . I +Y X ^DD("DD")
            . S BMXDOB=Y
            . ;The data node fields are in the same order as the column header, i.e. NAME^SEX^DOB
            . ;and terminated with a $C(30)
            . S ^ TMP(BMX,$J,BMXI)=$P(BMXNODE,U)_U_$P(BMXNODE,U,2)_U_BMXDOB_$C(30)
            ;
            ;After all the data nodes have been set, set the final node to $C(31) to indicate
            ;the end of the recordset
            S BMXI=BMXI+1
            S ^ TMP(BMX,$J,BMXI)=$C(31)
            Q
            ;
            PDERR	;Error trap for PDEMO
            ;
            S ^ TMP(BMX,$J,BMXI+1)=$C(31)
            Q
Register as an RPC

NAME: BMX DEMO TAG: PDEMO ROUTINE: BMXRPC6 RETURN VALUE TYPE: GLOBAL ARRAY

Call using a RemoteSession
Copy Code
            DataTable demoTable=aRemoteSession.TableFromCommand("BMX DEMO^S^10");

See Also

RemoteSession Interface
TableFromCommand Overload
IndianHealthService.BMXNet Namespace


TableFromCommand Method (String, DataSet, String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::TableFromCommand Method (String, DataSet, String)

BMXNET 4.0 Developer API

Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromCommand(
    string aCommand,
    DataSet aDataSet,
    string aTableName
)
Function TableFromCommand ( _
    aCommand As String, _
    aDataSet As DataSet, _
    aTableName As String _
) As DataTable
DataTable^ TableFromCommand(
    String^ aCommand,
    DataSet^ aDataSet,
    String^ aTableName
)

Parameters

aCommand
String
The co /// The name of the RPC
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create

Return Value

The resulting DataTable

Remarks

Normally the AppContext is set once, after logging into the BMX, with a single AppContext for the current applications or specified in every RPC call.

Examples

The VEN namespace is for PCC+ and the example below would be used at the beginning of a PCC+ application.
Copy Code
            aRemoteSession.AppContext = "VEN RPC";
The M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients. See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
Copy Code
            Figure 5 2 shows the M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients.  See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
            PDEMO(BMXY,BMXPAT,BMXCOUNT)	;EP
                ;This simple RPC demonstrates how to format data
            ;for the BMXNet ADO.NET data provider
            ;
            ;Returns a maximum of BMXCOUNT records from the
            ;VA PATIENT file whose names begin with BMXPAT
            ;
            N BMXI,BMXD,BMXC,BMXNODE,BMXDOB
            ;
            ; BMXY is passed in by reference.  Set it to
            ;the value of the variable in which we will return our data:
            S BMXY="^TMP(BMX,"_$J_")"
            ;
            ;The first subnode of the data global contains the column header information
            ;in the form "txxxxxCOLUMN1NAME^txxxxxCOLUMN2NAME"_$C(30)
            ;where t is the column data type:
            ;	T for text
            ;	I for integer
            ;	N for floating point number
            ;	D for date/time.
            ;xxxxx is the length of the column in characters.
            ;
            S BMXI=0,BMXC=0
            S ^ TMP(BMX,$J,BMXI)="T00030NAME^T00010SEX^D00020DOB"_$C(30)
            ;
            ;You MUST set an error trap:
            S X="PDERR^BMXRPC6",@^%ZOSF("TRAP")
            ;
            ;Strip CR, LF, TAB from BMXCOUNT parameter
            S BMXCOUNT=$TR(BMXCOUNT,$C(13),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(10),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(9),"")
            ;
            ;Iterate through the global and set the data nodes:
            S:BMXPAT="" BMXPAT="A"
            S BMXPAT=$O(^DPT("B",BMXPAT),-1)
            S BMXD=0
            F  S BMXPAT=$O(^DPT("B",BMXPAT)) Q:BMXPAT=""  S BMXD=$O(^DPT("B",BMXPAT,0)) I +BMXD  S BMXC=BMXC+1 Q:(BMXCOUNT)BMXC BMXCOUNT)  D
            . Q:'$D(^DPT(BMXD,0))
            . S BMXI=BMXI+1
            . S BMXNODE=^DPT(BMXD,0)
            . ;Convert the DOB from FM date to external form
            . S Y=$P(BMXNODE,U,3)
            . I +Y X ^DD("DD")
            . S BMXDOB=Y
            . ;The data node fields are in the same order as the column header, i.e. NAME^SEX^DOB
            . ;and terminated with a $C(30)
            . S ^ TMP(BMX,$J,BMXI)=$P(BMXNODE,U)_U_$P(BMXNODE,U,2)_U_BMXDOB_$C(30)
            ;
            ;After all the data nodes have been set, set the final node to $C(31) to indicate
            ;the end of the recordset
            S BMXI=BMXI+1
            S ^ TMP(BMX,$J,BMXI)=$C(31)
            Q
            ;
            PDERR	;Error trap for PDEMO
            ;
            S ^ TMP(BMX,$J,BMXI+1)=$C(31)
            Q
Register as an RPC

NAME: BMX DEMO TAG: PDEMO ROUTINE: BMXRPC6 RETURN VALUE TYPE: GLOBAL ARRAY

Call using a RemoteSession
Copy Code
            DataTable demoTable=aRemoteSession.TableFromCommand("BMX DEMO^S^10");

See Also

RemoteSession Interface
TableFromCommand Overload
IndianHealthService.BMXNet Namespace


TableFromCommand Method (String, DataSet, String, String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::TableFromCommand Method (String, DataSet, String, String)

BMXNET 4.0 Developer API

Calling a Custom Remote Procedure call (RPC) registered in VA FileMan’s REMOTE PROCEDURE file that results in a DataTable. You must design your remote procedure’s M routine to build its result its data in the specific format described later in this document.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromCommand(
    string aCommand,
    DataSet aDataSet,
    string aTableName,
    string aContext
)
Function TableFromCommand ( _
    aCommand As String, _
    aDataSet As DataSet, _
    aTableName As String, _
    aContext As String _
) As DataTable
DataTable^ TableFromCommand(
    String^ aCommand,
    DataSet^ aDataSet,
    String^ aTableName,
    String^ aContext
)

Parameters

aCommand
String
The co /// The name of the RPC
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create
aContext
String
The AppContext to set prior to the call

Return Value

The resulting DataTable

Remarks

Normally the AppContext is set once, after logging into the BMX, with a single AppContext for the current applications or specified in every RPC call.

Examples

The VEN namespace is for PCC+ and the example below would be used at the beginning of a PCC+ application.
Copy Code
            aRemoteSession.AppContext = "VEN RPC";
The M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients. See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
Copy Code
            Figure 5 2 shows the M code for a simple remote procedure call (BMX PATIENT DEMO) with two parameters to return a list of patients.  See the following example. Note the inclusion of an error trap in the routine; BMXNet RPC routines must contain a functional error trap.
            PDEMO(BMXY,BMXPAT,BMXCOUNT)	;EP
                ;This simple RPC demonstrates how to format data
            ;for the BMXNet ADO.NET data provider
            ;
            ;Returns a maximum of BMXCOUNT records from the
            ;VA PATIENT file whose names begin with BMXPAT
            ;
            N BMXI,BMXD,BMXC,BMXNODE,BMXDOB
            ;
            ; BMXY is passed in by reference.  Set it to
            ;the value of the variable in which we will return our data:
            S BMXY="^TMP(BMX,"_$J_")"
            ;
            ;The first subnode of the data global contains the column header information
            ;in the form "txxxxxCOLUMN1NAME^txxxxxCOLUMN2NAME"_$C(30)
            ;where t is the column data type:
            ;	T for text
            ;	I for integer
            ;	N for floating point number
            ;	D for date/time.
            ;xxxxx is the length of the column in characters.
            ;
            S BMXI=0,BMXC=0
            S ^ TMP(BMX,$J,BMXI)="T00030NAME^T00010SEX^D00020DOB"_$C(30)
            ;
            ;You MUST set an error trap:
            S X="PDERR^BMXRPC6",@^%ZOSF("TRAP")
            ;
            ;Strip CR, LF, TAB from BMXCOUNT parameter
            S BMXCOUNT=$TR(BMXCOUNT,$C(13),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(10),"")
            S BMXCOUNT=$TR(BMXCOUNT,$C(9),"")
            ;
            ;Iterate through the global and set the data nodes:
            S:BMXPAT="" BMXPAT="A"
            S BMXPAT=$O(^DPT("B",BMXPAT),-1)
            S BMXD=0
            F  S BMXPAT=$O(^DPT("B",BMXPAT)) Q:BMXPAT=""  S BMXD=$O(^DPT("B",BMXPAT,0)) I +BMXD  S BMXC=BMXC+1 Q:(BMXCOUNT)BMXC BMXCOUNT)  D
            . Q:'$D(^DPT(BMXD,0))
            . S BMXI=BMXI+1
            . S BMXNODE=^DPT(BMXD,0)
            . ;Convert the DOB from FM date to external form
            . S Y=$P(BMXNODE,U,3)
            . I +Y X ^DD("DD")
            . S BMXDOB=Y
            . ;The data node fields are in the same order as the column header, i.e. NAME^SEX^DOB
            . ;and terminated with a $C(30)
            . S ^ TMP(BMX,$J,BMXI)=$P(BMXNODE,U)_U_$P(BMXNODE,U,2)_U_BMXDOB_$C(30)
            ;
            ;After all the data nodes have been set, set the final node to $C(31) to indicate
            ;the end of the recordset
            S BMXI=BMXI+1
            S ^ TMP(BMX,$J,BMXI)=$C(31)
            Q
            ;
            PDERR	;Error trap for PDEMO
            ;
            S ^ TMP(BMX,$J,BMXI+1)=$C(31)
            Q
Register as an RPC

NAME: BMX DEMO TAG: PDEMO ROUTINE: BMXRPC6 RETURN VALUE TYPE: GLOBAL ARRAY

Call using a RemoteSession
Copy Code
            DataTable demoTable=aRemoteSession.TableFromCommand("BMX DEMO^S^10");

See Also

RemoteSession Interface
TableFromCommand Overload
IndianHealthService.BMXNet Namespace


TableFromRPC Method

JavaScript

RemoteSession..::TableFromRPC Method

BMXNET 4.0 Developer API

Overload List

Name | Description
TableFromRPC(String, String) | TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, String) | TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, DataSet, String) | TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.
TableFromRPC(String, String, DataSet, String, String) | TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


TableFromRPC Method (String, String)

JavaScript

RemoteSession..::TableFromRPC Method (String, String)

BMXNET 4.0 Developer API

TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromRPC(
    string rpcCommand,
    string rpcParameter
)
Function TableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String _
) As DataTable
DataTable^ TableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters

Return Value

The resulting DataTable

See Also

RemoteSession Interface
TableFromRPC Overload
IndianHealthService.BMXNet Namespace


TableFromRPC Method (String, String, String)

JavaScript

RemoteSession..::TableFromRPC Method (String, String, String)

BMXNET 4.0 Developer API

TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromRPC(
    string rpcCommand,
    string rpcParameter,
    string aContext
)
Function TableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    aContext As String _
) As DataTable
DataTable^ TableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    String^ aContext
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters
aContext
String
The AppContext to set prior to the call

Return Value

The resulting DataTable

See Also

RemoteSession Interface
TableFromRPC Overload
IndianHealthService.BMXNet Namespace


TableFromRPC Method (String, String, DataSet, String)

JavaScript

RemoteSession..::TableFromRPC Method (String, String, DataSet, String)

BMXNET 4.0 Developer API

TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromRPC(
    string rpcCommand,
    string rpcParameter,
    DataSet aDataSet,
    string aTableName
)
Function TableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    aDataSet As DataSet, _
    aTableName As String _
) As DataTable
DataTable^ TableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    DataSet^ aDataSet,
    String^ aTableName
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create

Return Value

The resulting DataTable

See Also

RemoteSession Interface
TableFromRPC Overload
IndianHealthService.BMXNet Namespace


TableFromRPC Method (String, String, DataSet, String, String)

JavaScript

RemoteSession..::TableFromRPC Method (String, String, DataSet, String, String)

BMXNET 4.0 Developer API

TabletFromRpc is a double-dispatch method that is used by some developers. Developers create an RPC call the returns a properly format BMX command (custom or BMX SS ADO) that is then transmitted back to RPMS to retrieve the Data Table.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromRPC(
    string rpcCommand,
    string rpcParameter,
    DataSet aDataSet,
    string aTableName,
    string context
)
Function TableFromRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    aDataSet As DataSet, _
    aTableName As String, _
    context As String _
) As DataTable
DataTable^ TableFromRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    DataSet^ aDataSet,
    String^ aTableName,
    String^ context
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters
aDataSet
DataSet
The DataSet to be populated with a resulting DataTable named aTableNAme
aTableName
String
The name of the DataTable in the DataSet to populate or to create
context
String

Return Value

The resulting DataTable

See Also

RemoteSession Interface
TableFromRPC Overload
IndianHealthService.BMXNet Namespace


TableFromSQL Method

JavaScript

RemoteSession..::TableFromSQL Method

BMXNET 4.0 Developer API

Overload List

Name | Description
TableFromSQL(String) |
TableFromSQL(String, String) |
TableFromSQL(String, DataSet, String) |
TableFromSQL(String, DataSet, String, String) | SELECT VA_PATIENT.NAME, VA_PATIENT.SSN, PATIENT.CURRENT_COMMUNITY FROM VA_PATIENT, PATIENT WHERE VA_PATIENT.BMXIEN =* INTERNAL[PATIENT.NAME] AND VA_PATIENT.NAME LIKE 'DEMO%' AND VA_PATIENT.AGE BETWEEN 15 AND 24 SHOWPLAN

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


TableFromSQL Method (String)

JavaScript

RemoteSession..::TableFromSQL Method (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromSQL(
    string anSqlStatement
)
Function TableFromSQL ( _
    anSqlStatement As String _
) As DataTable
DataTable^ TableFromSQL(
    String^ anSqlStatement
)

Parameters

anSqlStatement
String

See Also

RemoteSession Interface
TableFromSQL Overload
IndianHealthService.BMXNet Namespace


TableFromSQL Method (String, String)

JavaScript

RemoteSession..::TableFromSQL Method (String, String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromSQL(
    string anSqlStatement,
    string aContext
)
Function TableFromSQL ( _
    anSqlStatement As String, _
    aContext As String _
) As DataTable
DataTable^ TableFromSQL(
    String^ anSqlStatement,
    String^ aContext
)

Parameters

anSqlStatement
String
aContext
String

See Also

RemoteSession Interface
TableFromSQL Overload
IndianHealthService.BMXNet Namespace


TableFromSQL Method (String, DataSet, String)

JavaScript

RemoteSession..::TableFromSQL Method (String, DataSet, String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromSQL(
    string anSqlStatement,
    DataSet aDataSet,
    string aTableName
)
Function TableFromSQL ( _
    anSqlStatement As String, _
    aDataSet As DataSet, _
    aTableName As String _
) As DataTable
DataTable^ TableFromSQL(
    String^ anSqlStatement,
    DataSet^ aDataSet,
    String^ aTableName
)

Parameters

anSqlStatement
String
aDataSet
DataSet
aTableName
String

See Also

RemoteSession Interface
TableFromSQL Overload
IndianHealthService.BMXNet Namespace


TableFromSQL Method (String, DataSet, String, String)

JavaScript

RemoteSession..::TableFromSQL Method (String, DataSet, String, String)

BMXNET 4.0 Developer API

SELECT VA_PATIENT.NAME, VA_PATIENT.SSN, PATIENT.CURRENT_COMMUNITY FROM VA_PATIENT, PATIENT WHERE VA_PATIENT.BMXIEN =* INTERNAL[PATIENT.NAME] AND VA_PATIENT.NAME LIKE 'DEMO%' AND VA_PATIENT.AGE BETWEEN 15 AND 24 SHOWPLAN

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable TableFromSQL(
    string anSqlStatement,
    DataSet aDataSet,
    string aTableName,
    string aContext
)
Function TableFromSQL ( _
    anSqlStatement As String, _
    aDataSet As DataSet, _
    aTableName As String, _
    aContext As String _
) As DataTable
DataTable^ TableFromSQL(
    String^ anSqlStatement,
    DataSet^ aDataSet,
    String^ aTableName,
    String^ aContext
)

Parameters

anSqlStatement
String
aDataSet
DataSet
aTableName
String
aContext
String

Return Value

See Also

RemoteSession Interface
TableFromSQL Overload
IndianHealthService.BMXNet Namespace


TransmitRPC Method

JavaScript

RemoteSession..::TransmitRPC Method

BMXNET 4.0 Developer API

Overload List

Name | Description
TransmitRPC(String, String) | Calls a remote procedure on the RPMS server and returns the result as a String.
TransmitRPC(String, String, String) |

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


TransmitRPC Method (String, String)

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::TransmitRPC Method (String, String)

BMXNET 4.0 Developer API

Calls a remote procedure on the RPMS server and returns the result as a String.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string TransmitRPC(
    string rpcCommand,
    string rpcParameter
)
Function TransmitRPC ( _
    rpcCommand As String, _
    rpcParameter As String _
) As String
String^ TransmitRPC(
    String^ rpcCommand,
    String^ rpcParameter
)

Parameters

rpcCommand
String
The remote procedure call name
rpcParameter
String
A carrot ^ delimited string of input parameters

Return Value

The result of the RPC call

Remarks

Presumes that the AppContext was set prior to the call.

Examples

Copy Code
            ...
            this.RemoteSession.AppContext="VEN RPC";
            ...
            String asqThreadholds= this.RemoteSession.TransmitRPC("VEN ASQ GET DATA", this.Context.Patient.Ien);

See Also

RemoteSession Interface
TransmitRPC Overload
IndianHealthService.BMXNet Namespace


TransmitRPC Method (String, String, String)

JavaScript

RemoteSession..::TransmitRPC Method (String, String, String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string TransmitRPC(
    string rpcCommand,
    string rpcParameter,
    string aContext
)
Function TransmitRPC ( _
    rpcCommand As String, _
    rpcParameter As String, _
    aContext As String _
) As String
String^ TransmitRPC(
    String^ rpcCommand,
    String^ rpcParameter,
    String^ aContext
)

Parameters

rpcCommand
String
rpcParameter
String
aContext
String

See Also

RemoteSession Interface
TransmitRPC Overload
IndianHealthService.BMXNet Namespace


RemoteSession Properties

JavaScript

RemoteSession Properties

BMXNET 4.0 Developer API

The RemoteSession type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AppContext | The active AppContext (OPTION) of this remote session.
DebugLastRpcResult | String value of last successful non-DataTable RPC call
DebugLastRpcSignature | String describing RPC call and input parameters of last non-DataTable RPC call
DebugLastTableResult | Last DataTable retrieved by non-async calls
EventServices | Access the session's RemoteEventServices service provider to configure receiving remote events and to source new events.
HostAddress | BMX Broker's host address name or IP Address
IsPrimary | The primary session has the unique in that it holds the authenication privileges for all sessions. If you close the primary session, then all will close.
Job | Job number of server-side Cache/MDB process. Very useful for debugging.
Log |
ReceiveTimeout | The networking data receive timeout (in milliseconds). This value can be changed if the developer finds it neccessary to extend the time after login.
RpcResult | String value of last successful non-DataTable RPC call
SendTimeout | The networking data send timeout (in milliseconds). This value can be changed if the developer finds it neccessary to extend the time after login but normally the send timeout should be kept short unless network conditions are poor.
User | Authenticated user associated with this remote session

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


AppContext Property

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::AppContext Property

BMXNET 4.0 Developer API

The active AppContext (OPTION) of this remote session.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string AppContext { get; set; }
Property AppContext As String
property String^ AppContext {
    String^ get ();
    void set (String^ value);
}

Remarks

Normally the AppContext is set once, after logging into the BMX, with a single AppContext for the current applications. The AppContext can also be set in every RPC call. If the AppContext is the same as the currently set AppContext, the AppContext will not be re-set.

Examples

The VEN namespace is for PCC+ and the example below would be used at the beginning of a PCC+ application.
Copy Code
            aRemoteSession.AppContext = "VEN RPC";

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


DebugLastRpcResult Property

JavaScript

RemoteSession..::DebugLastRpcResult Property

BMXNET 4.0 Developer API

String value of last successful non-DataTable RPC call

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string DebugLastRpcResult { get; }
ReadOnly Property DebugLastRpcResult As String
property String^ DebugLastRpcResult {
    String^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


DebugLastRpcSignature Property

JavaScript

RemoteSession..::DebugLastRpcSignature Property

BMXNET 4.0 Developer API

String describing RPC call and input parameters of last non-DataTable RPC call

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string DebugLastRpcSignature { get; }
ReadOnly Property DebugLastRpcSignature As String
property String^ DebugLastRpcSignature {
    String^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


DebugLastTableResult Property

JavaScript

RemoteSession..::DebugLastTableResult Property

BMXNET 4.0 Developer API

Last DataTable retrieved by non-async calls

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DataTable DebugLastTableResult { get; }
ReadOnly Property DebugLastTableResult As DataTable
property DataTable^ DebugLastTableResult {
    DataTable^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


EventServices Property

JavaScript

RemoteSession..::EventServices Property

BMXNET 4.0 Developer API

Access the session's RemoteEventServices service provider to configure receiving remote events and to source new events.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
RemoteEventService EventServices { get; }
ReadOnly Property EventServices As RemoteEventService
property RemoteEventService^ EventServices {
    RemoteEventService^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


HostAddress Property

JavaScript

RemoteSession..::HostAddress Property

BMXNET 4.0 Developer API

BMX Broker's host address name or IP Address

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string HostAddress { get; }
ReadOnly Property HostAddress As String
property String^ HostAddress {
    String^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


IsPrimary Property

JavaScript

RemoteSession..::IsPrimary Property

BMXNET 4.0 Developer API

The primary session has the unique in that it holds the authenication privileges for all sessions. If you close the primary session, then all will close.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsPrimary { get; }
ReadOnly Property IsPrimary As Boolean
property bool IsPrimary {
    bool get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


Job Property

JavaScript

RemoteSession..::Job Property

BMXNET 4.0 Developer API

Job number of server-side Cache/MDB process. Very useful for debugging.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Job { get; }
ReadOnly Property Job As String
property String^ Job {
    String^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


Log Property

JavaScript

RemoteSession..::Log Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Log Log { get; }
ReadOnly Property Log As Log
property Log^ Log {
    Log^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


ReceiveTimeout Property

JavaScript

RemoteSession..::ReceiveTimeout Property

BMXNET 4.0 Developer API

The networking data receive timeout (in milliseconds). This value can be changed if the developer finds it neccessary to extend the time after login.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int ReceiveTimeout { get; set; }
Property ReceiveTimeout As Integer
property int ReceiveTimeout {
    int get ();
    void set (int value);
}

Remarks

Only applicable for the WinFramework

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


RpcResult Property

JavaScript

RemoteSession..::RpcResult Property

BMXNET 4.0 Developer API

String value of last successful non-DataTable RPC call

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string RpcResult { get; }
ReadOnly Property RpcResult As String
property String^ RpcResult {
    String^ get ();
}

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


SendTimeout Property

JavaScript

RemoteSession..::SendTimeout Property

BMXNET 4.0 Developer API

The networking data send timeout (in milliseconds). This value can be changed if the developer finds it neccessary to extend the time after login but normally the send timeout should be kept short unless network conditions are poor.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int SendTimeout { get; set; }
Property SendTimeout As Integer
property int SendTimeout {
    int get ();
    void set (int value);
}

Remarks

Only applicable for the WinFramework

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


User Property

JavaScript

| Example | See Also
.NET Framework Class Library
RemoteSession..::User Property

BMXNET 4.0 Developer API

Authenticated user associated with this remote session

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
User User { get; }
ReadOnly Property User As User
property User^ User {
    User^ get ();
}

Remarks

If there is a remoteSession user, it will be the same as the localSession User object

Examples

this.StatusLabel.Text="Logged in: "+ aRemoteSession.User.Name;

See Also

RemoteSession Interface
IndianHealthService.BMXNet Namespace


RemoteSessionConsumer Interface

JavaScript

| Members | See Also
.NET Framework Class Library
RemoteSessionConsumer Interface

BMXNET 4.0 Developer API

This interface is used on an UserControl-based components that are designed to work both inside the EHR and inside a WinForm application. The "Consumer" interfaces basically tell Frameworks that "Consumer" implementating objects need an specific service.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface RemoteSessionConsumer
Public Interface RemoteSessionConsumer
public interface class RemoteSessionConsumer

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RemoteSession | This property will be set with the primary RemoteSession that the interface implementer can use for communicating with the RPMS server.

Remarks

If your component doesn't implement RemoteConsumer you can still user your component. Implementing RemoteConsumer is very common and is essential for communicating with the RPMS server.

See Also

IndianHealthService.BMXNet Namespace


RemoteSessionConsumer Properties

JavaScript

RemoteSessionConsumer Properties

BMXNET 4.0 Developer API

The RemoteSessionConsumer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RemoteSession | This property will be set with the primary RemoteSession that the interface implementer can use for communicating with the RPMS server.

See Also

RemoteSessionConsumer Interface
IndianHealthService.BMXNet Namespace


RemoteSession Property

JavaScript

RemoteSessionConsumer..::RemoteSession Property

BMXNET 4.0 Developer API

This property will be set with the primary RemoteSession that the interface implementer can use for communicating with the RPMS server.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
RemoteSession RemoteSession { set; }
WriteOnly Property RemoteSession As RemoteSession
property RemoteSession^ RemoteSession {
    void set (RemoteSession^ value);
}

Remarks

If also using a RemoteSessionPool, it's important to realize the if the primary RemoteSession that is set through this interface is closed then every session in the RemoteSessionPool is also clsoed as well as the broker connection to RPMS.

See Also

RemoteSessionConsumer Interface
IndianHealthService.BMXNet Namespace


RemoteSessionPool Interface

JavaScript

| Members | See Also
.NET Framework Class Library
RemoteSessionPool Interface

BMXNET 4.0 Developer API

Each BMX connection to RPMS contains a single RemoteSessionPool with at least one Session, the primary session. Applications that need additional server processes beyond what can be done with async commands can used the RemoteSessionPool.

Access to the RemoteSessionPool is accomplished by implementing the RemoteSessionPoolConsumer interface on your component/control. Secondary sessions can be opened and closed as they are needed. If the AvailableSessionCount is zero then a null RemoteSession is returned so it is recommend to first check the if a pool HasAvailableSessions before an OpenSession() request.

RemoteSessionPool high-performance can be achieved by keeping RPMS server jobs alive even after secondary sessions are closed. The pool will maintain MaxSessions - 1 number of jobs alive on the server. If the application is finished for awhile needing IdleSessionCount idle jobs, then TerminateIdleSessions() will release those resources on the server. New jobs will then be created on demand.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface RemoteSessionPool
Public Interface RemoteSessionPool
public interface class RemoteSessionPool

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AvailableSessionCount | The number of additional secondary RemoteSessions that can be opened.
Close()()() |
HasAvailableSession | True if another secondary session can be opened.
IdleSessionCount |
MaxSessions | The maximum number of RemoteSessions than can be opened
OpenSession()()() | Open a RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool.
OpenSession(Log) | Open a new RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool. An implementation of Log can be included to trace RPC execution.
TerminateIdleSessions()()() |

See Also

IndianHealthService.BMXNet Namespace


RemoteSessionPool Methods

JavaScript

RemoteSessionPool Methods

BMXNET 4.0 Developer API

The RemoteSessionPool type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()() |
OpenSession()()() | Open a RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool.
OpenSession(Log) | Open a new RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool. An implementation of Log can be included to trace RPC execution.
TerminateIdleSessions()()() |

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


Close Method

JavaScript

RemoteSessionPool..::Close Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void Close()
Sub Close
void Close()

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


OpenSession Method

JavaScript

RemoteSessionPool..::OpenSession Method

BMXNET 4.0 Developer API

Overload List

Name | Description
OpenSession()()() | Open a RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool.
OpenSession(Log) | Open a new RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool. An implementation of Log can be included to trace RPC execution.

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


OpenSession Method

JavaScript

RemoteSessionPool..::OpenSession Method

BMXNET 4.0 Developer API

Open a RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
RemoteSession OpenSession()
Function OpenSession As RemoteSession
RemoteSession^ OpenSession()

Return Value

A newly created or recycled RemoteSession or null if the number of RemoteSessions has reach the MaxSessions count

See Also

RemoteSessionPool Interface
OpenSession Overload
IndianHealthService.BMXNet Namespace


OpenSession Method (Log)

JavaScript

RemoteSessionPool..::OpenSession Method (Log)

BMXNET 4.0 Developer API

Open a new RemoteSession and answer it. If an idle Session exists, it will be recycled and answered. Use Close() on the RemoteSession to release this secondary RemoteSession back to the pool. An implementation of Log can be included to trace RPC execution.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
RemoteSession OpenSession(
    Log aLog
)
Function OpenSession ( _
    aLog As Log _
) As RemoteSession
RemoteSession^ OpenSession(
    Log^ aLog
)

Parameters

aLog
Log

Return Value

A newly created or recycled RemoteSession or null if the number of RemoteSessions has reach the MaxSessions count

Remarks

Logging is not heavily used in BMXNET40

See Also

RemoteSessionPool Interface
OpenSession Overload
IndianHealthService.BMXNet Namespace


TerminateIdleSessions Method

JavaScript

RemoteSessionPool..::TerminateIdleSessions Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void TerminateIdleSessions()
Sub TerminateIdleSessions
void TerminateIdleSessions()

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


RemoteSessionPool Properties

JavaScript

RemoteSessionPool Properties

BMXNET 4.0 Developer API

The RemoteSessionPool type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AvailableSessionCount | The number of additional secondary RemoteSessions that can be opened.
HasAvailableSession | True if another secondary session can be opened.
IdleSessionCount |
MaxSessions | The maximum number of RemoteSessions than can be opened

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


AvailableSessionCount Property

JavaScript

RemoteSessionPool..::AvailableSessionCount Property

BMXNET 4.0 Developer API

The number of additional secondary RemoteSessions that can be opened.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int AvailableSessionCount { get; }
ReadOnly Property AvailableSessionCount As Integer
property int AvailableSessionCount {
    int get ();
}

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


HasAvailableSession Property

JavaScript

RemoteSessionPool..::HasAvailableSession Property

BMXNET 4.0 Developer API

True if another secondary session can be opened.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool HasAvailableSession { get; }
ReadOnly Property HasAvailableSession As Boolean
property bool HasAvailableSession {
    bool get ();
}

Remarks

For this version of BMX, the EHR does not support secondary RemoteSessions and this method always returns false. If possible, develop your software using the API so when secondary RemoteSessions are supported your application will work.

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


IdleSessionCount Property

JavaScript

RemoteSessionPool..::IdleSessionCount Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int IdleSessionCount { get; }
ReadOnly Property IdleSessionCount As Integer
property int IdleSessionCount {
    int get ();
}

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


MaxSessions Property

JavaScript

RemoteSessionPool..::MaxSessions Property

BMXNET 4.0 Developer API

The maximum number of RemoteSessions than can be opened

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
int MaxSessions { get; set; }
Property MaxSessions As Integer
property int MaxSessions {
    int get ();
    void set (int value);
}

See Also

RemoteSessionPool Interface
IndianHealthService.BMXNet Namespace


RemoteSessionPoolConsumer Interface

JavaScript

| Members | See Also
.NET Framework Class Library
RemoteSessionPoolConsumer Interface

BMXNET 4.0 Developer API

This interface is used on an UserControl-based components that are designed to work both inside the EHR and inside a WinForm application. The "Consumer" interfaces basically tell Frameworks that "Consumer" implementating objects need an specific service.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface RemoteSessionPoolConsumer
Public Interface RemoteSessionPoolConsumer
public interface class RemoteSessionPoolConsumer

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RemoteSessionPool | This property will be set with the RemoteSessionPool that is used by the Framework.

Remarks

This interface is rarely used but is essential for application needing multiple server-side jobs.

See Also

IndianHealthService.BMXNet Namespace


RemoteSessionPoolConsumer Properties

JavaScript

RemoteSessionPoolConsumer Properties

BMXNET 4.0 Developer API

The RemoteSessionPoolConsumer type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RemoteSessionPool | This property will be set with the RemoteSessionPool that is used by the Framework.

See Also

RemoteSessionPoolConsumer Interface
IndianHealthService.BMXNet Namespace


RemoteSessionPool Property

JavaScript

RemoteSessionPoolConsumer..::RemoteSessionPool Property

BMXNET 4.0 Developer API

This property will be set with the RemoteSessionPool that is used by the Framework.

Namespace: IndianHealthService.BMXNet
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
RemoteSessionPool RemoteSessionPool { set; }
WriteOnly Property RemoteSessionPool As RemoteSessionPool
property RemoteSessionPool^ RemoteSessionPool {
    void set (RemoteSessionPool^ value);
}

Remarks

If you only need one RemoteSession, the most common usage pattern, you do not need the RemoteSessionPoolConsumer and should use RemoteSessionConsumer.

See Also

RemoteSessionPoolConsumer Interface
IndianHealthService.BMXNet Namespace


IndianHealthService.BMXNet.Ado Namespace

JavaScript

IndianHealthService.BMXNet.Ado Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes
Name | Description
BMXNetCommand | BMXNET implementaiton of DbCommand. This class can be used like any ADO.NET DbCommand implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.
BMXNetDataAdapter | BMXNET implementaiton of DbDataAdaptor. This class can be used like any ADO.NET DbDataAdaptor implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.
BMXNetDataReader | BMXNET implementaiton of IDataReader. This class can be used like any ADO.NET IDataReader implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.
BMXNetTransaction | BMXNET implementaiton of IDbTransaction. This class can be used like any ADO.NET IDbTransaction implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.
DataTableFuture | DataTableFutures are created synchrounously when Async calls are made on a RemoteSession. A DataTabelFuture is used to manage each async call and has a variety of methods to support the relativelty long and dynamic lifecycle and an Async call.
DataTableFutureEventArgs | The event args for all DataTableFuture events.


BMXNetCommand Class

JavaScript

| Members | See Also
.NET Framework Class Library
BMXNetCommand Class

BMXNET 4.0 Developer API

BMXNET implementaiton of DbCommand. This class can be used like any ADO.NET DbCommand implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class BMXNetCommand : DbCommand,
    IDbCommand, IDisposable
Public Class BMXNetCommand _
    Inherits DbCommand _
    Implements IDbCommand, IDisposable
public ref class BMXNetCommand : public DbCommand,
    IDbCommand, IDisposable

Members

All Members | Constructors | Properties | Methods | Events | Explicit Interface Implementations
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BMXNetCommand()()() |
BMXNetCommand(String) |
BMXBuildUpdateCommand(DataTable) |
Cancel()()() | (Overrides DbCommand..::.Cancel()()().)
CanRaiseEvents | (Inherited from Component.)
CommandText | (Overrides DbCommand..::.CommandText.)
CommandTimeout | (Overrides DbCommand..::.CommandTimeout.)
CommandType | (Overrides DbCommand..::.CommandType.)
IDbCommand..::.Connection | (Inherited from DbCommand.)
Connection |
Container | (Inherited from Component.)
CreateDbParameter()()() | (Overrides DbCommand..::.CreateDbParameter()()().)
CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
IDbCommand..::.CreateParameter()()() | (Inherited from DbCommand.)
CreateParameter()()() |
DbConnection | (Overrides DbCommand..::.DbConnection.)
DbParameterCollection | (Overrides DbCommand..::.DbParameterCollection.)
DbTransaction | (Overrides DbCommand..::.DbTransaction.)
DesignMode | (Inherited from Component.)
DesignTimeVisible | (Overrides DbCommand..::.DesignTimeVisible.)
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | (Inherited from Component.)
IDisposable..::.Dispose()()() |
Disposed | (Inherited from Component.)
Equals(Object) | (Inherited from Object.)
Events | (Inherited from Component.)
ExecuteDbDataReader(CommandBehavior) | (Overrides DbCommand..::.ExecuteDbDataReader(CommandBehavior).)
ExecuteNonQuery()()() | (Overrides DbCommand..::.ExecuteNonQuery()()().)
IDbCommand..::.ExecuteReader()()() | (Inherited from DbCommand.)
IDbCommand..::.ExecuteReader(CommandBehavior) | (Inherited from DbCommand.)
ExecuteReader()()() |
ExecuteReader(CommandBehavior) |
ExecuteScalar()()() | (Overrides DbCommand..::.ExecuteScalar()()().)
Finalize()()() | (Inherited from Component.)
GetHashCode()()() | (Inherited from Object.)
GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
GetService(Type) | (Inherited from Component.)
GetType()()() | (Inherited from Object.)
InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Parameters | (Inherited from DbCommand.)
IDbCommand..::.Parameters | (Inherited from DbCommand.)
Prepare()()() | (Overrides DbCommand..::.Prepare()()().)
Site | (Inherited from Component.)
ToString()()() | (Inherited from Component.)
IDbCommand..::.Transaction | (Inherited from DbCommand.)
Transaction |
UpdatedRowSource | (Overrides DbCommand..::.UpdatedRowSource.)

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Data.Common..::.DbCommand
IndianHealthService.BMXNet.Ado..::.BMXNetCommand

See Also

IndianHealthService.BMXNet.Ado Namespace


BMXNetCommand Constructor

JavaScript

BMXNetCommand Constructor

BMXNET 4.0 Developer API

Overload List

Name | Description
BMXNetCommand()()() |
BMXNetCommand(String) |

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetCommand Constructor

JavaScript

BMXNetCommand Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetCommand()
Public Sub New
public:
BMXNetCommand()

See Also

BMXNetCommand Class
BMXNetCommand Overload
IndianHealthService.BMXNet.Ado Namespace


BMXNetCommand Constructor (String)

JavaScript

BMXNetCommand Constructor (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetCommand(
    string cmdText
)
Public Sub New ( _
    cmdText As String _
)
public:
BMXNetCommand(
    String^ cmdText
)

Parameters

cmdText
String

See Also

BMXNetCommand Class
BMXNetCommand Overload
IndianHealthService.BMXNet.Ado Namespace


BMXNetCommand Methods

JavaScript

BMXNetCommand Methods

BMXNET 4.0 Developer API

The BMXNetCommand type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BMXBuildUpdateCommand(DataTable) |
Cancel()()() | (Overrides DbCommand..::.Cancel()()().)
CreateDbParameter()()() | (Overrides DbCommand..::.CreateDbParameter()()().)
CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
IDbCommand..::.CreateParameter()()() | (Inherited from DbCommand.)
CreateParameter()()() |
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | (Inherited from Component.)
IDisposable..::.Dispose()()() |
Equals(Object) | (Inherited from Object.)
ExecuteDbDataReader(CommandBehavior) | (Overrides DbCommand..::.ExecuteDbDataReader(CommandBehavior).)
ExecuteNonQuery()()() | (Overrides DbCommand..::.ExecuteNonQuery()()().)
IDbCommand..::.ExecuteReader()()() | (Inherited from DbCommand.)
IDbCommand..::.ExecuteReader(CommandBehavior) | (Inherited from DbCommand.)
ExecuteReader()()() |
ExecuteReader(CommandBehavior) |
ExecuteScalar()()() | (Overrides DbCommand..::.ExecuteScalar()()().)
Finalize()()() | (Inherited from Component.)
GetHashCode()()() | (Inherited from Object.)
GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
GetService(Type) | (Inherited from Component.)
GetType()()() | (Inherited from Object.)
InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Prepare()()() | (Overrides DbCommand..::.Prepare()()().)
ToString()()() | (Inherited from Component.)

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


Dispose Method

JavaScript

BMXNetCommand..::Dispose Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose

Implements

IDisposable..::.Dispose()()()

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


BMXBuildUpdateCommand Method

JavaScript

BMXNetCommand..::BMXBuildUpdateCommand Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void BMXBuildUpdateCommand(
    DataTable dtSchema
)
Public Sub BMXBuildUpdateCommand ( _
    dtSchema As DataTable _
)
public:
void BMXBuildUpdateCommand(
    DataTable^ dtSchema
)

Parameters

dtSchema
DataTable

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


Cancel Method

JavaScript

BMXNetCommand..::Cancel Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override void Cancel()
Public Overrides Sub Cancel
public:
virtual void Cancel() override

Implements

IDbCommand..::.Cancel()()()
IDbCommand..::.Cancel()()()

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


CreateDbParameter Method

JavaScript

BMXNetCommand..::CreateDbParameter Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override DbParameter CreateDbParameter()
Protected Overrides Function CreateDbParameter As DbParameter
protected:
virtual DbParameter^ CreateDbParameter() override

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


CreateParameter Method

JavaScript

BMXNetCommand..::CreateParameter Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDbDataParameter CreateParameter()
Public Function CreateParameter As IDbDataParameter
public:
virtual IDbDataParameter^ CreateParameter() sealed

Implements

IDbCommand..::.CreateParameter()()()

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


Dispose Method

JavaScript

BMXNetCommand..::Dispose Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) |

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


ExecuteDbDataReader Method

JavaScript

BMXNetCommand..::ExecuteDbDataReader Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override DbDataReader ExecuteDbDataReader(
    CommandBehavior behavior
)
Protected Overrides Function ExecuteDbDataReader ( _
    behavior As CommandBehavior _
) As DbDataReader
protected:
virtual DbDataReader^ ExecuteDbDataReader(
    CommandBehavior behavior
) override

Parameters

behavior
CommandBehavior

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


ExecuteNonQuery Method

JavaScript

BMXNetCommand..::ExecuteNonQuery Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override int ExecuteNonQuery()
Public Overrides Function ExecuteNonQuery As Integer
public:
virtual int ExecuteNonQuery() override

Implements

IDbCommand..::.ExecuteNonQuery()()()
IDbCommand..::.ExecuteNonQuery()()()

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


ExecuteReader Method

JavaScript

BMXNetCommand..::ExecuteReader Method

BMXNET 4.0 Developer API

Overload List

Name | Description
IDbCommand..::.ExecuteReader()()() |
IDbCommand..::.ExecuteReader(CommandBehavior) |

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


ExecuteReader Method

JavaScript

BMXNetCommand..::ExecuteReader Method

BMXNET 4.0 Developer API

Overload List

Name | Description
ExecuteReader()()() |
ExecuteReader(CommandBehavior) |

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


ExecuteReader Method

JavaScript

BMXNetCommand..::ExecuteReader Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDataReader ExecuteReader()
Public Function ExecuteReader As IDataReader
public:
virtual IDataReader^ ExecuteReader() sealed

Implements

IDbCommand..::.ExecuteReader()()()

See Also

BMXNetCommand Class
ExecuteReader Overload
IndianHealthService.BMXNet.Ado Namespace


ExecuteReader Method (CommandBehavior)

JavaScript

BMXNetCommand..::ExecuteReader Method (CommandBehavior)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDataReader ExecuteReader(
    CommandBehavior behavior
)
Public Function ExecuteReader ( _
    behavior As CommandBehavior _
) As IDataReader
public:
virtual IDataReader^ ExecuteReader(
    CommandBehavior behavior
) sealed

Parameters

behavior
CommandBehavior

Implements

IDbCommand..::.ExecuteReader(CommandBehavior)

See Also

BMXNetCommand Class
ExecuteReader Overload
IndianHealthService.BMXNet.Ado Namespace


ExecuteScalar Method

JavaScript

BMXNetCommand..::ExecuteScalar Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override Object ExecuteScalar()
Public Overrides Function ExecuteScalar As Object
public:
virtual Object^ ExecuteScalar() override

Implements

IDbCommand..::.ExecuteScalar()()()
IDbCommand..::.ExecuteScalar()()()

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


MemberwiseClone Method

JavaScript

BMXNetCommand..::MemberwiseClone Method

BMXNET 4.0 Developer API

Overload List

Name | Description
MemberwiseClone()()() |
MemberwiseClone(Boolean) |

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


Prepare Method

JavaScript

BMXNetCommand..::Prepare Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override void Prepare()
Public Overrides Sub Prepare
public:
virtual void Prepare() override

Implements

IDbCommand..::.Prepare()()()
IDbCommand..::.Prepare()()()

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetCommand Properties

JavaScript

BMXNetCommand Properties

BMXNET 4.0 Developer API

The BMXNetCommand type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CanRaiseEvents | (Inherited from Component.)
CommandText | (Overrides DbCommand..::.CommandText.)
CommandTimeout | (Overrides DbCommand..::.CommandTimeout.)
CommandType | (Overrides DbCommand..::.CommandType.)
IDbCommand..::.Connection | (Inherited from DbCommand.)
Connection |
Container | (Inherited from Component.)
DbConnection | (Overrides DbCommand..::.DbConnection.)
DbParameterCollection | (Overrides DbCommand..::.DbParameterCollection.)
DbTransaction | (Overrides DbCommand..::.DbTransaction.)
DesignMode | (Inherited from Component.)
DesignTimeVisible | (Overrides DbCommand..::.DesignTimeVisible.)
Events | (Inherited from Component.)
Parameters | (Inherited from DbCommand.)
IDbCommand..::.Parameters | (Inherited from DbCommand.)
Site | (Inherited from Component.)
IDbCommand..::.Transaction | (Inherited from DbCommand.)
Transaction |
UpdatedRowSource | (Overrides DbCommand..::.UpdatedRowSource.)

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


CommandText Property

JavaScript

BMXNetCommand..::CommandText Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override string CommandText { get; set; }
Public Overrides Property CommandText As String
public:
virtual property String^ CommandText {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IDbCommand..::.CommandText
IDbCommand..::.CommandText

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


CommandTimeout Property

JavaScript

BMXNetCommand..::CommandTimeout Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override int CommandTimeout { get; set; }
Public Overrides Property CommandTimeout As Integer
public:
virtual property int CommandTimeout {
    int get () override;
    void set (int value) override;
}

Implements

IDbCommand..::.CommandTimeout
IDbCommand..::.CommandTimeout

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


CommandType Property

JavaScript

BMXNetCommand..::CommandType Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override CommandType CommandType { get; set; }
Public Overrides Property CommandType As CommandType
public:
virtual property CommandType CommandType {
    CommandType get () override;
    void set (CommandType value) override;
}

Implements

IDbCommand..::.CommandType
IDbCommand..::.CommandType

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


Connection Property

JavaScript

BMXNetCommand..::Connection Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDbConnection Connection { get; set; }
Public Property Connection As IDbConnection
public:
virtual property IDbConnection^ Connection {
    IDbConnection^ get () sealed;
    void set (IDbConnection^ value) sealed;
}

Implements

IDbCommand..::.Connection

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


DbConnection Property

JavaScript

BMXNetCommand..::DbConnection Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override DbConnection DbConnection { get; set; }
Protected Overrides Property DbConnection As DbConnection
protected:
virtual property DbConnection^ DbConnection {
    DbConnection^ get () override;
    void set (DbConnection^ value) override;
}

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


DbParameterCollection Property

JavaScript

BMXNetCommand..::DbParameterCollection Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override DbParameterCollection DbParameterCollection { get; }
Protected Overrides ReadOnly Property DbParameterCollection As DbParameterCollection
protected:
virtual property DbParameterCollection^ DbParameterCollection {
    DbParameterCollection^ get () override;
}

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


DbTransaction Property

JavaScript

BMXNetCommand..::DbTransaction Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override DbTransaction DbTransaction { get; set; }
Protected Overrides Property DbTransaction As DbTransaction
protected:
virtual property DbTransaction^ DbTransaction {
    DbTransaction^ get () override;
    void set (DbTransaction^ value) override;
}

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


DesignTimeVisible Property

JavaScript

BMXNetCommand..::DesignTimeVisible Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override bool DesignTimeVisible { get; set; }
Public Overrides Property DesignTimeVisible As Boolean
public:
virtual property bool DesignTimeVisible {
    bool get () override;
    void set (bool value) override;
}

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


Transaction Property

JavaScript

BMXNetCommand..::Transaction Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDbTransaction Transaction { get; set; }
Public Property Transaction As IDbTransaction
public:
virtual property IDbTransaction^ Transaction {
    IDbTransaction^ get () sealed;
    void set (IDbTransaction^ value) sealed;
}

Implements

IDbCommand..::.Transaction

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


UpdatedRowSource Property

JavaScript

BMXNetCommand..::UpdatedRowSource Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override UpdateRowSource UpdatedRowSource { get; set; }
Public Overrides Property UpdatedRowSource As UpdateRowSource
public:
virtual property UpdateRowSource UpdatedRowSource {
    UpdateRowSource get () override;
    void set (UpdateRowSource value) override;
}

Implements

IDbCommand..::.UpdatedRowSource
IDbCommand..::.UpdatedRowSource

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetCommand Events

JavaScript

BMXNetCommand Events

BMXNET 4.0 Developer API

The BMXNetCommand type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Disposed | (Inherited from Component.)

See Also

BMXNetCommand Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetDataAdapter Class

JavaScript

| Members | See Also
.NET Framework Class Library
BMXNetDataAdapter Class

BMXNET 4.0 Developer API

BMXNET implementaiton of DbDataAdaptor. This class can be used like any ADO.NET DbDataAdaptor implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class BMXNetDataAdapter : DbDataAdapter,
    IDbDataAdapter, IDataAdapter
Public Class BMXNetDataAdapter _
    Inherits DbDataAdapter _
    Implements IDbDataAdapter, IDataAdapter
public ref class BMXNetDataAdapter : public DbDataAdapter,
    IDbDataAdapter, IDataAdapter

Members

All Members | Constructors | Properties | Methods | Events | Explicit Interface Implementations
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BMXNetDataAdapter()()() |
AcceptChangesDuringFill | (Inherited from DataAdapter.)
AcceptChangesDuringUpdate | (Inherited from DataAdapter.)
AddToBatch(IDbCommand) | (Inherited from DbDataAdapter.)
CanRaiseEvents | (Inherited from Component.)
ClearBatch()()() | (Inherited from DbDataAdapter.)
ICloneable..::.Clone()()() | (Inherited from DbDataAdapter.)
CloneInternals()()() | Obsolete. (Inherited from DataAdapter.)
Container | (Inherited from Component.)
ContinueUpdateOnError | (Inherited from DataAdapter.)
CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
CreateRowUpdatedEvent(DataRow, IDbCommand, StatementType, DataTableMapping) | (Overrides DbDataAdapter..::.CreateRowUpdatedEvent(DataRow, IDbCommand, StatementType, DataTableMapping).)
CreateRowUpdatingEvent(DataRow, IDbCommand, StatementType, DataTableMapping) | (Overrides DbDataAdapter..::.CreateRowUpdatingEvent(DataRow, IDbCommand, StatementType, DataTableMapping).)
CreateTableMappings()()() | (Inherited from DataAdapter.)
DeleteCommand |
IDbDataAdapter..::.DeleteCommand |
DesignMode | (Inherited from Component.)
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | (Inherited from DbDataAdapter.)
Disposed | (Inherited from Component.)
Equals(Object) | (Inherited from Object.)
Events | (Inherited from Component.)
ExecuteBatch()()() | (Inherited from DbDataAdapter.)
Fill(DataTable) | (Inherited from DbDataAdapter.)
Fill(DataSet) | (Overrides DbDataAdapter..::.Fill(DataSet).)
Fill(DataSet, String) | (Inherited from DbDataAdapter.)
Fill(DataTable, IDataReader) | (Inherited from DataAdapter.)
Fill(Int32, Int32, array<DataTable>[]()[]) | (Inherited from DbDataAdapter.)
Fill(DataTable, IDbCommand, CommandBehavior) | (Inherited from DbDataAdapter.)
Fill(DataSet, Int32, Int32, String) | (Inherited from DbDataAdapter.)
Fill(array<DataTable>[]()[], IDataReader, Int32, Int32) | (Inherited from DataAdapter.)
Fill(array<DataTable>[]()[], Int32, Int32, IDbCommand, CommandBehavior) | (Inherited from DbDataAdapter.)
Fill(DataSet, String, IDataReader, Int32, Int32) | (Inherited from DataAdapter.)
Fill(DataSet, Int32, Int32, String, IDbCommand, CommandBehavior) | (Inherited from DbDataAdapter.)
FillCommandBehavior | (Inherited from DbDataAdapter.)
FillError | (Inherited from DataAdapter.)
FillLoadOption | (Inherited from DataAdapter.)
FillSchema(DataTable, SchemaType) | (Inherited from DbDataAdapter.)
FillSchema(DataSet, SchemaType) | (Inherited from DbDataAdapter.)
FillSchema(DataSet, SchemaType, String) | (Inherited from DbDataAdapter.)
FillSchema(DataTable, SchemaType, IDataReader) | (Inherited from DataAdapter.)
FillSchema(DataSet, SchemaType, String, IDataReader) | (Inherited from DataAdapter.)
FillSchema(DataTable, SchemaType, IDbCommand, CommandBehavior) | (Overrides DbDataAdapter..::.FillSchema(DataTable, SchemaType, IDbCommand, CommandBehavior).)
FillSchema(DataSet, SchemaType, IDbCommand, String, CommandBehavior) | (Inherited from DbDataAdapter.)
Finalize()()() | (Inherited from Component.)
GetBatchedParameter(Int32, Int32) | (Inherited from DbDataAdapter.)
GetBatchedRecordsAffected(Int32, Int32%, Exception%) | (Inherited from DbDataAdapter.)
GetFillParameters()()() | (Inherited from DbDataAdapter.)
GetHashCode()()() | (Inherited from Object.)
GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
GetService(Type) | (Inherited from Component.)
GetType()()() | (Inherited from Object.)
HasTableMappings()()() | (Inherited from DataAdapter.)
InitializeBatching()()() | (Inherited from DbDataAdapter.)
InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
InsertCommand |
IDbDataAdapter..::.InsertCommand |
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
MissingMappingAction | (Inherited from DataAdapter.)
MissingSchemaAction | (Inherited from DataAdapter.)
OnFillError(FillErrorEventArgs) | (Inherited from DataAdapter.)
OnRowUpdated(RowUpdatedEventArgs) | (Overrides DbDataAdapter..::.OnRowUpdated(RowUpdatedEventArgs).)
OnRowUpdating(RowUpdatingEventArgs) | (Overrides DbDataAdapter..::.OnRowUpdating(RowUpdatingEventArgs).)
ResetFillLoadOption()()() | (Inherited from DataAdapter.)
ReturnProviderSpecificTypes | (Inherited from DataAdapter.)
SelectCommand |
IDbDataAdapter..::.SelectCommand |
ShouldSerializeAcceptChangesDuringFill()()() | (Inherited from DataAdapter.)
ShouldSerializeFillLoadOption()()() | (Inherited from DataAdapter.)
ShouldSerializeTableMappings()()() | (Inherited from DataAdapter.)
Site | (Inherited from Component.)
TableMappings | (Inherited from DataAdapter.)
IDataAdapter..::.TableMappings | (Inherited from DataAdapter.)
TerminateBatching()()() | (Inherited from DbDataAdapter.)
ToString()()() | (Inherited from Component.)
Update(DataSet) | (Inherited from DbDataAdapter.)
Update(array<DataRow>[]()[]) | (Inherited from DbDataAdapter.)
Update(DataTable) | (Inherited from DbDataAdapter.)
Update(DataSet, String) | (Inherited from DbDataAdapter.)
Update(array<DataRow>[]()[], DataTableMapping) | (Overrides DbDataAdapter..::.Update(array<DataRow>[]()[], DataTableMapping).)
UpdateBatchSize | (Inherited from DbDataAdapter.)
IDbDataAdapter..::.UpdateCommand |
UpdateCommand |

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Data.Common..::.DataAdapter
System.Data.Common..::.DbDataAdapter
IndianHealthService.BMXNet.Ado..::.BMXNetDataAdapter

See Also

IndianHealthService.BMXNet.Ado Namespace


BMXNetDataAdapter Constructor

JavaScript

BMXNetDataAdapter Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetDataAdapter()
Public Sub New
public:
BMXNetDataAdapter()

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetDataAdapter Methods

JavaScript

BMXNetDataAdapter Methods

BMXNET 4.0 Developer API

The BMXNetDataAdapter type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddToBatch(IDbCommand) | (Inherited from DbDataAdapter.)
ClearBatch()()() | (Inherited from DbDataAdapter.)
ICloneable..::.Clone()()() | (Inherited from DbDataAdapter.)
CloneInternals()()() | Obsolete. (Inherited from DataAdapter.)
CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
CreateRowUpdatedEvent(DataRow, IDbCommand, StatementType, DataTableMapping) | (Overrides DbDataAdapter..::.CreateRowUpdatedEvent(DataRow, IDbCommand, StatementType, DataTableMapping).)
CreateRowUpdatingEvent(DataRow, IDbCommand, StatementType, DataTableMapping) | (Overrides DbDataAdapter..::.CreateRowUpdatingEvent(DataRow, IDbCommand, StatementType, DataTableMapping).)
CreateTableMappings()()() | (Inherited from DataAdapter.)
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | (Inherited from DbDataAdapter.)
Equals(Object) | (Inherited from Object.)
ExecuteBatch()()() | (Inherited from DbDataAdapter.)
Fill(DataTable) | (Inherited from DbDataAdapter.)
Fill(DataSet) | (Overrides DbDataAdapter..::.Fill(DataSet).)
Fill(DataSet, String) | (Inherited from DbDataAdapter.)
Fill(DataTable, IDataReader) | (Inherited from DataAdapter.)
Fill(Int32, Int32, array<DataTable>[]()[]) | (Inherited from DbDataAdapter.)
Fill(DataTable, IDbCommand, CommandBehavior) | (Inherited from DbDataAdapter.)
Fill(DataSet, Int32, Int32, String) | (Inherited from DbDataAdapter.)
Fill(array<DataTable>[]()[], IDataReader, Int32, Int32) | (Inherited from DataAdapter.)
Fill(array<DataTable>[]()[], Int32, Int32, IDbCommand, CommandBehavior) | (Inherited from DbDataAdapter.)
Fill(DataSet, String, IDataReader, Int32, Int32) | (Inherited from DataAdapter.)
Fill(DataSet, Int32, Int32, String, IDbCommand, CommandBehavior) | (Inherited from DbDataAdapter.)
FillSchema(DataTable, SchemaType) | (Inherited from DbDataAdapter.)
FillSchema(DataSet, SchemaType) | (Inherited from DbDataAdapter.)
FillSchema(DataSet, SchemaType, String) | (Inherited from DbDataAdapter.)
FillSchema(DataTable, SchemaType, IDataReader) | (Inherited from DataAdapter.)
FillSchema(DataSet, SchemaType, String, IDataReader) | (Inherited from DataAdapter.)
FillSchema(DataTable, SchemaType, IDbCommand, CommandBehavior) | (Overrides DbDataAdapter..::.FillSchema(DataTable, SchemaType, IDbCommand, CommandBehavior).)
FillSchema(DataSet, SchemaType, IDbCommand, String, CommandBehavior) | (Inherited from DbDataAdapter.)
Finalize()()() | (Inherited from Component.)
GetBatchedParameter(Int32, Int32) | (Inherited from DbDataAdapter.)
GetBatchedRecordsAffected(Int32, Int32%, Exception%) | (Inherited from DbDataAdapter.)
GetFillParameters()()() | (Inherited from DbDataAdapter.)
GetHashCode()()() | (Inherited from Object.)
GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
GetService(Type) | (Inherited from Component.)
GetType()()() | (Inherited from Object.)
HasTableMappings()()() | (Inherited from DataAdapter.)
InitializeBatching()()() | (Inherited from DbDataAdapter.)
InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
OnFillError(FillErrorEventArgs) | (Inherited from DataAdapter.)
OnRowUpdated(RowUpdatedEventArgs) | (Overrides DbDataAdapter..::.OnRowUpdated(RowUpdatedEventArgs).)
OnRowUpdating(RowUpdatingEventArgs) | (Overrides DbDataAdapter..::.OnRowUpdating(RowUpdatingEventArgs).)
ResetFillLoadOption()()() | (Inherited from DataAdapter.)
ShouldSerializeAcceptChangesDuringFill()()() | (Inherited from DataAdapter.)
ShouldSerializeFillLoadOption()()() | (Inherited from DataAdapter.)
ShouldSerializeTableMappings()()() | (Inherited from DataAdapter.)
TerminateBatching()()() | (Inherited from DbDataAdapter.)
ToString()()() | (Inherited from Component.)
Update(DataSet) | (Inherited from DbDataAdapter.)
Update(array<DataRow>[]()[]) | (Inherited from DbDataAdapter.)
Update(DataTable) | (Inherited from DbDataAdapter.)
Update(DataSet, String) | (Inherited from DbDataAdapter.)
Update(array<DataRow>[]()[], DataTableMapping) | (Overrides DbDataAdapter..::.Update(array<DataRow>[]()[], DataTableMapping).)

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


CreateRowUpdatedEvent Method

JavaScript

BMXNetDataAdapter..::CreateRowUpdatedEvent Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override RowUpdatedEventArgs CreateRowUpdatedEvent(
    DataRow dataRow,
    IDbCommand command,
    StatementType statementType,
    DataTableMapping tableMapping
)
Protected Overrides Function CreateRowUpdatedEvent ( _
    dataRow As DataRow, _
    command As IDbCommand, _
    statementType As StatementType, _
    tableMapping As DataTableMapping _
) As RowUpdatedEventArgs
protected:
virtual RowUpdatedEventArgs^ CreateRowUpdatedEvent(
    DataRow^ dataRow,
    IDbCommand^ command,
    StatementType statementType,
    DataTableMapping^ tableMapping
) override

Parameters

dataRow
DataRow
command
IDbCommand
statementType
StatementType
tableMapping
DataTableMapping

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


CreateRowUpdatingEvent Method

JavaScript

BMXNetDataAdapter..::CreateRowUpdatingEvent Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override RowUpdatingEventArgs CreateRowUpdatingEvent(
    DataRow dataRow,
    IDbCommand command,
    StatementType statementType,
    DataTableMapping tableMapping
)
Protected Overrides Function CreateRowUpdatingEvent ( _
    dataRow As DataRow, _
    command As IDbCommand, _
    statementType As StatementType, _
    tableMapping As DataTableMapping _
) As RowUpdatingEventArgs
protected:
virtual RowUpdatingEventArgs^ CreateRowUpdatingEvent(
    DataRow^ dataRow,
    IDbCommand^ command,
    StatementType statementType,
    DataTableMapping^ tableMapping
) override

Parameters

dataRow
DataRow
command
IDbCommand
statementType
StatementType
tableMapping
DataTableMapping

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


Dispose Method

JavaScript

BMXNetDataAdapter..::Dispose Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) | (Overrides DataAdapter.Dispose(Boolean).)

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


Fill Method

JavaScript

BMXNetDataAdapter..::Fill Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Fill(DataTable) |
Fill(DataSet) | (Overrides DbDataAdapter.Fill(DataSet).)
Fill(DataSet, String) |
Fill(DataTable, IDataReader) |
Fill(Int32, Int32, array<DataTable>[]()[]) |
Fill(DataTable, IDbCommand, CommandBehavior) |
Fill(DataSet, Int32, Int32, String) |
Fill(array<DataTable>[]()[], IDataReader, Int32, Int32) |
Fill(array<DataTable>[]()[], Int32, Int32, IDbCommand, CommandBehavior) |
Fill(DataSet, String, IDataReader, Int32, Int32) |
Fill(DataSet, Int32, Int32, String, IDbCommand, CommandBehavior) |

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


Fill Method (DataSet)

JavaScript

BMXNetDataAdapter..::Fill Method (DataSet)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public override int Fill(
    DataSet ds
)
Public Overrides Function Fill ( _
    ds As DataSet _
) As Integer
public:
virtual int Fill(
    DataSet^ ds
) override

Parameters

ds
DataSet

Implements

IDataAdapter..::.Fill(DataSet)
IDataAdapter..::.Fill(DataSet)
IDataAdapter..::.Fill(DataSet)

See Also

BMXNetDataAdapter Class
Fill Overload
IndianHealthService.BMXNet.Ado Namespace


FillSchema Method

JavaScript

BMXNetDataAdapter..::FillSchema Method

BMXNET 4.0 Developer API

Overload List

Name | Description
FillSchema(DataTable, SchemaType) |
FillSchema(DataSet, SchemaType) | (Overrides DataAdapter.FillSchema(DataSet, SchemaType).)
FillSchema(DataSet, SchemaType, String) |
FillSchema(DataTable, SchemaType, IDataReader) |
FillSchema(DataSet, SchemaType, String, IDataReader) |
FillSchema(DataTable, SchemaType, IDbCommand, CommandBehavior) | (Overrides DbDataAdapter.FillSchema(DataTable, SchemaType, IDbCommand, CommandBehavior).)
FillSchema(DataSet, SchemaType, IDbCommand, String, CommandBehavior) |

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


FillSchema Method (DataTable, SchemaType, IDbCommand, CommandBehavior)

JavaScript

BMXNetDataAdapter..::FillSchema Method (DataTable, SchemaType, IDbCommand, CommandBehavior)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override DataTable FillSchema(
    DataTable dataTable,
    SchemaType schemaType,
    IDbCommand command,
    CommandBehavior behavior
)
Protected Overrides Function FillSchema ( _
    dataTable As DataTable, _
    schemaType As SchemaType, _
    command As IDbCommand, _
    behavior As CommandBehavior _
) As DataTable
protected:
virtual DataTable^ FillSchema(
    DataTable^ dataTable,
    SchemaType schemaType,
    IDbCommand^ command,
    CommandBehavior behavior
) override

Parameters

dataTable
DataTable
schemaType
SchemaType
command
IDbCommand
behavior
CommandBehavior

See Also

BMXNetDataAdapter Class
FillSchema Overload
IndianHealthService.BMXNet.Ado Namespace


MemberwiseClone Method

JavaScript

BMXNetDataAdapter..::MemberwiseClone Method

BMXNET 4.0 Developer API

Overload List

Name | Description
MemberwiseClone()()() |
MemberwiseClone(Boolean) |

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


OnRowUpdated Method

JavaScript

BMXNetDataAdapter..::OnRowUpdated Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override void OnRowUpdated(
    RowUpdatedEventArgs value
)
Protected Overrides Sub OnRowUpdated ( _
    value As RowUpdatedEventArgs _
)
protected:
virtual void OnRowUpdated(
    RowUpdatedEventArgs^ value
) override

Parameters

value
RowUpdatedEventArgs

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


OnRowUpdating Method

JavaScript

BMXNetDataAdapter..::OnRowUpdating Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override void OnRowUpdating(
    RowUpdatingEventArgs value
)
Protected Overrides Sub OnRowUpdating ( _
    value As RowUpdatingEventArgs _
)
protected:
virtual void OnRowUpdating(
    RowUpdatingEventArgs^ value
) override

Parameters

value
RowUpdatingEventArgs

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


Update Method

JavaScript

BMXNetDataAdapter..::Update Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Update(DataSet) | (Overrides DataAdapter.Update(DataSet).)
Update(array<DataRow>[]()[]) |
Update(DataTable) |
Update(DataSet, String) |
Update(array<DataRow>[]()[], DataTableMapping) | (Overrides DbDataAdapter.Update(array<DataRow>[]()[], DataTableMapping).)

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


Update Method (DataRow[], DataTableMapping)

JavaScript

BMXNetDataAdapter..::Update Method (array<DataRow>[]()[], DataTableMapping)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override int Update(
    DataRow[] dataRows,
    DataTableMapping tableMapping
)
Protected Overrides Function Update ( _
    dataRows As DataRow(), _
    tableMapping As DataTableMapping _
) As Integer
protected:
virtual int Update(
    array<DataRow^>^ dataRows,
    DataTableMapping^ tableMapping
) override

Parameters

dataRows
array< DataRow >[]()[]
tableMapping
DataTableMapping

See Also

BMXNetDataAdapter Class
Update Overload
IndianHealthService.BMXNet.Ado Namespace


BMXNetDataAdapter Properties

JavaScript

BMXNetDataAdapter Properties

BMXNET 4.0 Developer API

The BMXNetDataAdapter type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AcceptChangesDuringFill | (Inherited from DataAdapter.)
AcceptChangesDuringUpdate | (Inherited from DataAdapter.)
CanRaiseEvents | (Inherited from Component.)
Container | (Inherited from Component.)
ContinueUpdateOnError | (Inherited from DataAdapter.)
DeleteCommand |
IDbDataAdapter..::.DeleteCommand |
DesignMode | (Inherited from Component.)
Events | (Inherited from Component.)
FillCommandBehavior | (Inherited from DbDataAdapter.)
FillLoadOption | (Inherited from DataAdapter.)
InsertCommand |
IDbDataAdapter..::.InsertCommand |
MissingMappingAction | (Inherited from DataAdapter.)
MissingSchemaAction | (Inherited from DataAdapter.)
ReturnProviderSpecificTypes | (Inherited from DataAdapter.)
SelectCommand |
IDbDataAdapter..::.SelectCommand |
Site | (Inherited from Component.)
TableMappings | (Inherited from DataAdapter.)
IDataAdapter..::.TableMappings | (Inherited from DataAdapter.)
UpdateBatchSize | (Inherited from DbDataAdapter.)
IDbDataAdapter..::.UpdateCommand |
UpdateCommand |

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


DeleteCommand Property

JavaScript

BMXNetDataAdapter..::DeleteCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
IDbCommand IDbDataAdapter.DeleteCommand { get; set; }
Private Property DeleteCommand As IDbCommand
    Implements IDbDataAdapter.DeleteCommand
private:
virtual property IDbCommand^ DeleteCommand {
    IDbCommand^ get () sealed = IDbDataAdapter::DeleteCommand::get;
    void set (IDbCommand^ value) sealed = IDbDataAdapter::DeleteCommand::set;
}

Implements

IDbDataAdapter..::.DeleteCommand

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


InsertCommand Property

JavaScript

BMXNetDataAdapter..::InsertCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
IDbCommand IDbDataAdapter.InsertCommand { get; set; }
Private Property InsertCommand As IDbCommand
    Implements IDbDataAdapter.InsertCommand
private:
virtual property IDbCommand^ InsertCommand {
    IDbCommand^ get () sealed = IDbDataAdapter::InsertCommand::get;
    void set (IDbCommand^ value) sealed = IDbDataAdapter::InsertCommand::set;
}

Implements

IDbDataAdapter..::.InsertCommand

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


SelectCommand Property

JavaScript

BMXNetDataAdapter..::SelectCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
IDbCommand IDbDataAdapter.SelectCommand { get; set; }
Private Property SelectCommand As IDbCommand
    Implements IDbDataAdapter.SelectCommand
private:
virtual property IDbCommand^ SelectCommand {
    IDbCommand^ get () sealed = IDbDataAdapter::SelectCommand::get;
    void set (IDbCommand^ value) sealed = IDbDataAdapter::SelectCommand::set;
}

Implements

IDbDataAdapter..::.SelectCommand

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


UpdateCommand Property

JavaScript

BMXNetDataAdapter..::UpdateCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
IDbCommand IDbDataAdapter.UpdateCommand { get; set; }
Private Property UpdateCommand As IDbCommand
    Implements IDbDataAdapter.UpdateCommand
private:
virtual property IDbCommand^ UpdateCommand {
    IDbCommand^ get () sealed = IDbDataAdapter::UpdateCommand::get;
    void set (IDbCommand^ value) sealed = IDbDataAdapter::UpdateCommand::set;
}

Implements

IDbDataAdapter..::.UpdateCommand

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


DeleteCommand Property

JavaScript

BMXNetDataAdapter..::DeleteCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetCommand DeleteCommand { get; set; }
Public Property DeleteCommand As BMXNetCommand
public:
property BMXNetCommand^ DeleteCommand {
    BMXNetCommand^ get ();
    void set (BMXNetCommand^ value);
}

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


InsertCommand Property

JavaScript

BMXNetDataAdapter..::InsertCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetCommand InsertCommand { get; set; }
Public Property InsertCommand As BMXNetCommand
public:
property BMXNetCommand^ InsertCommand {
    BMXNetCommand^ get ();
    void set (BMXNetCommand^ value);
}

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


SelectCommand Property

JavaScript

BMXNetDataAdapter..::SelectCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetCommand SelectCommand { get; set; }
Public Property SelectCommand As BMXNetCommand
public:
property BMXNetCommand^ SelectCommand {
    BMXNetCommand^ get ();
    void set (BMXNetCommand^ value);
}

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


UpdateCommand Property

JavaScript

BMXNetDataAdapter..::UpdateCommand Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetCommand UpdateCommand { get; set; }
Public Property UpdateCommand As BMXNetCommand
public:
property BMXNetCommand^ UpdateCommand {
    BMXNetCommand^ get ();
    void set (BMXNetCommand^ value);
}

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetDataAdapter Events

JavaScript

BMXNetDataAdapter Events

BMXNET 4.0 Developer API

The BMXNetDataAdapter type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Disposed | (Inherited from Component.)
FillError | (Inherited from DataAdapter.)

See Also

BMXNetDataAdapter Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetDataReader Class

JavaScript

| Members | See Also
.NET Framework Class Library
BMXNetDataReader Class

BMXNET 4.0 Developer API

BMXNET implementaiton of IDataReader. This class can be used like any ADO.NET IDataReader implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class BMXNetDataReader : IDataReader,
    IDisposable, IDataRecord
Public Class BMXNetDataReader _
    Implements IDataReader, IDisposable, IDataRecord
public ref class BMXNetDataReader : IDataReader,
    IDisposable, IDataRecord

Members

All Members | Properties | Methods | Explicit Interface Implementations
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()() |
Depth |
IDisposable..::.Dispose()()() |
Equals(Object) | (Inherited from Object.)
FieldCount |
Finalize()()() | (Inherited from Object.)
GetBoolean(Int32) |
GetByte(Int32) |
GetBytes(Int32, Int64, array<Byte>[]()[], Int32, Int32) |
GetChar(Int32) |
GetChars(Int32, Int64, array<Char>[]()[], Int32, Int32) |
GetData(Int32) |
GetDataTypeName(Int32) |
GetDateTime(Int32) |
GetDecimal(Int32) |
GetDouble(Int32) |
GetFieldType(Int32) |
GetFloat(Int32) |
GetGuid(Int32) |
GetHashCode()()() | (Inherited from Object.)
GetInt16(Int32) |
GetInt32(Int32) |
GetInt64(Int32) |
GetName(Int32) |
GetOrdinal(String) |
GetSchemaTable()()() |
GetString(Int32) |
GetType()()() | (Inherited from Object.)
GetValue(Int32) |
GetValues(array<Object>[]()[]) |
IsClosed |
IsDBNull(Int32) |
Item[([(Int32])]) |
Item[([(String])]) |
MemberwiseClone()()() | (Inherited from Object.)
NextResult()()() |
Read()()() |
RecordsAffected |
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.Ado..::.BMXNetDataReader

See Also

IndianHealthService.BMXNet.Ado Namespace


BMXNetDataReader Methods

JavaScript

BMXNetDataReader Methods

BMXNET 4.0 Developer API

The BMXNetDataReader type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Close()()() |
IDisposable..::.Dispose()()() |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetBoolean(Int32) |
GetByte(Int32) |
GetBytes(Int32, Int64, array<Byte>[]()[], Int32, Int32) |
GetChar(Int32) |
GetChars(Int32, Int64, array<Char>[]()[], Int32, Int32) |
GetData(Int32) |
GetDataTypeName(Int32) |
GetDateTime(Int32) |
GetDecimal(Int32) |
GetDouble(Int32) |
GetFieldType(Int32) |
GetFloat(Int32) |
GetGuid(Int32) |
GetHashCode()()() | (Inherited from Object.)
GetInt16(Int32) |
GetInt32(Int32) |
GetInt64(Int32) |
GetName(Int32) |
GetOrdinal(String) |
GetSchemaTable()()() |
GetString(Int32) |
GetType()()() | (Inherited from Object.)
GetValue(Int32) |
GetValues(array<Object>[]()[]) |
IsDBNull(Int32) |
MemberwiseClone()()() | (Inherited from Object.)
NextResult()()() |
Read()()() |
ToString()()() | (Inherited from Object.)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


Dispose Method

JavaScript

BMXNetDataReader..::Dispose Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
void IDisposable.Dispose()
Private Sub Dispose Implements IDisposable.Dispose
private:
virtual void Dispose() sealed = IDisposable::Dispose

Implements

IDisposable..::.Dispose()()()

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


Close Method

JavaScript

BMXNetDataReader..::Close Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Close()
Public Sub Close
public:
virtual void Close() sealed

Implements

IDataReader..::.Close()()()

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetBoolean Method

JavaScript

BMXNetDataReader..::GetBoolean Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool GetBoolean(
    int i
)
Public Function GetBoolean ( _
    i As Integer _
) As Boolean
public:
virtual bool GetBoolean(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetBoolean(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetByte Method

JavaScript

BMXNetDataReader..::GetByte Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public byte GetByte(
    int i
)
Public Function GetByte ( _
    i As Integer _
) As Byte
public:
virtual unsigned char GetByte(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetByte(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetBytes Method

JavaScript

BMXNetDataReader..::GetBytes Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public long GetBytes(
    int i,
    long fieldOffset,
    byte[] buffer,
    int bufferoffset,
    int length
)
Public Function GetBytes ( _
    i As Integer, _
    fieldOffset As Long, _
    buffer As Byte(), _
    bufferoffset As Integer, _
    length As Integer _
) As Long
public:
virtual long long GetBytes(
    int i,
    long long fieldOffset,
    array<unsigned char>^ buffer,
    int bufferoffset,
    int length
) sealed

Parameters

i
Int32
fieldOffset
Int64
buffer
array< Byte >[]()[]
bufferoffset
Int32
length
Int32

Implements

IDataRecord..::.GetBytes(Int32, Int64, array<Byte>[]()[], Int32, Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetChar Method

JavaScript

BMXNetDataReader..::GetChar Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public char GetChar(
    int i
)
Public Function GetChar ( _
    i As Integer _
) As Char
public:
virtual wchar_t GetChar(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetChar(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetChars Method

JavaScript

BMXNetDataReader..::GetChars Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public long GetChars(
    int i,
    long fieldoffset,
    char[] buffer,
    int bufferoffset,
    int length
)
Public Function GetChars ( _
    i As Integer, _
    fieldoffset As Long, _
    buffer As Char(), _
    bufferoffset As Integer, _
    length As Integer _
) As Long
public:
virtual long long GetChars(
    int i,
    long long fieldoffset,
    array<wchar_t>^ buffer,
    int bufferoffset,
    int length
) sealed

Parameters

i
Int32
fieldoffset
Int64
buffer
array< Char >[]()[]
bufferoffset
Int32
length
Int32

Implements

IDataRecord..::.GetChars(Int32, Int64, array<Char>[]()[], Int32, Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetData Method

JavaScript

BMXNetDataReader..::GetData Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDataReader GetData(
    int i
)
Public Function GetData ( _
    i As Integer _
) As IDataReader
public:
virtual IDataReader^ GetData(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetData(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetDataTypeName Method

JavaScript

BMXNetDataReader..::GetDataTypeName Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string GetDataTypeName(
    int i
)
Public Function GetDataTypeName ( _
    i As Integer _
) As String
public:
virtual String^ GetDataTypeName(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetDataTypeName(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetDateTime Method

JavaScript

BMXNetDataReader..::GetDateTime Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DateTime GetDateTime(
    int i
)
Public Function GetDateTime ( _
    i As Integer _
) As DateTime
public:
virtual DateTime GetDateTime(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetDateTime(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetDecimal Method

JavaScript

BMXNetDataReader..::GetDecimal Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public decimal GetDecimal(
    int i
)
Public Function GetDecimal ( _
    i As Integer _
) As Decimal
public:
virtual Decimal GetDecimal(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetDecimal(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetDouble Method

JavaScript

BMXNetDataReader..::GetDouble Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public double GetDouble(
    int i
)
Public Function GetDouble ( _
    i As Integer _
) As Double
public:
virtual double GetDouble(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetDouble(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetFieldType Method

JavaScript

BMXNetDataReader..::GetFieldType Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Type GetFieldType(
    int i
)
Public Function GetFieldType ( _
    i As Integer _
) As Type
public:
virtual Type^ GetFieldType(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetFieldType(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetFloat Method

JavaScript

BMXNetDataReader..::GetFloat Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public float GetFloat(
    int i
)
Public Function GetFloat ( _
    i As Integer _
) As Single
public:
virtual float GetFloat(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetFloat(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetGuid Method

JavaScript

BMXNetDataReader..::GetGuid Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Guid GetGuid(
    int i
)
Public Function GetGuid ( _
    i As Integer _
) As Guid
public:
virtual Guid GetGuid(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetGuid(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetInt16 Method

JavaScript

BMXNetDataReader..::GetInt16 Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public short GetInt16(
    int i
)
Public Function GetInt16 ( _
    i As Integer _
) As Short
public:
virtual short GetInt16(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetInt16(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetInt32 Method

JavaScript

BMXNetDataReader..::GetInt32 Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int GetInt32(
    int i
)
Public Function GetInt32 ( _
    i As Integer _
) As Integer
public:
virtual int GetInt32(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetInt32(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetInt64 Method

JavaScript

BMXNetDataReader..::GetInt64 Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public long GetInt64(
    int i
)
Public Function GetInt64 ( _
    i As Integer _
) As Long
public:
virtual long long GetInt64(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetInt64(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetName Method

JavaScript

BMXNetDataReader..::GetName Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string GetName(
    int i
)
Public Function GetName ( _
    i As Integer _
) As String
public:
virtual String^ GetName(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetName(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetOrdinal Method

JavaScript

BMXNetDataReader..::GetOrdinal Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int GetOrdinal(
    string name
)
Public Function GetOrdinal ( _
    name As String _
) As Integer
public:
virtual int GetOrdinal(
    String^ name
) sealed

Parameters

name
String

Implements

IDataRecord..::.GetOrdinal(String)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetSchemaTable Method

JavaScript

BMXNetDataReader..::GetSchemaTable Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable GetSchemaTable()
Public Function GetSchemaTable As DataTable
public:
virtual DataTable^ GetSchemaTable() sealed

Implements

IDataReader..::.GetSchemaTable()()()

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetString Method

JavaScript

BMXNetDataReader..::GetString Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string GetString(
    int i
)
Public Function GetString ( _
    i As Integer _
) As String
public:
virtual String^ GetString(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetString(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetValue Method

JavaScript

BMXNetDataReader..::GetValue Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Object GetValue(
    int i
)
Public Function GetValue ( _
    i As Integer _
) As Object
public:
virtual Object^ GetValue(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.GetValue(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


GetValues Method

JavaScript

BMXNetDataReader..::GetValues Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int GetValues(
    Object[] values
)
Public Function GetValues ( _
    values As Object() _
) As Integer
public:
virtual int GetValues(
    array<Object^>^ values
) sealed

Parameters

values
array< Object >[]()[]

Implements

IDataRecord..::.GetValues(array<Object>[]()[])

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


IsDBNull Method

JavaScript

BMXNetDataReader..::IsDBNull Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsDBNull(
    int i
)
Public Function IsDBNull ( _
    i As Integer _
) As Boolean
public:
virtual bool IsDBNull(
    int i
) sealed

Parameters

i
Int32

Implements

IDataRecord..::.IsDBNull(Int32)

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


NextResult Method

JavaScript

BMXNetDataReader..::NextResult Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool NextResult()
Public Function NextResult As Boolean
public:
virtual bool NextResult() sealed

Implements

IDataReader..::.NextResult()()()

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


Read Method

JavaScript

BMXNetDataReader..::Read Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Read()
Public Function Read As Boolean
public:
virtual bool Read() sealed

Implements

IDataReader..::.Read()()()

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetDataReader Properties

JavaScript

BMXNetDataReader Properties

BMXNET 4.0 Developer API

The BMXNetDataReader type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Depth |
FieldCount |
IsClosed |
Item[([(Int32])]) |
Item[([(String])]) |
RecordsAffected |

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


Depth Property

JavaScript

BMXNetDataReader..::Depth Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int Depth { get; }
Public ReadOnly Property Depth As Integer
public:
virtual property int Depth {
    int get () sealed;
}

Implements

IDataReader..::.Depth

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


FieldCount Property

JavaScript

BMXNetDataReader..::FieldCount Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int FieldCount { get; }
Public ReadOnly Property FieldCount As Integer
public:
virtual property int FieldCount {
    int get () sealed;
}

Implements

IDataRecord..::.FieldCount

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


IsClosed Property

JavaScript

BMXNetDataReader..::IsClosed Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
public:
virtual property bool IsClosed {
    bool get () sealed;
}

Implements

IDataReader..::.IsClosed

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


Item Property

JavaScript

BMXNetDataReader..::Item Property

BMXNET 4.0 Developer API

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(String])]) |

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


Item Property (Int32)

JavaScript

BMXNetDataReader..::Item Property (Int32)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Object Item[
    int i
] { get; }
Public ReadOnly Property Item ( _
    i As Integer _
) As Object
public:
virtual property Object^ Item[int i] {
    Object^ get (int i) sealed;
}

Parameters

i
Int32

Implements

IDataRecord..::.Item[([(Int32])])

See Also

BMXNetDataReader Class
Item Overload
IndianHealthService.BMXNet.Ado Namespace


Item Property (String)

JavaScript

BMXNetDataReader..::Item Property (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Object Item[
    string name
] { get; }
Public ReadOnly Property Item ( _
    name As String _
) As Object
public:
virtual property Object^ Item[String^ name] {
    Object^ get (String^ name) sealed;
}

Parameters

name
String

Implements

IDataRecord..::.Item[([(String])])

See Also

BMXNetDataReader Class
Item Overload
IndianHealthService.BMXNet.Ado Namespace


RecordsAffected Property

JavaScript

BMXNetDataReader..::RecordsAffected Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int RecordsAffected { get; }
Public ReadOnly Property RecordsAffected As Integer
public:
virtual property int RecordsAffected {
    int get () sealed;
}

Implements

IDataReader..::.RecordsAffected

See Also

BMXNetDataReader Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetTransaction Class

JavaScript

| Members | See Also
.NET Framework Class Library
BMXNetTransaction Class

BMXNET 4.0 Developer API

BMXNET implementaiton of IDbTransaction. This class can be used like any ADO.NET IDbTransaction implementation or the suggested RemoteSession API's can be used. See ADO.NET documentation for details of this class.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class BMXNetTransaction : IDbTransaction,
    IDisposable
Public Class BMXNetTransaction _
    Implements IDbTransaction, IDisposable
public ref class BMXNetTransaction : IDbTransaction,
    IDisposable

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BMXNetTransaction()()() |
Commit()()() |
Connection |
Dispose()()() |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IsolationLevel |
MemberwiseClone()()() | (Inherited from Object.)
Rollback()()() |
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.Ado..::.BMXNetTransaction

See Also

IndianHealthService.BMXNet.Ado Namespace


BMXNetTransaction Constructor

JavaScript

BMXNetTransaction Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXNetTransaction()
Public Sub New
public:
BMXNetTransaction()

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetTransaction Methods

JavaScript

BMXNetTransaction Methods

BMXNET 4.0 Developer API

The BMXNetTransaction type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Commit()()() |
Dispose()()() |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
Rollback()()() |
ToString()()() | (Inherited from Object.)

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


Commit Method

JavaScript

BMXNetTransaction..::Commit Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Commit()
Public Sub Commit
public:
virtual void Commit() sealed

Implements

IDbTransaction..::.Commit()()()

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


Dispose Method

JavaScript

BMXNetTransaction..::Dispose Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed

Implements

IDisposable..::.Dispose()()()

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


Rollback Method

JavaScript

BMXNetTransaction..::Rollback Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Rollback()
Public Sub Rollback
public:
virtual void Rollback() sealed

Implements

IDbTransaction..::.Rollback()()()

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


BMXNetTransaction Properties

JavaScript

BMXNetTransaction Properties

BMXNET 4.0 Developer API

The BMXNetTransaction type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Connection |
IsolationLevel |

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


Connection Property

JavaScript

BMXNetTransaction..::Connection Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IDbConnection Connection { get; }
Public ReadOnly Property Connection As IDbConnection
public:
virtual property IDbConnection^ Connection {
    IDbConnection^ get () sealed;
}

Implements

IDbTransaction..::.Connection

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


IsolationLevel Property

JavaScript

BMXNetTransaction..::IsolationLevel Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public IsolationLevel IsolationLevel { get; }
Public ReadOnly Property IsolationLevel As IsolationLevel
public:
virtual property IsolationLevel IsolationLevel {
    IsolationLevel get () sealed;
}

Implements

IDbTransaction..::.IsolationLevel

See Also

BMXNetTransaction Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFuture Class

JavaScript

| Members | See Also
.NET Framework Class Library
DataTableFuture Class

BMXNET 4.0 Developer API

DataTableFutures are created synchrounously when Async calls are made on a RemoteSession. A DataTabelFuture is used to manage each async call and has a variety of methods to support the relativelty long and dynamic lifecycle and an Async call.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class DataTableFuture
Public Class DataTableFuture
public ref class DataTableFuture

Members

All Members | Constructors | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataTableFuture()()() |
Aborted |
Cancel()()() | Method to cancel the Async call. This does not stop the server-side processing. The Aborted event will be called immediately.
Equals(Object) | (Inherited from Object.)
ErrorException | Access to any exceptions that occur during Async call.
Finalize()()() | (Inherited from Object.)
FutureTime | The time the async call returned (the future)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
HasData | Answer true if the data has been fetched from the server and is ready to be used by the application.
HasReturned | Answer true if the Async call has completed on the server and that a result is ready.
HasTimedOut | Answer true if the Async call has timeed-out (a time-based version of Cancel)
InvokedControl |
IsAutoFetchEnabled | If set to true the result will be fetched before the Returned event is called, otherwise the Returned event will be triggered and the application code needs to call PostFetch() to retrieve the result. True by default.
MaxWaitTime | Number of seconds to wait for an async response before returning without a response.
MemberwiseClone()()() | (Inherited from Object.)
PostFetch()()() | If IsAutoFetchEnabled is false, then the results must be fetched synchrounously useding PostFetch(). Call PostFetch() once and check if HasData is true. If not true, there is was error related to the async call.
PresentTime | The time the Future was created.
Result | The result table if any, or null.
ResultAppContext | The AppContext that the async call was made with
ResultDataSet | The data set the result data table is in.
ResultKey |
ResultTableName |
Returned | Triggered with the async returns, see DataTableFutureEventArgs to know if there is a result waiting. It's very common to hook the Returned event after each Async call and then unhook it when the Returned or Aborted calls return.
ToString()()() | (Inherited from Object.)
TriggerAbortedEvent()()() |
TriggerReturnedEvent()()() |
WaitTime | How long in milliseconds the Async call took to complete.
WasCancelled | Answer true if canceled. It's common that a dialog would allow the user to cancel the Async call and the Dialog that is holding on the the Future will cancel the Future. Cancelling the Future does not stop the server-side processing but when the server returns nothing will happen.

Remarks

Beware that all return communications are not on the UI thread unless an InvokedControl is specify.

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.Ado..::.DataTableFuture

See Also

IndianHealthService.BMXNet.Ado Namespace


DataTableFuture Constructor

JavaScript

DataTableFuture Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTableFuture()
Public Sub New
public:
DataTableFuture()

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFuture Methods

JavaScript

DataTableFuture Methods

BMXNET 4.0 Developer API

The DataTableFuture type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cancel()()() | Method to cancel the Async call. This does not stop the server-side processing. The Aborted event will be called immediately.
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
PostFetch()()() | If IsAutoFetchEnabled is false, then the results must be fetched synchrounously useding PostFetch(). Call PostFetch() once and check if HasData is true. If not true, there is was error related to the async call.
ToString()()() | (Inherited from Object.)
TriggerAbortedEvent()()() |
TriggerReturnedEvent()()() |

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


Cancel Method

JavaScript

DataTableFuture..::Cancel Method

BMXNET 4.0 Developer API

Method to cancel the Async call. This does not stop the server-side processing. The Aborted event will be called immediately.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Cancel()
Public Sub Cancel
public:
void Cancel()

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


PostFetch Method

JavaScript

DataTableFuture..::PostFetch Method

BMXNET 4.0 Developer API

If IsAutoFetchEnabled is false, then the results must be fetched synchrounously useding PostFetch(). Call PostFetch() once and check if HasData is true. If not true, there is was error related to the async call.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void PostFetch()
Public Sub PostFetch
public:
void PostFetch()

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


TriggerAbortedEvent Method

JavaScript

DataTableFuture..::TriggerAbortedEvent Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected void TriggerAbortedEvent()
Protected Sub TriggerAbortedEvent
protected:
void TriggerAbortedEvent()

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


TriggerReturnedEvent Method

JavaScript

DataTableFuture..::TriggerReturnedEvent Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected void TriggerReturnedEvent()
Protected Sub TriggerReturnedEvent
protected:
void TriggerReturnedEvent()

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFuture Properties

JavaScript

DataTableFuture Properties

BMXNET 4.0 Developer API

The DataTableFuture type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ErrorException | Access to any exceptions that occur during Async call.
FutureTime | The time the async call returned (the future)
HasData | Answer true if the data has been fetched from the server and is ready to be used by the application.
HasReturned | Answer true if the Async call has completed on the server and that a result is ready.
HasTimedOut | Answer true if the Async call has timeed-out (a time-based version of Cancel)
InvokedControl |
IsAutoFetchEnabled | If set to true the result will be fetched before the Returned event is called, otherwise the Returned event will be triggered and the application code needs to call PostFetch() to retrieve the result. True by default.
MaxWaitTime | Number of seconds to wait for an async response before returning without a response.
PresentTime | The time the Future was created.
Result | The result table if any, or null.
ResultAppContext | The AppContext that the async call was made with
ResultDataSet | The data set the result data table is in.
ResultKey |
ResultTableName |
WaitTime | How long in milliseconds the Async call took to complete.
WasCancelled | Answer true if canceled. It's common that a dialog would allow the user to cancel the Async call and the Dialog that is holding on the the Future will cancel the Future. Cancelling the Future does not stop the server-side processing but when the server returns nothing will happen.

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


ErrorException Property

JavaScript

DataTableFuture..::ErrorException Property

BMXNET 4.0 Developer API

Access to any exceptions that occur during Async call.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Exception ErrorException { get; set; }
Public Property ErrorException As Exception
public:
property Exception^ ErrorException {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


FutureTime Property

JavaScript

DataTableFuture..::FutureTime Property

BMXNET 4.0 Developer API

The time the async call returned (the future)

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Nullable<DateTime> FutureTime { get; set; }
Public Property FutureTime As Nullable(Of DateTime)
public:
property Nullable<DateTime> FutureTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


HasData Property

JavaScript

DataTableFuture..::HasData Property

BMXNET 4.0 Developer API

Answer true if the data has been fetched from the server and is ready to be used by the application.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool HasData { get; set; }
Public Property HasData As Boolean
public:
property bool HasData {
    bool get ();
    void set (bool value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


HasReturned Property

JavaScript

DataTableFuture..::HasReturned Property

BMXNET 4.0 Developer API

Answer true if the Async call has completed on the server and that a result is ready.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool HasReturned { get; set; }
Public Property HasReturned As Boolean
public:
property bool HasReturned {
    bool get ();
    void set (bool value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


HasTimedOut Property

JavaScript

DataTableFuture..::HasTimedOut Property

BMXNET 4.0 Developer API

Answer true if the Async call has timeed-out (a time-based version of Cancel)

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool HasTimedOut { get; set; }
Public Property HasTimedOut As Boolean
public:
property bool HasTimedOut {
    bool get ();
    void set (bool value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


InvokedControl Property

JavaScript

DataTableFuture..::InvokedControl Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Control InvokedControl { get; set; }
Public Property InvokedControl As Control
public:
property Control^ InvokedControl {
    Control^ get ();
    void set (Control^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


IsAutoFetchEnabled Property

JavaScript

DataTableFuture..::IsAutoFetchEnabled Property

BMXNET 4.0 Developer API

If set to true the result will be fetched before the Returned event is called, otherwise the Returned event will be triggered and the application code needs to call PostFetch() to retrieve the result. True by default.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsAutoFetchEnabled { get; set; }
Public Property IsAutoFetchEnabled As Boolean
public:
property bool IsAutoFetchEnabled {
    bool get ();
    void set (bool value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


MaxWaitTime Property

JavaScript

DataTableFuture..::MaxWaitTime Property

BMXNET 4.0 Developer API

Number of seconds to wait for an async response before returning without a response.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public int MaxWaitTime { get; set; }
Public Property MaxWaitTime As Integer
public:
property int MaxWaitTime {
    int get ();
    void set (int value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


PresentTime Property

JavaScript

DataTableFuture..::PresentTime Property

BMXNET 4.0 Developer API

The time the Future was created.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DateTime PresentTime { get; set; }
Public Property PresentTime As DateTime
public:
property DateTime PresentTime {
    DateTime get ();
    void set (DateTime value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


Result Property

JavaScript

DataTableFuture..::Result Property

BMXNET 4.0 Developer API

The result table if any, or null.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable Result { get; set; }
Public Property Result As DataTable
public:
property DataTable^ Result {
    DataTable^ get ();
    void set (DataTable^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


ResultAppContext Property

JavaScript

DataTableFuture..::ResultAppContext Property

BMXNET 4.0 Developer API

The AppContext that the async call was made with

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string ResultAppContext { get; set; }
Public Property ResultAppContext As String
public:
property String^ ResultAppContext {
    String^ get ();
    void set (String^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


ResultDataSet Property

JavaScript

DataTableFuture..::ResultDataSet Property

BMXNET 4.0 Developer API

The data set the result data table is in.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataSet ResultDataSet { get; set; }
Public Property ResultDataSet As DataSet
public:
property DataSet^ ResultDataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


ResultKey Property

JavaScript

DataTableFuture..::ResultKey Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
protected string ResultKey { get; set; }
Protected Property ResultKey As String
protected:
property String^ ResultKey {
    String^ get ();
    void set (String^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


ResultTableName Property

JavaScript

DataTableFuture..::ResultTableName Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string ResultTableName { get; set; }
Public Property ResultTableName As String
public:
property String^ ResultTableName {
    String^ get ();
    void set (String^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


WaitTime Property

JavaScript

DataTableFuture..::WaitTime Property

BMXNET 4.0 Developer API

How long in milliseconds the Async call took to complete.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public double WaitTime { get; }
Public ReadOnly Property WaitTime As Double
public:
property double WaitTime {
    double get ();
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


WasCancelled Property

JavaScript

DataTableFuture..::WasCancelled Property

BMXNET 4.0 Developer API

Answer true if canceled. It's common that a dialog would allow the user to cancel the Async call and the Dialog that is holding on the the Future will cancel the Future. Cancelling the Future does not stop the server-side processing but when the server returns nothing will happen.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool WasCancelled { get; set; }
Public Property WasCancelled As Boolean
public:
property bool WasCancelled {
    bool get ();
    void set (bool value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFuture Events

JavaScript

DataTableFuture Events

BMXNET 4.0 Developer API

The DataTableFuture type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Aborted |
Returned | Triggered with the async returns, see DataTableFutureEventArgs to know if there is a result waiting. It's very common to hook the Returned event after each Async call and then unhook it when the Returned or Aborted calls return.

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


Aborted Event

JavaScript

DataTableFuture..::Aborted Event

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public event EventHandler<DataTableFutureEventArgs> Aborted
Public Event Aborted As EventHandler(Of DataTableFutureEventArgs)
public:
 event EventHandler<DataTableFutureEventArgs^>^ Aborted {
    void add (EventHandler<DataTableFutureEventArgs^>^ value);
    void remove (EventHandler<DataTableFutureEventArgs^>^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


Returned Event

JavaScript

DataTableFuture..::Returned Event

BMXNET 4.0 Developer API

Triggered with the async returns, see DataTableFutureEventArgs to know if there is a result waiting. It's very common to hook the Returned event after each Async call and then unhook it when the Returned or Aborted calls return.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public event EventHandler<DataTableFutureEventArgs> Returned
Public Event Returned As EventHandler(Of DataTableFutureEventArgs)
public:
 event EventHandler<DataTableFutureEventArgs^>^ Returned {
    void add (EventHandler<DataTableFutureEventArgs^>^ value);
    void remove (EventHandler<DataTableFutureEventArgs^>^ value);
}

See Also

DataTableFuture Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFutureEventArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
DataTableFutureEventArgs Class

BMXNET 4.0 Developer API

The event args for all DataTableFuture events.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class DataTableFutureEventArgs : EventArgs
Public Class DataTableFutureEventArgs _
    Inherits EventArgs
public ref class DataTableFutureEventArgs : public EventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DataTableFutureEventArgs()()() |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
Future | The future object that can be used to determine the state of the future, cancel the future, and perform some post future processing.
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

Remarks

The DataTableFuture events are trigger in the non-UI thread and will break any application that is not managing it's UI calls properly. If implementing a basic GUI-based application, it's recommended to set the InvokedControl on every DataTableFuture you created. This EventArgs provides the future, which is the same instance created when the Async call was made.

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
IndianHealthService.BMXNet.Ado..::.DataTableFutureEventArgs

See Also

IndianHealthService.BMXNet.Ado Namespace


DataTableFutureEventArgs Constructor

JavaScript

DataTableFutureEventArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTableFutureEventArgs()
Public Sub New
public:
DataTableFutureEventArgs()

See Also

DataTableFutureEventArgs Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFutureEventArgs Methods

JavaScript

DataTableFutureEventArgs Methods

BMXNET 4.0 Developer API

The DataTableFutureEventArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

DataTableFutureEventArgs Class
IndianHealthService.BMXNet.Ado Namespace


DataTableFutureEventArgs Properties

JavaScript

DataTableFutureEventArgs Properties

BMXNET 4.0 Developer API

The DataTableFutureEventArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Future | The future object that can be used to determine the state of the future, cancel the future, and perform some post future processing.

See Also

DataTableFutureEventArgs Class
IndianHealthService.BMXNet.Ado Namespace


Future Property

JavaScript

DataTableFutureEventArgs..::Future Property

BMXNET 4.0 Developer API

The future object that can be used to determine the state of the future, cancel the future, and perform some post future processing.

Namespace: IndianHealthService.BMXNet.Ado
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTableFuture Future { get; set; }
Public Property Future As DataTableFuture
public:
property DataTableFuture^ Future {
    DataTableFuture^ get ();
    void set (DataTableFuture^ value);
}

See Also

DataTableFutureEventArgs Class
IndianHealthService.BMXNet.Ado Namespace


IndianHealthService.BMXNet.EHR Namespace

JavaScript

IndianHealthService.BMXNet.EHR Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes | Interfaces
Name | Description
EhrFramework |
IEhrComponent | To support the HelpFile framework in the EHR menu, your component must implement this interface.
IEhrEvents | This interface is used to route EHR events to the common BMX context module.


EhrFramework Class

JavaScript

| Members | See Also
.NET Framework Class Library
EhrFramework Class

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public class EhrFramework
Public Class EhrFramework
public ref class EhrFramework

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
EhrFramework()()()
AttachTo(Object)
Attach the services to the aConsumer. This is basically a push of services versus a service lookup. aConsumer will be offered to cosume: LocalSession via LocalConsumer RemoteSession via RemoteSessionConsumer RemoteSessionPool via RemoteSessionPoolConsumer
Close()()()
Close the EhrFramework

Remarks

Releases all COM objects
CssSession
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IncomingEventCallback(String, String)
Forward an incoming event from the COM object to the EhrFramework
LocalSession
Access the LocalSession.

Remarks

This is used by the partial class to prime your LocalSessionConsumer implementing control
MemberwiseClone()()() | (Inherited from Object.)
On(CSS_Session, IEhrEvents, ICSS_SessionEvents)
Used to create the single EhrFramework instance used for each EHR/VueCentric-based component
RemoteSession
Access the primary RemoteSession.

Remarks

This is used by the partial class to prime your RemoteSessionConsumer implementing control
Setup(CSS_Session, IEhrEvents, ICSS_SessionEvents)
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.EHR..::.EhrFramework

See Also

IndianHealthService.BMXNet.EHR Namespace


EhrFramework Constructor

JavaScript

EhrFramework Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public EhrFramework()
Public Sub New
public:
EhrFramework()

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


EhrFramework Methods

JavaScript

EhrFramework Methods

BMXNET 4.0 Developer API

The EhrFramework type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttachTo(Object)
Attach the services to the aConsumer. This is basically a push of services versus a service lookup. aConsumer will be offered to cosume: LocalSession via LocalConsumer RemoteSession via RemoteSessionConsumer RemoteSessionPool via RemoteSessionPoolConsumer
Close()()()
Close the EhrFramework

Remarks

Releases all COM objects
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IncomingEventCallback(String, String)
Forward an incoming event from the COM object to the EhrFramework
MemberwiseClone()()() | (Inherited from Object.)
On(CSS_Session, IEhrEvents, ICSS_SessionEvents)
Used to create the single EhrFramework instance used for each EHR/VueCentric-based component
Setup(CSS_Session, IEhrEvents, ICSS_SessionEvents)
ToString()()() | (Inherited from Object.)

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


AttachTo Method

JavaScript

EhrFramework..::AttachTo Method

BMXNET 4.0 Developer API

Attach the services to the aConsumer. This is basically a push of services versus a service lookup. aConsumer will be offered to cosume: LocalSession via LocalConsumer RemoteSession via RemoteSessionConsumer RemoteSessionPool via RemoteSessionPoolConsumer

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public void AttachTo(
    Object aConsumer
)
Public Sub AttachTo ( _
    aConsumer As Object _
)
public:
void AttachTo(
    Object^ aConsumer
)

Parameters

aConsumer
Object
An object optionally implementing LocalConsumer, RemoteSessionConsumer, and/or RemoteSessionPoolConsumer

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


Close Method

JavaScript

EhrFramework..::Close Method

BMXNET 4.0 Developer API

Close the EhrFramework

Remarks

Releases all COM objects

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Close()
Public Sub Close
public:
void Close()

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


IncomingEventCallback Method

JavaScript

EhrFramework..::IncomingEventCallback Method

BMXNET 4.0 Developer API

Forward an incoming event from the COM object to the EhrFramework

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public void IncomingEventCallback(
    string anEventType,
    string someDetails
)
Public Sub IncomingEventCallback ( _
    anEventType As String, _
    someDetails As String _
)
public:
void IncomingEventCallback(
    String^ anEventType,
    String^ someDetails
)

Parameters

anEventType
String
This string corresponds to well-known/shared EventTypes used to identify different events published and subscribed within a local desktop application (WinFramework) or in the EHR.
someDetails
String
This is an optional peice of data with some event-specific details.

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


On Method

JavaScript

EhrFramework..::On Method

BMXNET 4.0 Developer API

Used to create the single EhrFramework instance used for each EHR/VueCentric-based component

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public static EhrFramework On(
    CSS_Session aCssSession,
    IEhrEvents anEventSource,
    ICSS_SessionEvents sessionEvents
)
Public Shared Function On ( _
    aCssSession As CSS_Session, _
    anEventSource As IEhrEvents, _
    sessionEvents As ICSS_SessionEvents _
) As EhrFramework
public:
static EhrFramework^ On(
    CSS_Session^ aCssSession,
    IEhrEvents^ anEventSource,
    ICSS_SessionEvents^ sessionEvents
)

Parameters

aCssSession
CSS_Session
A COM instance of CSS_Session. The EhrFramework will Release() it
anEventSource
IEhrEvents
The event source bridge to pass events from your COM-Visible control to the EhrFramework
sessionEvents
ICSS_SessionEvents
A COM instance of ICSS_SessionEvents. The EhrFramework will Release() it

Return Value

Remarks

Use the provided partial class to construct a UserControl-based component to host in the EHR/VueCentric framework

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


Setup Method

JavaScript

EhrFramework..::Setup Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
protected void Setup(
    CSS_Session aCssSession,
    IEhrEvents anEventSource,
    ICSS_SessionEvents sessionEvents
)
Protected Sub Setup ( _
    aCssSession As CSS_Session, _
    anEventSource As IEhrEvents, _
    sessionEvents As ICSS_SessionEvents _
)
protected:
void Setup(
    CSS_Session^ aCssSession,
    IEhrEvents^ anEventSource,
    ICSS_SessionEvents^ sessionEvents
)

Parameters

aCssSession
CSS_Session
anEventSource
IEhrEvents
sessionEvents
ICSS_SessionEvents

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


EhrFramework Properties

JavaScript

EhrFramework Properties

BMXNET 4.0 Developer API

The EhrFramework type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
CssSession
LocalSession
Access the LocalSession.

Remarks

This is used by the partial class to prime your LocalSessionConsumer implementing control
RemoteSession
Access the primary RemoteSession.

Remarks

This is used by the partial class to prime your RemoteSessionConsumer implementing control

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


CssSession Property

JavaScript

EhrFramework..::CssSession Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
protected CSS_Session CssSession { get; set; }
Protected Property CssSession As CSS_Session
protected:
property CSS_Session^ CssSession {
    CSS_Session^ get ();
    void set (CSS_Session^ value);
}

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


LocalSession Property

JavaScript

EhrFramework..::LocalSession Property

BMXNET 4.0 Developer API

Access the LocalSession.

Remarks

This is used by the partial class to prime your LocalSessionConsumer implementing control

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public LocalSession LocalSession { get; set; }
Public Property LocalSession As LocalSession
public:
property LocalSession^ LocalSession {
    LocalSession^ get ();
    void set (LocalSession^ value);
}

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


RemoteSession Property

JavaScript

EhrFramework..::RemoteSession Property

BMXNET 4.0 Developer API

Access the primary RemoteSession.

Remarks

This is used by the partial class to prime your RemoteSessionConsumer implementing control

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public RemoteSession RemoteSession { get; set; }
Public Property RemoteSession As RemoteSession
public:
property RemoteSession^ RemoteSession {
    RemoteSession^ get ();
    void set (RemoteSession^ value);
}

See Also

EhrFramework Class
IndianHealthService.BMXNet.EHR Namespace


IEhrComponent Interface

JavaScript

| Members | See Also
.NET Framework Class Library
IEhrComponent Interface

BMXNET 4.0 Developer API

To support the HelpFile framework in the EHR menu, your component must implement this interface.

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface IEhrComponent : IDisposable
Public Interface IEhrComponent _
    Implements IDisposable
public interface class IEhrComponent : IDisposable

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dispose()()() | (Inherited from IDisposable.)
HelpContext | Not currently used
HelpFile | The name of the compiled Windows help file (.chm).
HelpString | Not currently used

See Also

IndianHealthService.BMXNet.EHR Namespace


IEhrComponent Methods

JavaScript

IEhrComponent Methods

BMXNET 4.0 Developer API

The IEhrComponent type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Dispose()()() | (Inherited from IDisposable.)

See Also

IEhrComponent Interface
IndianHealthService.BMXNet.EHR Namespace


IEhrComponent Properties

JavaScript

IEhrComponent Properties

BMXNET 4.0 Developer API

The IEhrComponent type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
HelpContext | Not currently used
HelpFile | The name of the compiled Windows help file (.chm).
HelpString | Not currently used

See Also

IEhrComponent Interface
IndianHealthService.BMXNet.EHR Namespace


HelpContext Property

JavaScript

IEhrComponent..::HelpContext Property

BMXNET 4.0 Developer API

Not currently used

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
string HelpContext { get; }
ReadOnly Property HelpContext As String
property String^ HelpContext {
    String^ get ();
}

See Also

IEhrComponent Interface
IndianHealthService.BMXNet.EHR Namespace


HelpFile Property

JavaScript

IEhrComponent..::HelpFile Property

BMXNET 4.0 Developer API

The name of the compiled Windows help file (.chm).

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
string HelpFile { get; }
ReadOnly Property HelpFile As String
property String^ HelpFile {
    String^ get ();
}

Remarks

See the EHR/VueCentric integration partial class for details on specifying a HelpFile

See Also

IEhrComponent Interface
IndianHealthService.BMXNet.EHR Namespace


HelpString Property

JavaScript

IEhrComponent..::HelpString Property

BMXNET 4.0 Developer API

Not currently used

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
string HelpString { get; }
ReadOnly Property HelpString As String
property String^ HelpString {
    String^ get ();
}

See Also

IEhrComponent Interface
IndianHealthService.BMXNet.EHR Namespace


IEhrEvents Interface

JavaScript

| Members | See Also
.NET Framework Class Library
IEhrEvents Interface

BMXNET 4.0 Developer API

This interface is used to route EHR events to the common BMX context module.

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface IEhrEvents
Public Interface IEhrEvents
public interface class IEhrEvents

Members

All Members | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ContextChanged | This event is used internally by the EhrFramework
ContextChanging | This event is used internally by the EhrFramework

Remarks

This interface is used by the EHR/VueCentric integration partial class, there is not need for BMX developers to directly use this interface

See Also

IndianHealthService.BMXNet.EHR Namespace


IEhrEvents Events

JavaScript

IEhrEvents Events

BMXNET 4.0 Developer API

The IEhrEvents type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ContextChanged | This event is used internally by the EhrFramework
ContextChanging | This event is used internally by the EhrFramework

See Also

IEhrEvents Interface
IndianHealthService.BMXNet.EHR Namespace


ContextChanged Event

JavaScript

IEhrEvents..::ContextChanged Event

BMXNET 4.0 Developer API

This event is used internally by the EhrFramework

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler<ContextChangedArgs> ContextChanged
Event ContextChanged As EventHandler(Of ContextChangedArgs)
 event EventHandler<ContextChangedArgs^>^ ContextChanged {
    void add (EventHandler<ContextChangedArgs^>^ value);
    void remove (EventHandler<ContextChangedArgs^>^ value);
}

See Also

IEhrEvents Interface
IndianHealthService.BMXNet.EHR Namespace


ContextChanging Event

JavaScript

IEhrEvents..::ContextChanging Event

BMXNET 4.0 Developer API

This event is used internally by the EhrFramework

Namespace: IndianHealthService.BMXNet.EHR
Assembly: BMXEHR40 (in BMXEHR40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler<ContextChangingArgs> ContextChanging
Event ContextChanging As EventHandler(Of ContextChangingArgs)
 event EventHandler<ContextChangingArgs^>^ ContextChanging {
    void add (EventHandler<ContextChangingArgs^>^ value);
    void remove (EventHandler<ContextChangingArgs^>^ value);
}

See Also

IEhrEvents Interface
IndianHealthService.BMXNet.EHR Namespace


IndianHealthService.BMXNet.Model Namespace

JavaScript

IndianHealthService.BMXNet.Model Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes | Interfaces
Name Description
Context
Context interface provides the current status and related events of the patient/visit context within an application, or the EHR.
ContextChangedArgs
The argument to the ContextChanged method. This event has methods that allow you to detect which aspects of the context have changed and what the new context is.
ContextChangingArgs
An instance of these args are included with the ContextChanging event and this event is a CancelEventArgs subclass. The Cancel property being set to True represents the desire to Veto the change so the patient (and potentially visit) does not change. The Veto can be overriden by the framework so be prepared for the context to change even if you don't want it to.
Division
This object represents the RPMS Division.
Patient
The Patient object is a read-only object used for patient context.
User
The user that established the connection to BMX either through the WinFramework dialogs or access/verify codes, or a user established through attach tho the EHR/VueCentric with the EhrFramework.

The user breaks down into who is it and what can they do with some identify and security key checing.

Visit
The visit object is used to determine the current context of the application. The key wrinkle in the visit class relates to create a common interface for EHR/VueCentric and WinForm applications. The EHR/VueCentric supports visit stubs by default and the WinFramework does not. If the consumer of the visit object is going to use it to make changes to RPMS then the visit can not be a stub and must the visit must be created.

Examples

In either EHR or WinForm applications, always check for a stub before you call RPC's to update RPMS. If you do not, the visit may not have been created on RPMS and the visit id will be null.
Copy Code
            if (this.Context.HasVisit)
            {
                if (this.Context.Visit.IsStub && !this.Context.Visit.Create())
                {
                    MessageBox.Show("Unable to establish visit.","Editing Disabled");
                    return;
                }

                //Call RPC to update RPMS with current visit ien
            }


Context Interface

JavaScript

| Members | See Also
.NET Framework Class Library
Context Interface

BMXNET 4.0 Developer API

Context interface provides the current status and related events of the patient/visit context within an application, or the EHR.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface Context
Public Interface Context
public interface class Context

Members

All Members | Properties | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
Changed
The most important aspect of the Context interface is the Changed event that allows the receiver of the event know when the user is changing patient and visit. Applications need to change the data displayed to represent the currnet Patient and optional visit. The Changed event occurs after there is confirmation that the change has not been vetoed or the veto has been overridden. See Changing event.
Changing
When the current patient or visit is being changed by the user, every subscriber to the Changing method has the option to "Veto" the event by Cancelling it:
Copy Code
            public void Startup()
             {
                 if (this.Context != null)
                 {
                     this.Context.Changed += new EventHandler<ContextChangedArgs>(Context_Changed);
                     this.Context.Changing += new EventHandler<ContextChangedArgs>(Context_Changing);
             }

             void Context_Changing(object sender, ContextChangingArgs e)
             {
                 e.Cancel = needToFinishSomethingElseBeforeChangingContext;
             }
However, a Veto is like a U.S. presential Veto and that it can be overridden. The WinFramework or EHR can override any Veto so all components (even if they veto changes) must be prepared to have the context changed at anytime.
HasPatient
Answer true/false if there is a patient currently selected. This is a convenience method.
HasUnlockedVisit
Answer true if there is a visit and if it is unlocked. The EHR/VueCentric has a notion of the locked visit, a visit that can no longer be visited. The EHR/VueCetnric has has a visit stub, a visit that has been create on the desktop but not in RPMS. If a visit is a visit stub, it is not considered unlocked.
HasVisit
Answer true/false if there is a patient currently selected. This is a convenience method.
Patient
The currently selected patient, or null. The value of the current patient is also in . The concept is that the context is set by external forces, ususally the user. Therefore there is no way to set the patient here.
User
The user that established the connection to BMX either through the WinFramework dialogs or access/verify codes, or a user established through attach tho the EHR/VueCentric with the EhrFramework.
Visit
The currently selected visit, or null. The value of the current visit is also in ContextChangedArgs. The concept is that the context is set by external forces, ususally the user. Therefore there is no way to set the visit here.

Remarks

Application developers use the WinFramework and ChangableContext to modify the context. Within the EHR/VueCentric framework, the Context interface is a basic wrapper of some of the EHR facilties.

See Also

IndianHealthService.BMXNet.Model Namespace


Context Properties

JavaScript

Context Properties

BMXNET 4.0 Developer API

The Context type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
HasPatient | Answer true/false if there is a patient currently selected. This is a convenience method.
HasUnlockedVisit | Answer true if there is a visit and if it is unlocked. The EHR/VueCentric has a notion of the locked visit, a visit that can no longer be visited. The EHR/VueCetnric has has a visit stub, a visit that has been create on the desktop but not in RPMS. If a visit is a visit stub, it is not considered unlocked.
HasVisit | Answer true/false if there is a patient currently selected. This is a convenience method.
Patient | The currently selected patient, or null. The value of the current patient is also in . The concept is that the context is set by external forces, ususally the user. Therefore there is no way to set the patient here.
User | The user that established the connection to BMX either through the WinFramework dialogs or access/verify codes, or a user established through attach tho the EHR/VueCentric with the EhrFramework.
Visit | The currently selected visit, or null. The value of the current visit is also in ContextChangedArgs. The concept is that the context is set by external forces, ususally the user. Therefore there is no way to set the visit here.

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


HasPatient Property

JavaScript

Context..::HasPatient Property

BMXNET 4.0 Developer API

Answer true/false if there is a patient currently selected. This is a convenience method.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool HasPatient { get; }
ReadOnly Property HasPatient As Boolean
property bool HasPatient {
    bool get ();
}

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


HasUnlockedVisit Property

JavaScript

Context..::HasUnlockedVisit Property

BMXNET 4.0 Developer API

Answer true if there is a visit and if it is unlocked. The EHR/VueCentric has a notion of the locked visit, a visit that can no longer be visited. The EHR/VueCetnric has has a visit stub, a visit that has been create on the desktop but not in RPMS. If a visit is a visit stub, it is not considered unlocked.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool HasUnlockedVisit { get; }
ReadOnly Property HasUnlockedVisit As Boolean
property bool HasUnlockedVisit {
    bool get ();
}

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


HasVisit Property

JavaScript

Context..::HasVisit Property

BMXNET 4.0 Developer API

Answer true/false if there is a patient currently selected. This is a convenience method.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool HasVisit { get; }
ReadOnly Property HasVisit As Boolean
property bool HasVisit {
    bool get ();
}

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


Patient Property

JavaScript

Context..::Patient Property

BMXNET 4.0 Developer API

The currently selected patient, or null. The value of the current patient is also in . The concept is that the context is set by external forces, ususally the user. Therefore there is no way to set the patient here.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Patient Patient { get; }
ReadOnly Property Patient As Patient
property Patient^ Patient {
    Patient^ get ();
}

Remarks

Remember to refresh your user interface based on the new selection to the information your application displays or edits is that same as the current context.

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace
IndianHealthService.BMXNet.Model..::.ContextChangedArgs


User Property

JavaScript

Context..::User Property

BMXNET 4.0 Developer API

The user that established the connection to BMX either through the WinFramework dialogs or access/verify codes, or a user established through attach tho the EHR/VueCentric with the EhrFramework.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
User User { get; }
ReadOnly Property User As User
property User^ User {
    User^ get ();
}

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


Visit Property

JavaScript

Context..::Visit Property

BMXNET 4.0 Developer API

The currently selected visit, or null. The value of the current visit is also in ContextChangedArgs. The concept is that the context is set by external forces, ususally the user. Therefore there is no way to set the visit here.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Visit Visit { get; }
ReadOnly Property Visit As Visit
property Visit^ Visit {
    Visit^ get ();
}

Remarks

In the EHR, a visit stub can be created. A visit stub does not create a visit in RPMS until some data is entered. IsVisit will return true for a visit stub but is it your responbilty to use HasUnlockedVisit or IsStub on the Visit to make sure you have a visit to edit with. Remember to refresh your user interface based on the new selection to the information your application displays or edits is that same as the current context.

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


Context Events

JavaScript

Context Events

BMXNET 4.0 Developer API

The Context type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
Changed
The most important aspect of the Context interface is the Changed event that allows the receiver of the event know when the user is changing patient and visit. Applications need to change the data displayed to represent the currnet Patient and optional visit. The Changed event occurs after there is confirmation that the change has not been vetoed or the veto has been overridden. See Changing event.
Changing
When the current patient or visit is being changed by the user, every subscriber to the Changing method has the option to "Veto" the event by Cancelling it:
Copy Code
            public void Startup()
             {
                 if (this.Context != null)
                 {
                     this.Context.Changed += new EventHandler<ContextChangedArgs>(Context_Changed);
                     this.Context.Changing += new EventHandler<ContextChangedArgs>(Context_Changing);
             }

             void Context_Changing(object sender, ContextChangingArgs e)
             {
                 e.Cancel = needToFinishSomethingElseBeforeChangingContext;
             }
However, a Veto is like a U.S. presential Veto and that it can be overridden. The WinFramework or EHR can override any Veto so all components (even if they veto changes) must be prepared to have the context changed at anytime.

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


Changed Event

JavaScript

| Example | See Also
.NET Framework Class Library
Context..::Changed Event

BMXNET 4.0 Developer API

The most important aspect of the Context interface is the Changed event that allows the receiver of the event know when the user is changing patient and visit. Applications need to change the data displayed to represent the currnet Patient and optional visit. The Changed event occurs after there is confirmation that the change has not been vetoed or the veto has been overridden. See Changing event.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler<ContextChangedArgs> Changed
Event Changed As EventHandler(Of ContextChangedArgs)
 event EventHandler<ContextChangedArgs^>^ Changed {
    void add (EventHandler<ContextChangedArgs^>^ value);
    void remove (EventHandler<ContextChangedArgs^>^ value);
}

Examples

Users of the Context object should hook the event ASAP. The
Copy Code
            public void Startup()
             {
                 if (this.Context != null)
                 {
                     this.Context.Changed += new EventHandler<ContextChangedArgs>(Context_Changed);
             }
The context can be obtained if your control or component is a LocalSessionConsumer and if so then define the Context property as follows:
Copy Code
             public Context Context
             {
                 get { return this.LocalSession == null ? null : this.LocalSession.Context; }
             }

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


Changing Event

JavaScript

Context..::Changing Event

BMXNET 4.0 Developer API

When the current patient or visit is being changed by the user, every subscriber to the Changing method has the option to "Veto" the event by Cancelling it:
Copy Code
            public void Startup()
             {
                 if (this.Context != null)
                 {
                     this.Context.Changed += new EventHandler<ContextChangedArgs>(Context_Changed);
                     this.Context.Changing += new EventHandler<ContextChangedArgs>(Context_Changing);
             }

             void Context_Changing(object sender, ContextChangingArgs e)
             {
                 e.Cancel = needToFinishSomethingElseBeforeChangingContext;
             }
However, a Veto is like a U.S. presential Veto and that it can be overridden. The WinFramework or EHR can override any Veto so all components (even if they veto changes) must be prepared to have the context changed at anytime.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
event EventHandler<ContextChangingArgs> Changing
Event Changing As EventHandler(Of ContextChangingArgs)
 event EventHandler<ContextChangingArgs^>^ Changing {
    void add (EventHandler<ContextChangingArgs^>^ value);
    void remove (EventHandler<ContextChangingArgs^>^ value);
}

See Also

Context Interface
IndianHealthService.BMXNet.Model Namespace


ContextChangedArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
ContextChangedArgs Class

BMXNET 4.0 Developer API

The argument to the ContextChanged method. This event has methods that allow you to detect which aspects of the context have changed and what the new context is.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class ContextChangedArgs : EventArgs
Public Class ContextChangedArgs _
    Inherits EventArgs
public ref class ContextChangedArgs : public EventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ContextChangedArgs()()() |
AfterContext | The current state of the context. This context object is that same instance used for the life of the LocalSession
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IsPatientChange | Answer if the patient had changed.
IsVisitChange | Answer if the visit had changed. When the patient changes and a visit had been selected, the visit will change to null.
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
IndianHealthService.BMXNet.Model..::.ContextChangedArgs

See Also

IndianHealthService.BMXNet.Model Namespace


ContextChangedArgs Constructor

JavaScript

ContextChangedArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public ContextChangedArgs()
Public Sub New
public:
ContextChangedArgs()

See Also

ContextChangedArgs Class
IndianHealthService.BMXNet.Model Namespace


ContextChangedArgs Methods

JavaScript

ContextChangedArgs Methods

BMXNET 4.0 Developer API

The ContextChangedArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

ContextChangedArgs Class
IndianHealthService.BMXNet.Model Namespace


ContextChangedArgs Properties

JavaScript

ContextChangedArgs Properties

BMXNET 4.0 Developer API

The ContextChangedArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AfterContext | The current state of the context. This context object is that same instance used for the life of the LocalSession
IsPatientChange | Answer if the patient had changed.
IsVisitChange | Answer if the visit had changed. When the patient changes and a visit had been selected, the visit will change to null.

See Also

ContextChangedArgs Class
IndianHealthService.BMXNet.Model Namespace


AfterContext Property

JavaScript

ContextChangedArgs..::AfterContext Property

BMXNET 4.0 Developer API

The current state of the context. This context object is that same instance used for the life of the LocalSession

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Context AfterContext { get; set; }
Public Property AfterContext As Context
public:
property Context^ AfterContext {
    Context^ get ();
    void set (Context^ value);
}

See Also

ContextChangedArgs Class
IndianHealthService.BMXNet.Model Namespace


IsPatientChange Property

JavaScript

ContextChangedArgs..::IsPatientChange Property

BMXNET 4.0 Developer API

Answer if the patient had changed.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsPatientChange { get; set; }
Public Property IsPatientChange As Boolean
public:
property bool IsPatientChange {
    bool get ();
    void set (bool value);
}

See Also

ContextChangedArgs Class
IndianHealthService.BMXNet.Model Namespace


IsVisitChange Property

JavaScript

| Example | See Also
.NET Framework Class Library
ContextChangedArgs..::IsVisitChange Property

BMXNET 4.0 Developer API

Answer if the visit had changed. When the patient changes and a visit had been selected, the visit will change to null.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsVisitChange { get; set; }
Public Property IsVisitChange As Boolean
public:
property bool IsVisitChange {
    bool get ();
    void set (bool value);
}

Examples

In the following example, the first tab of a notebook is selected whenever the patient changes.
Copy Code
            void Context_Changed(object sender, ContextChangedArgs e)
            {
                if (e.IsPatientChange)
                {
                    this.SelectedIndex = 1;
                    this.RefreshAll();
                }
            }

See Also

ContextChangedArgs Class
IndianHealthService.BMXNet.Model Namespace


ContextChangingArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
ContextChangingArgs Class

BMXNET 4.0 Developer API

An instance of these args are included with the ContextChanging event and this event is a CancelEventArgs subclass. The Cancel property being set to True represents the desire to Veto the change so the patient (and potentially visit) does not change. The Veto can be overriden by the framework so be prepared for the context to change even if you don't want it to.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public class ContextChangingArgs : CancelEventArgs
Public Class ContextChangingArgs _
    Inherits CancelEventArgs
public ref class ContextChangingArgs : public CancelEventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
ContextChangingArgs()()() |
BeforeContext | The current state of the Context.
Cancel | (Inherited from CancelEventArgs.)
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IsPatientChange | Answer True if the visit is about to be changed.
IsVisitChange | Answer True if the visit is about to be changed.
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
IndianHealthService.BMXNet.Model..::.ContextChangingArgs

See Also

IndianHealthService.BMXNet.Model Namespace


ContextChangingArgs Constructor

JavaScript

ContextChangingArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public ContextChangingArgs()
Public Sub New
public:
ContextChangingArgs()

See Also

ContextChangingArgs Class
IndianHealthService.BMXNet.Model Namespace


ContextChangingArgs Methods

JavaScript

ContextChangingArgs Methods

BMXNET 4.0 Developer API

The ContextChangingArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

ContextChangingArgs Class
IndianHealthService.BMXNet.Model Namespace


ContextChangingArgs Properties

JavaScript

ContextChangingArgs Properties

BMXNET 4.0 Developer API

The ContextChangingArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BeforeContext | The current state of the Context.
Cancel | (Inherited from CancelEventArgs.)
IsPatientChange | Answer True if the visit is about to be changed.
IsVisitChange | Answer True if the visit is about to be changed.

See Also

ContextChangingArgs Class
IndianHealthService.BMXNet.Model Namespace


BeforeContext Property

JavaScript

ContextChangingArgs..::BeforeContext Property

BMXNET 4.0 Developer API

The current state of the Context.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public Context BeforeContext { get; set; }
Public Property BeforeContext As Context
public:
property Context^ BeforeContext {
    Context^ get ();
    void set (Context^ value);
}

See Also

ContextChangingArgs Class
IndianHealthService.BMXNet.Model Namespace


IsPatientChange Property

JavaScript

ContextChangingArgs..::IsPatientChange Property

BMXNET 4.0 Developer API

Answer True if the visit is about to be changed.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsPatientChange { get; set; }
Public Property IsPatientChange As Boolean
public:
property bool IsPatientChange {
    bool get ();
    void set (bool value);
}

See Also

ContextChangingArgs Class
IndianHealthService.BMXNet.Model Namespace


IsVisitChange Property

JavaScript

ContextChangingArgs..::IsVisitChange Property

BMXNET 4.0 Developer API

Answer True if the visit is about to be changed.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsVisitChange { get; set; }
Public Property IsVisitChange As Boolean
public:
property bool IsVisitChange {
    bool get ();
    void set (bool value);
}

See Also

ContextChangingArgs Class
IndianHealthService.BMXNet.Model Namespace


Division Interface

JavaScript

| Members | See Also
.NET Framework Class Library
Division Interface

BMXNET 4.0 Developer API

This object represents the RPMS Division.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface Division
Public Interface Division
public interface class Division

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Ien |
Name |

Remarks

All BMX Broker connections must have an estalibshed Division

See Also

IndianHealthService.BMXNet.Model Namespace


Division Properties

JavaScript

Division Properties

BMXNET 4.0 Developer API

The Division type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Ien |
Name |

See Also

Division Interface
IndianHealthService.BMXNet.Model Namespace


Ien Property

JavaScript

Division..::Ien Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Ien { get; }
ReadOnly Property Ien As String
property String^ Ien {
    String^ get ();
}

See Also

Division Interface
IndianHealthService.BMXNet.Model Namespace


Name Property

JavaScript

Division..::Name Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}

See Also

Division Interface
IndianHealthService.BMXNet.Model Namespace


Patient Interface

JavaScript

| Members | See Also
.NET Framework Class Library
Patient Interface

BMXNET 4.0 Developer API

The Patient object is a read-only object used for patient context.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface Patient
Public Interface Patient
public interface class Patient

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdmitDate | The current admission date of the user. This is a nullable bool for the cases that the patient is not currently admitted.
Age | The current age of the patient.
Dob | If knownn, the DOB of the patient
HealthRecordNumber | The RPMS HRN or chart number
Ien | The RPMS intenal entry number for the patient
PatientName | The default displayable version of the patient's name
PrimaryProvider | The displayable name (external value) of the patient's primary provider.
Sex | The sex of the patient
Ssn | The patient's SSN or an abbrievation of the SSN

See Also

IndianHealthService.BMXNet.Model Namespace


Patient Properties

JavaScript

Patient Properties

BMXNET 4.0 Developer API

The Patient type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AdmitDate | The current admission date of the user. This is a nullable bool for the cases that the patient is not currently admitted.
Age | The current age of the patient.
Dob | If knownn, the DOB of the patient
HealthRecordNumber | The RPMS HRN or chart number
Ien | The RPMS intenal entry number for the patient
PatientName | The default displayable version of the patient's name
PrimaryProvider | The displayable name (external value) of the patient's primary provider.
Sex | The sex of the patient
Ssn | The patient's SSN or an abbrievation of the SSN

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


AdmitDate Property

JavaScript

Patient..::AdmitDate Property

BMXNET 4.0 Developer API

The current admission date of the user. This is a nullable bool for the cases that the patient is not currently admitted.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Nullable<DateTime> AdmitDate { get; }
ReadOnly Property AdmitDate As Nullable(Of DateTime)
property Nullable<DateTime> AdmitDate {
    Nullable<DateTime> get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


Age Property

JavaScript

Patient..::Age Property

BMXNET 4.0 Developer API

The current age of the patient.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
float Age { get; }
ReadOnly Property Age As Single
property float Age {
    float get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


Dob Property

JavaScript

Patient..::Dob Property

BMXNET 4.0 Developer API

If knownn, the DOB of the patient

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Nullable<DateTime> Dob { get; }
ReadOnly Property Dob As Nullable(Of DateTime)
property Nullable<DateTime> Dob {
    Nullable<DateTime> get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


HealthRecordNumber Property

JavaScript

Patient..::HealthRecordNumber Property

BMXNET 4.0 Developer API

The RPMS HRN or chart number

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string HealthRecordNumber { get; }
ReadOnly Property HealthRecordNumber As String
property String^ HealthRecordNumber {
    String^ get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


Ien Property

JavaScript

Patient..::Ien Property

BMXNET 4.0 Developer API

The RPMS intenal entry number for the patient

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Ien { get; }
ReadOnly Property Ien As String
property String^ Ien {
    String^ get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


PatientName Property

JavaScript

Patient..::PatientName Property

BMXNET 4.0 Developer API

The default displayable version of the patient's name

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string PatientName { get; }
ReadOnly Property PatientName As String
property String^ PatientName {
    String^ get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


PrimaryProvider Property

JavaScript

Patient..::PrimaryProvider Property

BMXNET 4.0 Developer API

The displayable name (external value) of the patient's primary provider.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string PrimaryProvider { get; }
ReadOnly Property PrimaryProvider As String
property String^ PrimaryProvider {
    String^ get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


Sex Property

JavaScript

Patient..::Sex Property

BMXNET 4.0 Developer API

The sex of the patient

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Sex { get; }
ReadOnly Property Sex As String
property String^ Sex {
    String^ get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


Ssn Property

JavaScript

Patient..::Ssn Property

BMXNET 4.0 Developer API

The patient's SSN or an abbrievation of the SSN

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Ssn { get; }
ReadOnly Property Ssn As String
property String^ Ssn {
    String^ get ();
}

See Also

Patient Interface
IndianHealthService.BMXNet.Model Namespace


User Interface

JavaScript

| Members | See Also
.NET Framework Class Library
User Interface

BMXNET 4.0 Developer API

The user that established the connection to BMX either through the WinFramework dialogs or access/verify codes, or a user established through attach tho the EHR/VueCentric with the EhrFramework.

The user breaks down into who is it and what can they do with some identify and security key checing.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface User
Public Interface User
public interface class User

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Division | The division that this user to currently operating within
Duz | The DUZ aka IEN of the NEW Person File of this user
HasSecurityKey(String) | Check aKey against the active RPMS keys for the user. If the user has the PROGMODE key this method will always return true.
HasSecurityKeys(array<String>[]()[]) | Return a list of keys that the user does NOT have. If the user has all of the keys then an empty list is returned
Name | A displayable name of the user
RequestKeys()()() | Fetch from RPMS the user's current keys. The user's division must be set before calling this metohd.

See Also

IndianHealthService.BMXNet.Model Namespace


User Methods

JavaScript

User Methods

BMXNET 4.0 Developer API

The User type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
HasSecurityKey(String) | Check aKey against the active RPMS keys for the user. If the user has the PROGMODE key this method will always return true.
HasSecurityKeys(array<String>[]()[]) | Return a list of keys that the user does NOT have. If the user has all of the keys then an empty list is returned
RequestKeys()()() | Fetch from RPMS the user's current keys. The user's division must be set before calling this metohd.

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


HasSecurityKey Method

JavaScript

User..::HasSecurityKey Method

BMXNET 4.0 Developer API

Check aKey against the active RPMS keys for the user. If the user has the PROGMODE key this method will always return true.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool HasSecurityKey(
    string aKey
)
Function HasSecurityKey ( _
    aKey As String _
) As Boolean
bool HasSecurityKey(
    String^ aKey
)

Parameters

aKey
String
The key name that is compared against the keys on the server

Return Value

Return true if the user has the key

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


HasSecurityKeys Method

JavaScript

| Example | See Also
.NET Framework Class Library
User..::HasSecurityKeys Method

BMXNET 4.0 Developer API

Return a list of keys that the user does NOT have. If the user has all of the keys then an empty list is returned

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
List<string> HasSecurityKeys(
    string[] keys
)
Function HasSecurityKeys ( _
    keys As String() _
) As List(Of String)
List<String^>^ HasSecurityKeys(
    array<String^>^ keys
)

Parameters

keys
array< String >[]()[]
a list of keys to compare against the user's keys

Return Value

A list of keys the user does not have, empty of the user has them all

Remarks

The HasSecurityKeys appraoch does not give those with PROGMODE a free-pass since it compares the actual keys. HasSecurityKeys uses RequestKeys

Examples

List<String> missingKeys=aUser.HasSecurityKeys(new string[] { "Key1","Key2" });
if (missingKeys.Count==0) {
    //Take a secured path
} else {
    MessageBox.Show(missingKeys);
}

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


RequestKeys Method

JavaScript

User..::RequestKeys Method

BMXNET 4.0 Developer API

Fetch from RPMS the user's current keys. The user's division must be set before calling this metohd.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
List<string> RequestKeys()
Function RequestKeys As List(Of String)
List<String^>^ RequestKeys()

Return Value

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


User Properties

JavaScript

User Properties

BMXNET 4.0 Developer API

The User type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Division | The division that this user to currently operating within
Duz | The DUZ aka IEN of the NEW Person File of this user
Name | A displayable name of the user

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


Division Property

JavaScript

User..::Division Property

BMXNET 4.0 Developer API

The division that this user to currently operating within

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
Division Division { get; set; }
Property Division As Division
property Division^ Division {
    Division^ get ();
    void set (Division^ value);
}

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


Duz Property

JavaScript

User..::Duz Property

BMXNET 4.0 Developer API

The DUZ aka IEN of the NEW Person File of this user

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Duz { get; }
ReadOnly Property Duz As String
property String^ Duz {
    String^ get ();
}

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


Name Property

JavaScript

User..::Name Property

BMXNET 4.0 Developer API

A displayable name of the user

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}

See Also

User Interface
IndianHealthService.BMXNet.Model Namespace


Visit Interface

JavaScript

| Members | See Also
.NET Framework Class Library
Visit Interface

BMXNET 4.0 Developer API

The visit object is used to determine the current context of the application. The key wrinkle in the visit class relates to create a common interface for EHR/VueCentric and WinForm applications. The EHR/VueCentric supports visit stubs by default and the WinFramework does not. If the consumer of the visit object is going to use it to make changes to RPMS then the visit can not be a stub and must the visit must be created.

Examples

In either EHR or WinForm applications, always check for a stub before you call RPC's to update RPMS. If you do not, the visit may not have been created on RPMS and the visit id will be null.
Copy Code
            if (this.Context.HasVisit)
            {
                if (this.Context.Visit.IsStub && !this.Context.Visit.Create())
                {
                    MessageBox.Show("Unable to establish visit.","Editing Disabled");
                    return;
                }

                //Call RPC to update RPMS with current visit ien
            }

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface Visit
Public Interface Visit
public interface class Visit

Members

All Members | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Create()()() | If the receiver is a stub, then call Create() to create a visit in RPMS and then new data can be added in the context of a created visit. In the WinForm edition, this all Visits are created to the method will do nothing yet you should call it to be consistent.
Create(Boolean) | In the EHR some visits need user interaction to change from a stub to a created visit.
DateTime | Official timetamp of the visit
Ien | This will be non-null if the visit has been created in RPMS, otherwise it is null and the receiver in considered a stub.
IsFutureAppointment | Answer true if a future appointment.
IsLocked | If a visit can not be added to if it is locked. In the WinForm edition, all visits answered by BMX FIND VISIT are considered unlocked.
IsStub | If a visit is transient in the client memory space, it is a stub. In the EHR visits are often created as stubs (Create New is not checked) Once data is entered, the visit is created. The WinForm only supports full created visits therefore IsStub is always false
LocationName | Hospital Location of the visit
ProviderName | Primary provider of the visit

See Also

IndianHealthService.BMXNet.Model Namespace


Visit Methods

JavaScript

Visit Methods

BMXNET 4.0 Developer API

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Create()()() | If the receiver is a stub, then call Create() to create a visit in RPMS and then new data can be added in the context of a created visit. In the WinForm edition, this all Visits are created to the method will do nothing yet you should call it to be consistent.
Create(Boolean) | In the EHR some visits need user interaction to change from a stub to a created visit.

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


Create Method

JavaScript

Visit..::Create Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Create()()() | If the receiver is a stub, then call Create() to create a visit in RPMS and then new data can be added in the context of a created visit. In the WinForm edition, this all Visits are created to the method will do nothing yet you should call it to be consistent.
Create(Boolean) | In the EHR some visits need user interaction to change from a stub to a created visit.

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


Create Method

JavaScript

Visit..::Create Method

BMXNET 4.0 Developer API

If the receiver is a stub, then call Create() to create a visit in RPMS and then new data can be added in the context of a created visit. In the WinForm edition, this all Visits are created to the method will do nothing yet you should call it to be consistent.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool Create()
Function Create As Boolean
bool Create()

Return Value

True if the visit has been created (always True for WinForm)

See Also

Visit Interface
Create Overload
IndianHealthService.BMXNet.Model Namespace


Create Method (Boolean)

JavaScript

Visit..::Create Method (Boolean)

BMXNET 4.0 Developer API

In the EHR some visits need user interaction to change from a stub to a created visit.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool Create(
    bool showGuiToCreateVisit
)
Function Create ( _
    showGuiToCreateVisit As Boolean _
) As Boolean
bool Create(
    bool showGuiToCreateVisit
)

Parameters

showGuiToCreateVisit
Boolean

Return Value

See Also

Visit Interface
Create Overload
IndianHealthService.BMXNet.Model Namespace


Visit Properties

JavaScript

Visit Properties

BMXNET 4.0 Developer API

The Visit type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
DateTime | Official timetamp of the visit
Ien | This will be non-null if the visit has been created in RPMS, otherwise it is null and the receiver in considered a stub.
IsFutureAppointment | Answer true if a future appointment.
IsLocked | If a visit can not be added to if it is locked. In the WinForm edition, all visits answered by BMX FIND VISIT are considered unlocked.
IsStub | If a visit is transient in the client memory space, it is a stub. In the EHR visits are often created as stubs (Create New is not checked) Once data is entered, the visit is created. The WinForm only supports full created visits therefore IsStub is always false
LocationName | Hospital Location of the visit
ProviderName | Primary provider of the visit

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


DateTime Property

JavaScript

Visit..::DateTime Property

BMXNET 4.0 Developer API

Official timetamp of the visit

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
DateTime DateTime { get; }
ReadOnly Property DateTime As DateTime
property DateTime DateTime {
    DateTime get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


Ien Property

JavaScript

Visit..::Ien Property

BMXNET 4.0 Developer API

This will be non-null if the visit has been created in RPMS, otherwise it is null and the receiver in considered a stub.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Ien { get; }
ReadOnly Property Ien As String
property String^ Ien {
    String^ get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


IsFutureAppointment Property

JavaScript

Visit..::IsFutureAppointment Property

BMXNET 4.0 Developer API

Answer true if a future appointment.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsFutureAppointment { get; }
ReadOnly Property IsFutureAppointment As Boolean
property bool IsFutureAppointment {
    bool get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


IsLocked Property

JavaScript

Visit..::IsLocked Property

BMXNET 4.0 Developer API

If a visit can not be added to if it is locked. In the WinForm edition, all visits answered by BMX FIND VISIT are considered unlocked.

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsLocked { get; }
ReadOnly Property IsLocked As Boolean
property bool IsLocked {
    bool get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


IsStub Property

JavaScript

Visit..::IsStub Property

BMXNET 4.0 Developer API

If a visit is transient in the client memory space, it is a stub. In the EHR visits are often created as stubs (Create New is not checked) Once data is entered, the visit is created. The WinForm only supports full created visits therefore IsStub is always false

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
bool IsStub { get; }
ReadOnly Property IsStub As Boolean
property bool IsStub {
    bool get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


LocationName Property

JavaScript

Visit..::LocationName Property

BMXNET 4.0 Developer API

Hospital Location of the visit

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string LocationName { get; }
ReadOnly Property LocationName As String
property String^ LocationName {
    String^ get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


ProviderName Property

JavaScript

Visit..::ProviderName Property

BMXNET 4.0 Developer API

Primary provider of the visit

Namespace: IndianHealthService.BMXNet.Model
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string ProviderName { get; }
ReadOnly Property ProviderName As String
property String^ ProviderName {
    String^ get ();
}

See Also

Visit Interface
IndianHealthService.BMXNet.Model Namespace


IndianHealthService.BMXNet.Net Namespace

JavaScript

IndianHealthService.BMXNet.Net Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes | Interfaces
Name | Description
BMXAdeCrypto | This implementation EncryptionProvider is the crypto used for the standard Indian Health Service socket-based BMXNET Broker.
EncryptionKeyProvider | A provider of the BMX Ade encryption key
EncryptionProvider | The crypto used to implement the socket-based BMXNET Broker. Any crypto can be used if a new .NET EncryptionProvider is written and a corresponding modification to the RPMS-side is done.


BMXAdeCrypto Class

JavaScript

| Members | See Also
.NET Framework Class Library
BMXAdeCrypto Class

BMXNET 4.0 Developer API

This implementation EncryptionProvider is the crypto used for the standard Indian Health Service socket-based BMXNET Broker.

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public sealed class BMXAdeCrypto : EncryptionProvider
Public NotInheritable Class BMXAdeCrypto _
    Implements EncryptionProvider
public ref class BMXAdeCrypto sealed : EncryptionProvider

Members

All Members | Constructors | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BMXAdeCrypto()()() |
Decrypt(String) | BMXAde Implementation
Encrypt(String) | BMXAde Implementation
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Keyed(array<String>[]()[]) |
MemberwiseClone()()() | (Inherited from Object.)
SetKey(array<String>[]()[]) | Set a site specific key
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.Net..::.BMXAdeCrypto

See Also

IndianHealthService.BMXNet.Net Namespace


BMXAdeCrypto Constructor

JavaScript

BMXAdeCrypto Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public BMXAdeCrypto()
Public Sub New
public:
BMXAdeCrypto()

See Also

BMXAdeCrypto Class
IndianHealthService.BMXNet.Net Namespace


BMXAdeCrypto Methods

JavaScript

BMXAdeCrypto Methods

BMXNET 4.0 Developer API

The BMXAdeCrypto type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Decrypt(String) | BMXAde Implementation
Encrypt(String) | BMXAde Implementation
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Keyed(array<String>[]()[]) |
MemberwiseClone()()() | (Inherited from Object.)
SetKey(array<String>[]()[]) | Set a site specific key
ToString()()() | (Inherited from Object.)

See Also

BMXAdeCrypto Class
IndianHealthService.BMXNet.Net Namespace


Decrypt Method

JavaScript

BMXAdeCrypto..::Decrypt Method

BMXNET 4.0 Developer API

BMXAde Implementation

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Decrypt(
    string aString
)
Public Function Decrypt ( _
    aString As String _
) As String
public:
virtual String^ Decrypt(
    String^ aString
) sealed

Parameters

aString
String
String to decrypt

Return Value

Decrypted string

Implements

EncryptionProvider..::.Decrypt(String)

See Also

BMXAdeCrypto Class
IndianHealthService.BMXNet.Net Namespace


Encrypt Method

JavaScript

BMXAdeCrypto..::Encrypt Method

BMXNET 4.0 Developer API

BMXAde Implementation

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Encrypt(
    string aString
)
Public Function Encrypt ( _
    aString As String _
) As String
public:
virtual String^ Encrypt(
    String^ aString
) sealed

Parameters

aString
String
String to encrypt

Return Value

Encrypt string

Implements

EncryptionProvider..::.Encrypt(String)

See Also

BMXAdeCrypto Class
IndianHealthService.BMXNet.Net Namespace


Keyed Method

JavaScript

BMXAdeCrypto..::Keyed Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static EncryptionProvider Keyed(
    string[] aKey
)
Public Shared Function Keyed ( _
    aKey As String() _
) As EncryptionProvider
public:
static EncryptionProvider^ Keyed(
    array<String^>^ aKey
)

Parameters

aKey
array< String >[]()[]

See Also

BMXAdeCrypto Class
IndianHealthService.BMXNet.Net Namespace


SetKey Method

JavaScript

BMXAdeCrypto..::SetKey Method

BMXNET 4.0 Developer API

Set a site specific key

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public void SetKey(
    string[] aKey
)
Public Sub SetKey ( _
    aKey As String() _
)
public:
void SetKey(
    array<String^>^ aKey
)

Parameters

aKey
array< String >[]()[]
The required key for BMX Ade

See Also

BMXAdeCrypto Class
IndianHealthService.BMXNet.Net Namespace


EncryptionKeyProvider Interface

JavaScript

| Members | See Also
.NET Framework Class Library
EncryptionKeyProvider Interface

BMXNET 4.0 Developer API

A provider of the BMX Ade encryption key

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface EncryptionKeyProvider
Public Interface EncryptionKeyProvider
public interface class EncryptionKeyProvider

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Keys |

See Also

IndianHealthService.BMXNet.Net Namespace


EncryptionKeyProvider Properties

JavaScript

EncryptionKeyProvider Properties

BMXNET 4.0 Developer API

The EncryptionKeyProvider type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Keys |

See Also

EncryptionKeyProvider Interface
IndianHealthService.BMXNet.Net Namespace


Keys Property

JavaScript

EncryptionKeyProvider..::Keys Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string[] Keys { get; }
ReadOnly Property Keys As String()
property array<String^>^ Keys {
    array<String^>^ get ();
}

See Also

EncryptionKeyProvider Interface
IndianHealthService.BMXNet.Net Namespace


EncryptionProvider Interface

JavaScript

| Members | See Also
.NET Framework Class Library
EncryptionProvider Interface

BMXNET 4.0 Developer API

The crypto used to implement the socket-based BMXNET Broker. Any crypto can be used if a new .NET EncryptionProvider is written and a corresponding modification to the RPMS-side is done.

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface EncryptionProvider
Public Interface EncryptionProvider
public interface class EncryptionProvider

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Decrypt(String) | Decrypt aString
Encrypt(String) | Encrypt aString

Remarks

An quick experiment can be done by implementing the following ClearText EncryptionProvider and modifying the RPMS-side encryption routines to do nothing.
Copy Code
            public class ClearText : EncryptionProvider
            {
                public string Encrypt(string aString)
                {
                    return aString;
                }

                public string Decrypt(string aString)
                {
                    return aString;
                }
            }

See Also

IndianHealthService.BMXNet.Net Namespace


EncryptionProvider Methods

JavaScript

EncryptionProvider Methods

BMXNET 4.0 Developer API

The EncryptionProvider type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Decrypt(String) | Decrypt aString
Encrypt(String) | Encrypt aString

See Also

EncryptionProvider Interface
IndianHealthService.BMXNet.Net Namespace


Decrypt Method

JavaScript

EncryptionProvider..::Decrypt Method

BMXNET 4.0 Developer API

Decrypt aString

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Decrypt(
    string aString
)
Function Decrypt ( _
    aString As String _
) As String
String^ Decrypt(
    String^ aString
)

Parameters

aString
String
The ASCII string to be decrypted

Return Value

An ASCII decrypted string

See Also

EncryptionProvider Interface
IndianHealthService.BMXNet.Net Namespace


Encrypt Method

JavaScript

EncryptionProvider..::Encrypt Method

BMXNET 4.0 Developer API

Encrypt aString

Namespace: IndianHealthService.BMXNet.Net
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
string Encrypt(
    string aString
)
Function Encrypt ( _
    aString As String _
) As String
String^ Encrypt(
    String^ aString
)

Parameters

aString
String
The string to be encrypted

Return Value

An ASCII encrypted string

See Also

EncryptionProvider Interface
IndianHealthService.BMXNet.Net Namespace


IndianHealthService.BMXNet.Util Namespace

JavaScript

IndianHealthService.BMXNet.Util Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes
Name Description
EntryAssemblyInfo
Convienence class to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyTitle("IndianHealthService.BMXNet.Test")]
            [assembly: AssemblyDescription("A test application")]
            [assembly: AssemblyCompany("IHS")]
            [assembly: AssemblyProduct("IndianHealthService.BMXNet.Test")]
            [assembly: AssemblyCopyright("IHS 2009")]
            [assembly: AssemblyVersion("2.0.0.0")]


EntryAssemblyInfo Class

JavaScript

| Members | See Also
.NET Framework Class Library
EntryAssemblyInfo Class

BMXNET 4.0 Developer API

Convienence class to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyTitle("IndianHealthService.BMXNet.Test")]
            [assembly: AssemblyDescription("A test application")]
            [assembly: AssemblyCompany("IHS")]
            [assembly: AssemblyProduct("IndianHealthService.BMXNet.Test")]
            [assembly: AssemblyCopyright("IHS 2009")]
            [assembly: AssemblyVersion("2.0.0.0")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static class EntryAssemblyInfo
Public NotInheritable Class EntryAssemblyInfo
public ref class EntryAssemblyInfo abstract sealed

Members

All Members | Properties
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AssemblyCompany
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyCompany("IHS")]
AssemblyCopyright
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyCopyright("IHS 2009")]
AssemblyDescription
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyDescription("A test application")]
AssemblyProduct
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyProduct("IndianHealthService.BMXNet.Test")]
AssemblyTitle
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyTitle("IndianHealthService.BMXNet.Test")]
AssemblyVersion
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyVersion("2.0.0.0")]

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.Util..::.EntryAssemblyInfo

See Also

IndianHealthService.BMXNet.Util Namespace


EntryAssemblyInfo Properties

JavaScript

EntryAssemblyInfo Properties

BMXNET 4.0 Developer API

The EntryAssemblyInfo type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member Description
AssemblyCompany
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyCompany("IHS")]
AssemblyCopyright
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyCopyright("IHS 2009")]
AssemblyDescription
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyDescription("A test application")]
AssemblyProduct
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyProduct("IndianHealthService.BMXNet.Test")]
AssemblyTitle
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyTitle("IndianHealthService.BMXNet.Test")]
AssemblyVersion
Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyVersion("2.0.0.0")]

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


AssemblyCompany Property

JavaScript

EntryAssemblyInfo..::AssemblyCompany Property

BMXNET 4.0 Developer API

Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyCompany("IHS")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string AssemblyCompany { get; }
Public Shared ReadOnly Property AssemblyCompany As String
public:
static property String^ AssemblyCompany {
    String^ get ();
}

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


AssemblyCopyright Property

JavaScript

EntryAssemblyInfo..::AssemblyCopyright Property

BMXNET 4.0 Developer API

Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyCopyright("IHS 2009")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string AssemblyCopyright { get; }
Public Shared ReadOnly Property AssemblyCopyright As String
public:
static property String^ AssemblyCopyright {
    String^ get ();
}

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


AssemblyDescription Property

JavaScript

EntryAssemblyInfo..::AssemblyDescription Property

BMXNET 4.0 Developer API

Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyDescription("A test application")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string AssemblyDescription { get; }
Public Shared ReadOnly Property AssemblyDescription As String
public:
static property String^ AssemblyDescription {
    String^ get ();
}

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


AssemblyProduct Property

JavaScript

EntryAssemblyInfo..::AssemblyProduct Property

BMXNET 4.0 Developer API

Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyProduct("IndianHealthService.BMXNet.Test")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string AssemblyProduct { get; }
Public Shared ReadOnly Property AssemblyProduct As String
public:
static property String^ AssemblyProduct {
    String^ get ();
}

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


AssemblyTitle Property

JavaScript

EntryAssemblyInfo..::AssemblyTitle Property

BMXNET 4.0 Developer API

Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyTitle("IndianHealthService.BMXNet.Test")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string AssemblyTitle { get; }
Public Shared ReadOnly Property AssemblyTitle As String
public:
static property String^ AssemblyTitle {
    String^ get ();
}

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


AssemblyVersion Property

JavaScript

EntryAssemblyInfo..::AssemblyVersion Property

BMXNET 4.0 Developer API

Convienence method to provide information from the AssembleInfo
Copy Code
            [assembly: AssemblyVersion("2.0.0.0")]

Namespace: IndianHealthService.BMXNet.Util
Assembly: BMXNET40 (in BMXNET40.dll)

Syntax

C# | Visual Basic | Visual C++
public static string AssemblyVersion { get; }
Public Shared ReadOnly Property AssemblyVersion As String
public:
static property String^ AssemblyVersion {
    String^ get ();
}

See Also

EntryAssemblyInfo Class
IndianHealthService.BMXNet.Util Namespace


IndianHealthService.BMXNet.WinForm Namespace

JavaScript

IndianHealthService.BMXNet.WinForm Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes
Name Description
AboutDialog
Stardardized "About" dialog that displays information from the executable's (RootAssembly) AssemblyInfo: AssemblyTitle AssemblyProduct AssemblyVersion AssemblyCopyright AssemblyCompany AssemblyDescription

Additionally, a list box showing all non-system .NET assemblies is displayed. Set IncludeRoot=True if the RootAssembly should be included in the list.

Examples

Usage of dialog:
Copy Code
            AboutDialog dialog=new AboutDialog();
            dialog.RootAssembly = Assembly.GetExecutingAssembly();
            dialog.IncludeRoot = true;
            dialog.Show(this.Parent);
By default, the RootAssebmly is the Assembly.GetExecutingAssembly();
AttemptingLoginEventArgs
The LoginProcess provides the AttemptingLoginEvent to allow changes in workflow with this Cancelable event args class
LoginAttemptedEventArgs
The LoginProcess provides feedback after every LoginAttempt, even if the login attempt was performer using the AttemptingLoginEvent. If a custom dialog box or action can take place and Handled set to True, the LoginProcess will not display the standard dialog. The LoginProcess is available so examine or modify.
LoginProcess
This class models the workflow of the LoginProcess. It correographs UI and non-UI login methods, login cancelling, management dialogs, and provides hooks (events) to customize the login workflow.
WinFramework
Instance manages the context/access to RPMS - Configuration information - Login entry points - External changes to patient context


AboutDialog Class

JavaScript

| Members | See Also
.NET Framework Class Library
AboutDialog Class

BMXNET 4.0 Developer API

Stardardized "About" dialog that displays information from the executable's (RootAssembly) AssemblyInfo: AssemblyTitle AssemblyProduct AssemblyVersion AssemblyCopyright AssemblyCompany AssemblyDescription

Additionally, a list box showing all non-system .NET assemblies is displayed. Set IncludeRoot=True if the RootAssembly should be included in the list.

Examples

Usage of dialog:
Copy Code
            AboutDialog dialog=new AboutDialog();
            dialog.RootAssembly = Assembly.GetExecutingAssembly();
            dialog.IncludeRoot = true;
            dialog.Show(this.Parent);
By default, the RootAssebmly is the Assembly.GetExecutingAssembly();

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class AboutDialog : Form
Public Class AboutDialog _
    Inherits Form
public ref class AboutDialog : public Form

Members

All Members | Constructors | Properties | Methods | Events | Explicit Interface Implementations
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AboutDialog()()() |
AcceptButton | (Inherited from Form.)
AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
AccessibilityObject | (Inherited from Control.)
AccessibleDefaultActionDescription | (Inherited from Control.)
AccessibleDescription | (Inherited from Control.)
AccessibleName | (Inherited from Control.)
AccessibleRole | (Inherited from Control.)
Activate()()() | (Inherited from Form.)
IContainerControl..::.ActivateControl(Control) | (Inherited from ContainerControl.)
Activated | (Inherited from Form.)
ActivateMdiChild(Form) | (Inherited from Form.)
ActiveControl | (Inherited from ContainerControl.)
ActiveMdiChild | (Inherited from Form.)
AddOwnedForm(Form) | (Inherited from Form.)
AdjustFormScrollbars(Boolean) | (Inherited from Form.)
AllowDrop | (Inherited from Control.)
AllowTransparency | (Inherited from Form.)
Anchor | (Inherited from Control.)
ApplyAutoScaling()()() | Obsolete. (Inherited from Form.)
AutoScale | Obsolete. (Inherited from Form.)
AutoScaleBaseSize | (Inherited from Form.)
AutoScaleDimensions | (Inherited from ContainerControl.)
AutoScaleFactor | (Inherited from ContainerControl.)
AutoScaleMode | (Inherited from ContainerControl.)
AutoScroll | (Inherited from Form.)
AutoScrollMargin | (Inherited from ScrollableControl.)
AutoScrollMinSize | (Inherited from ScrollableControl.)
AutoScrollOffset | (Inherited from Control.)
AutoScrollPosition | (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoSizeMode | (Inherited from Form.)
AutoValidate | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackColorChanged | (Inherited from Control.)
BackgroundImage | (Inherited from Control.)
BackgroundImageChanged | (Inherited from Control.)
BackgroundImageLayout | (Inherited from Control.)
BackgroundImageLayoutChanged | (Inherited from Control.)
BeginInvoke(Delegate) | (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
BindingContextChanged | (Inherited from Control.)
Bottom | (Inherited from Control.)
Bounds | (Inherited from Control.)
BringToFront()()() | (Inherited from Control.)
CancelButton | (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | (Inherited from Control.)
CanRaiseEvents | (Inherited from Control.)
CanSelect | (Inherited from Control.)
Capture | (Inherited from Control.)
CausesValidation | (Inherited from Control.)
CausesValidationChanged | (Inherited from Control.)
CenterToParent()()() | (Inherited from Form.)
CenterToScreen()()() | (Inherited from Form.)
ChangeUICues | (Inherited from Control.)
Click | (Inherited from Control.)
ClientRectangle | (Inherited from Control.)
ClientSize | (Inherited from Form.)
ClientSizeChanged | (Inherited from Control.)
Close()()() | (Inherited from Form.)
Closed | (Inherited from Form.)
Closing | (Inherited from Form.)
CompanyName | (Inherited from Control.)
Container | (Inherited from Component.)
Contains(Control) | (Inherited from Control.)
ContainsFocus | (Inherited from Control.)
ContextMenu | (Inherited from Control.)
ContextMenuChanged | (Inherited from Control.)
ContextMenuStrip | (Inherited from Control.)
ContextMenuStripChanged | (Inherited from Control.)
ControlAdded | (Inherited from Control.)
ControlBox | (Inherited from Form.)
ControlRemoved | (Inherited from Control.)
Controls | (Inherited from Control.)
CreateAccessibilityInstance()()() | (Inherited from Control.)
CreateControl()()() | (Inherited from Control.)
CreateControlsInstance()()() | (Inherited from Form.)
Created | (Inherited from Control.)
CreateGraphics()()() | (Inherited from Control.)
CreateHandle()()() | (Inherited from Form.)
CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Cursor | (Inherited from Control.)
CursorChanged | (Inherited from Control.)
DataBindings | (Inherited from Control.)
Deactivate | (Inherited from Form.)
DefaultCursor | (Inherited from Control.)
DefaultImeMode | (Inherited from Form.)
DefaultMargin | (Inherited from Control.)
DefaultMaximumSize | (Inherited from Control.)
DefaultMinimumSize | (Inherited from Control.)
DefaultPadding | (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DefWndProc(Message%) | (Inherited from Form.)
DesignMode | (Inherited from Component.)
DesktopBounds | (Inherited from Form.)
DesktopLocation | (Inherited from Form.)
DestroyHandle()()() | (Inherited from Control.)
DialogResult | (Inherited from Form.)
DisplayRectangle | (Inherited from ScrollableControl.)
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)
Disposed | (Inherited from Component.)
Disposing | (Inherited from Control.)
Dock | (Inherited from Control.)
DockChanged | (Inherited from Control.)
DockPadding | (Inherited from ScrollableControl.)
DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
DoubleBuffered | (Inherited from Control.)
DoubleClick | (Inherited from Control.)
DragDrop | (Inherited from Control.)
DragEnter | (Inherited from Control.)
DragLeave | (Inherited from Control.)
DragOver | (Inherited from Control.)
DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
Enabled | (Inherited from Control.)
EnabledChanged | (Inherited from Control.)
EndInvoke(IAsyncResult) | (Inherited from Control.)
Enter | (Inherited from Control.)
Equals(Object) | (Inherited from Object.)
Events | (Inherited from Component.)
Finalize()()() | (Inherited from Component.)
FindForm()()() | (Inherited from Control.)
Focus()()() | (Inherited from Control.)
Focused | (Inherited from Control.)
Font | (Inherited from Control.)
FontChanged | (Inherited from Control.)
FontHeight | (Inherited from Control.)
ForeColor | (Inherited from Control.)
ForeColorChanged | (Inherited from Control.)
FormBorderStyle | (Inherited from Form.)
FormClosed | (Inherited from Form.)
FormClosing | (Inherited from Form.)
GetAccessibilityObjectById(Int32) | (Inherited from Control.)
GetAutoSizeMode()()() | (Inherited from Control.)
GetChildAtPoint(Point) | (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
GetContainerControl()()() | (Inherited from Control.)
GetHashCode()()() | (Inherited from Object.)
GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
GetNextControl(Control, Boolean) | (Inherited from Control.)
GetPreferredSize(Size) | (Inherited from Control.)
GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
GetScrollState(Int32) | (Inherited from ScrollableControl.)
GetService(Type) | (Inherited from Component.)
GetStyle(ControlStyles) | (Inherited from Control.)
GetTopLevel()()() | (Inherited from Control.)
GetType()()() | (Inherited from Object.)
GiveFeedback | (Inherited from Control.)
GotFocus | (Inherited from Control.)
Handle | (Inherited from Control.)
HandleCreated | (Inherited from Control.)
HandleDestroyed | (Inherited from Control.)
HasChildren | (Inherited from Control.)
Height | (Inherited from Control.)
HelpButton | (Inherited from Form.)
HelpButtonClicked | (Inherited from Form.)
HelpRequested | (Inherited from Control.)
Hide()()() | (Inherited from Control.)
HorizontalScroll | (Inherited from ScrollableControl.)
HScroll | (Inherited from ScrollableControl.)
Icon | (Inherited from Form.)
ImeMode | (Inherited from Control.)
ImeModeBase()()() | (Inherited from Control.)
ImeModeChanged | (Inherited from Control.)
IncludeRoot | Set to True if the RootAssembly should be included in the list of displayed assemblies. False by default.
InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
InitLayout()()() | (Inherited from Control.)
InputLanguageChanged | (Inherited from Form.)
InputLanguageChanging | (Inherited from Form.)
Invalidate()()() | (Inherited from Control.)
Invalidate(Region) | (Inherited from Control.)
Invalidate(Boolean) | (Inherited from Control.)
Invalidate(Rectangle) | (Inherited from Control.)
Invalidate(Region, Boolean) | (Inherited from Control.)
Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Invalidated | (Inherited from Control.)
Invoke(Delegate) | (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
InvokeRequired | (Inherited from Control.)
IsAccessible | (Inherited from Control.)
IsDisposed | (Inherited from Control.)
IsHandleCreated | (Inherited from Control.)
IsInputChar(Char) | (Inherited from Control.)
IsInputKey(Keys) | (Inherited from Control.)
IsMdiChild | (Inherited from Form.)
IsMdiContainer | (Inherited from Form.)
IsMirrored | (Inherited from Control.)
IsRestrictedWindow | (Inherited from Form.)
KeyDown | (Inherited from Control.)
KeyPress | (Inherited from Control.)
KeyPreview | (Inherited from Form.)
KeyUp | (Inherited from Control.)
Layout | (Inherited from Control.)
LayoutEngine | (Inherited from Control.)
LayoutMdi(MdiLayout) | (Inherited from Form.)
Leave | (Inherited from Control.)
Left | (Inherited from Control.)
Load | (Inherited from Form.)
Location | (Inherited from Form.)
LocationChanged | (Inherited from Control.)
LostFocus | (Inherited from Control.)
MainMenuStrip | (Inherited from Form.)
Margin | (Inherited from Form.)
MarginChanged | (Inherited from Form.)
MaximizeBox | (Inherited from Form.)
MaximizedBounds | (Inherited from Form.)
MaximizedBoundsChanged | (Inherited from Form.)
MaximumSize | (Inherited from Form.)
MaximumSizeChanged | (Inherited from Form.)
MdiChildActivate | (Inherited from Form.)
MdiChildren | (Inherited from Form.)
MdiParent | (Inherited from Form.)
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Menu | (Inherited from Form.)
MenuComplete | (Inherited from Form.)
MenuStart | (Inherited from Form.)
MergedMenu | (Inherited from Form.)
MinimizeBox | (Inherited from Form.)
MinimumSize | (Inherited from Form.)
MinimumSizeChanged | (Inherited from Form.)
Modal | (Inherited from Form.)
MouseCaptureChanged | (Inherited from Control.)
MouseClick | (Inherited from Control.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from Control.)
MouseEnter | (Inherited from Control.)
MouseHover | (Inherited from Control.)
MouseLeave | (Inherited from Control.)
MouseMove | (Inherited from Control.)
MouseUp | (Inherited from Control.)
MouseWheel | (Inherited from Control.)
Move | (Inherited from Control.)
Name | (Inherited from Control.)
NotifyInvalidate(Rectangle) | (Inherited from Control.)
OnActivated(EventArgs) | (Inherited from Form.)
OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
OnBackColorChanged(EventArgs) | (Inherited from Control.)
OnBackgroundImageChanged(EventArgs) | (Inherited from Form.)
OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Form.)
OnBindingContextChanged(EventArgs) | (Inherited from Control.)
OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
OnClick(EventArgs) | (Inherited from Control.)
OnClientSizeChanged(EventArgs) | (Inherited from Control.)
OnClosed(EventArgs) | (Inherited from Form.)
OnClosing(CancelEventArgs) | (Inherited from Form.)
OnContextMenuChanged(EventArgs) | (Inherited from Control.)
OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
OnControlAdded(ControlEventArgs) | (Inherited from Control.)
OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
OnCreateControl()()() | (Inherited from Form.)
OnCursorChanged(EventArgs) | (Inherited from Control.)
OnDeactivate(EventArgs) | (Inherited from Form.)
OnDockChanged(EventArgs) | (Inherited from Control.)
OnDoubleClick(EventArgs) | (Inherited from Control.)
OnDragDrop(DragEventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragDrop(DragEventArgs) | (Inherited from Control.)
OnDragEnter(DragEventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragEnter(DragEventArgs) | (Inherited from Control.)
OnDragLeave(EventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragLeave(EventArgs) | (Inherited from Control.)
OnDragOver(DragEventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragOver(DragEventArgs) | (Inherited from Control.)
OnEnabledChanged(EventArgs) | (Inherited from Form.)
OnEnter(EventArgs) | (Inherited from Form.)
OnFontChanged(EventArgs) | (Inherited from Form.)
OnForeColorChanged(EventArgs) | (Inherited from Control.)
OnFormClosed(FormClosedEventArgs) | (Inherited from Form.)
OnFormClosing(FormClosingEventArgs) | (Inherited from Form.)
OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
OnGotFocus(EventArgs) | (Inherited from Control.)
OnHandleCreated(EventArgs) | (Inherited from Form.)
OnHandleDestroyed(EventArgs) | (Inherited from Form.)
OnHelpButtonClicked(CancelEventArgs) | (Inherited from Form.)
OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
OnImeModeChanged(EventArgs) | (Inherited from Control.)
OnInputLanguageChanged(InputLanguageChangedEventArgs) | (Inherited from Form.)
OnInputLanguageChanging(InputLanguageChangingEventArgs) | (Inherited from Form.)
OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
OnKeyDown(KeyEventArgs) | (Inherited from Control.)
OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
OnKeyUp(KeyEventArgs) | (Inherited from Control.)
OnLayout(LayoutEventArgs) | (Inherited from Form.)
OnLeave(EventArgs) | (Inherited from Control.)
OnLoad(EventArgs) | (Inherited from Form.)
OnLocationChanged(EventArgs) | (Inherited from Control.)
OnLostFocus(EventArgs) | (Inherited from Control.)
OnMarginChanged(EventArgs) | (Inherited from Control.)
OnMaximizedBoundsChanged(EventArgs) | (Inherited from Form.)
OnMaximumSizeChanged(EventArgs) | (Inherited from Form.)
OnMdiChildActivate(EventArgs) | (Inherited from Form.)
OnMenuComplete(EventArgs) | (Inherited from Form.)
OnMenuStart(EventArgs) | (Inherited from Form.)
OnMinimumSizeChanged(EventArgs) | (Inherited from Form.)
OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
OnMouseClick(MouseEventArgs) | (Inherited from Control.)
OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
OnMouseDown(MouseEventArgs) | (Inherited from Control.)
OnMouseEnter(EventArgs) | (Inherited from Control.)
OnMouseHover(EventArgs) | (Inherited from Control.)
OnMouseLeave(EventArgs) | (Inherited from Control.)
OnMouseMove(MouseEventArgs) | (Inherited from Control.)
OnMouseUp(MouseEventArgs) | (Inherited from Control.)
OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
OnMove(EventArgs) | (Inherited from Control.)
OnNotifyMessage(Message) | (Inherited from Control.)
OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
OnPaint(PaintEventArgs) | (Inherited from Form.)
OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
OnParentCursorChanged(EventArgs) | (Inherited from Control.)
OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
OnParentFontChanged(EventArgs) | (Inherited from Control.)
OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
OnPrint(PaintEventArgs) | (Inherited from Control.)
OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
OnRegionChanged(EventArgs) | (Inherited from Control.)
OnResize(EventArgs) | (Inherited from Form.)
OnResizeBegin(EventArgs) | (Inherited from Form.)
OnResizeEnd(EventArgs) | (Inherited from Form.)
OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged(EventArgs) | (Inherited from Form.)
OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
OnShown(EventArgs) | (Inherited from Form.)
OnSizeChanged(EventArgs) | (Inherited from Control.)
OnStyleChanged(EventArgs) | (Inherited from Form.)
OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
OnTabIndexChanged(EventArgs) | (Inherited from Control.)
OnTabStopChanged(EventArgs) | (Inherited from Control.)
OnTextChanged(EventArgs) | (Inherited from Form.)
OnValidated(EventArgs) | (Inherited from Control.)
OnValidating(CancelEventArgs) | (Inherited from Control.)
OnVisibleChanged(EventArgs) | (Inherited from Form.)
Opacity | (Inherited from Form.)
OwnedForms | (Inherited from Form.)
Owner | (Inherited from Form.)
Padding | (Inherited from Control.)
PaddingChanged | (Inherited from Control.)
Paint | (Inherited from Control.)
Parent | (Inherited from Control.)
ParentChanged | (Inherited from Control.)
ParentForm | (Inherited from ContainerControl.)
PerformAutoScale()()() | (Inherited from ContainerControl.)
PerformLayout()()() | (Inherited from Control.)
PerformLayout(Control, String) | (Inherited from Control.)
PointToClient(Point) | (Inherited from Control.)
PointToScreen(Point) | (Inherited from Control.)
PreferredSize | (Inherited from Control.)
PreProcessControlMessage(Message%) | (Inherited from Control.)
PreProcessMessage(Message%) | (Inherited from Control.)
PreviewKeyDown | (Inherited from Control.)
ProcessCmdKey(Message%, Keys) | (Inherited from Form.)
ProcessDialogChar(Char) | (Inherited from Form.)
ProcessDialogKey(Keys) | (Inherited from Form.)
ProcessKeyEventArgs(Message%) | (Inherited from Control.)
ProcessKeyMessage(Message%) | (Inherited from Control.)
ProcessKeyPreview(Message%) | (Inherited from Form.)
ProcessMnemonic(Char) | (Inherited from Form.)
ProcessTabKey(Boolean) | (Inherited from Form.)
ProductName | (Inherited from Control.)
ProductVersion | (Inherited from Control.)
QueryAccessibilityHelp | (Inherited from Control.)
QueryContinueDrag | (Inherited from Control.)
RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
RecreateHandle()()() | (Inherited from Control.)
RecreatingHandle | (Inherited from Control.)
RectangleToClient(Rectangle) | (Inherited from Control.)
RectangleToScreen(Rectangle) | (Inherited from Control.)
Refresh()()() | (Inherited from Control.)
Region | (Inherited from Control.)
RegionChanged | (Inherited from Control.)
RemoveOwnedForm(Form) | (Inherited from Form.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResetBackColor()()() | (Inherited from Control.)
ResetBindings()()() | (Inherited from Control.)
ResetCursor()()() | (Inherited from Control.)
ResetFont()()() | (Inherited from Control.)
ResetForeColor()()() | (Inherited from Control.)
ResetImeMode()()() | (Inherited from Control.)
ResetMouseEventArgs()()() | (Inherited from Control.)
ResetRightToLeft()()() | (Inherited from Control.)
ResetText()()() | (Inherited from Control.)
Resize | (Inherited from Control.)
ResizeBegin | (Inherited from Form.)
ResizeEnd | (Inherited from Form.)
ResizeRedraw | (Inherited from Control.)
RestoreBounds | (Inherited from Form.)
ResumeLayout()()() | (Inherited from Control.)
ResumeLayout(Boolean) | (Inherited from Control.)
Right | (Inherited from Control.)
RightToLeft | (Inherited from Control.)
RightToLeftChanged | (Inherited from Control.)
RightToLeftLayout | (Inherited from Form.)
RightToLeftLayoutChanged | (Inherited from Form.)
RootAssembly | The assembly that all references are followed from. The EntryAssembly by default.
RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)
ScaleChildren | (Inherited from Control.)
ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
ScaleCore(Single, Single) | (Inherited from Form.)
Scroll | (Inherited from ScrollableControl.)
ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
ScrollToControl(Control) | (Inherited from ScrollableControl.)
Select()()() | (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from Form.)
SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
SendToBack()()() | (Inherited from Control.)
SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
SetClientSizeCore(Int32, Int32) | (Inherited from Form.)
SetDesktopBounds(Int32, Int32, Int32, Int32) | (Inherited from Form.)
SetDesktopLocation(Int32, Int32) | (Inherited from Form.)
SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
SetTopLevel(Boolean) | (Inherited from Control.)
SetVisibleCore(Boolean) | (Inherited from Form.)
Show()()() | (Inherited from Control.)
Show(IWin32Window) | (Inherited from Form.)
ShowDialog()()() | (Inherited from Form.)
ShowDialog(IWin32Window) | (Inherited from Form.)
ShowFocusCues | (Inherited from Control.)
ShowIcon | (Inherited from Form.)
ShowInTaskbar | (Inherited from Form.)
ShowKeyboardCues | (Inherited from Control.)
Shown | (Inherited from Form.)
ShowWithoutActivation | (Inherited from Form.)
Site | (Inherited from Control.)
Size | (Inherited from Form.)
SizeChanged | (Inherited from Control.)
SizeFromClientSize(Size) | (Inherited from Control.)
SizeGripStyle | (Inherited from Form.)
StartPosition | (Inherited from Form.)
StyleChanged | (Inherited from Control.)
SuspendLayout()()() | (Inherited from Control.)
SystemColorsChanged | (Inherited from Control.)
TabIndex | (Inherited from Form.)
TabIndexChanged | (Inherited from Form.)
TabStop | (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
Tag | (Inherited from Control.)
Text | (Inherited from Form.)
TextChanged | (Inherited from Control.)
Top | (Inherited from Control.)
TopLevel | (Inherited from Form.)
TopLevelControl | (Inherited from Control.)
TopMost | (Inherited from Form.)
ToString()()() | (Inherited from Form.)
TransparencyKey | (Inherited from Form.)
Update()()() | (Inherited from Control.)
UpdateBounds()()() | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
UpdateDefaultButton()()() | (Inherited from Form.)
UpdateStyles()()() | (Inherited from Control.)
UpdateZOrder()()() | (Inherited from Control.)
UseWaitCursor | (Inherited from Control.)
Validate()()() | (Inherited from ContainerControl.)
Validate(Boolean) | (Inherited from ContainerControl.)
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Validated | (Inherited from Control.)
Validating | (Inherited from Control.)
VerticalScroll | (Inherited from ScrollableControl.)
Visible | (Inherited from Control.)
VisibleChanged | (Inherited from Control.)
VScroll | (Inherited from ScrollableControl.)
Width | (Inherited from Control.)
WindowState | (Inherited from Form.)
WindowTarget | (Inherited from Control.)
WndProc(Message%) | (Inherited from Form.)

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.ComponentModel..::.Component
System.Windows.Forms..::.Control
System.Windows.Forms..::.ScrollableControl
System.Windows.Forms..::.ContainerControl
System.Windows.Forms..::.Form
IndianHealthService.BMXNet.WinForm..::.AboutDialog

See Also

IndianHealthService.BMXNet.WinForm Namespace


AboutDialog Constructor

JavaScript

AboutDialog Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public AboutDialog()
Public Sub New
public:
AboutDialog()

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


AboutDialog Methods

JavaScript

AboutDialog Methods

BMXNET 4.0 Developer API

The AboutDialog type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Activate()()() | (Inherited from Form.)
IContainerControl..::.ActivateControl(Control) | (Inherited from ContainerControl.)
ActivateMdiChild(Form) | (Inherited from Form.)
AddOwnedForm(Form) | (Inherited from Form.)
AdjustFormScrollbars(Boolean) | (Inherited from Form.)
ApplyAutoScaling()()() | Obsolete. (Inherited from Form.)
BeginInvoke(Delegate) | (Inherited from Control.)
BeginInvoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
BringToFront()()() | (Inherited from Control.)
CenterToParent()()() | (Inherited from Form.)
CenterToScreen()()() | (Inherited from Form.)
Close()()() | (Inherited from Form.)
Contains(Control) | (Inherited from Control.)
CreateAccessibilityInstance()()() | (Inherited from Control.)
CreateControl()()() | (Inherited from Control.)
CreateControlsInstance()()() | (Inherited from Form.)
CreateGraphics()()() | (Inherited from Control.)
CreateHandle()()() | (Inherited from Form.)
CreateObjRef(Type) | (Inherited from MarshalByRefObject.)
DefWndProc(Message%) | (Inherited from Form.)
DestroyHandle()()() | (Inherited from Control.)
Dispose()()() | (Inherited from Component.)
Dispose(Boolean) | Clean up any resources being used. (Overrides Form..::.Dispose(Boolean).)
DoDragDrop(Object, DragDropEffects) | (Inherited from Control.)
DrawToBitmap(Bitmap, Rectangle) | (Inherited from Control.)
EndInvoke(IAsyncResult) | (Inherited from Control.)
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Component.)
FindForm()()() | (Inherited from Control.)
Focus()()() | (Inherited from Control.)
GetAccessibilityObjectById(Int32) | (Inherited from Control.)
GetAutoSizeMode()()() | (Inherited from Control.)
GetChildAtPoint(Point) | (Inherited from Control.)
GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
GetContainerControl()()() | (Inherited from Control.)
GetHashCode()()() | (Inherited from Object.)
GetLifetimeService()()() | (Inherited from MarshalByRefObject.)
GetNextControl(Control, Boolean) | (Inherited from Control.)
GetPreferredSize(Size) | (Inherited from Control.)
GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | (Inherited from Form.)
GetScrollState(Int32) | (Inherited from ScrollableControl.)
GetService(Type) | (Inherited from Component.)
GetStyle(ControlStyles) | (Inherited from Control.)
GetTopLevel()()() | (Inherited from Control.)
GetType()()() | (Inherited from Object.)
Hide()()() | (Inherited from Control.)
InitializeLifetimeService()()() | (Inherited from MarshalByRefObject.)
InitLayout()()() | (Inherited from Control.)
Invalidate()()() | (Inherited from Control.)
Invalidate(Region) | (Inherited from Control.)
Invalidate(Boolean) | (Inherited from Control.)
Invalidate(Rectangle) | (Inherited from Control.)
Invalidate(Region, Boolean) | (Inherited from Control.)
Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Invoke(Delegate) | (Inherited from Control.)
Invoke(Delegate, array<Object>[]()[]) | (Inherited from Control.)
InvokeGotFocus(Control, EventArgs) | (Inherited from Control.)
InvokeLostFocus(Control, EventArgs) | (Inherited from Control.)
InvokeOnClick(Control, EventArgs) | (Inherited from Control.)
InvokePaint(Control, PaintEventArgs) | (Inherited from Control.)
InvokePaintBackground(Control, PaintEventArgs) | (Inherited from Control.)
IsInputChar(Char) | (Inherited from Control.)
IsInputKey(Keys) | (Inherited from Control.)
LayoutMdi(MdiLayout) | (Inherited from Form.)
MemberwiseClone()()() | (Inherited from Object.)
MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
NotifyInvalidate(Rectangle) | (Inherited from Control.)
OnActivated(EventArgs) | (Inherited from Form.)
OnAutoSizeChanged(EventArgs) | (Inherited from Control.)
OnAutoValidateChanged(EventArgs) | (Inherited from ContainerControl.)
OnBackColorChanged(EventArgs) | (Inherited from Control.)
OnBackgroundImageChanged(EventArgs) | (Inherited from Form.)
OnBackgroundImageLayoutChanged(EventArgs) | (Inherited from Form.)
OnBindingContextChanged(EventArgs) | (Inherited from Control.)
OnCausesValidationChanged(EventArgs) | (Inherited from Control.)
OnChangeUICues(UICuesEventArgs) | (Inherited from Control.)
OnClick(EventArgs) | (Inherited from Control.)
OnClientSizeChanged(EventArgs) | (Inherited from Control.)
OnClosed(EventArgs) | (Inherited from Form.)
OnClosing(CancelEventArgs) | (Inherited from Form.)
OnContextMenuChanged(EventArgs) | (Inherited from Control.)
OnContextMenuStripChanged(EventArgs) | (Inherited from Control.)
OnControlAdded(ControlEventArgs) | (Inherited from Control.)
OnControlRemoved(ControlEventArgs) | (Inherited from Control.)
OnCreateControl()()() | (Inherited from Form.)
OnCursorChanged(EventArgs) | (Inherited from Control.)
OnDeactivate(EventArgs) | (Inherited from Form.)
OnDockChanged(EventArgs) | (Inherited from Control.)
OnDoubleClick(EventArgs) | (Inherited from Control.)
OnDragDrop(DragEventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragDrop(DragEventArgs) | (Inherited from Control.)
OnDragEnter(DragEventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragEnter(DragEventArgs) | (Inherited from Control.)
OnDragLeave(EventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragLeave(EventArgs) | (Inherited from Control.)
OnDragOver(DragEventArgs) | (Inherited from Control.)
IDropTarget..::.OnDragOver(DragEventArgs) | (Inherited from Control.)
OnEnabledChanged(EventArgs) | (Inherited from Form.)
OnEnter(EventArgs) | (Inherited from Form.)
OnFontChanged(EventArgs) | (Inherited from Form.)
OnForeColorChanged(EventArgs) | (Inherited from Control.)
OnFormClosed(FormClosedEventArgs) | (Inherited from Form.)
OnFormClosing(FormClosingEventArgs) | (Inherited from Form.)
OnGiveFeedback(GiveFeedbackEventArgs) | (Inherited from Control.)
OnGotFocus(EventArgs) | (Inherited from Control.)
OnHandleCreated(EventArgs) | (Inherited from Form.)
OnHandleDestroyed(EventArgs) | (Inherited from Form.)
OnHelpButtonClicked(CancelEventArgs) | (Inherited from Form.)
OnHelpRequested(HelpEventArgs) | (Inherited from Control.)
OnImeModeChanged(EventArgs) | (Inherited from Control.)
OnInputLanguageChanged(InputLanguageChangedEventArgs) | (Inherited from Form.)
OnInputLanguageChanging(InputLanguageChangingEventArgs) | (Inherited from Form.)
OnInvalidated(InvalidateEventArgs) | (Inherited from Control.)
OnKeyDown(KeyEventArgs) | (Inherited from Control.)
OnKeyPress(KeyPressEventArgs) | (Inherited from Control.)
OnKeyUp(KeyEventArgs) | (Inherited from Control.)
OnLayout(LayoutEventArgs) | (Inherited from Form.)
OnLeave(EventArgs) | (Inherited from Control.)
OnLoad(EventArgs) | (Inherited from Form.)
OnLocationChanged(EventArgs) | (Inherited from Control.)
OnLostFocus(EventArgs) | (Inherited from Control.)
OnMarginChanged(EventArgs) | (Inherited from Control.)
OnMaximizedBoundsChanged(EventArgs) | (Inherited from Form.)
OnMaximumSizeChanged(EventArgs) | (Inherited from Form.)
OnMdiChildActivate(EventArgs) | (Inherited from Form.)
OnMenuComplete(EventArgs) | (Inherited from Form.)
OnMenuStart(EventArgs) | (Inherited from Form.)
OnMinimumSizeChanged(EventArgs) | (Inherited from Form.)
OnMouseCaptureChanged(EventArgs) | (Inherited from Control.)
OnMouseClick(MouseEventArgs) | (Inherited from Control.)
OnMouseDoubleClick(MouseEventArgs) | (Inherited from Control.)
OnMouseDown(MouseEventArgs) | (Inherited from Control.)
OnMouseEnter(EventArgs) | (Inherited from Control.)
OnMouseHover(EventArgs) | (Inherited from Control.)
OnMouseLeave(EventArgs) | (Inherited from Control.)
OnMouseMove(MouseEventArgs) | (Inherited from Control.)
OnMouseUp(MouseEventArgs) | (Inherited from Control.)
OnMouseWheel(MouseEventArgs) | (Inherited from ScrollableControl.)
OnMove(EventArgs) | (Inherited from Control.)
OnNotifyMessage(Message) | (Inherited from Control.)
OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
OnPaint(PaintEventArgs) | (Inherited from Form.)
OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
OnParentBackColorChanged(EventArgs) | (Inherited from Control.)
OnParentBackgroundImageChanged(EventArgs) | (Inherited from Control.)
OnParentBindingContextChanged(EventArgs) | (Inherited from Control.)
OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
OnParentCursorChanged(EventArgs) | (Inherited from Control.)
OnParentEnabledChanged(EventArgs) | (Inherited from Control.)
OnParentFontChanged(EventArgs) | (Inherited from Control.)
OnParentForeColorChanged(EventArgs) | (Inherited from Control.)
OnParentRightToLeftChanged(EventArgs) | (Inherited from Control.)
OnParentVisibleChanged(EventArgs) | (Inherited from Control.)
OnPreviewKeyDown(PreviewKeyDownEventArgs) | (Inherited from Control.)
OnPrint(PaintEventArgs) | (Inherited from Control.)
OnQueryContinueDrag(QueryContinueDragEventArgs) | (Inherited from Control.)
OnRegionChanged(EventArgs) | (Inherited from Control.)
OnResize(EventArgs) | (Inherited from Form.)
OnResizeBegin(EventArgs) | (Inherited from Form.)
OnResizeEnd(EventArgs) | (Inherited from Form.)
OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
OnRightToLeftLayoutChanged(EventArgs) | (Inherited from Form.)
OnScroll(ScrollEventArgs) | (Inherited from ScrollableControl.)
OnShown(EventArgs) | (Inherited from Form.)
OnSizeChanged(EventArgs) | (Inherited from Control.)
OnStyleChanged(EventArgs) | (Inherited from Form.)
OnSystemColorsChanged(EventArgs) | (Inherited from Control.)
OnTabIndexChanged(EventArgs) | (Inherited from Control.)
OnTabStopChanged(EventArgs) | (Inherited from Control.)
OnTextChanged(EventArgs) | (Inherited from Form.)
OnValidated(EventArgs) | (Inherited from Control.)
OnValidating(CancelEventArgs) | (Inherited from Control.)
OnVisibleChanged(EventArgs) | (Inherited from Form.)
PerformAutoScale()()() | (Inherited from ContainerControl.)
PerformLayout()()() | (Inherited from Control.)
PerformLayout(Control, String) | (Inherited from Control.)
PointToClient(Point) | (Inherited from Control.)
PointToScreen(Point) | (Inherited from Control.)
PreProcessControlMessage(Message%) | (Inherited from Control.)
PreProcessMessage(Message%) | (Inherited from Control.)
ProcessCmdKey(Message%, Keys) | (Inherited from Form.)
ProcessDialogChar(Char) | (Inherited from Form.)
ProcessDialogKey(Keys) | (Inherited from Form.)
ProcessKeyEventArgs(Message%) | (Inherited from Control.)
ProcessKeyMessage(Message%) | (Inherited from Control.)
ProcessKeyPreview(Message%) | (Inherited from Form.)
ProcessMnemonic(Char) | (Inherited from Form.)
ProcessTabKey(Boolean) | (Inherited from Form.)
RaiseDragEvent(Object, DragEventArgs) | (Inherited from Control.)
RaiseKeyEvent(Object, KeyEventArgs) | (Inherited from Control.)
RaiseMouseEvent(Object, MouseEventArgs) | (Inherited from Control.)
RaisePaintEvent(Object, PaintEventArgs) | (Inherited from Control.)
RecreateHandle()()() | (Inherited from Control.)
RectangleToClient(Rectangle) | (Inherited from Control.)
RectangleToScreen(Rectangle) | (Inherited from Control.)
Refresh()()() | (Inherited from Control.)
RemoveOwnedForm(Form) | (Inherited from Form.)
ResetBackColor()()() | (Inherited from Control.)
ResetBindings()()() | (Inherited from Control.)
ResetCursor()()() | (Inherited from Control.)
ResetFont()()() | (Inherited from Control.)
ResetForeColor()()() | (Inherited from Control.)
ResetImeMode()()() | (Inherited from Control.)
ResetMouseEventArgs()()() | (Inherited from Control.)
ResetRightToLeft()()() | (Inherited from Control.)
ResetText()()() | (Inherited from Control.)
ResumeLayout()()() | (Inherited from Control.)
ResumeLayout(Boolean) | (Inherited from Control.)
RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
RtlTranslateContent(ContentAlignment) | (Inherited from Control.)
RtlTranslateHorizontal(HorizontalAlignment) | (Inherited from Control.)
RtlTranslateLeftRight(LeftRightAlignment) | (Inherited from Control.)
Scale(Single) | Obsolete. (Inherited from Control.)
Scale(SizeF) | (Inherited from Control.)
Scale(Single, Single) | Obsolete. (Inherited from Control.)
ScaleControl(SizeF, BoundsSpecified) | (Inherited from Form.)
ScaleCore(Single, Single) | (Inherited from Form.)
ScrollControlIntoView(Control) | (Inherited from ScrollableControl.)
ScrollToControl(Control) | (Inherited from ScrollableControl.)
Select()()() | (Inherited from Control.)
Select(Boolean, Boolean) | (Inherited from Form.)
SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | (Inherited from Control.)
SendToBack()()() | (Inherited from Control.)
SetAutoScrollMargin(Int32, Int32) | (Inherited from ScrollableControl.)
SetAutoSizeMode(AutoSizeMode) | (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Form.)
SetClientSizeCore(Int32, Int32) | (Inherited from Form.)
SetDesktopBounds(Int32, Int32, Int32, Int32) | (Inherited from Form.)
SetDesktopLocation(Int32, Int32) | (Inherited from Form.)
SetDisplayRectLocation(Int32, Int32) | (Inherited from ScrollableControl.)
SetScrollState(Int32, Boolean) | (Inherited from ScrollableControl.)
SetStyle(ControlStyles, Boolean) | (Inherited from Control.)
SetTopLevel(Boolean) | (Inherited from Control.)
SetVisibleCore(Boolean) | (Inherited from Form.)
Show()()() | (Inherited from Control.)
Show(IWin32Window) | (Inherited from Form.)
ShowDialog()()() | (Inherited from Form.)
ShowDialog(IWin32Window) | (Inherited from Form.)
SizeFromClientSize(Size) | (Inherited from Control.)
SuspendLayout()()() | (Inherited from Control.)
ToString()()() | (Inherited from Form.)
Update()()() | (Inherited from Control.)
UpdateBounds()()() | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
UpdateDefaultButton()()() | (Inherited from Form.)
UpdateStyles()()() | (Inherited from Control.)
UpdateZOrder()()() | (Inherited from Control.)
Validate()()() | (Inherited from ContainerControl.)
Validate(Boolean) | (Inherited from ContainerControl.)
ValidateChildren()()() | (Inherited from Form.)
ValidateChildren(ValidationConstraints) | (Inherited from Form.)
WndProc(Message%) | (Inherited from Form.)

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


AccessibilityNotifyClients Method

JavaScript

AboutDialog..::AccessibilityNotifyClients Method

BMXNET 4.0 Developer API

Overload List

Name | Description
AccessibilityNotifyClients(AccessibleEvents, Int32) |
AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


BeginInvoke Method

JavaScript

AboutDialog..::BeginInvoke Method

BMXNET 4.0 Developer API

Overload List

Name | Description
BeginInvoke(Delegate) |
BeginInvoke(Delegate, array<Object>[]()[]) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Dispose Method

JavaScript

AboutDialog..::Dispose Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Dispose()()() |
Dispose(Boolean) | Clean up any resources being used. (Overrides Form.Dispose(Boolean).)

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Dispose Method (Boolean)

JavaScript

AboutDialog..::Dispose Method (Boolean)

BMXNET 4.0 Developer API

Clean up any resources being used.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Boolean

See Also

AboutDialog Class
Dispose Overload
IndianHealthService.BMXNet.WinForm Namespace


GetChildAtPoint Method

JavaScript

AboutDialog..::GetChildAtPoint Method

BMXNET 4.0 Developer API

Overload List

Name | Description
GetChildAtPoint(Point) |
GetChildAtPoint(Point, GetChildAtPointSkip) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Invalidate Method

JavaScript

AboutDialog..::Invalidate Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Invalidate()()() |
Invalidate(Region) |
Invalidate(Boolean) |
Invalidate(Rectangle) |
Invalidate(Region, Boolean) |
Invalidate(Rectangle, Boolean) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Invoke Method

JavaScript

AboutDialog..::Invoke Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Invoke(Delegate) |
Invoke(Delegate, array<Object>[]()[]) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


MemberwiseClone Method

JavaScript

AboutDialog..::MemberwiseClone Method

BMXNET 4.0 Developer API

Overload List

Name | Description
MemberwiseClone()()() |
MemberwiseClone(Boolean) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


PerformLayout Method

JavaScript

AboutDialog..::PerformLayout Method

BMXNET 4.0 Developer API

Overload List

Name | Description
PerformLayout()()() |
PerformLayout(Control, String) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


ResumeLayout Method

JavaScript

AboutDialog..::ResumeLayout Method

BMXNET 4.0 Developer API

Overload List

Name | Description
ResumeLayout()()() |
ResumeLayout(Boolean) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


RtlTranslateAlignment Method

JavaScript

AboutDialog..::RtlTranslateAlignment Method

BMXNET 4.0 Developer API

Overload List

Name | Description
RtlTranslateAlignment(HorizontalAlignment) |
RtlTranslateAlignment(LeftRightAlignment) |
RtlTranslateAlignment(ContentAlignment) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Scale Method

JavaScript

AboutDialog..::Scale Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Scale(Single) | Obsolete.
Scale(SizeF) |
Scale(Single, Single) | Obsolete.

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Select Method

JavaScript

AboutDialog..::Select Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Select()()() |
Select(Boolean, Boolean) | (Overrides ContainerControl.Select(Boolean, Boolean).)

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


SetBounds Method

JavaScript

AboutDialog..::SetBounds Method

BMXNET 4.0 Developer API

Overload List

Name | Description
SetBounds(Int32, Int32, Int32, Int32) |
SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Show Method

JavaScript

AboutDialog..::Show Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Show()()() |
Show(IWin32Window) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


ShowDialog Method

JavaScript

AboutDialog..::ShowDialog Method

BMXNET 4.0 Developer API

Overload List

Name | Description
ShowDialog()()() |
ShowDialog(IWin32Window) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


UpdateBounds Method

JavaScript

AboutDialog..::UpdateBounds Method

BMXNET 4.0 Developer API

Overload List

Name | Description
UpdateBounds()()() |
UpdateBounds(Int32, Int32, Int32, Int32) |
UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


Validate Method

JavaScript

AboutDialog..::Validate Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Validate()()() |
Validate(Boolean) |

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


ValidateChildren Method

JavaScript

AboutDialog..::ValidateChildren Method

BMXNET 4.0 Developer API

Overload List

Name | Description
ValidateChildren()()() | (Overrides ContainerControl.ValidateChildren()()().)
ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


AboutDialog Properties

JavaScript

AboutDialog Properties

BMXNET 4.0 Developer API

The AboutDialog type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AcceptButton | (Inherited from Form.)
AccessibilityObject | (Inherited from Control.)
AccessibleDefaultActionDescription | (Inherited from Control.)
AccessibleDescription | (Inherited from Control.)
AccessibleName | (Inherited from Control.)
AccessibleRole | (Inherited from Control.)
ActiveControl | (Inherited from ContainerControl.)
ActiveMdiChild | (Inherited from Form.)
AllowDrop | (Inherited from Control.)
AllowTransparency | (Inherited from Form.)
Anchor | (Inherited from Control.)
AutoScale | Obsolete. (Inherited from Form.)
AutoScaleBaseSize | (Inherited from Form.)
AutoScaleDimensions | (Inherited from ContainerControl.)
AutoScaleFactor | (Inherited from ContainerControl.)
AutoScaleMode | (Inherited from ContainerControl.)
AutoScroll | (Inherited from Form.)
AutoScrollMargin | (Inherited from ScrollableControl.)
AutoScrollMinSize | (Inherited from ScrollableControl.)
AutoScrollOffset | (Inherited from Control.)
AutoScrollPosition | (Inherited from ScrollableControl.)
AutoSize | (Inherited from Form.)
AutoSizeMode | (Inherited from Form.)
AutoValidate | (Inherited from Form.)
BackColor | (Inherited from Form.)
BackgroundImage | (Inherited from Control.)
BackgroundImageLayout | (Inherited from Control.)
BindingContext | (Inherited from ContainerControl.)
Bottom | (Inherited from Control.)
Bounds | (Inherited from Control.)
CancelButton | (Inherited from Form.)
CanEnableIme | (Inherited from ContainerControl.)
CanFocus | (Inherited from Control.)
CanRaiseEvents | (Inherited from Control.)
CanSelect | (Inherited from Control.)
Capture | (Inherited from Control.)
CausesValidation | (Inherited from Control.)
ClientRectangle | (Inherited from Control.)
ClientSize | (Inherited from Form.)
CompanyName | (Inherited from Control.)
Container | (Inherited from Component.)
ContainsFocus | (Inherited from Control.)
ContextMenu | (Inherited from Control.)
ContextMenuStrip | (Inherited from Control.)
ControlBox | (Inherited from Form.)
Controls | (Inherited from Control.)
Created | (Inherited from Control.)
CreateParams | (Inherited from Form.)
CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Cursor | (Inherited from Control.)
DataBindings | (Inherited from Control.)
DefaultCursor | (Inherited from Control.)
DefaultImeMode | (Inherited from Form.)
DefaultMargin | (Inherited from Control.)
DefaultMaximumSize | (Inherited from Control.)
DefaultMinimumSize | (Inherited from Control.)
DefaultPadding | (Inherited from Control.)
DefaultSize | (Inherited from Form.)
DesignMode | (Inherited from Component.)
DesktopBounds | (Inherited from Form.)
DesktopLocation | (Inherited from Form.)
DialogResult | (Inherited from Form.)
DisplayRectangle | (Inherited from ScrollableControl.)
Disposing | (Inherited from Control.)
Dock | (Inherited from Control.)
DockPadding | (Inherited from ScrollableControl.)
DoubleBuffered | (Inherited from Control.)
Enabled | (Inherited from Control.)
Events | (Inherited from Component.)
Focused | (Inherited from Control.)
Font | (Inherited from Control.)
FontHeight | (Inherited from Control.)
ForeColor | (Inherited from Control.)
FormBorderStyle | (Inherited from Form.)
Handle | (Inherited from Control.)
HasChildren | (Inherited from Control.)
Height | (Inherited from Control.)
HelpButton | (Inherited from Form.)
HorizontalScroll | (Inherited from ScrollableControl.)
HScroll | (Inherited from ScrollableControl.)
Icon | (Inherited from Form.)
ImeMode | (Inherited from Control.)
ImeModeBase()()() | (Inherited from Control.)
IncludeRoot | Set to True if the RootAssembly should be included in the list of displayed assemblies. False by default.
InvokeRequired | (Inherited from Control.)
IsAccessible | (Inherited from Control.)
IsDisposed | (Inherited from Control.)
IsHandleCreated | (Inherited from Control.)
IsMdiChild | (Inherited from Form.)
IsMdiContainer | (Inherited from Form.)
IsMirrored | (Inherited from Control.)
IsRestrictedWindow | (Inherited from Form.)
KeyPreview | (Inherited from Form.)
LayoutEngine | (Inherited from Control.)
Left | (Inherited from Control.)
Location | (Inherited from Form.)
MainMenuStrip | (Inherited from Form.)
Margin | (Inherited from Form.)
MaximizeBox | (Inherited from Form.)
MaximizedBounds | (Inherited from Form.)
MaximumSize | (Inherited from Form.)
MdiChildren | (Inherited from Form.)
MdiParent | (Inherited from Form.)
Menu | (Inherited from Form.)
MergedMenu | (Inherited from Form.)
MinimizeBox | (Inherited from Form.)
MinimumSize | (Inherited from Form.)
Modal | (Inherited from Form.)
Name | (Inherited from Control.)
Opacity | (Inherited from Form.)
OwnedForms | (Inherited from Form.)
Owner | (Inherited from Form.)
Padding | (Inherited from Control.)
Parent | (Inherited from Control.)
ParentForm | (Inherited from ContainerControl.)
PreferredSize | (Inherited from Control.)
ProductName | (Inherited from Control.)
ProductVersion | (Inherited from Control.)
RecreatingHandle | (Inherited from Control.)
Region | (Inherited from Control.)
RenderRightToLeft | Obsolete. (Inherited from Control.)
ResizeRedraw | (Inherited from Control.)
RestoreBounds | (Inherited from Form.)
Right | (Inherited from Control.)
RightToLeft | (Inherited from Control.)
RightToLeftLayout | (Inherited from Form.)
RootAssembly | The assembly that all references are followed from. The EntryAssembly by default.
ScaleChildren | (Inherited from Control.)
ShowFocusCues | (Inherited from Control.)
ShowIcon | (Inherited from Form.)
ShowInTaskbar | (Inherited from Form.)
ShowKeyboardCues | (Inherited from Control.)
ShowWithoutActivation | (Inherited from Form.)
Site | (Inherited from Control.)
Size | (Inherited from Form.)
SizeGripStyle | (Inherited from Form.)
StartPosition | (Inherited from Form.)
TabIndex | (Inherited from Form.)
TabStop | (Inherited from Form.)
Tag | (Inherited from Control.)
Text | (Inherited from Form.)
Top | (Inherited from Control.)
TopLevel | (Inherited from Form.)
TopLevelControl | (Inherited from Control.)
TopMost | (Inherited from Form.)
TransparencyKey | (Inherited from Form.)
UseWaitCursor | (Inherited from Control.)
VerticalScroll | (Inherited from ScrollableControl.)
Visible | (Inherited from Control.)
VScroll | (Inherited from ScrollableControl.)
Width | (Inherited from Control.)
WindowState | (Inherited from Form.)
WindowTarget | (Inherited from Control.)

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


IncludeRoot Property

JavaScript

AboutDialog..::IncludeRoot Property

BMXNET 4.0 Developer API

Set to True if the RootAssembly should be included in the list of displayed assemblies. False by default.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IncludeRoot { get; set; }
Public Property IncludeRoot As Boolean
public:
property bool IncludeRoot {
    bool get ();
    void set (bool value);
}

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


RootAssembly Property

JavaScript

AboutDialog..::RootAssembly Property

BMXNET 4.0 Developer API

The assembly that all references are followed from. The EntryAssembly by default.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Assembly RootAssembly { get; set; }
Public Property RootAssembly As Assembly
public:
property Assembly^ RootAssembly {
    Assembly^ get ();
    void set (Assembly^ value);
}

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


AboutDialog Events

JavaScript

AboutDialog Events

BMXNET 4.0 Developer API

The AboutDialog type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Activated | (Inherited from Form.)
AutoSizeChanged | (Inherited from Form.)
AutoValidateChanged | (Inherited from Form.)
BackColorChanged | (Inherited from Control.)
BackgroundImageChanged | (Inherited from Control.)
BackgroundImageLayoutChanged | (Inherited from Control.)
BindingContextChanged | (Inherited from Control.)
CausesValidationChanged | (Inherited from Control.)
ChangeUICues | (Inherited from Control.)
Click | (Inherited from Control.)
ClientSizeChanged | (Inherited from Control.)
Closed | (Inherited from Form.)
Closing | (Inherited from Form.)
ContextMenuChanged | (Inherited from Control.)
ContextMenuStripChanged | (Inherited from Control.)
ControlAdded | (Inherited from Control.)
ControlRemoved | (Inherited from Control.)
CursorChanged | (Inherited from Control.)
Deactivate | (Inherited from Form.)
Disposed | (Inherited from Component.)
DockChanged | (Inherited from Control.)
DoubleClick | (Inherited from Control.)
DragDrop | (Inherited from Control.)
DragEnter | (Inherited from Control.)
DragLeave | (Inherited from Control.)
DragOver | (Inherited from Control.)
EnabledChanged | (Inherited from Control.)
Enter | (Inherited from Control.)
FontChanged | (Inherited from Control.)
ForeColorChanged | (Inherited from Control.)
FormClosed | (Inherited from Form.)
FormClosing | (Inherited from Form.)
GiveFeedback | (Inherited from Control.)
GotFocus | (Inherited from Control.)
HandleCreated | (Inherited from Control.)
HandleDestroyed | (Inherited from Control.)
HelpButtonClicked | (Inherited from Form.)
HelpRequested | (Inherited from Control.)
ImeModeChanged | (Inherited from Control.)
InputLanguageChanged | (Inherited from Form.)
InputLanguageChanging | (Inherited from Form.)
Invalidated | (Inherited from Control.)
KeyDown | (Inherited from Control.)
KeyPress | (Inherited from Control.)
KeyUp | (Inherited from Control.)
Layout | (Inherited from Control.)
Leave | (Inherited from Control.)
Load | (Inherited from Form.)
LocationChanged | (Inherited from Control.)
LostFocus | (Inherited from Control.)
MarginChanged | (Inherited from Form.)
MaximizedBoundsChanged | (Inherited from Form.)
MaximumSizeChanged | (Inherited from Form.)
MdiChildActivate | (Inherited from Form.)
MenuComplete | (Inherited from Form.)
MenuStart | (Inherited from Form.)
MinimumSizeChanged | (Inherited from Form.)
MouseCaptureChanged | (Inherited from Control.)
MouseClick | (Inherited from Control.)
MouseDoubleClick | (Inherited from Control.)
MouseDown | (Inherited from Control.)
MouseEnter | (Inherited from Control.)
MouseHover | (Inherited from Control.)
MouseLeave | (Inherited from Control.)
MouseMove | (Inherited from Control.)
MouseUp | (Inherited from Control.)
MouseWheel | (Inherited from Control.)
Move | (Inherited from Control.)
PaddingChanged | (Inherited from Control.)
Paint | (Inherited from Control.)
ParentChanged | (Inherited from Control.)
PreviewKeyDown | (Inherited from Control.)
QueryAccessibilityHelp | (Inherited from Control.)
QueryContinueDrag | (Inherited from Control.)
RegionChanged | (Inherited from Control.)
Resize | (Inherited from Control.)
ResizeBegin | (Inherited from Form.)
ResizeEnd | (Inherited from Form.)
RightToLeftChanged | (Inherited from Control.)
RightToLeftLayoutChanged | (Inherited from Form.)
Scroll | (Inherited from ScrollableControl.)
Shown | (Inherited from Form.)
SizeChanged | (Inherited from Control.)
StyleChanged | (Inherited from Control.)
SystemColorsChanged | (Inherited from Control.)
TabIndexChanged | (Inherited from Form.)
TabStopChanged | (Inherited from Form.)
TextChanged | (Inherited from Control.)
Validated | (Inherited from Control.)
Validating | (Inherited from Control.)
VisibleChanged | (Inherited from Control.)

See Also

AboutDialog Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptingLoginEventArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
AttemptingLoginEventArgs Class

BMXNET 4.0 Developer API

The LoginProcess provides the AttemptingLoginEvent to allow changes in workflow with this Cancelable event args class

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class AttemptingLoginEventArgs : CancelEventArgs
Public Class AttemptingLoginEventArgs _
    Inherits CancelEventArgs
public ref class AttemptingLoginEventArgs : public CancelEventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttemptingLoginEventArgs()()() |
Cancel | (Inherited from CancelEventArgs.)
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Handled | The receiver of the event can perform the login differently or not allow the login. If Handled is set the True the LoginProcess assumes the login was attempted.
HandledSucccessfully | Set HandledSucccessfully is the Handled logging was successful.
MemberwiseClone()()() | (Inherited from Object.)
Process | The LoginProcess can be modified (e.g. ConnectionSpec) after the user has OK'd the dialog but before the login attempt is made.
ToString()()() | (Inherited from Object.)

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
IndianHealthService.BMXNet.WinForm..::.AttemptingLoginEventArgs

See Also

IndianHealthService.BMXNet.WinForm Namespace


AttemptingLoginEventArgs Constructor

JavaScript

AttemptingLoginEventArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public AttemptingLoginEventArgs()
Public Sub New
public:
AttemptingLoginEventArgs()

See Also

AttemptingLoginEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptingLoginEventArgs Methods

JavaScript

AttemptingLoginEventArgs Methods

BMXNET 4.0 Developer API

The AttemptingLoginEventArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

AttemptingLoginEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptingLoginEventArgs Properties

JavaScript

AttemptingLoginEventArgs Properties

BMXNET 4.0 Developer API

The AttemptingLoginEventArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cancel | (Inherited from CancelEventArgs.)
Handled | The receiver of the event can perform the login differently or not allow the login. If Handled is set the True the LoginProcess assumes the login was attempted.
HandledSucccessfully | Set HandledSucccessfully is the Handled logging was successful.
Process | The LoginProcess can be modified (e.g. ConnectionSpec) after the user has OK'd the dialog but before the login attempt is made.

See Also

AttemptingLoginEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


Handled Property

JavaScript

AttemptingLoginEventArgs..::Handled Property

BMXNET 4.0 Developer API

The receiver of the event can perform the login differently or not allow the login. If Handled is set the True the LoginProcess assumes the login was attempted.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Handled { get; set; }
Public Property Handled As Boolean
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

AttemptingLoginEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


HandledSucccessfully Property

JavaScript

AttemptingLoginEventArgs..::HandledSucccessfully Property

BMXNET 4.0 Developer API

Set HandledSucccessfully is the Handled logging was successful.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool HandledSucccessfully { get; set; }
Public Property HandledSucccessfully As Boolean
public:
property bool HandledSucccessfully {
    bool get ();
    void set (bool value);
}

See Also

AttemptingLoginEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


Process Property

JavaScript

AttemptingLoginEventArgs..::Process Property

BMXNET 4.0 Developer API

The LoginProcess can be modified (e.g. ConnectionSpec) after the user has OK'd the dialog but before the login attempt is made.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LoginProcess Process { get; set; }
Public Property Process As LoginProcess
public:
property LoginProcess^ Process {
    LoginProcess^ get ();
    void set (LoginProcess^ value);
}

See Also

AttemptingLoginEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


LoginAttemptedEventArgs Class

JavaScript

| Members | See Also
.NET Framework Class Library
LoginAttemptedEventArgs Class

BMXNET 4.0 Developer API

The LoginProcess provides feedback after every LoginAttempt, even if the login attempt was performer using the AttemptingLoginEvent. If a custom dialog box or action can take place and Handled set to True, the LoginProcess will not display the standard dialog. The LoginProcess is available so examine or modify.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class LoginAttemptedEventArgs : CancelEventArgs
Public Class LoginAttemptedEventArgs _
    Inherits CancelEventArgs
public ref class LoginAttemptedEventArgs : public CancelEventArgs

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LoginAttemptedEventArgs()()() |
Cancel | (Inherited from CancelEventArgs.)
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Handled |
MemberwiseClone()()() | (Inherited from Object.)
Process |
ToString()()() | (Inherited from Object.)
WasSuccessful |

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.CancelEventArgs
IndianHealthService.BMXNet.WinForm..::.LoginAttemptedEventArgs

See Also

IndianHealthService.BMXNet.WinForm Namespace


LoginAttemptedEventArgs Constructor

JavaScript

LoginAttemptedEventArgs Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LoginAttemptedEventArgs()
Public Sub New
public:
LoginAttemptedEventArgs()

See Also

LoginAttemptedEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


LoginAttemptedEventArgs Methods

JavaScript

LoginAttemptedEventArgs Methods

BMXNET 4.0 Developer API

The LoginAttemptedEventArgs type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

LoginAttemptedEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


LoginAttemptedEventArgs Properties

JavaScript

LoginAttemptedEventArgs Properties

BMXNET 4.0 Developer API

The LoginAttemptedEventArgs type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Cancel | (Inherited from CancelEventArgs.)
Handled |
Process |
WasSuccessful |

See Also

LoginAttemptedEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


Handled Property

JavaScript

LoginAttemptedEventArgs..::Handled Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Handled { get; set; }
Public Property Handled As Boolean
public:
property bool Handled {
    bool get ();
    void set (bool value);
}

See Also

LoginAttemptedEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


Process Property

JavaScript

LoginAttemptedEventArgs..::Process Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LoginProcess Process { get; set; }
Public Property Process As LoginProcess
public:
property LoginProcess^ Process {
    LoginProcess^ get ();
    void set (LoginProcess^ value);
}

See Also

LoginAttemptedEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


WasSuccessful Property

JavaScript

LoginAttemptedEventArgs..::WasSuccessful Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool WasSuccessful { get; set; }
Public Property WasSuccessful As Boolean
public:
property bool WasSuccessful {
    bool get ();
    void set (bool value);
}

See Also

LoginAttemptedEventArgs Class
IndianHealthService.BMXNet.WinForm Namespace


LoginProcess Class

JavaScript

| Example | Members | See Also
.NET Framework Class Library
LoginProcess Class

BMXNET 4.0 Developer API

This class models the workflow of the LoginProcess. It correographs UI and non-UI login methods, login cancelling, management dialogs, and provides hooks (events) to customize the login workflow.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class LoginProcess
Public Class LoginProcess
public ref class LoginProcess

Members

All Members | Properties | Methods | Events
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttemptAccessVerifyLogin(RpmsConnectionSpec, String, String) | Attempt a headless non-interactive UI login. This would be useful for an ASP.NET or NT-service type application
AttemptingLogin | Triggered before every login attempt. See AttemptingLoginEventArgs for details .
AttemptUserInputLogin(String, Int32, Boolean, IWin32Window) | Attempt an interactive UI login. There are several useful arguments to control the process and appearance of the this process.
AttemptWindowsAuthLogin()()() | Using the current default connection spec, attempt a WindowsAuthentication Login and answer true if it was successful.
AttemptWindowsAuthLogin(RpmsConnectionSpec) | Attempt a WindowsAuthentication Login and answer true if it was successful.
AutoSetDivisionToLastLookup | If set to True, RPMS is checked and if there was a previously set division for the user it will be used, otherwise MustResolveDivision will be set to True and the division will need to be set for the user. The default is True
Cancel | During a LoginAttempted the LoginProcess can be Cancelled by setting Cancel to True.
ConnectionSpec | The active ConnectionSpec being used to login. With care, the property can be changed or the instance can be modified during the AttemptingLogin and LoginAttempted events with care.
Equals(Object) | (Inherited from Object.)
FailureException | If an exception occured during the last login attempt, FailureException will be set to it.
FailureMessage | A reasonable message to display to the user if the last login attempt failed.
Finalize()()() | (Inherited from Object.)
Framework |
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
HandleLoginAttemptedFailed()()() | Will trigger the LoginAttempted event
HasDefaultConnectionWithUseWindowsAuth | Answer True if there is a default managed connection that uses WindowsAuthenication
IsSwitchServerModeEnabled | If set to True, the Connection combo box on the Login screen with be dropped down when the dialog is displayed. This is useful for applications that have an option to change Connections. The default is False.
LoginAttempted | Triggered after every login attempt. See LoginAttemptedEventArgs for details .
LoginAttempts | The number of login attempts so far. This value can be modified during the AttemptingLogin and LoginAttempted events.
MaxAttempts | The number of login attempts before cancelling the LoginProcess. The default value is 3. This value can be modified during the AttemptingLogin and LoginAttempted events.
MemberwiseClone()()() | (Inherited from Object.)
MustResolveDivision | If the division for the user has not been determine after the LoginProcess, MustResolveDivision will be set to True. The default if False.
Succeeded()()() | If the application is managing the actual login, send Succeeded() to indicate success.
ToString()()() | (Inherited from Object.)
WasLoginAttempted | True if a login was attempted. False if the user is presented with a LoginDialog and "Cancel" is selected. The value is changed during every login attempt cycle.
WasSuccessful | True if the most recent login attempt was successful.

Examples

See the SDK for other examples.
Copy Code
             this.Framework = WinFramework.CreateWithNetworkBroker(true);
             this.Framework.LoadSettings(LocalPersistentStore.CreateIn(Environment.SpecialFolder.LocalApplicationData, EntryAssemblyInfo.AssemblyCompany + "/" + EntryAssemblyInfo.AssemblyProduct, false), "settings");
             this.Framework.LoadConnectionSpecs(LocalPersistentStore.CreateIn(Environment.SpecialFolder.LocalApplicationData, EntryAssemblyInfo.AssemblyCompany + "/" + EntryAssemblyInfo.AssemblyProduct, false), "connectiosn");
             LoginProcess login = this.Framework.CreateLoginProcess();

             //Attempt a non-UI WindowsAuth if and only if there is a default connection with WindowsAuth
             //Of course, an application can set its own policy of when to AttemptWindowsAuthLogin()

             if (login.HasDefaultConnectionWithUseWindowsAuth)
             {
                 login.AttemptWindowsAuthLogin();
             }

             //If not attempted yet, i.e. skipped the AttemptWindowsAuthLogin(), or was unsuccessul, try and UI login
             if (!login.WasLoginAttempted || !login.WasSuccessful)
             {
                 login.AttemptUserInputLogin(IndianHealthService.BMXNet.Util.EntryAssemblyInfo.AssemblyTitle+" Login", 3,!this.Framework.BootStrapSettings.Get("lockedit",false), this);
             }

             //If the login process was unable to login after the max tries (or fow other configuration reasons), exit the application
             if (!login.WasSuccessful)
             {
                 this.Close();
                 return;
             }

             // Making sure that the user's division is set.  Can use AttemptUserInputSetDivision() or the application can devise another solution
             if ((this.Framework.User.Division == null) && !this.Framework.AttemptUserInputSetDivision("Set Initial Division", this))
             {
                 this.Close();
                 return;
             }

             // Logged in with valid user and division
              this.RemoteSession = this.Framework.PrimaryRemoteSession;

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.WinForm..::.LoginProcess

See Also

IndianHealthService.BMXNet.WinForm Namespace


LoginProcess Methods

JavaScript

LoginProcess Methods

BMXNET 4.0 Developer API

The LoginProcess type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttemptAccessVerifyLogin(RpmsConnectionSpec, String, String) | Attempt a headless non-interactive UI login. This would be useful for an ASP.NET or NT-service type application
AttemptUserInputLogin(String, Int32, Boolean, IWin32Window) | Attempt an interactive UI login. There are several useful arguments to control the process and appearance of the this process.
AttemptWindowsAuthLogin()()() | Using the current default connection spec, attempt a WindowsAuthentication Login and answer true if it was successful.
AttemptWindowsAuthLogin(RpmsConnectionSpec) | Attempt a WindowsAuthentication Login and answer true if it was successful.
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
HandleLoginAttemptedFailed()()() | Will trigger the LoginAttempted event
MemberwiseClone()()() | (Inherited from Object.)
Succeeded()()() | If the application is managing the actual login, send Succeeded() to indicate success.
ToString()()() | (Inherited from Object.)

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptAccessVerifyLogin Method

JavaScript

LoginProcess..::AttemptAccessVerifyLogin Method

BMXNET 4.0 Developer API

Attempt a headless non-interactive UI login. This would be useful for an ASP.NET or NT-service type application

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AttemptAccessVerifyLogin(
    RpmsConnectionSpec aSpec,
    string anAccessCode,
    string aVerifyCode
)
Public Function AttemptAccessVerifyLogin ( _
    aSpec As RpmsConnectionSpec, _
    anAccessCode As String, _
    aVerifyCode As String _
) As Boolean
public:
bool AttemptAccessVerifyLogin(
    RpmsConnectionSpec^ aSpec,
    String^ anAccessCode,
    String^ aVerifyCode
)

Parameters

aSpec
RpmsConnectionSpec
The RpmsConnectionSpec to use during the login process
anAccessCode
String
The clear text access code
aVerifyCode
String
The clear text verify code

Return Value

True if the login was successful

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptUserInputLogin Method

JavaScript

LoginProcess..::AttemptUserInputLogin Method

BMXNET 4.0 Developer API

Attempt an interactive UI login. There are several useful arguments to control the process and appearance of the this process.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AttemptUserInputLogin(
    string aDialogTitle,
    int maxAttempts,
    bool enableConnectionManagement,
    IWin32Window aUiOwnerForPositioningDialog
)
Public Function AttemptUserInputLogin ( _
    aDialogTitle As String, _
    maxAttempts As Integer, _
    enableConnectionManagement As Boolean, _
    aUiOwnerForPositioningDialog As IWin32Window _
) As Boolean
public:
bool AttemptUserInputLogin(
    String^ aDialogTitle,
    int maxAttempts,
    bool enableConnectionManagement,
    IWin32Window^ aUiOwnerForPositioningDialog
)

Parameters

aDialogTitle
String
The title of the login. Customize to be something like "MyApplication Login"
maxAttempts
Int32
The number of attempts before cancelling
enableConnectionManagement
Boolean
If false, the user will not be able to change the connections. This is useful for lockdown situations
aUiOwnerForPositioningDialog
IWin32Window
Provide your main application as the window owner so the LoginDialog box is correctly managed.

Return Value

True if login was successful

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptWindowsAuthLogin Method

JavaScript

LoginProcess..::AttemptWindowsAuthLogin Method

BMXNET 4.0 Developer API

Overload List

Name | Description
AttemptWindowsAuthLogin()()() | Using the current default connection spec, attempt a WindowsAuthentication Login and answer true if it was successful.
AttemptWindowsAuthLogin(RpmsConnectionSpec) | Attempt a WindowsAuthentication Login and answer true if it was successful.

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptWindowsAuthLogin Method

JavaScript

LoginProcess..::AttemptWindowsAuthLogin Method

BMXNET 4.0 Developer API

Using the current default connection spec, attempt a WindowsAuthentication Login and answer true if it was successful.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AttemptWindowsAuthLogin()
Public Function AttemptWindowsAuthLogin As Boolean
public:
bool AttemptWindowsAuthLogin()

Return Value

True if login was successful

Remarks

Most common approach when using the DefaultConnection feature the RpmsConnection spec class.

See Also

LoginProcess Class
AttemptWindowsAuthLogin Overload
IndianHealthService.BMXNet.WinForm Namespace


AttemptWindowsAuthLogin Method (RpmsConnectionSpec)

JavaScript

LoginProcess..::AttemptWindowsAuthLogin Method (RpmsConnectionSpec)

BMXNET 4.0 Developer API

Attempt a WindowsAuthentication Login and answer true if it was successful.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AttemptWindowsAuthLogin(
    RpmsConnectionSpec aConnectionSpec
)
Public Function AttemptWindowsAuthLogin ( _
    aConnectionSpec As RpmsConnectionSpec _
) As Boolean
public:
bool AttemptWindowsAuthLogin(
    RpmsConnectionSpec^ aConnectionSpec
)

Parameters

aConnectionSpec
RpmsConnectionSpec

Return Value

True if login was successful

See Also

LoginProcess Class
AttemptWindowsAuthLogin Overload
IndianHealthService.BMXNet.WinForm Namespace


HandleLoginAttemptedFailed Method

JavaScript

LoginProcess..::HandleLoginAttemptedFailed Method

BMXNET 4.0 Developer API

Will trigger the LoginAttempted event

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool HandleLoginAttemptedFailed()
Public Function HandleLoginAttemptedFailed As Boolean
public:
bool HandleLoginAttemptedFailed()

Return Value

Answer true if the LoginProcess has been Canceled or handled

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


Succeeded Method

JavaScript

LoginProcess..::Succeeded Method

BMXNET 4.0 Developer API

If the application is managing the actual login, send Succeeded() to indicate success.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Succeeded()
Public Function Succeeded As Boolean
public:
bool Succeeded()

Return Value

True if successful

Remarks

Do not set WasSuccessful to true.

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


LoginProcess Properties

JavaScript

LoginProcess Properties

BMXNET 4.0 Developer API

The LoginProcess type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AutoSetDivisionToLastLookup | If set to True, RPMS is checked and if there was a previously set division for the user it will be used, otherwise MustResolveDivision will be set to True and the division will need to be set for the user. The default is True
Cancel | During a LoginAttempted the LoginProcess can be Cancelled by setting Cancel to True.
ConnectionSpec | The active ConnectionSpec being used to login. With care, the property can be changed or the instance can be modified during the AttemptingLogin and LoginAttempted events with care.
FailureException | If an exception occured during the last login attempt, FailureException will be set to it.
FailureMessage | A reasonable message to display to the user if the last login attempt failed.
Framework |
HasDefaultConnectionWithUseWindowsAuth | Answer True if there is a default managed connection that uses WindowsAuthenication
IsSwitchServerModeEnabled | If set to True, the Connection combo box on the Login screen with be dropped down when the dialog is displayed. This is useful for applications that have an option to change Connections. The default is False.
LoginAttempts | The number of login attempts so far. This value can be modified during the AttemptingLogin and LoginAttempted events.
MaxAttempts | The number of login attempts before cancelling the LoginProcess. The default value is 3. This value can be modified during the AttemptingLogin and LoginAttempted events.
MustResolveDivision | If the division for the user has not been determine after the LoginProcess, MustResolveDivision will be set to True. The default if False.
WasLoginAttempted | True if a login was attempted. False if the user is presented with a LoginDialog and "Cancel" is selected. The value is changed during every login attempt cycle.
WasSuccessful | True if the most recent login attempt was successful.

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


AutoSetDivisionToLastLookup Property

JavaScript

LoginProcess..::AutoSetDivisionToLastLookup Property

BMXNET 4.0 Developer API

If set to True, RPMS is checked and if there was a previously set division for the user it will be used, otherwise MustResolveDivision will be set to True and the division will need to be set for the user. The default is True

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AutoSetDivisionToLastLookup { get; set; }
Public Property AutoSetDivisionToLastLookup As Boolean
public:
property bool AutoSetDivisionToLastLookup {
    bool get ();
    void set (bool value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


Cancel Property

JavaScript

LoginProcess..::Cancel Property

BMXNET 4.0 Developer API

During a LoginAttempted the LoginProcess can be Cancelled by setting Cancel to True.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Cancel { get; set; }
Public Property Cancel As Boolean
public:
property bool Cancel {
    bool get ();
    void set (bool value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


ConnectionSpec Property

JavaScript

LoginProcess..::ConnectionSpec Property

BMXNET 4.0 Developer API

The active ConnectionSpec being used to login. With care, the property can be changed or the instance can be modified during the AttemptingLogin and LoginAttempted events with care.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RpmsConnectionSpec ConnectionSpec { get; set; }
Public Property ConnectionSpec As RpmsConnectionSpec
public:
property RpmsConnectionSpec^ ConnectionSpec {
    RpmsConnectionSpec^ get ();
    void set (RpmsConnectionSpec^ value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


FailureException Property

JavaScript

LoginProcess..::FailureException Property

BMXNET 4.0 Developer API

If an exception occured during the last login attempt, FailureException will be set to it.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Exception FailureException { get; set; }
Public Property FailureException As Exception
public:
property Exception^ FailureException {
    Exception^ get ();
    void set (Exception^ value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


FailureMessage Property

JavaScript

LoginProcess..::FailureMessage Property

BMXNET 4.0 Developer API

A reasonable message to display to the user if the last login attempt failed.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string FailureMessage { get; set; }
Public Property FailureMessage As String
public:
property String^ FailureMessage {
    String^ get ();
    void set (String^ value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


Framework Property

JavaScript

LoginProcess..::Framework Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
protected internal WinFramework Framework { get; set; }
Protected Friend Property Framework As WinFramework
protected public:
property WinFramework^ Framework {
    WinFramework^ get ();
    void set (WinFramework^ value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


HasDefaultConnectionWithUseWindowsAuth Property

JavaScript

LoginProcess..::HasDefaultConnectionWithUseWindowsAuth Property

BMXNET 4.0 Developer API

Answer True if there is a default managed connection that uses WindowsAuthenication

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool HasDefaultConnectionWithUseWindowsAuth { get; }
Public ReadOnly Property HasDefaultConnectionWithUseWindowsAuth As Boolean
public:
property bool HasDefaultConnectionWithUseWindowsAuth {
    bool get ();
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


IsSwitchServerModeEnabled Property

JavaScript

LoginProcess..::IsSwitchServerModeEnabled Property

BMXNET 4.0 Developer API

If set to True, the Connection combo box on the Login screen with be dropped down when the dialog is displayed. This is useful for applications that have an option to change Connections. The default is False.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsSwitchServerModeEnabled { get; set; }
Public Property IsSwitchServerModeEnabled As Boolean
public:
property bool IsSwitchServerModeEnabled {
    bool get ();
    void set (bool value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


LoginAttempts Property

JavaScript

LoginProcess..::LoginAttempts Property

BMXNET 4.0 Developer API

The number of login attempts so far. This value can be modified during the AttemptingLogin and LoginAttempted events.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public int LoginAttempts { get; set; }
Public Property LoginAttempts As Integer
public:
property int LoginAttempts {
    int get ();
    void set (int value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


MaxAttempts Property

JavaScript

LoginProcess..::MaxAttempts Property

BMXNET 4.0 Developer API

The number of login attempts before cancelling the LoginProcess. The default value is 3. This value can be modified during the AttemptingLogin and LoginAttempted events.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public int MaxAttempts { get; set; }
Public Property MaxAttempts As Integer
public:
property int MaxAttempts {
    int get ();
    void set (int value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


MustResolveDivision Property

JavaScript

LoginProcess..::MustResolveDivision Property

BMXNET 4.0 Developer API

If the division for the user has not been determine after the LoginProcess, MustResolveDivision will be set to True. The default if False.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool MustResolveDivision { get; set; }
Public Property MustResolveDivision As Boolean
public:
property bool MustResolveDivision {
    bool get ();
    void set (bool value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


WasLoginAttempted Property

JavaScript

LoginProcess..::WasLoginAttempted Property

BMXNET 4.0 Developer API

True if a login was attempted. False if the user is presented with a LoginDialog and "Cancel" is selected. The value is changed during every login attempt cycle.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool WasLoginAttempted { get; set; }
Public Property WasLoginAttempted As Boolean
public:
property bool WasLoginAttempted {
    bool get ();
    void set (bool value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


WasSuccessful Property

JavaScript

LoginProcess..::WasSuccessful Property

BMXNET 4.0 Developer API

True if the most recent login attempt was successful.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool WasSuccessful { get; set; }
Public Property WasSuccessful As Boolean
public:
property bool WasSuccessful {
    bool get ();
    void set (bool value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


LoginProcess Events

JavaScript

LoginProcess Events

BMXNET 4.0 Developer API

The LoginProcess type exposes the following events.

Events

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttemptingLogin | Triggered before every login attempt. See AttemptingLoginEventArgs for details .
LoginAttempted | Triggered after every login attempt. See LoginAttemptedEventArgs for details .

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptingLogin Event

JavaScript

LoginProcess..::AttemptingLogin Event

BMXNET 4.0 Developer API

Triggered before every login attempt. See AttemptingLoginEventArgs for details .

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public event EventHandler<AttemptingLoginEventArgs> AttemptingLogin
Public Event AttemptingLogin As EventHandler(Of AttemptingLoginEventArgs)
public:
 event EventHandler<AttemptingLoginEventArgs^>^ AttemptingLogin {
    void add (EventHandler<AttemptingLoginEventArgs^>^ value);
    void remove (EventHandler<AttemptingLoginEventArgs^>^ value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


LoginAttempted Event

JavaScript

LoginProcess..::LoginAttempted Event

BMXNET 4.0 Developer API

Triggered after every login attempt. See LoginAttemptedEventArgs for details .

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public event EventHandler<LoginAttemptedEventArgs> LoginAttempted
Public Event LoginAttempted As EventHandler(Of LoginAttemptedEventArgs)
public:
 event EventHandler<LoginAttemptedEventArgs^>^ LoginAttempted {
    void add (EventHandler<LoginAttemptedEventArgs^>^ value);
    void remove (EventHandler<LoginAttemptedEventArgs^>^ value);
}

See Also

LoginProcess Class
IndianHealthService.BMXNet.WinForm Namespace


WinFramework Class

JavaScript

| Members | See Also
.NET Framework Class Library
WinFramework Class

BMXNET 4.0 Developer API

Instance manages the context/access to RPMS - Configuration information - Login entry points - External changes to patient context

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class WinFramework : Log
Public Class WinFramework _
    Implements Log
public ref class WinFramework : Log

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
WinFramework()()() |
AttemptUserInputSetDivision(String, IWin32Window) | Answer true if changed, false if the same
BootStrapSettings |
ChangePatient(Patient) |
ChangePatient(Patient, Boolean) |
ChangeVisit(Visit) |
ChangeVisit(Visit, Boolean) |
Close()()() |
ConnectionSettings |
Context |
CreateLoginProcess()()() |
CreateWithNetworkBroker()()() |
CreateWithNetworkBroker(Boolean) |
CreateWithNetworkBroker(Boolean, Log) |
DivisionTable(User) |
DivisionTable(String) |
EasyLogin(IWin32Window, array<String>[]()[]) |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
FindPatient(String) |
FindPatients(String, Int32) |
FindPatientsAsTable(String, Int32) |
GetAssemblyIdentityFromEvidence(Evidence) |
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
GetTypeFromEvidence(Evidence, Type) |
HardCodedSettings |
ImHereServer()()() | Ping the server, will reset read-timeout
IsLogging |
LoadConnectionSpecs(PersistentStore, array<String>[]()[]) |
LoadConnectionSpecsAndMergeWithExistingBMXConfiguration(Assembly, PersistentStore, array<String>[]()[]) |
LoadSettings(PersistentStore, array<String>[]()[]) |
LocalSession |
Log..::.Log(String, String, array<String>[]()[]) |
Log..::.Log(String, String, Exception, array<String>[]()[]) |
Log | Logger to be used by all BMX objects.
Login |
MemberwiseClone()()() | (Inherited from Object.)
OpenOn(RemoteSession) |
PrimaryRemoteSession |
RemoteSessionPool |
RetrievePriorBMXConfiguration(Assembly) |
SetDivision(Division) |
SetDivision(String) |
Settengs |
ToString()()() | (Inherited from Object.)
TriggerLocalEvent(String, String) |
User |
Visits(Patient, Int32) |
Visits(String, Int32) |
VisitsAsTable(Patient, Int32) |
VisitsAsTable(String, Int32) |

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.WinForm..::.WinFramework

See Also

IndianHealthService.BMXNet.WinForm Namespace


WinFramework Constructor

JavaScript

WinFramework Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public WinFramework()
Public Sub New
public:
WinFramework()

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


WinFramework Methods

JavaScript

WinFramework Methods

BMXNET 4.0 Developer API

The WinFramework type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttemptUserInputSetDivision(String, IWin32Window) | Answer true if changed, false if the same
ChangePatient(Patient) |
ChangePatient(Patient, Boolean) |
ChangeVisit(Visit) |
ChangeVisit(Visit, Boolean) |
Close()()() |
CreateLoginProcess()()() |
CreateWithNetworkBroker()()() |
CreateWithNetworkBroker(Boolean) |
CreateWithNetworkBroker(Boolean, Log) |
DivisionTable(User) |
DivisionTable(String) |
EasyLogin(IWin32Window, array<String>[]()[]) |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
FindPatient(String) |
FindPatients(String, Int32) |
FindPatientsAsTable(String, Int32) |
GetAssemblyIdentityFromEvidence(Evidence) |
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
GetTypeFromEvidence(Evidence, Type) |
ImHereServer()()() | Ping the server, will reset read-timeout
LoadConnectionSpecs(PersistentStore, array<String>[]()[]) |
LoadConnectionSpecsAndMergeWithExistingBMXConfiguration(Assembly, PersistentStore, array<String>[]()[]) |
LoadSettings(PersistentStore, array<String>[]()[]) |
Log..::.Log(String, String, array<String>[]()[]) |
Log..::.Log(String, String, Exception, array<String>[]()[]) |
MemberwiseClone()()() | (Inherited from Object.)
OpenOn(RemoteSession) |
RetrievePriorBMXConfiguration(Assembly) |
SetDivision(Division) |
SetDivision(String) |
ToString()()() | (Inherited from Object.)
TriggerLocalEvent(String, String) |
Visits(Patient, Int32) |
Visits(String, Int32) |
VisitsAsTable(Patient, Int32) |
VisitsAsTable(String, Int32) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


AttemptUserInputSetDivision Method

JavaScript

WinFramework..::AttemptUserInputSetDivision Method

BMXNET 4.0 Developer API

Answer true if changed, false if the same

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AttemptUserInputSetDivision(
    string aDialogTitle,
    IWin32Window aUiOwnerForPositioningDialog
)
Public Function AttemptUserInputSetDivision ( _
    aDialogTitle As String, _
    aUiOwnerForPositioningDialog As IWin32Window _
) As Boolean
public:
bool AttemptUserInputSetDivision(
    String^ aDialogTitle,
    IWin32Window^ aUiOwnerForPositioningDialog
)

Parameters

aDialogTitle
String
aUiOwnerForPositioningDialog
IWin32Window

Return Value

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


ChangePatient Method

JavaScript

WinFramework..::ChangePatient Method

BMXNET 4.0 Developer API

Overload List

Name | Description
ChangePatient(Patient) |
ChangePatient(Patient, Boolean) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


ChangePatient Method (Patient)

JavaScript

WinFramework..::ChangePatient Method (Patient)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool ChangePatient(
    Patient aPatient
)
Public Function ChangePatient ( _
    aPatient As Patient _
) As Boolean
public:
bool ChangePatient(
    Patient^ aPatient
)

Parameters

aPatient
Patient

See Also

WinFramework Class
ChangePatient Overload
IndianHealthService.BMXNet.WinForm Namespace


ChangePatient Method (Patient, Boolean)

JavaScript

WinFramework..::ChangePatient Method (Patient, Boolean)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool ChangePatient(
    Patient aPatient,
    bool force
)
Public Function ChangePatient ( _
    aPatient As Patient, _
    force As Boolean _
) As Boolean
public:
bool ChangePatient(
    Patient^ aPatient,
    bool force
)

Parameters

aPatient
Patient
force
Boolean

See Also

WinFramework Class
ChangePatient Overload
IndianHealthService.BMXNet.WinForm Namespace


ChangeVisit Method

JavaScript

WinFramework..::ChangeVisit Method

BMXNET 4.0 Developer API

Overload List

Name | Description
ChangeVisit(Visit) |
ChangeVisit(Visit, Boolean) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


ChangeVisit Method (Visit)

JavaScript

WinFramework..::ChangeVisit Method (Visit)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool ChangeVisit(
    Visit aVisit
)
Public Function ChangeVisit ( _
    aVisit As Visit _
) As Boolean
public:
bool ChangeVisit(
    Visit^ aVisit
)

Parameters

aVisit
Visit

See Also

WinFramework Class
ChangeVisit Overload
IndianHealthService.BMXNet.WinForm Namespace


ChangeVisit Method (Visit, Boolean)

JavaScript

WinFramework..::ChangeVisit Method (Visit, Boolean)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool ChangeVisit(
    Visit aVisit,
    bool force
)
Public Function ChangeVisit ( _
    aVisit As Visit, _
    force As Boolean _
) As Boolean
public:
bool ChangeVisit(
    Visit^ aVisit,
    bool force
)

Parameters

aVisit
Visit
force
Boolean

See Also

WinFramework Class
ChangeVisit Overload
IndianHealthService.BMXNet.WinForm Namespace


Close Method

JavaScript

WinFramework..::Close Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Close()
Public Sub Close
public:
void Close()

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


CreateLoginProcess Method

JavaScript

WinFramework..::CreateLoginProcess Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LoginProcess CreateLoginProcess()
Public Function CreateLoginProcess As LoginProcess
public:
LoginProcess^ CreateLoginProcess()

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


CreateWithNetworkBroker Method

JavaScript

WinFramework..::CreateWithNetworkBroker Method

BMXNET 4.0 Developer API

Overload List

Name | Description
CreateWithNetworkBroker()()() |
CreateWithNetworkBroker(Boolean) |
CreateWithNetworkBroker(Boolean, Log) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


CreateWithNetworkBroker Method

JavaScript

WinFramework..::CreateWithNetworkBroker Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static WinFramework CreateWithNetworkBroker()
Public Shared Function CreateWithNetworkBroker As WinFramework
public:
static WinFramework^ CreateWithNetworkBroker()

See Also

WinFramework Class
CreateWithNetworkBroker Overload
IndianHealthService.BMXNet.WinForm Namespace


CreateWithNetworkBroker Method (Boolean)

JavaScript

WinFramework..::CreateWithNetworkBroker Method (Boolean)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static WinFramework CreateWithNetworkBroker(
    bool parseCommandLineArguments
)
Public Shared Function CreateWithNetworkBroker ( _
    parseCommandLineArguments As Boolean _
) As WinFramework
public:
static WinFramework^ CreateWithNetworkBroker(
    bool parseCommandLineArguments
)

Parameters

parseCommandLineArguments
Boolean

See Also

WinFramework Class
CreateWithNetworkBroker Overload
IndianHealthService.BMXNet.WinForm Namespace


CreateWithNetworkBroker Method (Boolean, Log)

JavaScript

WinFramework..::CreateWithNetworkBroker Method (Boolean, Log)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static WinFramework CreateWithNetworkBroker(
    bool parseCommandLineArguments,
    Log aLogger
)
Public Shared Function CreateWithNetworkBroker ( _
    parseCommandLineArguments As Boolean, _
    aLogger As Log _
) As WinFramework
public:
static WinFramework^ CreateWithNetworkBroker(
    bool parseCommandLineArguments,
    Log^ aLogger
)

Parameters

parseCommandLineArguments
Boolean
aLogger
Log

See Also

WinFramework Class
CreateWithNetworkBroker Overload
IndianHealthService.BMXNet.WinForm Namespace


DivisionTable Method

JavaScript

WinFramework..::DivisionTable Method

BMXNET 4.0 Developer API

Overload List

Name | Description
DivisionTable(User) |
DivisionTable(String) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


DivisionTable Method (User)

JavaScript

WinFramework..::DivisionTable Method (User)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable DivisionTable(
    User aUser
)
Public Function DivisionTable ( _
    aUser As User _
) As DataTable
public:
DataTable^ DivisionTable(
    User^ aUser
)

Parameters

aUser
User

See Also

WinFramework Class
DivisionTable Overload
IndianHealthService.BMXNet.WinForm Namespace


DivisionTable Method (String)

JavaScript

WinFramework..::DivisionTable Method (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable DivisionTable(
    string anIen
)
Public Function DivisionTable ( _
    anIen As String _
) As DataTable
public:
DataTable^ DivisionTable(
    String^ anIen
)

Parameters

anIen
String

See Also

WinFramework Class
DivisionTable Overload
IndianHealthService.BMXNet.WinForm Namespace


EasyLogin Method

JavaScript

WinFramework..::EasyLogin Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static WinFramework EasyLogin(
    IWin32Window aUiOwnerForPositioningDialog,
    params string[] configKeys
)
Public Shared Function EasyLogin ( _
    aUiOwnerForPositioningDialog As IWin32Window, _
    ParamArray configKeys As String() _
) As WinFramework
public:
static WinFramework^ EasyLogin(
    IWin32Window^ aUiOwnerForPositioningDialog,
    ... array<String^>^ configKeys
)

Parameters

aUiOwnerForPositioningDialog
IWin32Window
configKeys
array< String >[]()[]

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


FindPatient Method

JavaScript

WinFramework..::FindPatient Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Patient FindPatient(
    string aSearchString
)
Public Function FindPatient ( _
    aSearchString As String _
) As Patient
public:
Patient^ FindPatient(
    String^ aSearchString
)

Parameters

aSearchString
String

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


FindPatients Method

JavaScript

WinFramework..::FindPatients Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public List<Patient> FindPatients(
    string aSearchString,
    int max
)
Public Function FindPatients ( _
    aSearchString As String, _
    max As Integer _
) As List(Of Patient)
public:
List<Patient^>^ FindPatients(
    String^ aSearchString,
    int max
)

Parameters

aSearchString
String
max
Int32

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


FindPatientsAsTable Method

JavaScript

WinFramework..::FindPatientsAsTable Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable FindPatientsAsTable(
    string aSearchString,
    int max
)
Public Function FindPatientsAsTable ( _
    aSearchString As String, _
    max As Integer _
) As DataTable
public:
DataTable^ FindPatientsAsTable(
    String^ aSearchString,
    int max
)

Parameters

aSearchString
String
max
Int32

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


GetAssemblyIdentityFromEvidence Method

JavaScript

WinFramework..::GetAssemblyIdentityFromEvidence Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
protected Object GetAssemblyIdentityFromEvidence(
    Evidence evidence
)
Protected Function GetAssemblyIdentityFromEvidence ( _
    evidence As Evidence _
) As Object
protected:
Object^ GetAssemblyIdentityFromEvidence(
    Evidence^ evidence
)

Parameters

evidence
Evidence

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


GetTypeFromEvidence Method

JavaScript

WinFramework..::GetTypeFromEvidence Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
protected Object GetTypeFromEvidence(
    Evidence evidence,
    Type aType
)
Protected Function GetTypeFromEvidence ( _
    evidence As Evidence, _
    aType As Type _
) As Object
protected:
Object^ GetTypeFromEvidence(
    Evidence^ evidence,
    Type^ aType
)

Parameters

evidence
Evidence
aType
Type

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


ImHereServer Method

JavaScript

WinFramework..::ImHereServer Method

BMXNET 4.0 Developer API

Ping the server, will reset read-timeout

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public double ImHereServer()
Public Function ImHereServer As Double
public:
double ImHereServer()

Return Value

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


LoadConnectionSpecs Method

JavaScript

WinFramework..::LoadConnectionSpecs Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void LoadConnectionSpecs(
    PersistentStore aPersistentStore,
    params string[] keys
)
Public Sub LoadConnectionSpecs ( _
    aPersistentStore As PersistentStore, _
    ParamArray keys As String() _
)
public:
void LoadConnectionSpecs(
    PersistentStore^ aPersistentStore,
    ... array<String^>^ keys
)

Parameters

aPersistentStore
PersistentStore
keys
array< String >[]()[]

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


LoadConnectionSpecsAndMergeWithExistingBMXConfiguration Method

JavaScript

WinFramework..::LoadConnectionSpecsAndMergeWithExistingBMXConfiguration Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void LoadConnectionSpecsAndMergeWithExistingBMXConfiguration(
    Assembly priorAssemblyReadFromFile,
    PersistentStore aPersistentStore,
    params string[] keys
)
Public Sub LoadConnectionSpecsAndMergeWithExistingBMXConfiguration ( _
    priorAssemblyReadFromFile As Assembly, _
    aPersistentStore As PersistentStore, _
    ParamArray keys As String() _
)
public:
void LoadConnectionSpecsAndMergeWithExistingBMXConfiguration(
    Assembly^ priorAssemblyReadFromFile,
    PersistentStore^ aPersistentStore,
    ... array<String^>^ keys
)

Parameters

priorAssemblyReadFromFile
Assembly
aPersistentStore
PersistentStore
keys
array< String >[]()[]

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


LoadSettings Method

JavaScript

WinFramework..::LoadSettings Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void LoadSettings(
    PersistentStore aPersistentStore,
    params string[] keys
)
Public Sub LoadSettings ( _
    aPersistentStore As PersistentStore, _
    ParamArray keys As String() _
)
public:
void LoadSettings(
    PersistentStore^ aPersistentStore,
    ... array<String^>^ keys
)

Parameters

aPersistentStore
PersistentStore
keys
array< String >[]()[]

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Log Method

JavaScript

WinFramework..::Log Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Log..::.Log(String, String, array<String>[]()[]) |
Log..::.Log(String, String, Exception, array<String>[]()[]) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Log Method (String, String, String[])

JavaScript

WinFramework..::Log Method (String, String, array<String>[]()[])

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
void Log.Log(
    string aClass,
    string aCategory,
    params string[] lines
)
Private Sub Log ( _
    aClass As String, _
    aCategory As String, _
    ParamArray lines As String() _
) Implements Log.Log
private:
virtual void Log(
    String^ aClass,
    String^ aCategory,
    ... array<String^>^ lines
) sealed = Log::Log

Parameters

aClass
String
aCategory
String
lines
array< String >[]()[]

Implements

Log..::.Log(String, String, array<String>[]()[])

See Also

WinFramework Class
WinFramework Overload
IndianHealthService.BMXNet.WinForm Namespace


Log Method (String, String, Exception, String[])

JavaScript

WinFramework..::Log Method (String, String, Exception, array<String>[]()[])

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
void Log.Log(
    string aClass,
    string aCategory,
    Exception anException,
    params string[] lines
)
Private Sub Log ( _
    aClass As String, _
    aCategory As String, _
    anException As Exception, _
    ParamArray lines As String() _
) Implements Log.Log
private:
virtual void Log(
    String^ aClass,
    String^ aCategory,
    Exception^ anException,
    ... array<String^>^ lines
) sealed = Log::Log

Parameters

aClass
String
aCategory
String
anException
Exception
lines
array< String >[]()[]

Implements

Log..::.Log(String, String, Exception, array<String>[]()[])

See Also

WinFramework Class
WinFramework Overload
IndianHealthService.BMXNet.WinForm Namespace


OpenOn Method

JavaScript

WinFramework..::OpenOn Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static WinFramework OpenOn(
    RemoteSession aSession
)
Public Shared Function OpenOn ( _
    aSession As RemoteSession _
) As WinFramework
public:
static WinFramework^ OpenOn(
    RemoteSession^ aSession
)

Parameters

aSession
RemoteSession

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


RetrievePriorBMXConfiguration Method

JavaScript

WinFramework..::RetrievePriorBMXConfiguration Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
protected RpmsConnectionSpec RetrievePriorBMXConfiguration(
    Assembly priorAssemblyReadFromFile
)
Protected Function RetrievePriorBMXConfiguration ( _
    priorAssemblyReadFromFile As Assembly _
) As RpmsConnectionSpec
protected:
RpmsConnectionSpec^ RetrievePriorBMXConfiguration(
    Assembly^ priorAssemblyReadFromFile
)

Parameters

priorAssemblyReadFromFile
Assembly

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


SetDivision Method

JavaScript

WinFramework..::SetDivision Method

BMXNET 4.0 Developer API

Overload List

Name | Description
SetDivision(Division) |
SetDivision(String) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


SetDivision Method (Division)

JavaScript

WinFramework..::SetDivision Method (Division)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool SetDivision(
    Division aDivision
)
Public Function SetDivision ( _
    aDivision As Division _
) As Boolean
public:
bool SetDivision(
    Division^ aDivision
)

Parameters

aDivision
Division

See Also

WinFramework Class
SetDivision Overload
IndianHealthService.BMXNet.WinForm Namespace


SetDivision Method (String)

JavaScript

WinFramework..::SetDivision Method (String)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool SetDivision(
    string aDivisionIen
)
Public Function SetDivision ( _
    aDivisionIen As String _
) As Boolean
public:
bool SetDivision(
    String^ aDivisionIen
)

Parameters

aDivisionIen
String

See Also

WinFramework Class
SetDivision Overload
IndianHealthService.BMXNet.WinForm Namespace


TriggerLocalEvent Method

JavaScript

WinFramework..::TriggerLocalEvent Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void TriggerLocalEvent(
    string anEvent,
    string eventInfo
)
Public Sub TriggerLocalEvent ( _
    anEvent As String, _
    eventInfo As String _
)
public:
void TriggerLocalEvent(
    String^ anEvent,
    String^ eventInfo
)

Parameters

anEvent
String
eventInfo
String

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Visits Method

JavaScript

WinFramework..::Visits Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Visits(Patient, Int32) |
Visits(String, Int32) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Visits Method (Patient, Int32)

JavaScript

WinFramework..::Visits Method (Patient, Int32)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public List<Visit> Visits(
    Patient aPatient,
    int aMax
)
Public Function Visits ( _
    aPatient As Patient, _
    aMax As Integer _
) As List(Of Visit)
public:
List<Visit^>^ Visits(
    Patient^ aPatient,
    int aMax
)

Parameters

aPatient
Patient
aMax
Int32

See Also

WinFramework Class
Visits Overload
IndianHealthService.BMXNet.WinForm Namespace


Visits Method (String, Int32)

JavaScript

WinFramework..::Visits Method (String, Int32)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public List<Visit> Visits(
    string aDFN,
    int aMax
)
Public Function Visits ( _
    aDFN As String, _
    aMax As Integer _
) As List(Of Visit)
public:
List<Visit^>^ Visits(
    String^ aDFN,
    int aMax
)

Parameters

aDFN
String
aMax
Int32

See Also

WinFramework Class
Visits Overload
IndianHealthService.BMXNet.WinForm Namespace


VisitsAsTable Method

JavaScript

WinFramework..::VisitsAsTable Method

BMXNET 4.0 Developer API

Overload List

Name | Description
VisitsAsTable(Patient, Int32) |
VisitsAsTable(String, Int32) |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


VisitsAsTable Method (Patient, Int32)

JavaScript

WinFramework..::VisitsAsTable Method (Patient, Int32)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable VisitsAsTable(
    Patient aPatient,
    int aMax
)
Public Function VisitsAsTable ( _
    aPatient As Patient, _
    aMax As Integer _
) As DataTable
public:
DataTable^ VisitsAsTable(
    Patient^ aPatient,
    int aMax
)

Parameters

aPatient
Patient
aMax
Int32

See Also

WinFramework Class
VisitsAsTable Overload
IndianHealthService.BMXNet.WinForm Namespace


VisitsAsTable Method (String, Int32)

JavaScript

WinFramework..::VisitsAsTable Method (String, Int32)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public DataTable VisitsAsTable(
    string aDFN,
    int aMax
)
Public Function VisitsAsTable ( _
    aDFN As String, _
    aMax As Integer _
) As DataTable
public:
DataTable^ VisitsAsTable(
    String^ aDFN,
    int aMax
)

Parameters

aDFN
String
aMax
Int32

See Also

WinFramework Class
VisitsAsTable Overload
IndianHealthService.BMXNet.WinForm Namespace


WinFramework Properties

JavaScript

WinFramework Properties

BMXNET 4.0 Developer API

The WinFramework type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BootStrapSettings |
ConnectionSettings |
Context |
HardCodedSettings |
IsLogging |
LocalSession |
Log | Logger to be used by all BMX objects.
Login |
PrimaryRemoteSession |
RemoteSessionPool |
Settengs |
User |

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


BootStrapSettings Property

JavaScript

WinFramework..::BootStrapSettings Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Settings BootStrapSettings { get; set; }
Public Property BootStrapSettings As Settings
public:
property Settings^ BootStrapSettings {
    Settings^ get ();
    void set (Settings^ value);
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


ConnectionSettings Property

JavaScript

WinFramework..::ConnectionSettings Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RpmsConnectionSettings ConnectionSettings { get; set; }
Public Property ConnectionSettings As RpmsConnectionSettings
public:
property RpmsConnectionSettings^ ConnectionSettings {
    RpmsConnectionSettings^ get ();
    void set (RpmsConnectionSettings^ value);
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Context Property

JavaScript

WinFramework..::Context Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Context Context { get; }
Public ReadOnly Property Context As Context
public:
property Context^ Context {
    Context^ get ();
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


HardCodedSettings Property

JavaScript

WinFramework..::HardCodedSettings Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Settings HardCodedSettings { get; set; }
Public Property HardCodedSettings As Settings
public:
property Settings^ HardCodedSettings {
    Settings^ get ();
    void set (Settings^ value);
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


IsLogging Property

JavaScript

WinFramework..::IsLogging Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsLogging { get; set; }
Public Property IsLogging As Boolean
public:
virtual property bool IsLogging {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

Log..::.IsLogging

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


LocalSession Property

JavaScript

WinFramework..::LocalSession Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LocalSession LocalSession { get; }
Public ReadOnly Property LocalSession As LocalSession
public:
property LocalSession^ LocalSession {
    LocalSession^ get ();
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Log Property

JavaScript

WinFramework..::Log Property

BMXNET 4.0 Developer API

Logger to be used by all BMX objects.

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Log Log { get; set; }
Public Property Log As Log
public:
property Log^ Log {
    Log^ get ();
    void set (Log^ value);
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Login Property

JavaScript

WinFramework..::Login Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LoginProcess Login { get; set; }
Public Property Login As LoginProcess
public:
property LoginProcess^ Login {
    LoginProcess^ get ();
    void set (LoginProcess^ value);
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


PrimaryRemoteSession Property

JavaScript

WinFramework..::PrimaryRemoteSession Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RemoteSession PrimaryRemoteSession { get; set; }
Public Property PrimaryRemoteSession As RemoteSession
public:
property RemoteSession^ PrimaryRemoteSession {
    RemoteSession^ get ();
    void set (RemoteSession^ value);
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


RemoteSessionPool Property

JavaScript

WinFramework..::RemoteSessionPool Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RemoteSessionPool RemoteSessionPool { get; }
Public ReadOnly Property RemoteSessionPool As RemoteSessionPool
public:
property RemoteSessionPool^ RemoteSessionPool {
    RemoteSessionPool^ get ();
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


Settengs Property

JavaScript

WinFramework..::Settengs Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Settings Settengs { get; }
Public ReadOnly Property Settengs As Settings
public:
property Settings^ Settengs {
    Settings^ get ();
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


User Property

JavaScript

WinFramework..::User Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public User User { get; }
Public ReadOnly Property User As User
public:
property User^ User {
    User^ get ();
}

See Also

WinFramework Class
IndianHealthService.BMXNet.WinForm Namespace


IndianHealthService.BMXNet.WinForm.Configuration Namespace

JavaScript

IndianHealthService.BMXNet.WinForm.Configuration Namespace

BMXNET 4.0 Developer API

Types

All Types | Classes | Interfaces
Name | Description
LocalPersistentStore | LocalPersistentStore is the core BMX implementation for the most common local setting store patterns: 1) In a special folder 2) In any specified path 3) In IsolatedStorage Use the object factory static class methods to create the different storage mechanisms.
PersistentStore | The persistent store interface is to save local setting configuration data. The settings are written and read based on a string a keys, like a path. The keys are application specific. Some example could be: "Product","Version" The location of the PersistentStore is based on the implementation. The LocalPersistentStore provides the settings to be stored in special OS forlders like Environment.SpecialFolder.LocalApplicationData so that the settings would be based both on the logged in user and keys.
RpmsConnectionSettings | Container for all persistent and available connection spec
RpmsConnectionSpec | Specification for BMX RPMS Connection. Instances of this class are serialized as XML to a PersisentStore and are used is picklists for users to select from.
Settings | Provides settings interface and implementation for settings from command-line, stored in PersistentStore, or hardcoded in application.


LocalPersistentStore Class

JavaScript

| Members | See Also
.NET Framework Class Library
LocalPersistentStore Class

BMXNET 4.0 Developer API

LocalPersistentStore is the core BMX implementation for the most common local setting store patterns: 1) In a special folder 2) In any specified path 3) In IsolatedStorage Use the object factory static class methods to create the different storage mechanisms.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class LocalPersistentStore : PersistentStore
Public Class LocalPersistentStore _
    Implements PersistentStore
public ref class LocalPersistentStore : PersistentStore

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
LocalPersistentStore()()() |
AttemptAncestorKeysOnRead |
CreateDefaultStorage(Boolean) |
CreateIn(IsolatedStorageScope, Boolean) |
CreateIn(String, Boolean) |
CreateIn(Environment..::.SpecialFolder, String, Boolean) |
DirectoryPath |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IsolatedStorageScope |
MemberwiseClone()()() | (Inherited from Object.)
Read<(Of <(T>)>)(array<String>[]()[]) |
SpecialFolder |
ToString()()() | (Inherited from Object.)
Write<(Of <(T>)>)(T, array<String>[]()[]) |

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.WinForm.Configuration..::.LocalPersistentStore

See Also

IndianHealthService.BMXNet.WinForm.Configuration Namespace


LocalPersistentStore Constructor

JavaScript

LocalPersistentStore Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public LocalPersistentStore()
Public Sub New
public:
LocalPersistentStore()

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


LocalPersistentStore Methods

JavaScript

LocalPersistentStore Methods

BMXNET 4.0 Developer API

The LocalPersistentStore type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CreateDefaultStorage(Boolean) |
CreateIn(IsolatedStorageScope, Boolean) |
CreateIn(String, Boolean) |
CreateIn(Environment..::.SpecialFolder, String, Boolean) |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
Read<(Of <(T>)>)(array<String>[]()[]) |
ToString()()() | (Inherited from Object.)
Write<(Of <(T>)>)(T, array<String>[]()[]) |

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


CreateDefaultStorage Method

JavaScript

LocalPersistentStore..::CreateDefaultStorage Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static LocalPersistentStore CreateDefaultStorage(
    bool tryParentKeysOnRead
)
Public Shared Function CreateDefaultStorage ( _
    tryParentKeysOnRead As Boolean _
) As LocalPersistentStore
public:
static LocalPersistentStore^ CreateDefaultStorage(
    bool tryParentKeysOnRead
)

Parameters

tryParentKeysOnRead
Boolean

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


CreateIn Method

JavaScript

LocalPersistentStore..::CreateIn Method

BMXNET 4.0 Developer API

Overload List

Name | Description
CreateIn(IsolatedStorageScope, Boolean) |
CreateIn(String, Boolean) |
CreateIn(Environment..::.SpecialFolder, String, Boolean) |

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


CreateIn Method (IsolatedStorageScope, Boolean)

JavaScript

LocalPersistentStore..::CreateIn Method (IsolatedStorageScope, Boolean)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
protected static LocalPersistentStore CreateIn(
    IsolatedStorageScope aScope,
    bool tryParentKeysOnRead
)
Protected Shared Function CreateIn ( _
    aScope As IsolatedStorageScope, _
    tryParentKeysOnRead As Boolean _
) As LocalPersistentStore
protected:
static LocalPersistentStore^ CreateIn(
    IsolatedStorageScope aScope,
    bool tryParentKeysOnRead
)

Parameters

aScope
IsolatedStorageScope
tryParentKeysOnRead
Boolean

See Also

LocalPersistentStore Class
CreateIn Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


CreateIn Method (String, Boolean)

JavaScript

LocalPersistentStore..::CreateIn Method (String, Boolean)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static LocalPersistentStore CreateIn(
    string aDirectoryPath,
    bool tryParentKeysOnRead
)
Public Shared Function CreateIn ( _
    aDirectoryPath As String, _
    tryParentKeysOnRead As Boolean _
) As LocalPersistentStore
public:
static LocalPersistentStore^ CreateIn(
    String^ aDirectoryPath,
    bool tryParentKeysOnRead
)

Parameters

aDirectoryPath
String
tryParentKeysOnRead
Boolean

See Also

LocalPersistentStore Class
CreateIn Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


CreateIn Method (Environment.SpecialFolder, String, Boolean)

JavaScript

LocalPersistentStore..::CreateIn Method (Environment..::.SpecialFolder, String, Boolean)

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public static LocalPersistentStore CreateIn(
    Environment..::.SpecialFolder aSpecialFolder,
    string subDirectoryPath,
    bool tryParentKeysOnRead
)
Public Shared Function CreateIn ( _
    aSpecialFolder As Environment..::.SpecialFolder, _
    subDirectoryPath As String, _
    tryParentKeysOnRead As Boolean _
) As LocalPersistentStore
public:
static LocalPersistentStore^ CreateIn(
    Environment..::.SpecialFolder aSpecialFolder,
    String^ subDirectoryPath,
    bool tryParentKeysOnRead
)

Parameters

aSpecialFolder
Environment..::.SpecialFolder
subDirectoryPath
String
tryParentKeysOnRead
Boolean

See Also

LocalPersistentStore Class
CreateIn Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Read Generic Method

JavaScript

LocalPersistentStore..::Read<(Of <(T>)>) Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public T Read<T>(
    params string[] keys
)

Public Function Read(Of T) ( _
    ParamArray keys As String() _
) As T
public:
generic<typename T>
virtual T Read(
    ... array<String^>^ keys
) sealed

Parameters

keys
array< String >[]()[]

Type Parameters

T

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Write Generic Method

JavaScript

LocalPersistentStore..::Write<(Of <(T>)>) Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Write<T>(
    T anObject,
    params string[] keys
)

Public Sub Write(Of T) ( _
    anObject As T, _
    ParamArray keys As String() _
)
public:
generic<typename T>
virtual void Write(
    T anObject,
    ... array<String^>^ keys
) sealed

Parameters

anObject
T
keys
array< String >[]()[]

Type Parameters

T

Implements

PersistentStore..::.Write<(Of <(T>)>)(T, array<String>[]()[])

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


LocalPersistentStore Properties

JavaScript

LocalPersistentStore Properties

BMXNET 4.0 Developer API

The LocalPersistentStore type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AttemptAncestorKeysOnRead |
DirectoryPath |
IsolatedStorageScope |
SpecialFolder |

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


AttemptAncestorKeysOnRead Property

JavaScript

LocalPersistentStore..::AttemptAncestorKeysOnRead Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool AttemptAncestorKeysOnRead { get; set; }
Public Property AttemptAncestorKeysOnRead As Boolean
public:
property bool AttemptAncestorKeysOnRead {
    bool get ();
    void set (bool value);
}

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


DirectoryPath Property

JavaScript

LocalPersistentStore..::DirectoryPath Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string DirectoryPath { get; set; }
Public Property DirectoryPath As String
public:
property String^ DirectoryPath {
    String^ get ();
    void set (String^ value);
}

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


IsolatedStorageScope Property

JavaScript

LocalPersistentStore..::IsolatedStorageScope Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Nullable<IsolatedStorageScope> IsolatedStorageScope { get; set; }
Public Property IsolatedStorageScope As Nullable(Of IsolatedStorageScope)
public:
property Nullable<IsolatedStorageScope> IsolatedStorageScope {
    Nullable<IsolatedStorageScope> get ();
    void set (Nullable<IsolatedStorageScope> value);
}

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


SpecialFolder Property

JavaScript

LocalPersistentStore..::SpecialFolder Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Nullable<Environment..::.SpecialFolder> SpecialFolder { get; set; }
Public Property SpecialFolder As Nullable(Of Environment..::.SpecialFolder)
public:
property Nullable<Environment..::.SpecialFolder> SpecialFolder {
    Nullable<Environment..::.SpecialFolder> get ();
    void set (Nullable<Environment..::.SpecialFolder> value);
}

See Also

LocalPersistentStore Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


PersistentStore Interface

JavaScript

| Members | See Also
.NET Framework Class Library
PersistentStore Interface

BMXNET 4.0 Developer API

The persistent store interface is to save local setting configuration data. The settings are written and read based on a string a keys, like a path. The keys are application specific. Some example could be: "Product","Version" The location of the PersistentStore is based on the implementation. The LocalPersistentStore provides the settings to be stored in special OS forlders like Environment.SpecialFolder.LocalApplicationData so that the settings would be based both on the logged in user and keys.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public interface PersistentStore
Public Interface PersistentStore
public interface class PersistentStore

Members

All Members | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Read<(Of <(T>)>)(array<String>[]()[]) | The implementor must deserialize an object of type T from the given location based on the keys
Write<(Of <(T>)>)(T, array<String>[]()[]) | The implementor must serialize the object anObject given the keys.

See Also

IndianHealthService.BMXNet.WinForm.Configuration Namespace


PersistentStore Methods

JavaScript

PersistentStore Methods

BMXNET 4.0 Developer API

The PersistentStore type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Read<(Of <(T>)>)(array<String>[]()[]) | The implementor must deserialize an object of type T from the given location based on the keys
Write<(Of <(T>)>)(T, array<String>[]()[]) | The implementor must serialize the object anObject given the keys.

See Also

PersistentStore Interface
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Read Generic Method

JavaScript

PersistentStore..::Read<(Of <(T>)>) Method

BMXNET 4.0 Developer API

The implementor must deserialize an object of type T from the given location based on the keys

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
T Read<T>(
    params string[] keys
)

Function Read(Of T) ( _
    ParamArray keys As String() _
) As T
generic<typename T>
T Read(
    ... array<String^>^ keys
)

Parameters

keys
array< String >[]()[]
The keys used to locate the object

Type Parameters

T
The type of the object to be deserialized from the store

Return Value

An deserialized object, or null if no valid objects exists at the keys

See Also

PersistentStore Interface
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Write Generic Method

JavaScript

PersistentStore..::Write<(Of <(T>)>) Method

BMXNET 4.0 Developer API

The implementor must serialize the object anObject given the keys.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
void Write<T>(
    T anObject,
    params string[] keys
)

Sub Write(Of T) ( _
    anObject As T, _
    ParamArray keys As String() _
)
generic<typename T>
void Write(
    T anObject,
    ... array<String^>^ keys
)

Parameters

anObject
T
The objects to be stored
keys
array< String >[]()[]
The key used to locate the settings

Type Parameters

T
The type of the object to be serialized to the store

See Also

PersistentStore Interface
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSettings Class

JavaScript

| Members | See Also
.NET Framework Class Library
RpmsConnectionSettings Class

BMXNET 4.0 Developer API

Container for all persistent and available connection spec

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class RpmsConnectionSettings
Public Class RpmsConnectionSettings
public ref class RpmsConnectionSettings

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RpmsConnectionSettings()()() |
AddConnectionSpec(RpmsConnectionSpec) | Add aSpec to the receiver. Not persisted
CommandLineConnectionSpec |
ConnectionSpecs | Answer all available connection specs, including command-line spec
DefaultConnectionSpec | Answer the default connection spec. If there is not user defined default, answer the first connection spec
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Load()()() |
ManagedConnectionSpecs | Answer all connection specs in user defined order
MemberwiseClone()()() | (Inherited from Object.)
MoveConnectionSpecDown(RpmsConnectionSpec) |
MoveConnectionSpecUp(RpmsConnectionSpec) |
RemoveConnectionSpec(RpmsConnectionSpec) | Remove aSpec from the receiver. Not persisted.
Revert()()() | Refresh the receiver from the current state of the persistent store
Save()()() |
SetConnectionSpecAsDefault(RpmsConnectionSpec) |
StorageKeys |
Store |
ToString()()() | (Inherited from Object.)
UserSettings |

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.WinForm.Configuration..::.RpmsConnectionSettings

See Also

IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSettings Constructor

JavaScript

RpmsConnectionSettings Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RpmsConnectionSettings()
Public Sub New
public:
RpmsConnectionSettings()

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSettings Methods

JavaScript

RpmsConnectionSettings Methods

BMXNET 4.0 Developer API

The RpmsConnectionSettings type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
AddConnectionSpec(RpmsConnectionSpec) | Add aSpec to the receiver. Not persisted
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Load()()() |
MemberwiseClone()()() | (Inherited from Object.)
MoveConnectionSpecDown(RpmsConnectionSpec) |
MoveConnectionSpecUp(RpmsConnectionSpec) |
RemoveConnectionSpec(RpmsConnectionSpec) | Remove aSpec from the receiver. Not persisted.
Revert()()() | Refresh the receiver from the current state of the persistent store
Save()()() |
SetConnectionSpecAsDefault(RpmsConnectionSpec) |
ToString()()() | (Inherited from Object.)

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


AddConnectionSpec Method

JavaScript

RpmsConnectionSettings..::AddConnectionSpec Method

BMXNET 4.0 Developer API

Add aSpec to the receiver. Not persisted

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void AddConnectionSpec(
    RpmsConnectionSpec aSpec
)
Public Sub AddConnectionSpec ( _
    aSpec As RpmsConnectionSpec _
)
public:
void AddConnectionSpec(
    RpmsConnectionSpec^ aSpec
)

Parameters

aSpec
RpmsConnectionSpec

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Load Method

JavaScript

RpmsConnectionSettings..::Load Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Load()
Public Sub Load
public:
void Load()

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


MoveConnectionSpecDown Method

JavaScript

RpmsConnectionSettings..::MoveConnectionSpecDown Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool MoveConnectionSpecDown(
    RpmsConnectionSpec aSpec
)
Public Function MoveConnectionSpecDown ( _
    aSpec As RpmsConnectionSpec _
) As Boolean
public:
bool MoveConnectionSpecDown(
    RpmsConnectionSpec^ aSpec
)

Parameters

aSpec
RpmsConnectionSpec

Return Value

True if there was any movement

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


MoveConnectionSpecUp Method

JavaScript

RpmsConnectionSettings..::MoveConnectionSpecUp Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool MoveConnectionSpecUp(
    RpmsConnectionSpec aSpec
)
Public Function MoveConnectionSpecUp ( _
    aSpec As RpmsConnectionSpec _
) As Boolean
public:
bool MoveConnectionSpecUp(
    RpmsConnectionSpec^ aSpec
)

Parameters

aSpec
RpmsConnectionSpec

Return Value

True if there was any movement

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RemoveConnectionSpec Method

JavaScript

RpmsConnectionSettings..::RemoveConnectionSpec Method

BMXNET 4.0 Developer API

Remove aSpec from the receiver. Not persisted.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void RemoveConnectionSpec(
    RpmsConnectionSpec aSpec
)
Public Sub RemoveConnectionSpec ( _
    aSpec As RpmsConnectionSpec _
)
public:
void RemoveConnectionSpec(
    RpmsConnectionSpec^ aSpec
)

Parameters

aSpec
RpmsConnectionSpec

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Revert Method

JavaScript

RpmsConnectionSettings..::Revert Method

BMXNET 4.0 Developer API

Refresh the receiver from the current state of the persistent store

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Revert()
Public Sub Revert
public:
void Revert()

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Save Method

JavaScript

RpmsConnectionSettings..::Save Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Save()
Public Sub Save
public:
void Save()

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


SetConnectionSpecAsDefault Method

JavaScript

RpmsConnectionSettings..::SetConnectionSpecAsDefault Method

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void SetConnectionSpecAsDefault(
    RpmsConnectionSpec aSpec
)
Public Sub SetConnectionSpecAsDefault ( _
    aSpec As RpmsConnectionSpec _
)
public:
void SetConnectionSpecAsDefault(
    RpmsConnectionSpec^ aSpec
)

Parameters

aSpec
RpmsConnectionSpec

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSettings Properties

JavaScript

RpmsConnectionSettings Properties

BMXNET 4.0 Developer API

The RpmsConnectionSettings type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
CommandLineConnectionSpec |
ConnectionSpecs | Answer all available connection specs, including command-line spec
DefaultConnectionSpec | Answer the default connection spec. If there is not user defined default, answer the first connection spec
ManagedConnectionSpecs | Answer all connection specs in user defined order
StorageKeys |
Store |
UserSettings |

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


CommandLineConnectionSpec Property

JavaScript

RpmsConnectionSettings..::CommandLineConnectionSpec Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RpmsConnectionSpec CommandLineConnectionSpec { get; set; }
Public Property CommandLineConnectionSpec As RpmsConnectionSpec
public:
property RpmsConnectionSpec^ CommandLineConnectionSpec {
    RpmsConnectionSpec^ get ();
    void set (RpmsConnectionSpec^ value);
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


ConnectionSpecs Property

JavaScript

RpmsConnectionSettings..::ConnectionSpecs Property

BMXNET 4.0 Developer API

Answer all available connection specs, including command-line spec

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public List<RpmsConnectionSpec> ConnectionSpecs { get; }
Public ReadOnly Property ConnectionSpecs As List(Of RpmsConnectionSpec)
public:
property List<RpmsConnectionSpec^>^ ConnectionSpecs {
    List<RpmsConnectionSpec^>^ get ();
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


DefaultConnectionSpec Property

JavaScript

RpmsConnectionSettings..::DefaultConnectionSpec Property

BMXNET 4.0 Developer API

Answer the default connection spec. If there is not user defined default, answer the first connection spec

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RpmsConnectionSpec DefaultConnectionSpec { get; set; }
Public Property DefaultConnectionSpec As RpmsConnectionSpec
public:
property RpmsConnectionSpec^ DefaultConnectionSpec {
    RpmsConnectionSpec^ get ();
    void set (RpmsConnectionSpec^ value);
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


ManagedConnectionSpecs Property

JavaScript

RpmsConnectionSettings..::ManagedConnectionSpecs Property

BMXNET 4.0 Developer API

Answer all connection specs in user defined order

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public List<RpmsConnectionSpec> ManagedConnectionSpecs { get; set; }
Public Property ManagedConnectionSpecs As List(Of RpmsConnectionSpec)
public:
property List<RpmsConnectionSpec^>^ ManagedConnectionSpecs {
    List<RpmsConnectionSpec^>^ get ();
    void set (List<RpmsConnectionSpec^>^ value);
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


StorageKeys Property

JavaScript

RpmsConnectionSettings..::StorageKeys Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string[] StorageKeys { get; set; }
Public Property StorageKeys As String()
public:
property array<String^>^ StorageKeys {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Store Property

JavaScript

RpmsConnectionSettings..::Store Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public PersistentStore Store { get; set; }
Public Property Store As PersistentStore
public:
property PersistentStore^ Store {
    PersistentStore^ get ();
    void set (PersistentStore^ value);
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


UserSettings Property

JavaScript

RpmsConnectionSettings..::UserSettings Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Settings UserSettings { get; set; }
Public Property UserSettings As Settings
public:
property Settings^ UserSettings {
    Settings^ get ();
    void set (Settings^ value);
}

See Also

RpmsConnectionSettings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSpec Class

JavaScript

| Members | See Also
.NET Framework Class Library
RpmsConnectionSpec Class

BMXNET 4.0 Developer API

Specification for BMX RPMS Connection. Instances of this class are serialized as XML to a PersisentStore and are used is picklists for users to select from.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class RpmsConnectionSpec
Public Class RpmsConnectionSpec
public ref class RpmsConnectionSpec

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
RpmsConnectionSpec()()() |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IsDefault | The optional flag to specify this connection as the users default.
MemberwiseClone()()() | (Inherited from Object.)
Name | The required display name of a connection used in pick lists
NameSpace | The optional Namespace to use in RPMS. Will default to BMX Brokers namespace.
Port | The required TCP/IP port number of the RPMS BMX Broker
ReceiveTimeout | The optional time in millseconds to wait for a response from RPMS
SendTimeout | The optional time in millseconds to wait when sending a request to RPMS
Server | The required Name/IP Address of the RPMS Host
ToString()()() | (Inherited from Object.)
UseDefaultNamespace | The optional flag to specify that the BMX Broker default namespace should be used.
UseWindowsAuthentication | The optional flag to specify that WindowsAuthenication should be attempted.

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.WinForm.Configuration..::.RpmsConnectionSpec

See Also

IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSpec Constructor

JavaScript

RpmsConnectionSpec Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public RpmsConnectionSpec()
Public Sub New
public:
RpmsConnectionSpec()

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSpec Methods

JavaScript

RpmsConnectionSpec Methods

BMXNET 4.0 Developer API

The RpmsConnectionSpec type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
MemberwiseClone()()() | (Inherited from Object.)
ToString()()() | (Inherited from Object.)

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


RpmsConnectionSpec Properties

JavaScript

RpmsConnectionSpec Properties

BMXNET 4.0 Developer API

The RpmsConnectionSpec type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
IsDefault | The optional flag to specify this connection as the users default.
Name | The required display name of a connection used in pick lists
NameSpace | The optional Namespace to use in RPMS. Will default to BMX Brokers namespace.
Port | The required TCP/IP port number of the RPMS BMX Broker
ReceiveTimeout | The optional time in millseconds to wait for a response from RPMS
SendTimeout | The optional time in millseconds to wait when sending a request to RPMS
Server | The required Name/IP Address of the RPMS Host
UseDefaultNamespace | The optional flag to specify that the BMX Broker default namespace should be used.
UseWindowsAuthentication | The optional flag to specify that WindowsAuthenication should be attempted.

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


IsDefault Property

JavaScript

RpmsConnectionSpec..::IsDefault Property

BMXNET 4.0 Developer API

The optional flag to specify this connection as the users default.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsDefault { get; set; }
Public Property IsDefault As Boolean
public:
property bool IsDefault {
    bool get ();
    void set (bool value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Name Property

JavaScript

RpmsConnectionSpec..::Name Property

BMXNET 4.0 Developer API

The required display name of a connection used in pick lists

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


NameSpace Property

JavaScript

RpmsConnectionSpec..::NameSpace Property

BMXNET 4.0 Developer API

The optional Namespace to use in RPMS. Will default to BMX Brokers namespace.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string NameSpace { get; set; }
Public Property NameSpace As String
public:
property String^ NameSpace {
    String^ get ();
    void set (String^ value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Port Property

JavaScript

RpmsConnectionSpec..::Port Property

BMXNET 4.0 Developer API

The required TCP/IP port number of the RPMS BMX Broker

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


ReceiveTimeout Property

JavaScript

RpmsConnectionSpec..::ReceiveTimeout Property

BMXNET 4.0 Developer API

The optional time in millseconds to wait for a response from RPMS

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public int ReceiveTimeout { get; set; }
Public Property ReceiveTimeout As Integer
public:
property int ReceiveTimeout {
    int get ();
    void set (int value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


SendTimeout Property

JavaScript

RpmsConnectionSpec..::SendTimeout Property

BMXNET 4.0 Developer API

The optional time in millseconds to wait when sending a request to RPMS

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public int SendTimeout { get; set; }
Public Property SendTimeout As Integer
public:
property int SendTimeout {
    int get ();
    void set (int value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Server Property

JavaScript

RpmsConnectionSpec..::Server Property

BMXNET 4.0 Developer API

The required Name/IP Address of the RPMS Host

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Server { get; set; }
Public Property Server As String
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


UseDefaultNamespace Property

JavaScript

RpmsConnectionSpec..::UseDefaultNamespace Property

BMXNET 4.0 Developer API

The optional flag to specify that the BMX Broker default namespace should be used.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool UseDefaultNamespace { get; set; }
Public Property UseDefaultNamespace As Boolean
public:
property bool UseDefaultNamespace {
    bool get ();
    void set (bool value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


UseWindowsAuthentication Property

JavaScript

RpmsConnectionSpec..::UseWindowsAuthentication Property

BMXNET 4.0 Developer API

The optional flag to specify that WindowsAuthenication should be attempted.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool UseWindowsAuthentication { get; set; }
Public Property UseWindowsAuthentication As Boolean
public:
property bool UseWindowsAuthentication {
    bool get ();
    void set (bool value);
}

See Also

RpmsConnectionSpec Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Settings Class

JavaScript

| Members | See Also
.NET Framework Class Library
Settings Class

BMXNET 4.0 Developer API

Provides settings interface and implementation for settings from command-line, stored in PersistentStore, or hardcoded in application.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public class Settings
Public Class Settings
public ref class Settings

Members

All Members | Constructors | Properties | Methods
Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Settings()()() |
BackupSettings |
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
Get(String, Boolean) | Get the boolean Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
Get(String, Int32) | Get the Integer Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
Get(String, String) | Get the string Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
IsPersistent | Answer true if the current Settings IsPersistent. It is possible that the Backup Settings IsPersistennt
Load()()() | Load the receiver's settings from the PersistentStore
MemberwiseClone()()() | (Inherited from Object.)
MergeSettings(Settings) | Merge the settings from someSettings into the receiver
Save()()() | Save the receiver's settings to the PersistentStore
Set(String, Boolean) | Update the Setting value aName to aBool
Set(String, Int32) | Update the Setting value aName to anInt
Set(String, String) | Update the Setting value aName to a string
ToString()()() | (Inherited from Object.)
WillPersistFutureSets | After set to true, every setting update will be flushed the PersistentStore if the Settings is configured with one

Inheritance Hierarchy

System..::.Object
IndianHealthService.BMXNet.WinForm.Configuration..::.Settings

See Also

IndianHealthService.BMXNet.WinForm.Configuration Namespace


Settings Constructor

JavaScript

Settings Constructor

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Settings()
Public Sub New
public:
Settings()

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Settings Methods

JavaScript

Settings Methods

BMXNET 4.0 Developer API

The Settings type exposes the following methods.

Methods

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
Equals(Object) | (Inherited from Object.)
Finalize()()() | (Inherited from Object.)
Get(String, Boolean) | Get the boolean Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
Get(String, Int32) | Get the Integer Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
Get(String, String) | Get the string Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
GetHashCode()()() | (Inherited from Object.)
GetType()()() | (Inherited from Object.)
Load()()() | Load the receiver's settings from the PersistentStore
MemberwiseClone()()() | (Inherited from Object.)
MergeSettings(Settings) | Merge the settings from someSettings into the receiver
Save()()() | Save the receiver's settings to the PersistentStore
Set(String, Boolean) | Update the Setting value aName to aBool
Set(String, Int32) | Update the Setting value aName to anInt
Set(String, String) | Update the Setting value aName to a string
ToString()()() | (Inherited from Object.)

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Get Method

JavaScript

Settings..::Get Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Get(String, Boolean) | Get the boolean Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
Get(String, Int32) | Get the Integer Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.
Get(String, String) | Get the string Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Get Method (String, Boolean)

JavaScript

Settings..::Get Method (String, Boolean)

BMXNET 4.0 Developer API

Get the boolean Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Get(
    string aString,
    bool defaultValue
)
Public Function Get ( _
    aString As String, _
    defaultValue As Boolean _
) As Boolean
public:
bool Get(
    String^ aString,
    bool defaultValue
)

Parameters

aString
String
Name of the setting
defaultValue
Boolean
Default value

Return Value

See Also

Settings Class
Get Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Get Method (String, Int32)

JavaScript

Settings..::Get Method (String, Int32)

BMXNET 4.0 Developer API

Get the Integer Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public int Get(
    string aString,
    int defaultValue
)
Public Function Get ( _
    aString As String, _
    defaultValue As Integer _
) As Integer
public:
int Get(
    String^ aString,
    int defaultValue
)

Parameters

aString
String
Name of the setting
defaultValue
Int32
Default value

Return Value

See Also

Settings Class
Get Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Get Method (String, String)

JavaScript

Settings..::Get Method (String, String)

BMXNET 4.0 Developer API

Get the string Setting named aString. Answer the defaultValue if the Setting named aString does not exist in the receiver or it's Backup chain.

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public string Get(
    string aString,
    string defaultValue
)
Public Function Get ( _
    aString As String, _
    defaultValue As String _
) As String
public:
String^ Get(
    String^ aString,
    String^ defaultValue
)

Parameters

aString
String
Name of the setting
defaultValue
String
Default value

Return Value

See Also

Settings Class
Get Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Load Method

JavaScript

Settings..::Load Method

BMXNET 4.0 Developer API

Load the receiver's settings from the PersistentStore

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Load()
Public Sub Load
public:
void Load()

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


MergeSettings Method

JavaScript

Settings..::MergeSettings Method

BMXNET 4.0 Developer API

Merge the settings from someSettings into the receiver

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void MergeSettings(
    Settings someSettings
)
Public Sub MergeSettings ( _
    someSettings As Settings _
)
public:
void MergeSettings(
    Settings^ someSettings
)

Parameters

someSettings
Settings
Settings to copy

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Save Method

JavaScript

Settings..::Save Method

BMXNET 4.0 Developer API

Save the receiver's settings to the PersistentStore

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public void Save()
Public Sub Save
public:
void Save()

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Set Method

JavaScript

Settings..::Set Method

BMXNET 4.0 Developer API

Overload List

Name | Description
Set(String, Boolean) | Update the Setting value aName to aBool
Set(String, Int32) | Update the Setting value aName to anInt
Set(String, String) | Update the Setting value aName to a string

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Set Method (String, Boolean)

JavaScript

Settings..::Set Method (String, Boolean)

BMXNET 4.0 Developer API

Update the Setting value aName to aBool

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Set(
    string aName,
    bool aBool
)
Public Function Set ( _
    aName As String, _
    aBool As Boolean _
) As Boolean
public:
bool Set(
    String^ aName,
    bool aBool
)

Parameters

aName
String
Name of the Setting
aBool
Boolean
Boolean value to set

Return Value

True if the setting was changed, False if the setting was the same value

See Also

Settings Class
Set Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Set Method (String, Int32)

JavaScript

Settings..::Set Method (String, Int32)

BMXNET 4.0 Developer API

Update the Setting value aName to anInt

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Set(
    string aName,
    int anInt
)
Public Function Set ( _
    aName As String, _
    anInt As Integer _
) As Boolean
public:
bool Set(
    String^ aName,
    int anInt
)

Parameters

aName
String
Name of the Setting
anInt
Int32

Return Value

True if the setting was changed, False if the setting was the same value

See Also

Settings Class
Set Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Set Method (String, String)

JavaScript

Settings..::Set Method (String, String)

BMXNET 4.0 Developer API

Update the Setting value aName to a string

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool Set(
    string aName,
    string aValue
)
Public Function Set ( _
    aName As String, _
    aValue As String _
) As Boolean
public:
bool Set(
    String^ aName,
    String^ aValue
)

Parameters

aName
String
Name of the Setting
aValue
String

Return Value

True if the setting was changed, False if the setting was the same value

See Also

Settings Class
Set Overload
IndianHealthService.BMXNet.WinForm.Configuration Namespace


Settings Properties

JavaScript

Settings Properties

BMXNET 4.0 Developer API

The Settings type exposes the following properties.

Properties

Public

Protected
Instance

Static
Declared

Inherited
XNA Framework Only

.NET Compact Framework Only

Member | Description
BackupSettings |
IsPersistent | Answer true if the current Settings IsPersistent. It is possible that the Backup Settings IsPersistennt
WillPersistFutureSets | After set to true, every setting update will be flushed the PersistentStore if the Settings is configured with one

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


BackupSettings Property

JavaScript

Settings..::BackupSettings Property

BMXNET 4.0 Developer API

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public Settings BackupSettings { get; set; }
Public Property BackupSettings As Settings
public:
property Settings^ BackupSettings {
    Settings^ get ();
    void set (Settings^ value);
}

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


IsPersistent Property

JavaScript

Settings..::IsPersistent Property

BMXNET 4.0 Developer API

Answer true if the current Settings IsPersistent. It is possible that the Backup Settings IsPersistennt

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool IsPersistent { get; }
Public ReadOnly Property IsPersistent As Boolean
public:
property bool IsPersistent {
    bool get ();
}

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace


WillPersistFutureSets Property

JavaScript

Settings..::WillPersistFutureSets Property

BMXNET 4.0 Developer API

After set to true, every setting update will be flushed the PersistentStore if the Settings is configured with one

Namespace: IndianHealthService.BMXNet.WinForm.Configuration
Assembly: BMXWIN40 (in BMXWIN40.dll)

Syntax

C# | Visual Basic | Visual C++
public bool WillPersistFutureSets { get; set; }
Public Property WillPersistFutureSets As Boolean
public:
property bool WillPersistFutureSets {
    bool get ();
    void set (bool value);
}

See Also

Settings Class
IndianHealthService.BMXNet.WinForm.Configuration Namespace